Re: [PATCH 6/6] usb: host: tegra: Tegra30 support

2013-08-01 Thread Stephen Warren
On 07/31/2013 11:42 AM, Tuomas Tynkkynen wrote: The Tegra30 EHCI controller is mostly compatible with the Tegra20 controller, except Tegra30 includes the HOSTPC register extension. The has_hostpc capability bit must be set in the ehci_hcd structure if the controller has such extensions. The

[PATCH V3 2/3] include: Convert ethernet mac address declarations to use ETH_ALEN

2013-08-01 Thread Joe Perches
It's convenient to have ethernet mac addresses use ETH_ALEN to be able to grep for them a bit easier and also to ensure that the addresses are __aligned(2). Add #include linux/if_ether.h as necessary. Signed-off-by: Joe Perches j...@perches.com Acked-by: Mauro Carvalho Chehab

[PATCH V3 0/3] networking: Use ETH_ALEN where appropriate

2013-08-01 Thread Joe Perches
Convert the uses mac addresses to ETH_ALEN so it's easier to find and verify where mac addresses need to be __aligned(2) Change in V2: - Remove include/acpi/actbl2.h conversion It's a file copied from outside ACPI sources Changes in V3: - Don't move the pasemi_mac.h mac address to be

[PATCH 0/3] usb: phy-samsung-usb: Simplify and cleanup

2013-08-01 Thread Julius Werner
This patch series cleans up and simplifies some of the Samsung USB PHY driver code. It changes the PMU register handling to carry the register address directly in the device tree and avoid a lot of special-cased address arithmatic in the code. Then it removes the USB_PHY_TYPE HOST/DEVICE

[PATCH 2/3] usb: phy-samsung-usb: trivial: rename pmuregs variable

2013-08-01 Thread Julius Werner
Now that the sphy-pmuregs variable always points to only a single register, let's rename it to make that more clear. Signed-off-by: Julius Werner jwer...@chromium.org --- drivers/usb/phy/phy-samsung-usb.c | 14 +++--- drivers/usb/phy/phy-samsung-usb.h | 4 ++--

[PATCH 3/3] usb: phy-samsung-usb: Remove USB_PHY_TYPE from Samsung PHY driver

2013-08-01 Thread Julius Werner
Since the PMU register handling was simplified, the last reason to differentiate between HOST and DEVICE PHYs in the Samsung USB PHY driver has disappeared. This patch removes that variable and reworks surrounding code to live without it to make the driver a little smaller and cleaner.

Re: USB Interrupt Transaction Scheduling

2013-08-01 Thread Peter Chen
On Thu, Aug 01, 2013 at 12:14:18PM -0300, Fabio Estevam wrote: Hi Nate, On Tue, Jul 30, 2013 at 6:33 PM, Stoddard, Nate (GE Healthcare) nate.stodd...@med.ge.com wrote: So you would expect a temporary CPU increase when a device is connected or reset since the scheduler will need to set

[PATCH 1/3] usb: phy-samsung-usb: Simplify PMU register handling

2013-08-01 Thread Julius Werner
This patch simplifies the way the phy-samsung-usb code finds the correct power management register to enable PHY clock gating. Previously, the code would calculate the register address from a device tree supplied base address and add an offset based on the PHY type. Since every PHY has its own

Re: USB Interrupt Transaction Scheduling

2013-08-01 Thread Peter Chen
On Tue, Jul 30, 2013 at 09:33:39PM +, Stoddard, Nate (GE Healthcare) wrote: The driver has to set up the data structures for the transfers, which includes scheduling when the SSPLIT and CSPLIT transactions will occur and figuring out how much bandwidth they will consume. The

Re: I've now caught up on my pending USB patches

2013-08-01 Thread Ming Lei
Hi Greg, On Sat, Jul 27, 2013 at 5:17 AM, Greg KH gre...@linuxfoundation.org wrote: Hi all, I've now caught up on all pending USB patches that were sent to me, with the exception of Ming's EHCI patches, which I need to test further next week. Gentle ping on these patches, :-) Thanks, --

[PATCH] USB: Removing the use of VLAIS from the gadget driver

2013-08-01 Thread behanw
From: Behan Webster beh...@converseincode.com The use of variable length arrays in structs (VLAIS) in the Linux Kernel code precludes the use of compilers which don't implement VLAIS (for instance the Clang compiler). This patch removes the use of VLAIS in the gadget driver. Signed-off-by: Mark

Re: question: do we have any UML like design diagram for usb core and driver model?

2013-08-01 Thread Chen Wang
On Thu, 2013-08-01 at 10:34 -0400, Alan Stern wrote: On Thu, 1 Aug 2013, Oliver Neukum wrote: On Thu, 2013-08-01 at 17:13 +0800, Chen Wang wrote: hello, I'm reading code of usb core and driver model/sysfs. I believe they are designed with OOP. Yes, much of the code is OO.

Re: [PATCH] USBIP:stub_dev.c fixing string splitted into multiple line issue

2013-08-01 Thread Kumar Gaurav
On Thursday 01 August 2013 10:27 AM, Jiany Wu wrote: I have the same idea with julia. It is more difficult to check the log if we use MACRO instead of the strings. If we search in the system log, according to the string, we will find out the macro first. later we also need to find out where

Re: question: do we have any UML like design diagram for usb core and driver model?

2013-08-01 Thread Greg KH
On Fri, Aug 02, 2013 at 09:56:17AM +0800, Chen Wang wrote: On Thu, 2013-08-01 at 10:34 -0400, Alan Stern wrote: On Thu, 1 Aug 2013, Oliver Neukum wrote: On Thu, 2013-08-01 at 17:13 +0800, Chen Wang wrote: hello, I'm reading code of usb core and driver model/sysfs. I believe they

Re: [PATCHv2 1/2][usbutils] lsusb: port to hwdb

2013-08-01 Thread Greg KH
On Wed, Jul 24, 2013 at 12:37:30PM +0200, Tom Gundersen wrote: Most of the information in usb.ids is now contained in udev's hwdb. Read the information from the hwdb instead of usb.ids. This would allow distributions to no longer ship (most of) usb.ids by default, but rather keep all the usb

Re: [PATCH v5 1/5] USB: HCD: support giveback of URB in tasklet context

2013-08-01 Thread Greg Kroah-Hartman
On Wed, Jul 03, 2013 at 10:53:07PM +0800, Ming Lei wrote: 1), for drivers, they don't care if the complete() is called in hard irq context or softirq context What about those 50+ patches you had that changed the locking for urb callbacks? Aren't they needed before this patch can go in? ---

Re: [PATCH] MAINTAINERS: Add separate section for USB NETWORKING DRIVERS

2013-08-01 Thread Greg KH
On Thu, Aug 01, 2013 at 01:09:55AM -0700, Joe Perches wrote: On Thu, 2013-08-01 at 15:56 +0800, Greg KH wrote: On Thu, Aug 01, 2013 at 12:48:48AM -0700, Joe Perches wrote: There are several drivers in drivers/net/usb/ that do not have specific MAINTAINERS that should have emails

Re: [PATCH v5 1/5] USB: HCD: support giveback of URB in tasklet context

2013-08-01 Thread Ming Lei
On Fri, Aug 2, 2013 at 11:28 AM, Greg Kroah-Hartman gre...@linuxfoundation.org wrote: On Wed, Jul 03, 2013 at 10:53:07PM +0800, Ming Lei wrote: 1), for drivers, they don't care if the complete() is called in hard irq context or softirq context What about those 50+ patches you had that changed

Re: [PATCH v5 1/5] USB: HCD: support giveback of URB in tasklet context

2013-08-01 Thread Greg Kroah-Hartman
On Fri, Aug 02, 2013 at 11:30:54AM +0800, Ming Lei wrote: On Fri, Aug 2, 2013 at 11:28 AM, Greg Kroah-Hartman gre...@linuxfoundation.org wrote: On Wed, Jul 03, 2013 at 10:53:07PM +0800, Ming Lei wrote: 1), for drivers, they don't care if the complete() is called in hard irq context or

Re: [PATCH] MAINTAINERS: Add separate section for USB NETWORKING DRIVERS

2013-08-01 Thread Joe Perches
On Fri, 2013-08-02 at 11:30 +0800, Greg KH wrote: On Thu, Aug 01, 2013 at 01:09:55AM -0700, Joe Perches wrote: Lots of maintainers don't apply patches. I have no idea what you are meaning here. Just that maintainers aren't necessarily appliers. In fact, most aren't. Add netdev to the L:

Re: [PATCH] MAINTAINERS: Add separate section for USB NETWORKING DRIVERS

2013-08-01 Thread Greg KH
On Thu, Aug 01, 2013 at 08:50:10PM -0700, Joe Perches wrote: On Fri, 2013-08-02 at 11:30 +0800, Greg KH wrote: On Thu, Aug 01, 2013 at 01:09:55AM -0700, Joe Perches wrote: Lots of maintainers don't apply patches. I have no idea what you are meaning here. Just that maintainers aren't

[PATCH resend] MAINTAINERS: Add separate section for USB NETWORKING DRIVERS

2013-08-01 Thread Joe Perches
There are several drivers in drivers/net/usb/ that do not have specific MAINTAINERS that should have emails forwarded to the linux-usb mailing list. Add a section for those drivers. Signed-off-by: Joe Perches j...@perches.com --- In the future, you do not need to send drivers/net/usb/ patches

Re: [PATCH] USBIP:stub_dev.c fixing string splitted into multiple line issue

2013-08-01 Thread Julia Lawall
Thanks you all for suggestions. I'll try finding some other way. If the strings don't fit, you can just go over 80 characters. julia -- To unsubscribe from this list: send the line unsubscribe linux-usb in the body of a message to majord...@vger.kernel.org More majordomo info at

<    1   2