Hi Greg

A lot of xhci cleanups, refactoring and changes for 4.11
Including major tracing rework by Felipe

-Mathias

Alexander Stein (1):
  xhci: Put warning message on a single line

Baolin Wang (1):
  usb: host: xhci: Remove unused 'addr_64' variable in xhci_hcd
    structure

Felipe Balbi (20):
  usb: xhci: add quirk flag for broken PED bits
  usb: host: xhci-plat: enable BROKEN_PED quirk if platform requested
  usb: host: xhci: change pre-increments to post-increments
  usb: host: xhci: print HCIVERSION on debug
  usb: host: xhci: rename completion codes to match spec
  usb: host: xhci: simplify irq handler return
  usb: host: xhci: remove unneded semicolon
  usb: host: xhci: use slightly better list helpers
  usb: host: xhci: reorder variable definitions
  usb: host: xhci: introduce xhci_td_cleanup()
  usb: host: xhci: remove bogus __releases()/__acquires() annotation
  usb: host: xhci: check for a valid ring when unmapping bounce buffer
  usb: host: xhci: unconditionally call xhci_unmap_td_bounce_buffer()
  usb: host: xhci: convert to list_for_each_entry_safe()
  usb: host: xhci: combine event TRB completion debugging messages
  usb: host: xhci: make a generic TRB tracer
  usb: host: xhci: add urb_enqueue/dequeue/giveback tracers
  usb: host: xhci: convert several if() to a single switch statement
  usb: host: xhci: remove newline from tracer
  usb: host: xhci: add xhci_virt_device tracer

Lu Baolu (5):
  usb: xhci: remove unnecessary second abort try
  usb: xhci: remove unnecessary assignment
  usb: xhci: avoid unnecessary calculation
  usb: xhci: use list_is_singular for cmd_list
  usb: xhci: remove unnecessary return in xhci_pci_setup()

Mathias Nyman (10):
  xhci: simplify if statement to make it more readable
  xhci: rename EP_HALT_PENDING to EP_STOP_CMD_PENDING
  xhci: detect stop endpoint race using pending timer instead of
    counter.
  xhci: remove unnecessary check for pending timer
  xhci: Introduce helper to turn one TRB into a no-op
  xhci: use the trb_to_noop() helper for command trbs
  xhci: rename size variable to num_tds
  xhci: Rename variables related to transfer descritpors
  xhci: simplify how we store TDs in urb private data
  xhci: refactor xhci_urb_enqueue

 Documentation/devicetree/bindings/usb/usb-xhci.txt |   1 +
 drivers/usb/host/xhci-dbg.c                        |  22 +-
 drivers/usb/host/xhci-ext-caps.h                   |   2 +-
 drivers/usb/host/xhci-hub.c                        |  14 +-
 drivers/usb/host/xhci-mem.c                        |  30 +-
 drivers/usb/host/xhci-pci.c                        |   6 +-
 drivers/usb/host/xhci-plat.c                       |   3 +
 drivers/usb/host/xhci-ring.c                       | 466 +++++++++---------
 drivers/usb/host/xhci-trace.h                      | 184 ++++++-
 drivers/usb/host/xhci.c                            | 212 ++++-----
 drivers/usb/host/xhci.h                            | 528 ++++++++++++++++++---
 11 files changed, 985 insertions(+), 483 deletions(-)

-- 
1.9.1

--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to