Re: iwlwifi: Queue 16 stuck for 10000 ms - Microcode SW error detected.

2015-06-07 Thread Emmanuel Grumbach
On Sun, Jun 7, 2015 at 5:53 PM, Emmanuel Grumbach egrumb...@gmail.com wrote: On Sun, Jun 7, 2015 at 3:47 PM, Dominik Brodowski li...@dominikbrodowski.net wrote: On Sun, May 31, 2015 at 12:37:19PM +0300, Emmanuel Grumbach wrote: On Sun, May 31, 2015 at 9:52 AM, Dominik Brodowski

Re: [PATCH] rtlwifi: rtl8192c: Add init codes for fw_version and fw_subversion.

2015-06-07 Thread Taehee Yoo
2015-06-07 1:18 GMT+09:00 Larry Finger larry.fin...@lwfinger.net: On 06/06/2015 06:02 AM, Taehee Yoo wrote: The variable fw_version is used in the _ResetDigitalProcedure1(). but It is not initialized. so I add init codes for fw_version and fw_subversion. Signed-off-by: Taehee Yoo

[PATCH] net:rtlwifi:fix tm_trigger usage

2015-06-07 Thread Hans Ulli Kroll
While working on getting my rtl8821au driver in pretty shape for inclusion, it is dicosvered that the tm_trigger flag is used only for the first device using this driver. This flag handles the thermal power management in the hardware. To change this add a entry in sttruct rtl_dm, so each device

Re: [PATCH V2 1/3] rtlwifi: rtl8192cu: remove duplicated routine in _rtl92c_phy_rf6052_config_parafile

2015-06-07 Thread Taehee Yoo
2015-06-06 21:42 GMT+09:00 Kalle Valo kv...@codeaurora.org: Taehee Yoo ap420...@gmail.com writes: in the _rtl92c_phy_rf6052_config_parafile(), cases RF90_PATH_A and RF90_PATH_B call the same routine. so i remove one of these routine. also the return routine is duplicated. so i remove it.

[PATCH V2 2/3] rtlwifi: rtl8192cu: debug message change RTL8192CE to RTL8192CU

2015-06-07 Thread Taehee Yoo
In the rtlwifi/rtl8192cu, I change debug message RTL8192CE to RTL8192CU. Signed-off-by: Taehee Yoo ap420...@gmail.com --- drivers/net/wireless/rtlwifi/rtl8192cu/phy.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/net/wireless/rtlwifi/rtl8192cu/phy.c

[PATCH 2/2] bcma: lower dependency of BCMA_DRIVER_PCI_HOSTMODE

2015-06-07 Thread Rafał Miłecki
This extension of BCMA_DRIVER_PCI has no reason to depend on BCMA_HOST_PCI. User may just want to have PCI device attached to SoC registered without enabling any extra client mode code. This can be useful when having non-bcma PCI device attached or when using other PCI driver. Signed-off-by:

[PATCH 1/2] bcma: make calls to PCI hostmode functions config-safe

2015-06-07 Thread Rafał Miłecki
Signed-off-by: Rafał Miłecki zaj...@gmail.com --- include/linux/bcma/bcma_driver_pci.h | 11 +++ 1 file changed, 11 insertions(+) diff --git a/include/linux/bcma/bcma_driver_pci.h b/include/linux/bcma/bcma_driver_pci.h index 5ba6918..9657f11 100644 ---

[PATCH 6/6] wil6210: reorder init sequence

2015-06-07 Thread Vladimir Kondratiev
Need to reorder init sequence to run wil_platform_init before pci_enable_device. Assumption is platform init may be required before device may be enabled. Another issue, platform uninit should be called after pci_disable_device because platform uninit may render pci device non-accessible.

[PATCH 5/6] wil6210: platform hooks for modile init/exit

2015-06-07 Thread Vladimir Kondratiev
Provide platform hooks for module init/exit. If platform require to perform some specific actions in global context, this is where to do so. Example may be turning on power for the PCIE based on DT information. Signed-off-by: Vladimir Kondratiev qca_vkond...@qca.qualcomm.com ---

[PATCH 4/6] wil6210: Support hidden SSID

2015-06-07 Thread Vladimir Kondratiev
From: Hamad Kadmany qca_hkadm...@qca.qualcomm.com Pass hidden SSID information to FW for proper operation. In order to be able to scan/connect to the hidden SSID, SSID setting is added when scan is requested from FW. SSID scanning currently supports single SSID due to FW limitation.

[PATCH 0/6] wil6210 patches

2015-06-07 Thread Vladimir Kondratiev
Small fixes here and there; save for hidden SSID Hamad Kadmany (1): wil6210: Support hidden SSID Vladimir Kondratiev (5): wil6210: modparam for bcast ring size wil6210: add NIC memory region mac_rgf_ext wil6210: add per-MCS Rx stats wil6210: platform hooks for modile init/exit

[PATCH 2/6] wil6210: add NIC memory region mac_rgf_ext

2015-06-07 Thread Vladimir Kondratiev
Firmware defines new memory region, mac_rgf_ext that need to be accessed from the host for debug purposes. Add corresponded mapping Signed-off-by: Vladimir Kondratiev qca_vkond...@qca.qualcomm.com --- drivers/net/wireless/ath/wil6210/wil6210.h | 2 +- drivers/net/wireless/ath/wil6210/wmi.c

[PATCH 3/6] wil6210: add per-MCS Rx stats

2015-06-07 Thread Vladimir Kondratiev
Provide detailed statistics for the Rx frames per MCS Statistics printed in stations debugfs entry Signed-off-by: Vladimir Kondratiev qca_vkond...@qca.qualcomm.com --- drivers/net/wireless/ath/wil6210/debugfs.c | 8 +++- drivers/net/wireless/ath/wil6210/txrx.c| 2 ++

[PATCH 1/6] wil6210: modparam for bcast ring size

2015-06-07 Thread Vladimir Kondratiev
Control Bcast ring size in similar way as Rx and Tx ones, through bcast_ring_order modparam, actual ring size is 1 order Signed-off-by: Vladimir Kondratiev qca_vkond...@qca.qualcomm.com --- drivers/net/wireless/ath/wil6210/main.c | 2 ++ 1 file changed, 2 insertions(+) diff --git

Re: [PATCH V2] rtlwifi: rtl8192c: Add init codes for fw_version and fw_subversion.

2015-06-07 Thread Taehee Yoo
2015-06-08 0:05 GMT+09:00 Larry Finger larry.fin...@lwfinger.net: On 06/07/2015 08:33 AM, Taehee Yoo wrote: The variable fw_version is used in the _ResetDigitalProcedure1(). but It is not initialized. so I add init codes for fw_version and fw_subversion. Signed-off-by: Taehee Yoo

[PATCH V2 3/3] rtlwifi: rtl8192cu: Fix variable isfirst_ampdu

2015-06-07 Thread Taehee Yoo
rtl92cu_rx_query_desc set a isampdu twice. but second code is related to isfirst_ampdu. so i change it. Signed-off-by: Taehee Yoo ap420...@gmail.com --- drivers/net/wireless/rtlwifi/rtl8192cu/trx.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

Re: iwlwifi: Queue 16 stuck for 10000 ms - Microcode SW error detected.

2015-06-07 Thread Dominik Brodowski
On Sun, May 31, 2015 at 12:37:19PM +0300, Emmanuel Grumbach wrote: On Sun, May 31, 2015 at 9:52 AM, Dominik Brodowski li...@dominikbrodowski.net wrote: On Sun, May 31, 2015 at 09:29:22AM +0300, Emmanuel Grumbach wrote: No joy. Firmware 25.27.13.0 also is not happy at times: Are you

Re: [PATCH V2] rtlwifi: rtl8192c: Add init codes for fw_version and fw_subversion.

2015-06-07 Thread Larry Finger
On 06/07/2015 08:33 AM, Taehee Yoo wrote: The variable fw_version is used in the _ResetDigitalProcedure1(). but It is not initialized. so I add init codes for fw_version and fw_subversion. Signed-off-by: Taehee Yoo ap420...@gmail.com --- V2 - Moved new statements into location where header is

[PATCH V2] rtlwifi: rtl8192c: Add init codes for fw_version and fw_subversion.

2015-06-07 Thread Taehee Yoo
The variable fw_version is used in the _ResetDigitalProcedure1(). but It is not initialized. so I add init codes for fw_version and fw_subversion. Signed-off-by: Taehee Yoo ap420...@gmail.com --- drivers/net/wireless/rtlwifi/rtl8192c/fw_common.c | 3 ++- 1 file changed, 2 insertions(+), 1

Re: [PATCH] rtlwifi: rtl8192cu: Modify _rtl92cu_phy_set_rf_power_state().

2015-06-07 Thread Taehee Yoo
2015-06-07 1:31 GMT+09:00 Larry Finger larry.fin...@lwfinger.net: On 06/06/2015 06:17 AM, Taehee Yoo wrote: I change the RTL8192CE routines to the RTL8192CU routines in the _rtl92cu_phy_set_rf_power_state(). These RTL8192CU routines are copy codes of vendor driver. Signed-off-by: Taehee Yoo

Re: [PATCH V2] rtlwifi: rtl8192c: Add init codes for fw_version and fw_subversion.

2015-06-07 Thread Larry Finger
On 06/07/2015 10:18 AM, Taehee Yoo wrote: 2015-06-08 0:05 GMT+09:00 Larry Finger larry.fin...@lwfinger.net: On 06/07/2015 08:33 AM, Taehee Yoo wrote: The variable fw_version is used in the _ResetDigitalProcedure1(). but It is not initialized. so I add init codes for fw_version and

[PATCH] ath10k: enable VHT for IBSS

2015-06-07 Thread Janusz Dziedzic
Enable VHT support for IBSS. Signed-off-by: Janusz Dziedzic janusz.dzied...@tieto.com --- drivers/net/wireless/ath/ath10k/mac.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/drivers/net/wireless/ath/ath10k/mac.c b/drivers/net/wireless/ath/ath10k/mac.c index f4de717..14a8f25 100644 ---

[PATCH v2 1/2] staging: rtl8723au: core: avoid bitwise arithmetic with forced endianness

2015-06-07 Thread David Decotigny
This fixes bitwise arithmetic performed on the host on a variable previously converted to little-endian, and subsequently converted again to little-endian: - issue_action_BA23a() called with status crafted in host byte order - status converted to LE - bitwise arithmetic on the (LE) status,

[PATCH v2 0/2] staging: rtl8723au: core: endianness issues

2015-06-07 Thread David Decotigny
The code shows a couple inconsistencies (described in commit descriptions) which would not be an issue on little-endian cpus, but could cause breakage on non-LE cpus. Note: I could not test on real hardware, these patches created based on sparse reports. Hostory: - resending the same patches to

[PATCH v2 2/2] staging: rtl8723au: core: remove redundant endianness conversion

2015-06-07 Thread David Decotigny
Source and destination have the same little-endian annotation: this patch removes incorrect byte-swap on non-LE cpus. This addresses the following sparse warning: drivers/staging/rtl8723au/core/rtw_mlme_ext.c:3911:56: warning: incorrect type in argument 1 (different base types)

RE: wl18xx: wlconf kernel compatibility

2015-06-07 Thread Machani, Yaniv
Hi, As the configuration file is HW depended it should be created per platform, we have set this wiki page and script to help with initial setup : http://processors.wiki.ti.com/index.php/Open_Source_Wireless_Connectivity_wlconf We have also pushed a patch that makes sure the driver will not crash