Re: [PATCH] nfc: s3fwrn5: fix platform_no_drv_owner.cocci warnings

2015-10-06 Thread Robert Baldyga
On 10/07/2015 02:40 AM, kbuild test robot wrote: > drivers/nfc/s3fwrn5/i2c.c:293:3-8: No need to set .owner here. The core will > do it. > > Remove .owner field if calls are used which set it automatically > > Generated by: scripts/coccinelle/api/platform_no_drv_owner.cocci > > CC: Robert Bald

[PATCH] staging: wilc1000: fix kzalloc-simple.cocci warnings

2015-10-06 Thread kbuild test robot
drivers/staging/wilc1000/host_interface.c:2852:15-22: WARNING: kzalloc should be used for pu8keybuf, instead of kmalloc/memset drivers/staging/wilc1000/host_interface.c:2904:15-22: WARNING: kzalloc should be used for pu8keybuf, instead of kmalloc/memset drivers/staging/wilc1000/host_interface.c:6

Re: [PATCH next] staging: wilc1000: avoid NULL pointer dereference on error

2015-10-06 Thread Dan Carpenter
On Wed, Oct 07, 2015 at 07:08:25AM +0200, Vincent Stehlé wrote: > drivers/staging/wilc1000/host_interface.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/staging/wilc1000/host_interface.c > b/drivers/staging/wilc1000/host_interface.c > index 2cf82b2..2fe3023 10

Re: [PATCH 2/2] ath10k: set peer MFP flag in peer assoc command

2015-10-06 Thread kbuild test robot
Hi Tamizh, [auto build test ERROR on next-20151006 -- if it's inappropriate base, please ignore] config: xtensa-allyesconfig (attached as .config) reproduce: wget https://git.kernel.org/cgit/linux/kernel/git/wfg/lkp-tests.git/plain/sbin/make.cross -O ~/bin/make.cross chm

Re: [PATCH 02/10] staging: wilc1000: remove typedef from tenuWIDtype

2015-10-06 Thread Tony Cho
On 2015년 10월 07일 00:14, Mike Rapoport wrote: On Tue, Oct 06, 2015 at 06:42:13PM +0900, Tony Cho wrote: From: Leo Kim This patch remove typedef from the enum tenuWIDtype and rename it to WID_TYPE. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/coreconfigurato

[PATCH 2/2] ath10k: set peer MFP flag in peer assoc command

2015-10-06 Thread c_traja
From: Tamizh chelvam Set peer's management frame protection flag in peer assoc command, this setting will enable/disable encrytion of management frames in fw. Setting of this flag is based on whether MFP is enabled/disabled at STA and a firmware feature flag ATH10K_FW_FEATURE_MFP_SUPPORT. This i

[PATCH 1/2] ath10k: Add abstraction layer for peer flags

2015-10-06 Thread c_traja
From: Tamizh chelvam Abstraction layer for peer flags is added to fix ABI breakage. Signed-off-by: Tamizh chelvam Signed-off-by: SenthilKumar Jegadeesan --- drivers/net/wireless/ath/ath10k/core.h|1 + drivers/net/wireless/ath/ath10k/mac.c | 33 +-- drivers/net/wireless/a

[PATCH] Revert "mac80211: remove exposing 'mfp' to drivers"

2015-10-06 Thread c_traja
From: Tamizh chelvam This reverts commit 5c48f1201744233d4f235c7dd916d5196ed20716. Some device drivers (ath10k) offload part of aggregation including AddBA/DelBA negotiations to firmware. In such scenario, the PMF configuration of the station needs to be provided to driver to enable encryption o

[PATCH next] staging: wilc1000: avoid NULL pointer dereference on error

2015-10-06 Thread Vincent Stehlé
The host_int_init() function can dereference the pstrWFIDrv pointer while it is NULL on its error path. Jump directly to the _fail_ error label in the end of the error handling path to avoid that. By doing that we also skip stopping our kthread and destroying our message queue, but they wer

Re: [PATCH v2] staging: rtl8723au: Fix sparse errors in rtl8723a_cmd.c

2015-10-06 Thread Jacob Kiefer
On Wed, Oct 07, 2015 at 12:11:34AM +0100, Al Viro wrote: > On Tue, Oct 06, 2015 at 12:32:28AM -0400, Jacob Kiefer wrote: > > > int rtl8723a_set_rssi_cmd(struct rtw_adapter *padapter, u8 *param) > > { > > - *((u32 *)param) = cpu_to_le32(*((u32 *)param)); > > + __le32 leparam; > > > > - Fil

[PATCH] nfc: s3fwrn5: fix platform_no_drv_owner.cocci warnings

2015-10-06 Thread kbuild test robot
drivers/nfc/s3fwrn5/i2c.c:293:3-8: No need to set .owner here. The core will do it. Remove .owner field if calls are used which set it automatically Generated by: scripts/coccinelle/api/platform_no_drv_owner.cocci CC: Robert Baldyga Signed-off-by: Fengguang Wu --- i2c.c |1 - 1 file ch

[PATCH] ath10k: Fix OFDM rx-rate reporting.

2015-10-06 Thread greearb
From: Ben Greear The ath10k hw_rate codes are duplicated for cck and ofdm modes, so we have to check a flag to see if rate is cck or not when searching for the proper bitrate. This fixes monitor mode reporting invalid rates on my setup. Signed-off-by: Ben Greear --- drivers/net/wireless/ath/a

Re: [PATCH v2] staging: rtl8723au: Fix sparse errors in rtl8723a_cmd.c

2015-10-06 Thread Al Viro
On Tue, Oct 06, 2015 at 12:32:28AM -0400, Jacob Kiefer wrote: > int rtl8723a_set_rssi_cmd(struct rtw_adapter *padapter, u8 *param) > { > - *((u32 *)param) = cpu_to_le32(*((u32 *)param)); > + __le32 leparam; > > - FillH2CCmd(padapter, RSSI_SETTING_EID, 3, param); > + leparam = cp

Re: [PATCH RESEND] ath9k: Fix NF CCA limits for AR9287 and AR9227

2015-10-06 Thread Adrian Chadd
from qca-wifi-1.2: ar5416phy.h:#define AR_PHY_CCA_NOM_VAL_KIWI_2GHZ -120 ar5416phy.h:#define AR_PHY_CCA_MIN_GOOD_VAL_KIWI_2GHZ-127 ar5416phy.h:#define AR_PHY_CCA_MAX_GOOD_VAL_KIWI_2GHZ-110 .. and: ar5416phy.h:#define AR_PHY_CCA_NOM_VAL_MERLIN_2GHZ -112 ar5416phy.h:#defi

Re: [PATCH 02/10] staging: wilc1000: remove typedef from tenuWIDtype

2015-10-06 Thread Mike Rapoport
On Tue, Oct 06, 2015 at 06:42:13PM +0900, Tony Cho wrote: > From: Leo Kim > > This patch remove typedef from the enum tenuWIDtype > and rename it to WID_TYPE. > > Signed-off-by: Leo Kim > Signed-off-by: Tony Cho > --- > drivers/staging/wilc1000/coreconfigurator.h | 2 +- > drivers/staging/wil

Re: [PATCH] rtlwifi: rtl818x: Move drivers into new realtek directory

2015-10-06 Thread Larry Finger
On 10/06/2015 09:39 AM, Kalle Valo wrote: Larry Finger writes: Now that a new mac80211-based driver for Realtek devices has been submitted, it is time to reorganize the directories. Rather than having directories rtlwifi and rtl818x be in drivers/net/wireless/, they will now be in drivers/net/

Re: [PATCH] rtlwifi: rtl818x: Move drivers into new realtek directory

2015-10-06 Thread Kalle Valo
Larry Finger writes: > Now that a new mac80211-based driver for Realtek devices has been submitted, > it is time to reorganize the directories. Rather than having directories > rtlwifi and rtl818x be in drivers/net/wireless/, they will now be in > drivers/net/wireless/realtek/. This change simpli

Re: [PATCH RESEND] ath9k: Fix NF CCA limits for AR9287 and AR9227

2015-10-06 Thread Kalle Valo
Martin Blumenstingl writes: > The FreeBSD driver [0] uses the same 2G values as for the AR9280 chips. > Using the same values in ath9k results in much better throughput for me. > > Before this patch I had a huge amount of packet loss (sometimes up to > 40%) and the max transfer speed was somewher

RE: [PATCH] mwifiex: control WLAN and bluetooth coexistence modes

2015-10-06 Thread Amitkumar Karwar
Hi Kalle, > From: Kalle Valo [mailto:kv...@codeaurora.org] > Sent: Saturday, September 26, 2015 11:23 PM > To: Amitkumar Karwar > Cc: linux-wireless@vger.kernel.org; Cathy Luo; Nishant Sarmukadam > Subject: Re: [PATCH] mwifiex: control WLAN and bluetooth coexistence > modes > > Amitkumar Karwar

Deadlock in mac80211 running 3.18.11 + compat-wireless 2015-03-09

2015-10-06 Thread Michael Braun
Dear Maintainer, I'm running a custom version of OpenWRT based on Linux 3.18.11 with compat-wireless 2015-03-09 and am sometimes experiencing deadlock warnings on P1020WLAN (PPC). Thought, I think I have reason to believe that the modifications do not affect the deadlock; I currently do not ha

Re: Deadlock in mac80211 running 3.18.11 + compat-wireless 2015-03-09

2015-10-06 Thread Johannes Berg
commit 2c158887f1185e04b3763ae346da9f71fcbc4429 Author: Johannes Berg Date: Thu Mar 12 19:28:31 2015 +0100 mac80211: agg-tx: avoid sending DelBA with sta->lock held The rate control locking caused a potential deadlock here due to the locks being acquired in different orders, so

[PATCH 2/2] ath10k: select board data based on BMI chip id and board id

2015-10-06 Thread Kalle Valo
From: Manikanta Pubbisetty QCA99X0 uses radio specific board names based on chip id and board id combinations. We get these IDs from the target using BMI after otp.bin has been started. This patch reorders the call to the function ath10k_core_fetch_board_file so that we have OTP binary before re

[PATCH 1/2] ath10k: add board 2 API support

2015-10-06 Thread Kalle Valo
From: Manikanta Pubbisetty QCA6174 needs different board files based on board type. To make it easier to distribute multiple board files and automatically choose correct board file create a simple TLV file format following the same principles as with FW IEs. The file is named board-2.bin and cont

[PATCH 0/2] ath10k: implement board API 2 support

2015-10-06 Thread Kalle Valo
Implement board 2 API to make it easier to have multiple board files and automatically choose correct one. --- Manikanta Pubbisetty (2): ath10k: add board 2 API support ath10k: select board data based on BMI chip id and board id drivers/net/wireless/ath/ath10k/bmi.h | 10 + dri

Re: [PATCH] ath10k: use pre-allocated DMA buffer in Tx

2015-10-06 Thread Kalle Valo
Peter Oh writes: > ath10k driver is using dma_pool_alloc per packet and dma_pool_free > in coresponding at Tx completion. > Use of pre-allocated DMA buffer in Tx will improve saving CPU resource > by 5% while it consumes about 56KB memory more as trade off. > > Signed-off-by: Peter Oh Applied,

Re: [PATCH] ath10k: use Rx decap mode configured when driver registered

2015-10-06 Thread Kalle Valo
Peter Oh writes: > ath10k is using Native WiFi mode as default mode for both of > Tx and Rx path, but it could be changed when driver registers > with a module parameter for specific purpose such as mesh. > > The Rx decap mode sent to firmware during WMI initialization should > use the same mode

Re: [PATCH 0/2] ath10k: implement debugfs interface for Transmit Power Control stats

2015-10-06 Thread Kalle Valo
Kalle Valo writes: > This implements a simple interface for debugging TPC stats. I did a small hack > to sparse to check endian usage with signed 32 bit values. > > --- > > Kalle Valo (1): > ath10k: add a_sle32_to_cpu() > > Maharaja Kennadyrajan (1): > ath10k: implement debugfs interf

Re: [PATCH 0/6] ath10k: few checkpatch fixes

2015-10-06 Thread Kalle Valo
Kalle Valo writes: > I found few checkpatch warnings and fixed those. All trivial. > > --- > > Kalle Valo (6): > ath10k: fix checkpatch warning about logical continuations > ath10k: indentation fixes > ath10k: brace style fixes > ath10k: remove void function return stateme

[PATCH 10/10] staging: wilc1000: remove _tstrJoinParam from join_bss_param

2015-10-06 Thread Tony Cho
From: Leo Kim This patch removes struct _tstrJoinParam from the struct join_bss_param because it is not used inside the struct. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/wilc1

[PATCH 07/10] staging: wilc1000: remove unused struct tstrWidJoinReqExt

2015-10-06 Thread Tony Cho
From: Leo Kim This patch removes struct tstrWidJoinReqExt because it's not used. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 6 -- 1 file changed, 6 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c b/drivers/staging/w

[PATCH 08/10] staging: wilc1000: remove unused struct tstrBssTable

2015-10-06 Thread Tony Cho
From: Leo Kim This patch removes struct tstrBssTable with related comment. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 6 -- 1 file changed, 6 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c b/drivers/staging/wilc100

[PATCH 04/10] staging: wilc1000: rename the member variable, u16WIDid of wid

2015-10-06 Thread Tony Cho
From: Leo Kim This patch renames u16WIDid of struct wid to id. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/coreconfigurator.c | 8 +- drivers/staging/wilc1000/coreconfigurator.h | 2 +- drivers/staging/wilc1000/host_interface.c | 188 ++---

[PATCH 09/10] staging: wilc1000: remove typedef from tstrJoinBssParam

2015-10-06 Thread Tony Cho
From: Leo Kim This patch removes typedef from the struct tstrJoinBssParam and renames it to join_bss_param. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 18 +- 1 file changed, 9 insertions(+), 9 deletions(-) diff --git a/drive

[PATCH 03/10] staging: wilc1000: rename the member variable, enuWIDtype of wid

2015-10-06 Thread Tony Cho
From: Leo Kim This patch renames enuWIDtype of struct wid to type. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/coreconfigurator.h | 2 +- drivers/staging/wilc1000/host_interface.c | 186 ++-- 2 files changed, 94 insertions(+), 94 del

[PATCH 06/10] staging: wilc1000: rename the member variable, ps8WidVal of wid

2015-10-06 Thread Tony Cho
From: Leo Kim This patch renames ps8WidVal of struct wid to val. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/coreconfigurator.c | 4 +- drivers/staging/wilc1000/coreconfigurator.h | 2 +- drivers/staging/wilc1000/host_interface.c | 278 ++-

[PATCH 02/10] staging: wilc1000: remove typedef from tenuWIDtype

2015-10-06 Thread Tony Cho
From: Leo Kim This patch remove typedef from the enum tenuWIDtype and rename it to WID_TYPE. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/coreconfigurator.h | 2 +- drivers/staging/wilc1000/host_interface.h | 2 +- drivers/staging/wilc1000/wilc_wlan_if.h |

[PATCH 05/10] staging: wilc1000: rename the member variable, s32ValueSize of wid

2015-10-06 Thread Tony Cho
From: Leo Kim This patch renames s32ValueSize of struct wid to size. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/coreconfigurator.c | 6 +- drivers/staging/wilc1000/coreconfigurator.h | 2 +- drivers/staging/wilc1000/host_interface.c | 210 ++-

[PATCH 01/10] staging: wilc1000: remove typedef from tstrWID

2015-10-06 Thread Tony Cho
From: Leo Kim This patch removes typedef from the struct tstrWID and rename it to wid. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/coreconfigurator.c | 2 +- drivers/staging/wilc1000/coreconfigurator.h | 7 +-- drivers/staging/wilc1000/host_interface.c | 92

[ath10k] Disable multicast rates

2015-10-06 Thread Ángel Suero
Dear Mr. Valo, Let me introduce you to our company. AOIFES is a spanish company which develops software for embedded systems. We are using wireless modules in our systems. These modules are using the ath10k driver. We are doing some wireless streaming tests using g+n wireless mode and we have som