Re: [PATCH] iwlwifi:Fix incorrect fallthrough in switch statement in the function iwl_mvm_check_running_scans

2015-10-08 Thread Coelho, Luciano
On Tue, 2015-09-22 at 20:24 -0400, Nicholas Krause wrote: > This fixes incorrect fallthrough in the switch statment checking > the scan type passed by the caller to iwl_mvm_check_running_scans > for the switch case IWL_MVM_SCAN_SCHED to return directly after > the call to iwl_mvm_scan_stop in

[PATCH 06/11] staging: wilc1000: rename strHostIFpmkidAttr of union host_if_key_attr

2015-10-08 Thread Tony Cho
This patch renames strHostIFpmkidAttr of union host_if_key_attr to pmkid to avoid CamelCase naming convention. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 18 +- 1 file changed, 9 insertions(+), 9 deletions(-) diff --git

[PATCH 04/11] staging: wilc1000: rename strHostIFwepAttr of union host_if_key_attr

2015-10-08 Thread Tony Cho
This patch renames strHostIFwepAttr of union host_if_key_attr to wep to avoid CamelCase naming convention. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 70 ++- 1 file changed, 31 insertions(+), 39 deletions(-) diff

[PATCH 02/11] staging: wilc1000: rename pstrCfgParamVal in struct cfg_param_attr

2015-10-08 Thread Tony Cho
This patch renames a variable of struct cfg_param_val in struct cfg_param_attr, pstrCfgParamVal to cfg_attr_info to avoid CamelCase naming convention. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 144 +++--- 1 file changed,

[PATCH 05/11] staging: wilc1000: rename strHostIFwpaAttr of union host_if_key_attr

2015-10-08 Thread Tony Cho
This patch renames strHostIFwpaAttr of union host_if_key_attr to wpa to avoid CamelCase naming convention. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 95 ++- 1 file changed, 44 insertions(+), 51 deletions(-) diff

[PATCH 03/11] staging: wilc1000: rename u32SetCfgFlag of struct cfg_param_val

2015-10-08 Thread Tony Cho
This patch renames u32SetCfgFlag of struct cfg_param_val to flag to avoid CamelCase naming convention. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 36 +++ drivers/staging/wilc1000/host_interface.h | 2 +-

[PATCH 10/11] staging: wilc1000: rename u8mode of struct host_if_wep_attr

2015-10-08 Thread Tony Cho
This patch renames u8mode of struct host_if_wep_attr to mode to avoid CamelCase naming convention. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git

Re: [PATCH] mac80211: add missing struct ieee80211_txq tid field initialization

2015-10-08 Thread Johannes Berg
Applied. johannes -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

[PATCH 07/11] staging: wilc1000: rename pu8WepKey of struct host_if_wep_attr

2015-10-08 Thread Tony Cho
This patch renames pu8WepKey of struct host_if_wep_attr to key in order to avoid CamelCase naming convention. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 18 +- 1 file changed, 9 insertions(+), 9 deletions(-) diff --git

Re: [PATCH] iw: Fix return values when parameters are wrong

2015-10-08 Thread Johannes Berg
On Wed, 2015-10-07 at 18:45 +0200, Ola Olsson wrote: > According to header file, wrong parameters > yield 1 as return value. > Also tried to fix the comments since one part > of it was unreadable. > That seems reasonable, but your patch (this one at least) is completely whitespace damaged. Did

[PATCH 11/11] staging: wilc1000: rename tenuAuth_type of struct host_if_wep_attr

2015-10-08 Thread Tony Cho
This patch renames tenuAuth_type of struct host_if_wep_attr to auth_type to avoid CamelCase naming convention. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git

Re: [PATCH] Revert "mac80211: remove exposing 'mfp' to drivers"

2015-10-08 Thread Johannes Berg
On Wed, 2015-10-07 at 09:52 -0700, Peter Oh wrote: > On 10/06/2015 10:10 PM, c_tr...@qti.qualcomm.com wrote: > > From: Tamizh chelvam > > > > This reverts commit 5c48f1201744233d4f235c7dd916d5196ed20716. > > > > Some device drivers (ath10k) offload part of aggregation

[PATCH 01/11] staging: wilc1000: replace drvHandler and hWFIDrv with hif_drv

2015-10-08 Thread Tony Cho
This patch replaces the variable names of struct host_if_drv used as the functions' input parameter, drvHandler and hWFIDrv with hif_drv. In addition, the local variable declared in many functions, pstrWFIDrv is removed and hif_drv is directly used. A debug message printing pstrWFIDrv is deleted

Re: [PATCH] iw: Memory leak in error condition

2015-10-08 Thread Johannes Berg
On Thu, 2015-10-01 at 01:27 +0200, Ola Olsson wrote: > Oh yes! :) > Suddenly valgrind was happy as well. > > From 2724dd259f2bf61a2b7c85a70a70fd640a583453 Mon Sep 17 00:00:00 > 2001 > From: Ola Olsson > Date: Thu, 1 Oct 2015 00:43:06 +0200 > Subject: [PATCH] iw:

Re: [PATCH] Remove superfluous header files

2015-10-08 Thread Johannes Berg
On Sun, 2015-10-04 at 23:08 +0200, Ola Olsson wrote: > if.h only contains if_nametoindex and the reverse. > Lets remove the inclusion in the source files where > these functions are not called. > Applied, with updated subject. Thanks! johannes -- To unsubscribe from this list: send the line

Re: [PATCH] iw: Display-interface-generation-if-available

2015-10-08 Thread Johannes Berg
On Tue, 2015-09-29 at 12:30 +0200, Olsson, Ola wrote: [attached patch] That email didn't make it to the list, perhaps due to the attachment. > + if (tb_msg[NL80211_ATTR_GENERATION]) > +>> > printf("%s\tgeneration %d\n", indent, > nla_get_u32(tb_msg[NL80211_ATTR_GENERATION]));

Re: [PATCH 01/14] staging: wilc1000: remove typedef from tstrWILC_UsrScanReq

2015-10-08 Thread Greg KH
On Thu, Oct 08, 2015 at 10:49:08AM +0900, Tony Cho wrote: > From: Leo Kim > > This patch removes typedef from the struct tstrWILC_UsrScanReq with > related comments and renames it to user_scan_req. > > Signed-off-by: Leo Kim > Signed-off-by: Tony Cho

Re: [PATCH 01/10] staging: wilc1000: remove typedef from tstrWID

2015-10-08 Thread Greg KH
On Tue, Oct 06, 2015 at 06:42:12PM +0900, Tony Cho wrote: > From: Leo Kim > > This patch removes typedef from the struct tstrWID and > rename it to wid. > > Signed-off-by: Leo Kim > Signed-off-by: Tony Cho > --- >

Re: [PATCH 01/11] staging: wilc1000: replace drvHandler and hWFIDrv with hif_drv

2015-10-08 Thread Greg KH
On Thu, Oct 08, 2015 at 06:10:46PM +0900, Tony Cho wrote: > This patch replaces the variable names of struct host_if_drv used as the > functions' input parameter, drvHandler and hWFIDrv with hif_drv. In > addition, the local variable declared in many functions, pstrWFIDrv is > removed and hif_drv

Re: [PATCH] ath10k: use pre-allocated DMA buffer in Tx

2015-10-08 Thread Kalle Valo
Peter Oh writes: > ath10k driver is using dma_pool_alloc per packet and dma_pool_free > in coresponding at Tx completion. > Use of pre-allocated DMA buffer in Tx will improve saving CPU resource > by 5% while it consumes about 56KB memory more as trade off. > >

[PATCH] ath10k: Fix cleanup in ath10k_thermal_unregister

2015-10-08 Thread Mohammed Shafi Shajakhan
From: Mohammed Shafi Shajakhan First remove the 'cooling_device#n' syslink created for ath10k and then unregsiter from the thermal subsystem(cooling) Signed-off-by: Mohammed Shafi Shajakhan --- drivers/net/wireless/ath/ath10k/thermal.c |

Re: [PATCH 1/6] staging: wilc1000: remove typedef from tstrWILC_WFIDrv

2015-10-08 Thread Greg KH
On Mon, Oct 05, 2015 at 07:28:09PM +0900, Tony Cho wrote: > From: Leo Kim > > This patch removes typedef from the struct tstrWILC_WFIDrv and > rename it to host_if_drv. > This patch includes the removal of the comment for tstrWILC_WFIDrv as well. > > Signed-off-by: Leo Kim

[PATCH] mac80211: Fix hwflags debugfs file format

2015-10-08 Thread Mohammed Shafi Shajakhan
From: Mohammed Shafi Shajakhan Commit 30686bf7f5b3 ("mac80211: convert HW flags to unsigned long bitmap") accidentally removed the newline delimiter from the hwflags debugfs file. Fix this by adding back the newline between the HW flags. Signed-off-by: Mohammed Shafi

Re: [PATCH 1/1] New driver: rtl8xxxu (mac80211)

2015-10-08 Thread Jakub Sitnicki
Hi Jes, On Sat, Aug 29, 2015 at 11:18 PM CEST, jes.soren...@redhat.com wrote: > This is an alternate driver for a number of Realtek WiFi USB devices, > including RTL8723AU, RTL8188CU, RTL8188RU, RTL8191CU, and RTL8192CU. > It was written from scratch utilizing the Linux mac80211 stack. > > After

[PATCH] ath10k: Cleanup ath10k_mac_register() error handling

2015-10-08 Thread Jeff Johnson
The logic in the error-handling path of ath10k_mac_register() is divergent from the logic in ath10k_mac_unregister(). Update the ath10k_mac_register() error handling logic to align with the ath10k_mac_unregister() logic. Signed-off-by: Jeff Johnson ---

Re: [PATCH] ath10k: use pre-allocated DMA buffer in Tx

2015-10-08 Thread Peter Oh
Does it happen after you applied copy engine patchset or even without the patchset? I saw ath10k_pci_htt_tx_cb in backtrace which is not merged to master branch yet. If it only happens after the patchset, I'll apply them and look into it if any possibilities are there. On 10/08/2015 04:49 AM,

Re: [PATCH] ath10k: use pre-allocated DMA buffer in Tx

2015-10-08 Thread Kalle Valo
Peter Oh writes: > Does it happen after you applied copy engine patchset or even without > the patchset? I saw ath10k_pci_htt_tx_cb in backtrace which is not > merged to master branch yet. If it only happens after the patchset, > I'll apply them and look into it if any

Re: [PATCH] ath10k: use pre-allocated DMA buffer in Tx

2015-10-08 Thread Peter Oh
I did quick glance on the warning. The dma unmap warning is caused by dma_unmap_single called per every received packet in ath10k_pci_htt_tx_cb() <- ath10k_pci_htt_rx_cb(). The physical address is assigned by rx refill function for rx ring. So it looks like copy engine patchset has a bug. FYI,

Re: [PATCH 01/11] brcmfmac: expose device memory to devcoredump subsystem

2015-10-08 Thread kbuild test robot
Hi Arend, [auto build test ERROR on next-20151008 -- if it's inappropriate base, please ignore] config: x86_64-randconfig-x011-201540 (attached as .config) reproduce: # save the attached .config to linux build tree make ARCH=x86_64 All errors (new ones prefixed

Re: [PATCH 1/1] New driver: rtl8xxxu (mac80211)

2015-10-08 Thread Jes Sorensen
Jakub Sitnicki writes: > Hi Jes, > > On Sat, Aug 29, 2015 at 11:18 PM CEST, jes.soren...@redhat.com wrote: >> This is an alternate driver for a number of Realtek WiFi USB devices, >> including RTL8723AU, RTL8188CU, RTL8188RU, RTL8191CU, and RTL8192CU. >> It was written from

Re: [PATCH 1/1] New driver: rtl8xxxu (mac80211)

2015-10-08 Thread Stefan Lippers-Hollmann
Hi On 2015-10-08, Jes Sorensen wrote: > Jakub Sitnicki writes: > > Hi Jes, > > > > On Sat, Aug 29, 2015 at 11:18 PM CEST, jes.soren...@redhat.com wrote: > >> This is an alternate driver for a number of Realtek WiFi USB devices, > >> including RTL8723AU, RTL8188CU, RTL8188RU,

Re: [PATCH 1/1] New driver: rtl8xxxu (mac80211)

2015-10-08 Thread Jes Sorensen
Stefan Lippers-Hollmann writes: > Hi > > On 2015-10-08, Jes Sorensen wrote: >> I have an 8188EU dongle in my wifi dongle pouch, together with several >> other yet to be supported ones :) I am currently trying to get the >> 8723BU and 8192EU working, but I haven't had time to work

Re: [PATCH 1/1] New driver: rtl8xxxu (mac80211)

2015-10-08 Thread Jes Sorensen
Jes Sorensen writes: > Jakub Sitnicki writes: >> AFAICT, in this regard, rtl8188eu driver has more in common with the >> rtlwifi/rtl8188ee driver. >> >> I'm curious what is your opinion on this. In particular, do you see any >> reason not to make an

[PATCH] brcmfmac: fix waitqueue_active without memory barrier in brcmfmac driver

2015-10-08 Thread Kosuke Tatsukawa
brcmf_msgbuf_ioctl_resp_wake() seems to be missing a memory barrier which might cause the waker to not notice the waiter and miss sending a wake_up as in the following figure. brcmf_msgbuf_ioctl_resp_wake brcmf_msgbuf_ioctl_resp_wait

[RFC PATCH 1/2] airo: Track APList_rid in struct airo_info

2015-10-08 Thread Ondrej Zary
Instead of dynamically allocating APList, make it a member of struct airo_info to always track state of APList_rid. This simplifies suspend/resume and allows removal of readAPListRid. Signed-off-by: Ondrej Zary --- drivers/net/wireless/airo.c | 57

[RFC PATCH 2/2] airo: fix scan after SIOCSIWAP (airo_set_wap)

2015-10-08 Thread Ondrej Zary
SIOCSIWAP (airo_set_wap) affects scan: only the AP specified by SIOCSIWAP is present in scan results. This makes NetworkManager work for the first time but then unable to find any other APs. Clear APList before starting scan and set it back after scan completes to work-around the problem.

staging: wilc1000: WILC1000_DYNAMICALLY_ALLOCATE_MEMROY

2015-10-08 Thread Stanislav Kholmanskikh
Hi! I noticed that drivers/staging/wilc1000/Kconfic defines: config WILC1000_DYNAMICALLY_ALLOCATE_MEMROY bool "Dynamically allocate memory in real time" ---help--- This choice supports dynamic allocation of the memory for the receive buffer. The driver will

[PATCH 00/11] brcmfmac: cfg80211 callbacks and coredump

2015-10-08 Thread Arend van Spriel
This series provides following: * using netdev carrier state. * add and rework some cfg80211 callbacks mainly for AP mode. * use devcoredump when triggered by firmware event. The series is intended for 4.4 kernel and applies to the master branch of wireless-drivers-next repository. Arend van

[PATCH 07/11] brcmfmac: Add RSSI information to get_station.

2015-10-08 Thread Arend van Spriel
From: Hante Meuleman Reviewed-by: Arend Van Spriel Reviewed-by: Pieter-Paul Giesberts Signed-off-by: Hante Meuleman Signed-off-by: Arend van Spriel ---

[PATCH 03/11] brcmfmac: rename firmware_path to alternative_fw_path

2015-10-08 Thread Arend van Spriel
From: Franky Lin In brcmfmac the module parameter "firmware_path" is used as an alternative relative path under the search path used by firmware_class or ueventhelper. Rename the parameter to alternative_fw_path to avoid confusion. Reviewed-by: Pieter-Paul Giesberts

[PATCH] brcm80211: Add support for brcm4371

2015-10-08 Thread Eric Caruso
This is a new Broadcom chip and we should be able to recognize it. Signed-off-by: Eric Caruso --- drivers/net/wireless/brcm80211/brcmfmac/chip.c | 1 + drivers/net/wireless/brcm80211/brcmfmac/pcie.c | 9 +

[PATCH 1/2] staging: wilc1000: linux_wlan_spi: correct types

2015-10-08 Thread Stanislav Kholmanskikh
linux_spi_write(), linux_spi_read(), linux_spi_write_read(): nwi->io_func.u.spi.spi_tx = linux_spi_write; nwi->io_func.u.spi.spi_rx = linux_spi_read; nwi->io_func.u.spi.spi_trx = linux_spi_write_read; are expected to accept arguments of 'u8 *', u32 types: struct { int

[PATCH 2/2] staging: wilc1000: linux_wlan_spi: include header

2015-10-08 Thread Stanislav Kholmanskikh
A check using 'sparse' shows warnings in linux_wlan_spi.c: drivers/staging/wilc1000/linux_wlan_spi.c:43:19: warning: symbol 'wilc_spi_dev' was not declared. Should it be static? drivers/staging/wilc1000/linux_wlan_spi.c:71:19: warning: symbol 'wilc_bus' was not declared. Should it be static?

[PATCH 02/11] brcmfmac: Fix race condition between USB probe/load and disconnect.

2015-10-08 Thread Arend van Spriel
From: Hante Meuleman When a USB device gets disconnected due to for example removal then it is possible that it is still in the loading phase due to the asynchronous load routines. These routines can then possible access memory which has been freed. Fix this by mutex

[PATCH 04/11] brcmfmac: remove conversational comment

2015-10-08 Thread Arend van Spriel
Removing a comment that was only useful during the review of the change that introduced it and which should never have been submitted. Reviewed-by: Hante Meuleman Signed-off-by: Arend van Spriel --- drivers/net/wireless/brcm80211/brcmfmac/msgbuf.c | 3

[PATCH 10/11] brcmfmac: Remove unused state AP creating.

2015-10-08 Thread Arend van Spriel
From: Hante Meuleman Reviewed-by: Arend Van Spriel Reviewed-by: Pieter-Paul Giesberts Signed-off-by: Hante Meuleman Signed-off-by: Arend van Spriel ---

[PATCH 06/11] brcmfmac: Fix station info rate information.

2015-10-08 Thread Arend van Spriel
From: Hante Meuleman Txrate and rxrate in get_station got assigned first with value in kbps and then divided by 100 to get it in 100kbps unit. The problem with that is that type of rate is u16 which resulted in incorrect values for high data rate values. Reviewed-by:

[PATCH 11/11] brcmfmac: Properly set carrier state of netdev.

2015-10-08 Thread Arend van Spriel
From: Hante Meuleman Use the netif_carrier api to correctly set carrier state on the different modes. Reviewed-by: Arend Van Spriel Reviewed-by: Pieter-Paul Giesberts Reviewed-by: Franky (Zhenhui) Lin

[PATCH 01/11] brcmfmac: expose device memory to devcoredump subsystem

2015-10-08 Thread Arend van Spriel
Upon PSM watchdog event received from firmware the driver will obtain a memory snapshot of the device and expose it to user-space through the devcoredump framework. This will trigger a uevent. Reviewed-by: Hante Meuleman Reviewed-by: Franky (Zhenhui) Lin

[PATCH 05/11] brcmfmac: Rework p2p attach, use single method for p2p dev creation.

2015-10-08 Thread Arend van Spriel
From: Hante Meuleman When module param p2pon is used a p2p device is created at init. This patch reworks how this is done by using the same method as for a dynamically (by user space) created p2p device. Reviewed-by: Arend Van Spriel Reviewed-by:

[PATCH 08/11] brcmfmac: Add dump_station support to cfg80221 ops.

2015-10-08 Thread Arend van Spriel
From: Hante Meuleman With this feature it becomes possible to request a station assoc list. Reviewed-by: Arend Van Spriel Reviewed-by: Pieter-Paul Giesberts Signed-off-by: Hante Meuleman Signed-off-by:

Re: staging: wilc1000: WILC1000_DYNAMICALLY_ALLOCATE_MEMROY

2015-10-08 Thread Greg KH
On Thu, Oct 08, 2015 at 09:29:35PM +0300, Stanislav Kholmanskikh wrote: > Hi! > > I noticed that drivers/staging/wilc1000/Kconfic defines: > > config WILC1000_DYNAMICALLY_ALLOCATE_MEMROY > bool "Dynamically allocate memory in real time" > ---help--- > This choice