Re: [PATCH] staging/wilc: fix Kconfig dependencies, second try

2015-10-19 Thread Tony Cho
Hi Arnd Bergmann, When I apply this patch, I cannot make WILC1000 module (wilc1000.ko) because CONFIG_WILC1000 is y and also I can see some link errors for the cfg80211 APIs. Can you consider this patch? Thanks, Tony. On 2015년 10월 17일 05:45, Arnd Bergmann wrote: My first attempt to fix

Re: new regdb file format

2015-10-19 Thread Johannes Berg
On Mon, 2015-10-19 at 14:28 +0300, Eliad Peller wrote: > while at it - is there any way to indicate exclusion of some > channels? > e.g. channels 38/42 in US (the current rule is "(5170 - 5250 @ 40)", > which doesn't seem to forbid them) > Hm? Why would you want to do that, if you are allowed

Re: new regdb file format

2015-10-19 Thread Eliad Peller
On Mon, Oct 19, 2015 at 2:31 PM, Johannes Berg wrote: > On Mon, 2015-10-19 at 14:28 +0300, Eliad Peller wrote: > >> while at it - is there any way to indicate exclusion of some >> channels? >> e.g. channels 38/42 in US (the current rule is "(5170 - 5250 @ 40)", >> which

Re: new regdb file format

2015-10-19 Thread Eliad Peller
On Mon, Oct 19, 2015 at 2:53 PM, Johannes Berg wrote: > On Mon, 2015-10-19 at 14:52 +0300, Eliad Peller wrote: >> >> > Hm? Why would you want to do that, if you are allowed to use that >> > band? >> > >> The spec seems to indicate the allowed channel set for each

Re: [PATCH V3] staging: wilc1000: wilc_msgqueue.c : add goto statement

2015-10-19 Thread Mike Rapoport
On Mon, Oct 19, 2015 at 06:03:15PM +0900, Tony Cho wrote: > From: Leo Kim > > This patch uses goto statement to separet error conditionals into release_lock > and mem_free in wilc_mq_send. If unexpected errors happen, this function > cannot up the semaphore, otherwise, if no

Re: new regdb file format

2015-10-19 Thread Eliad Peller
On Thu, Oct 15, 2015 at 12:01 AM, Johannes Berg wrote: > Err. Let's try that again. > > I spent a bit of time thinking about a file format that would be more > extensible, yet still be loadable into the kernel without having to > parse it into new data structures in the

Re: new regdb file format

2015-10-19 Thread Johannes Berg
On Mon, 2015-10-19 at 14:52 +0300, Eliad Peller wrote: > > > Hm? Why would you want to do that, if you are allowed to use that > > band? > > > The spec seems to indicate the allowed channel set for each operating > class, and some channels are allowed only in some countries (tables > E-1 vs.

[PATCH RESEND 6/6] staging: wilc1000: fixes comparison to NULL could be written

2015-10-19 Thread Tony Cho
From: Leo Kim This patch fixes the checks reported by checkpatch.pl for comparison to NULL could be written. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 181

[PATCH 0/6] WILC1000 rebase and resend some of patch series

2015-10-19 Thread Tony Cho
This series of patches are resent after some of 40 patches are rebased. Leo Kim (6): staging: wilc1000: rename variable s32Error staging: wilc1000: move variable clients_count staging: wilc1000: move variable FALSE_FRMWR_CHANNEL staging: wilc1000: fixes unnecessary variable replacement

[PATCH RESEND 5/6] staging: wilc1000: fixes alignment should match open parenthesis

2015-10-19 Thread Tony Cho
From: Leo Kim This patch fixes the checks reported by checkpatch.pl for alignment should match open parenthesis. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 153

Re: FCC DFS support

2015-10-19 Thread Zefir Kurtisi
On 10/16/2015 06:53 PM, Tim Harvey wrote: > Greetings, > > Is FCC DFS support (from the updated rules released in Aug 2014) fully > supported in ath10k by the driver/firmware/cards? > > The linux-wireless DFS page [1] has some great info but doesn't really > list what is currently in place and

[PATCH RESEND 2/6] staging: wilc1000: move variable clients_count

2015-10-19 Thread Tony Cho
From: Leo Kim This patch moves static variable clients_count to around where the local variables are togther. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 3 +-- 1 file changed, 1

[PATCH RESEND 4/6] staging: wilc1000: fixes unnecessary variable replacement

2015-10-19 Thread Tony Cho
From: Leo Kim This patch removes an unnecessary variable use for the errors and returns errors directly without a result variable. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 28

[PATCH RESEND 3/6] staging: wilc1000: move variable FALSE_FRMWR_CHANNEL

2015-10-19 Thread Tony Cho
From: Leo Kim This patch moves the variable 'FALSE_FRMWR_CHANNEL' to where local definitions are. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 2 +- 1 file changed, 1 insertion(+), 1

[PATCH V3] staging: wilc1000: wilc_msgqueue.c : add goto statement

2015-10-19 Thread Tony Cho
From: Leo Kim This patch uses goto statement to separet error conditionals into release_lock and mem_free in wilc_mq_send. If unexpected errors happen, this function cannot up the semaphore, otherwise, if no errors, the semaphore should be released, but freeing memory is not

Re: [PATCH] staging/wilc: fix Kconfig dependencies, second try

2015-10-19 Thread Arnd Bergmann
On Monday 19 October 2015 16:54:23 Tony Cho wrote: > Hi Arnd Bergmann, > > When I apply this patch, I cannot make WILC1000 module (wilc1000.ko) because > CONFIG_WILC1000 is y and also I can see some link errors for the cfg80211 > APIs. > > Can you consider this patch? Ah, you are right. I see

Re: [PATCH] staging/wilc: fix Kconfig dependencies, second try

2015-10-19 Thread Arnd Bergmann
On Monday 19 October 2015 11:39:31 Arnd Bergmann wrote: > On Monday 19 October 2015 16:54:23 Tony Cho wrote: > > Hi Arnd Bergmann, > > > > When I apply this patch, I cannot make WILC1000 module (wilc1000.ko) > > because CONFIG_WILC1000 is y and also I can see some link errors for the > >

Re: FCC DFS support

2015-10-19 Thread Tim Harvey
On Mon, Oct 19, 2015 at 2:10 AM, Zefir Kurtisi wrote: > On 10/16/2015 06:53 PM, Tim Harvey wrote: >> Greetings, >> >> Is FCC DFS support (from the updated rules released in Aug 2014) fully >> supported in ath10k by the driver/firmware/cards? >> >> The linux-wireless DFS

Re: [PATCH 1/2] NFC: delete null dereference

2015-10-19 Thread Dan Carpenter
The next goto after that is messed up as well: 1056 dev = nfc_get_device(idx); 1057 if (!dev) 1058 return -ENODEV; 1059 1060 device_lock(>dev); 1061 1062 local = nfc_llcp_find_local(dev); 1063 if (!local) { 1064

Re: [PATCH] ath10k: Disable PCI PS for QCA988X and QCA99X0

2015-10-19 Thread Kalle Valo
writes: > From: Anilkumar Kolli > > This patch disables PCI PS for QCA988X and QCA99X0, Since PCI PS is > validated for QCA6174, let it be enabled only for QCA6174. It would be > better to execute PCI PS related functions only for the supported

Re: [PATCH] ath10k: only advertise mesh support in raw mode

2015-10-19 Thread Kalle Valo
Bob Copeland writes: > Rather than always advertising mesh support and then generating > an error when the user attempts to bring up the device without > rawmode, only advertise it when available: that is, if the module > is loaded with rawmode=1, the firmware supports it,

Re: [PATCH 0/2 v2] ath10k: print firwmare stats specific to firmware version

2015-10-19 Thread Kalle Valo
writes: > From: Tamizh chelvam > > Currently printing fw stats in ath10k is common to all firmware versions. > Printing all the stats might lead to confusion because some of the stats > are firmware specific and when printed will have 0's. >

[PATCH] orinoco_usb: return error in ezusb_probe when alloc_orinocodev fails

2015-10-19 Thread John W. Linville
The current code exits after alloc_orinocodev, but fails to change the return value to something that indicates the failure. This patch changes the return value to -ENOMEM. https://bugzilla.kernel.org/show_bug.cgi?id=106181 Signed-off-by: John W. Linville ---

Re: [PATCH V2 01/40] staging: wilc1000: rename ssidLen of struct join_bss_param

2015-10-19 Thread Dan Carpenter
On Mon, Oct 19, 2015 at 10:32:10AM +0900, Tony Cho wrote: > > > On 2015년 10월 17일 13:59, Greg KH wrote: > >On Fri, Oct 16, 2015 at 01:37:31PM +0900, Tony Cho wrote: > >>From: Leo Kim > >> > >>This patch renames ssidLen of struct join_bss_param to ssid_len > >>to avoid

re: rtlwifi: rtl8723be: Add new driver

2015-10-19 Thread Dan Carpenter
Hello Larry Finger, The patch a619d1abe20c: "rtlwifi: rtl8723be: Add new driver" from Feb 28, 2014, leads to the following static checker warning: drivers/net/wireless/realtek/rtlwifi/rtl8723be/hw.c:1802 _rtl8723be_read_power_value_fromprom() warn: why is the last element

[PATCH] nfc: free skb buffer using skb_free_datagram

2015-10-19 Thread Insu Yun
Freeing sk_buff genereated by skb_recv_datagram is always by skb_free_datagram, not kfree_skb. Signed-off-by: Insu Yun --- net/nfc/llcp_sock.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/net/nfc/llcp_sock.c b/net/nfc/llcp_sock.c index b7de0da..15e681f

[PATCH v2 1/3] net: wireless: rsi: Coding Spaces

2015-10-19 Thread Paul McQuade
Removed space before that ',' Signed-off-by: Paul McQuade --- drivers/net/wireless/rsi/rsi_91x_sdio_ops.c | 2 +- drivers/net/wireless/rsi/rsi_mgmt.h | 4 ++-- 2 files changed, 3 insertions(+), 3 deletions(-) diff --git

Re: [PATCH v2 3/3] net: wireless: b43: Statics are init to 0

2015-10-19 Thread Michael Büsch
On Mon, 19 Oct 2015 17:02:23 +0100 Paul McQuade wrote: > diff --git a/drivers/net/wireless/b43/phy_lp.c > b/drivers/net/wireless/b43/phy_lp.c > index 058a9f2..086f0ba 100644 > --- a/drivers/net/wireless/b43/phy_lp.c > +++ b/drivers/net/wireless/b43/phy_lp.c > @@ -2502,7

[PATCH v2 2/3] net: wireless: b43: Coding Style

2015-10-19 Thread Paul McQuade
Fixed Pointer Coding Style Signed-off-by: Paul McQuade --- drivers/net/wireless/b43/main.c | 6 +++--- drivers/net/wireless/b43/main.h | 2 +- drivers/net/wireless/b43/xmit.h | 2 +- 3 files changed, 5 insertions(+), 5 deletions(-) diff --git

[PATCH v2 3/3] net: wireless: b43: Statics are init to 0

2015-10-19 Thread Paul McQuade
No Need to state Statics are a 0 or NULL Signed-off-by: Paul McQuade --- drivers/net/wireless/b43/main.c | 2 +- drivers/net/wireless/b43/phy_lp.c | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/net/wireless/b43/main.c

[PATCH v2 0/3] Coding Style Cleanning

2015-10-19 Thread Paul McQuade
Paul McQuade (3): net: wireless: rsi: Coding Spaces net: wireless: b43: Coding Style net: wireless: b43: Statics are init to 0 drivers/net/wireless/b43/main.c | 8 drivers/net/wireless/b43/main.h | 2 +- drivers/net/wireless/b43/phy_lp.c | 2 +-

Re: [PATCH v2 2/3] net: wireless: b43: Coding Style

2015-10-19 Thread Michael Büsch
On Mon, 19 Oct 2015 17:02:22 +0100 Paul McQuade wrote: > Fixed Pointer Coding Style > > Signed-off-by: Paul McQuade > --- > drivers/net/wireless/b43/main.c | 6 +++--- > drivers/net/wireless/b43/main.h | 2 +- > drivers/net/wireless/b43/xmit.h | 2

Re: rtlwifi: rtl8723be: Add new driver

2015-10-19 Thread Jakub Sitnicki
Hi Dan, On Mon, Oct 19, 2015 at 05:10 PM CEST, Dan Carpenter wrote: > The patch a619d1abe20c: "rtlwifi: rtl8723be: Add new driver" from Feb > 28, 2014, leads to the following static checker warning: > > drivers/net/wireless/realtek/rtlwifi/rtl8723be/hw.c:1802 >

[PATCH] mwifiex: toggle carrier state in start_ap/stop_ap.

2015-10-19 Thread Marty Faltesek
In uap mode the carrier is not enabled until after the first STA joins. The carrier triggers the bridge to start its state machine, and if STP is enabled, it takes 4 seconds as it transitions from disabled to forwarding. During this time the bridge drops all traffic, and the EAPOL handshake times

libertas_cs TX lockups

2015-10-19 Thread Dan MacDonald
Hi Linux wireless devs! I'm having probs maintaining a stable connection with the libertas_cs driver. When I use wifi for more than a few seconds I start to get errors like: libertas_cs 0.0 wlan0: TX lockup detected I get this error when I connect with iw, iwconfig, netctl or networkmanager,

Re: [PATCH 1/2] NFC: delete null dereference

2015-10-19 Thread Samuel Ortiz
Hi Julia, On Sat, Oct 17, 2015 at 11:32:19AM +0200, Julia Lawall wrote: > The exit label performs device_unlock(>dev);, which will fail when dev > is NULL, and nfc_put_device(dev);, which is not useful when dev is NULL, so > just exit the function immediately. > > Problem found using

Re: [PATCH] NFC: nfcwilink: Drop a useless static qualifier

2015-10-19 Thread Samuel Ortiz
Hi Christophe, On Tue, Oct 13, 2015 at 08:31:04AM +0200, Christophe JAILLET wrote: > There is no need to have the 'struct nfcwilink *drv' variable static in the > probe function. > It only wastes a few bytes of memory. > > Signed-off-by: Christophe JAILLET > --- >

Re: [PATCH] nfc: netlink: avoid NULL pointer dereference on error

2015-10-19 Thread Samuel Ortiz
Hi Vincent, On Wed, Oct 07, 2015 at 11:33:19AM +0200, Vincent Stehlé wrote: > The function nfc_genl_llc_sdreq() can dereference the dev pointer while > it is NULL on its error path. Create a new error handling label to avoid > that. > > This fixes the following coccinelle error: > >

Re: [PATCH] NFC: nxp-nci: constify nxp_nci_phy_ops structure

2015-10-19 Thread Samuel Ortiz
Hi Julia, On Sun, Oct 11, 2015 at 01:24:13PM +0200, Julia Lawall wrote: > The only instance of a nxp_nci_phy_ops structure is never modified. Thus > the declaration of the structure and all references to the structure type > can be made const. > > Done with the help of Coccinelle. > >

[PATCH V2 08/12] staging: wilc1000: move clean up codes into wl_wlan_cleanup function

2015-10-19 Thread Tony Cho
This patch moves clean up codes from exit_wilc_driver into the wl_wlan_cleanup newly introduced in this patch. In addition, it is called by linux_sdio_remove function. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/linux_wlan.c | 95 ---

[PATCH V2 10/12] staging: wilc1000: remove COMPLEMENT_BOOT

2015-10-19 Thread Tony Cho
This patch removes a preprocessor definition, COMPLEMENT_BOOT which is not used anymore. This is just workaround to avoid weird issue, which is that 11b core is not ready after the power is givin to the chip. However, this issue happened only in the unstable hardware a long time ago and no more

[PATCH V2 04/12] staging: wilc1000: rename aSrcAddress in the struct wilc_vif

2015-10-19 Thread Tony Cho
This patch renames aSrcAddress in the struct wilc_vif to the src_addr. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/linux_wlan.c | 4 ++-- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 8 drivers/staging/wilc1000/wilc_wfi_netdevice.h |

[PATCH V2 09/12] staging: wilc1000: rename wilc_firmware in the struct wilc

2015-10-19 Thread Tony Cho
This patch renames wilc_firmware in the struct wilc to the firmware. In addition, null assignments to the wl->firmware after release_firmware are removed because it is not necessary. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/linux_wlan.c | 15

[PATCH V2 03/12] staging: wilc1000: rename strInterfaceInfo in the sturct wilc

2015-10-19 Thread Tony Cho
This patch renames strInterfaceInfo in the struct wilc to the vif. In addition, unnecessary print statements around it are removed in this patch. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/linux_wlan.c | 91 +++

[PATCH V2 12/12] staging: wilc1000: assign pointer of g_linux_wlan to sdio device data

2015-10-19 Thread Tony Cho
This patch assigns wl pointer to sdio device data. The global variable g_linux_wlan will be removed finally. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/linux_wlan.c | 5 +++-- drivers/staging/wilc1000/linux_wlan_sdio.c| 5 +++--

[PATCH V2 07/12] staging: wilc1000: rename wilc_netdev in the struct wilc_vif

2015-10-19 Thread Tony Cho
This patch renames wilc_netdev in the struct wilc_vif to the ndev. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/linux_wlan.c | 50 +++ drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 34 +++

[PATCH V2 01/12] staging: wilc1000: change the type of wilc1000_initialized

2015-10-19 Thread Tony Cho
This patch changes the type of wilc1000_initialized in the struc wilc from int to bool and also renames it to the initialized. In addition, unnecessary wilc1000_initialized codes are removed in this patch. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/linux_wlan.c

[PATCH V2 02/12] staging: wilc1000: rename u8NoIfcs in the struct wilc

2015-10-19 Thread Tony Cho
This patch renames u8NoIfcs of the struct wilc to the vif_num to avoid CamelCase naming convention. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/linux_wlan.c | 18 +- drivers/staging/wilc1000/wilc_wfi_netdevice.h | 2 +- 2 files changed, 10

[PATCH V2 11/12] staging: wilc1000: introduce struct wilc_sdio for sdio data

2015-10-19 Thread Tony Cho
This patch introduces struct wilc_sdio for sdio driver data. The wilc_sdio is allocated and set as driver data when the sdio is probed and deallocated when the sdio is removed. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/linux_wlan_sdio.c | 16 1

[PATCH 00/12] WILC1000 V2 for the g_linux_wlan

2015-10-19 Thread Tony Cho
The series of V2 restore the global variable, wl to g_linux_wlan which is its original name becasue it will be replaced with local structure and deleted. Tony Cho (12): staging: wilc1000: change the type of wilc1000_initialized staging: wilc1000: rename u8NoIfcs in the struct wilc staging:

Re: [PATCH 1/3] NFC: pn544: Auto-select core module

2015-10-19 Thread Samuel Ortiz
Hi Jean, On Fri, Sep 25, 2015 at 10:49:36AM +0200, Jean Delvare wrote: > As I understand it, the core nfc_pn544 module is useless without > either the I2C or the MEI access module. So hide NFC_PN544 and > select it automatically if either NFC_PN544_I2C or NFC_PN544_MEI is > selected. > > This

[PATCH V2 06/12] staging: wilc1000: rename drvHandler in the struct wilc_vif

2015-10-19 Thread Tony Cho
This patch renames drvHandler in the struct wilc_vif to the hif_drv. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/linux_wlan.c | 2 +- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 24 +++

[PATCH V2 05/12] staging: wilc1000: rename aBSSID in the sturct wilc_vif

2015-10-19 Thread Tony Cho
This patch renames aBSSID in the struct wilc_vif to the bssid. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/linux_wlan.c | 14 +++--- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 6 +++--- drivers/staging/wilc1000/wilc_wfi_netdevice.h

Re: [PATCH] nfc: free skb buffer using skb_free_datagram

2015-10-19 Thread Eric Dumazet
On Mon, 2015-10-19 at 15:59 +, Insu Yun wrote: > Freeing sk_buff genereated by skb_recv_datagram is always by > skb_free_datagram, not kfree_skb. > > Signed-off-by: Insu Yun > --- > net/nfc/llcp_sock.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff