Re: [RFC/RFT 1/2] mac80211: Add NEED_ALIGNED4_SKBS hw flag

2015-12-17 Thread Johannes Berg
On Thu, 2015-12-17 at 10:20 +0100, Janusz Dziedzic wrote: > HW/driver should set NEED_ALIGNED4_SKBS flag in case require > aligned skbs to four-byte boundaries. > > Before we have to do memmove() in the driver before > pass this to HW and memmove() back in tx completion. > This patch allow to

Re: [RFC/RFT 1/2] mac80211: Add NEED_ALIGNED4_SKBS hw flag

2015-12-17 Thread Felix Fietkau
On 2015-12-17 10:20, Janusz Dziedzic wrote: > HW/driver should set NEED_ALIGNED4_SKBS flag in case require > aligned skbs to four-byte boundaries. > > Before we have to do memmove() in the driver before > pass this to HW and memmove() back in tx completion. > This patch allow to save CPU and skip

Re: [PATCH v2 11/13] ath9k: MCC add sta_ap_ratio module param

2015-12-17 Thread Janusz Dziedzic
On 11 December 2015 at 09:19, Kalle Valo wrote: > Janusz Dziedzic writes: > >> In case of MCC we can setup STA/AP(GO) ratio. >> Eg. setting sta_ap_ratio=80 >> STA will get 80% of time, while AP(GO) 20%. >> Setup correct ctwindow. >> >>

Re: [RFC/RFT 1/2] mac80211: Add NEED_ALIGNED4_SKBS hw flag

2015-12-17 Thread Felix Fietkau
On 2015-12-17 11:04, Johannes Berg wrote: > On Thu, 2015-12-17 at 10:20 +0100, Janusz Dziedzic wrote: >> HW/driver should set NEED_ALIGNED4_SKBS flag in case require >> aligned skbs to four-byte boundaries. >> >> Before we have to do memmove() in the driver before >> pass this to HW and memmove()

Re: [RFC/RFT 1/2] mac80211: Add NEED_ALIGNED4_SKBS hw flag

2015-12-17 Thread Felix Fietkau
On 2015-12-17 10:20, Janusz Dziedzic wrote: > HW/driver should set NEED_ALIGNED4_SKBS flag in case require > aligned skbs to four-byte boundaries. > > Before we have to do memmove() in the driver before > pass this to HW and memmove() back in tx completion. > This patch allow to save CPU and skip

Re: [RFC/RFT 1/2] mac80211: Add NEED_ALIGNED4_SKBS hw flag

2015-12-17 Thread Johannes Berg
On Thu, 2015-12-17 at 10:20 +0100, Janusz Dziedzic wrote: > HW/driver should set NEED_ALIGNED4_SKBS flag in case require > aligned skbs to four-byte boundaries. > > Before we have to do memmove() in the driver before > pass this to HW and memmove() back in tx completion. > This patch allow to

Re: [RFC/RFT 1/2] mac80211: Add NEED_ALIGNED4_SKBS hw flag

2015-12-17 Thread Felix Fietkau
On 2015-12-17 11:29, Johannes Berg wrote: > On Thu, 2015-12-17 at 10:20 +0100, Janusz Dziedzic wrote: >> HW/driver should set NEED_ALIGNED4_SKBS flag in case require >> aligned skbs to four-byte boundaries. >> >> Before we have to do memmove() in the driver before >> pass this to HW and memmove()

Re: question on "mac80211_hwsim: support any address in userspace"

2015-12-17 Thread Bob Copeland
On Wed, Dec 16, 2015 at 02:14:18PM -0800, Ben Greear wrote: > On 12/16/2015 09:30 AM, Adam R. Welle wrote: > > > >>Well, it was always rather awkward since it was the *second* address :) > > > >Could somebody provide background information on why the decision was > >made to use a second address

[PATCH 1/1] mac80211: improve the contiguous mask checking

2015-12-17 Thread Zeng Zhaoxiu
If the result of adding the first set bit to the mask is power of 2, the mask must be contiguous. "mask & -mask" can get the first set bit of mask gracefully. Signed-off-by: Zeng Zhaoxiu --- net/mac80211/iface.c | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-)

[PATCH v2 1/1] staging: rtl8723au: change parameter type in rtl8723a_set_rssi_cmd declaration

2015-12-17 Thread drivengroove
From: Anatoly Stepanov Previosly the function had the following prototype: int rtl8723a_set_rssi_cmd(struct rtw_adapter *padapter, u8 *param) My suggestion here is to modify the prototype this way: int rtl8723a_set_rssi_cmd(struct rtw_adapter *padapter, u32 param) We

[PATCH v2 0/1] staging: rtl8723au: change parameter type in rtl8723a_set_rssi_cmd declaration

2015-12-17 Thread drivengroove
From: Anatoly Stepanov Hi, Jes! I updated the patch, according to your idea, now "param" is passed by value. Anatoly Stepanov (1): staging: rtl8723au: change parameter type in rtl8723a_set_rssi_cmd declaration drivers/staging/rtl8723au/hal/odm.c |

Re: [PATCH] Print warnings for missing cfg80211_ops implementations

2015-12-17 Thread Johannes Berg
On Thu, 2015-12-17 at 03:01 -0800, Joe Perches wrote: > Following patterns is good, I just think the > pattern could be trivially improved. It's a question of what makes sense though - nobody implements stop_xyz without implementing start_xyz, and even if they do it's pointless. It's just that

Re: pull-request: mac80211 2015-12-15

2015-12-17 Thread Johannes Berg
On Wed, 2015-12-16 at 18:34 -0500, David Miller wrote: >  > Something about your text encoding kept this from ending up > in patchwork for some reason. > Hm. I don't see anything special with this, seems to just be plain text 8bit transfer encoding. Do you want me to watch out for things

Re: [PATCH 1/1] mac80211: improve the contiguous mask checking

2015-12-17 Thread Johannes Berg
On Thu, 2015-12-17 at 22:59 +0800, Zeng Zhaoxiu wrote: > If the result of adding the first set bit to the mask is power of 2, > the mask must be contiguous. "mask & -mask" can get the first set bit > of mask gracefully. > - if (__ffs64(mask) + hweight64(mask) != fls64(mask)) > { > +

Re: [ANNOUNCE] New location for wireless-testing tree

2015-12-17 Thread John W. Linville
On Wed, Dec 16, 2015 at 12:32:23PM -0500, Bob Copeland wrote: > As reported previously[1], John Linville will be moving on from maintenance > of the wireless-testing[2] tree at the end of the year. A huge thank you to > John for doing all this work for so many years! > > We now have a shared

Re: pull-request: mac80211 2015-12-15

2015-12-17 Thread David Miller
From: Johannes Berg Date: Thu, 17 Dec 2015 13:44:32 +0100 > On Wed, 2015-12-16 at 18:34 -0500, David Miller wrote: >>  >> Something about your text encoding kept this from ending up >> in patchwork for some reason. >> > > Hm. I don't see anything special with this,

Re: [ANNOUNCE] New location for wireless-testing tree

2015-12-17 Thread Emmanuel Grumbach
On Thu, Dec 17, 2015 at 5:56 PM, John W. Linville wrote: > On Wed, Dec 16, 2015 at 12:32:23PM -0500, Bob Copeland wrote: >> As reported previously[1], John Linville will be moving on from maintenance >> of the wireless-testing[2] tree at the end of the year. A huge thank

Re: pull-request: mac80211 2015-12-15

2015-12-17 Thread David Rivshin (Allworx)
On Thu, 17 Dec 2015 12:04:48 -0500 (EST) David Miller wrote: > From: Johannes Berg > Date: Thu, 17 Dec 2015 13:44:32 +0100 > > > On Wed, 2015-12-16 at 18:34 -0500, David Miller wrote: > >>  > >> Something about your text encoding kept this from

Re: pull-request: mac80211 2015-12-15

2015-12-17 Thread Joe Perches
On Thu, 2015-12-17 at 13:44 +0100, Johannes Berg wrote: > On Wed, 2015-12-16 at 18:34 -0500, David Miller wrote: > >   > > Something about your text encoding kept this from ending up > > in patchwork for some reason. > > > > Hm. I don't see anything special with this, seems to just be plain >

[PATCH] bcma: use module_init for the main part of bus initialization

2015-12-17 Thread Rafał Miłecki
So far we were using fs_initcall. It was (and still is) needed because struct bus_type has to be registered early. However main bus initialization has to happen later as it requires SPROM which depends on NVRAM which depends on mtd. Solve it by using fs_initcall only for bus_register call and

Re: [PATCH v1 3/7] ima: load policy using path

2015-12-17 Thread Luis R. Rodriguez
The subject should probably be: ima: add support to load policy from path Cc'ing Roberts who originally wanted SELinux file policy signing capabilities. Also Greg, who is reviewing the sysdata file changes I had proposed which would provide a generic file loading facility for modules, and later a

Re: About adding support for MT76x2U to Linux kernel

2015-12-17 Thread Johannes Stezenbach
Hi Felix and Jakub, On Wed, Dec 16, 2015 at 10:24:25PM +0100, Johannes Stezenbach wrote: > On Wed, Dec 16, 2015 at 07:53:04PM +0100, Felix Fietkau wrote: > > Once I'm done with mt7603 bringup (monitor mode rx already works), I > > plan on submitting mt76 upstream, and then we can see about adding

Re: [PATCH] ath10k: add modparam 'hw_csum' to make HW checksum configurable

2015-12-17 Thread Peter Oh
On 12/16/2015 11:29 PM, Michal Kazior wrote: On 17 December 2015 at 00:50, Peter Oh wrote: On 12/16/2015 01:54 PM, Felix Fietkau wrote: On 2015-12-16 22:19, Peter Oh wrote: [...] If mentioned to use the function to mesh frame only without touching mac80211, then how do

Re: [PATCH] ath10k: add modparam 'hw_csum' to make HW checksum configurable

2015-12-17 Thread Peter Oh
On 12/16/2015 03:59 PM, Felix Fietkau wrote: On 2015-12-17 00:50, Peter Oh wrote: On 12/16/2015 01:54 PM, Felix Fietkau wrote: On 2015-12-16 22:19, Peter Oh wrote: On 12/16/2015 12:53 PM, Felix Fietkau wrote: On 2015-12-16 21:46, Peter Oh wrote: On 12/16/2015 12:35 PM, Felix Fietkau wrote:

Re: [PATCH v3] bcma: switch GPIO portions to use GPIOLIB_IRQCHIP

2015-12-17 Thread Rafał Miłecki
I'm afraid it wasn't tested on BCM47XX (MIPS) :( On 14 August 2015 at 00:21, Hauke Mehrtens wrote: > @@ -218,9 +187,8 @@ int bcma_gpio_init(struct bcma_drv_cc *cc) > chip->set = bcma_gpio_set_value; > chip->direction_input =

Re: [PATCH] ath10k: add modparam 'hw_csum' to make HW checksum configurable

2015-12-17 Thread Peter Oh
On 12/17/2015 02:57 PM, Felix Fietkau wrote: On 2015-12-17 23:01, Peter Oh wrote: On 12/16/2015 03:59 PM, Felix Fietkau wrote: On 2015-12-17 00:50, Peter Oh wrote: On 12/16/2015 01:54 PM, Felix Fietkau wrote: On 2015-12-16 22:19, Peter Oh wrote: On 12/16/2015 12:53 PM, Felix Fietkau wrote:

Re: [PATCH] ath10k: add modparam 'hw_csum' to make HW checksum configurable

2015-12-17 Thread Felix Fietkau
On 2015-12-17 23:01, Peter Oh wrote: > > On 12/16/2015 03:59 PM, Felix Fietkau wrote: >> On 2015-12-17 00:50, Peter Oh wrote: >>> On 12/16/2015 01:54 PM, Felix Fietkau wrote: On 2015-12-16 22:19, Peter Oh wrote: > On 12/16/2015 12:53 PM, Felix Fietkau wrote: >> On 2015-12-16 21:46,

Re: [PATCH] Print warnings for missing cfg80211_ops implementations

2015-12-17 Thread Joe Perches
On Thu, 2015-12-17 at 08:57 +0100, Johannes Berg wrote: > On Thu, 2015-12-17 at 08:34 +0100, Ola Olsson wrote: > > > but maybe it should be > > > > > > WARN_ON((ops->add_station && !ops->del_station) || > > > (!opt->add_station && ops->del_station)) > > > > > > etc... > >

Re: [RFC/RFT 1/2] mac80211: Add NEED_ALIGNED4_SKBS hw flag

2015-12-17 Thread Johannes Berg
On Thu, 2015-12-17 at 11:35 +0100, Felix Fietkau wrote: >  > On many devices that I'm using, the data path is definitely too > bloated > for the packet to still be in cache, so I do think this will help. > Remember, having only 32 KiB Dcache (no L2) is not uncommon on > devices > running ath9k.

Re: [PATCH] Print warnings for missing cfg80211_ops implementations

2015-12-17 Thread Ola Olsson
> Using > WARN_ON(!a ^ !b) > which is logically the same as what I wrote above > for clarity is simply a bit more coverage and maybe > even a bit run-time faster. > > Didn't think about that. Love your bit fiddling trick! After an approval/rejection of my patch I can submit another one

Re: Problems loading firmware using built-in drivers with kernels that use initramfs.

2015-12-17 Thread Luis R. Rodriguez
On Sun, Aug 30, 2015 at 11:11 AM, Linus Torvalds wrote: > On Sun, Aug 30, 2015 at 1:25 AM, Arend van Spriel wrote: >> On 08/29/2015 12:38 PM, Ming Lei wrote: >> >> Does this mean a built-in driver can not get firmware from initramfs or >> built