[PATCH 05/10] rtlwifi: enable mac80211 fast-tx support

2018-01-09 Thread pkshih
From: Ping-Ke Shih To enable the mac80211 fast-tx feature, the hw/driver needs to support dynamic power saving and fragmentation. Since our driver does not need to fragment packet into smaller pieces, we just hook an empty callback of set_frag_threshold to avoid fragmentation

[PATCH 06/10] rtlwifi: Support A-MSDU in A-MPDU capability

2018-01-09 Thread pkshih
From: Steven Ting Due to the fact that A-MSDU deaggregation is done in software, we set this flag to support the A-MSDU in A-MPDU Signed-off-by: Steven Ting --- drivers/net/wireless/realtek/rtlwifi/base.c | 1 + 1 file changed, 1 insertion(+)

[PATCH 07/10] rtlwifi: btcoex: Add power_on_setting routine

2018-01-09 Thread pkshih
From: Ping-Ke Shih After mac power-on sequence, wifi will start to work so notify btcoex the event to configure registers especially related to antenna. This will not only help to assign antenna but also to yield better user experience. Signed-off-by: Ping-Ke Shih

[PATCH 10/10] rtlwifi: btcoex: add rfe_type parameter to btcoex

2018-01-09 Thread pkshih
From: Ping-Ke Shih btcoex configure antenna by rfe_type that is RF type programmed in efuse. Signed-off-by: Ping-Ke Shih --- drivers/net/wireless/realtek/rtlwifi/btcoexist/halbtcoutsrc.c | 10 ++

[PATCH 01/10] rtlwifi: Use mutex to replace spin_lock to protect IPS and LPS

2018-01-09 Thread pkshih
From: Ping-Ke Shih Enter/leavel IPS and LPS are large critical section, and they can't use sleep function because running in atomic-context, which own a spin_lock. In commit ba9f93f82aba ("rtlwifi: Fix enter/exit power_save"), it moves LPS functions to thread-context, so this

[PATCH 04/10] rtlwifi: unlink bss when un-association

2018-01-09 Thread pkshih
From: Tsang-Shian Lin When AP change bandwidth setting from 20M to 40M, STA may use old 20M AP information to association with AP. Driver unlink bss in the .bss_info_changed of ieee80211_ops to make sure that later scan can get correct AP bandwidth capability. Signed-off-by:

[PATCH 08/10] rtlwifi: btcoex: Remove global variables from btcoex

2018-01-09 Thread pkshih
From: Ping-Ke Shih Remove global variables, so btcoexist can support multiple instances simultaneously. Signed-off-by: Ping-Ke Shih --- .../realtek/rtlwifi/btcoexist/halbtcoutsrc.c | 79 - .../realtek/rtlwifi/btcoexist/halbtcoutsrc.h

[PATCH 09/10] rtlwifi: btcoex: Add common function for qeurying BT information

2018-01-09 Thread pkshih
From: Ping-Ke Shih This commit implement the common function to sort old features, and add more new features that are get_supported_feature, get_supported_version, get_ant_det_val, ble_scan_type, ble_scan_para, bt_dev_info, forbidden_slot_val, afh_map and etc. Signed-off-by:

[PATCH 00/10] rtlwifi: fix some bugs and add btcoex functions

2018-01-09 Thread pkshih
From: Ping-Ke Shih Fix some bugs reported by QC, and continue to submit btcoex patches for further use. Ping-Ke Shih (8): rtlwifi: Use mutex to replace spin_lock to protect IPS and LPS rtlwifi: fix scan channel 1 fail after IPS rtlwifi: Add sta_statistics of mac80211's

[PATCH 03/10] rtlwifi: Add sta_statistics of mac80211's op, and set filled=0 by default

2018-01-09 Thread pkshih
From: Ping-Ke Shih When using iwconfig to check wifi status, wext uses 'static struct' of sinfo to get station info so sinfo->filled will be persistent. Since the commit 2b9a7e1bac24 ("mac80211: allow drivers to provide most station statistics") assumes driver initializes

[PATCH] carl9170: Change from _COMPILER_VERSION to CMAKE_C_COMPILER_VERSION

2018-01-09 Thread Jason Self
Patch is attached. My problem started off this way: git clone https://github.com/chunkeey/carl9170fw.git cd carl9170fw make -C toolchain (time passes) ./autogen.sh (accept all default answers) ./autogen.sh install Installing firmware...Apply miniboot/autogen.sh: line 35: tools/src/miniboot:

Re: Re: [PATCH] mwifiex: cancel pcie/sdio work in remove/shutdown handler

2018-01-09 Thread Brian Norris
+ Christopher Hi Simon and Kalle, On Tue, Jan 09, 2018 at 11:42:21AM +, Xinming Hu wrote: > Hi, > > > -Original Message- > > From: Kalle Valo [mailto:kv...@codeaurora.org] > > Sent: 2018年1月9日 15:40 > > To: Brian Norris > > Cc: Xinming Hu

Re: [PATCH 00/18] prevent bounds-check bypass via speculative execution

2018-01-09 Thread Josh Poimboeuf
On Tue, Jan 09, 2018 at 11:44:05AM -0800, Dan Williams wrote: > On Tue, Jan 9, 2018 at 11:34 AM, Jiri Kosina wrote: > > On Fri, 5 Jan 2018, Dan Williams wrote: > > > > [ ... snip ... ] > >> Andi Kleen (1): > >> x86, barrier: stop speculation for failed access_ok > >> > >>

Re: [PATCH 00/18] prevent bounds-check bypass via speculative execution

2018-01-09 Thread Jiri Kosina
On Fri, 5 Jan 2018, Dan Williams wrote: [ ... snip ... ] > Andi Kleen (1): > x86, barrier: stop speculation for failed access_ok > > Dan Williams (13): > x86: implement nospec_barrier() > [media] uvcvideo: prevent bounds-check bypass via speculative execution > carl9170:

Re: [PATCH 00/18] prevent bounds-check bypass via speculative execution

2018-01-09 Thread Dan Williams
On Tue, Jan 9, 2018 at 11:34 AM, Jiri Kosina wrote: > On Fri, 5 Jan 2018, Dan Williams wrote: > > [ ... snip ... ] >> Andi Kleen (1): >> x86, barrier: stop speculation for failed access_ok >> >> Dan Williams (13): >> x86: implement nospec_barrier() >> [media]

Re: [PATCH] wireless: broadcom: radio_2056: delete duplicated macro definitions

2018-01-09 Thread Larry Finger
On 01/08/2018 03:26 PM, Rasmus Villemoes wrote: Ctrl-V was hit twice when these macros were inserted: $ sed -n '9,527p' ./drivers/net/wireless/broadcom/b43/radio_2056.h | md5sum 4db53450c59d9939e903d4e4ba6bc9b1 - $ sed -n '528,1046p' ./drivers/net/wireless/broadcom/b43/radio_2056.h | md5sum

Re: [PATCH v2] b43: Replace mdelay with usleep_range in b43_radio_2057_init_post

2018-01-09 Thread Larry Finger
On 01/08/2018 07:40 PM, Jia-Ju Bai wrote: b43_radio_2057_init_post is not called in an interrupt handler nor holding a spinlock. The function mdelay in it can be replaced with usleep_range, to reduce busy wait. Signed-off-by: Jia-Ju Bai --- v2: * Replace mdelay with

brcmfmac4329-sdio firmware load failed.

2018-01-09 Thread Kyle Evans
This is linux-4.15-rc2 on an ASUS TF101. This device was shipped with Android and a custom kernel using bcmdhd. I have taken nvram.txt from /system/etc/ on the stock filesystem and copied to /lib/firmware/brcm/brcmfmac4329-sdio.txt. Below is the result. [2.729157] brcmfmac: F1 signature

Re: [PATCH][next] rtlwifi: btcoexist: remove redundant variable fw_ps_state

2018-01-09 Thread Larry Finger
On 01/09/2018 10:43 AM, Colin King wrote: From: Colin Ian King Variable fw_ps_state is assigned a value but it is never read, hence it is redundant and can be removed. Acked-by: Larry Finger Thanks, Larry Cleans up clang warning:

[PATCH][next] rtlwifi: btcoexist: remove redundant variable fw_ps_state

2018-01-09 Thread Colin King
From: Colin Ian King Variable fw_ps_state is assigned a value but it is never read, hence it is redundant and can be removed. Cleans up clang warning: drivers/net/wireless/realtek/rtlwifi/btcoexist/halbtcoutsrc.c:736:2: warning: Value stored to 'fw_ps_state' is never

Re: Poor performance on 5G network with Intel 9000 series cards

2018-01-09 Thread Emmanuel Grumbach
On Mon, Jan 8, 2018 at 8:34 AM, AceLan Kao wrote: > > Hi all, > > Forgot to append the device info, here it is. > > 02:00.0 Network controller [0280]: Intel Corporation Device [8086:2526] (rev > 29) > Subsystem: Intel Corporation Device [8086:4010] > > Best

Re: [v2,01/10] qtnfmac: check that MAC exists in regulatory notifier

2018-01-09 Thread Kalle Valo
Sergey Matyukevich writes: > Thanks Kalle, > >> > It is possible that regulatory notifier is called before MAC data >> > was allocated. We need to verify that MAC data exists before trying >> > to send a regulatory change event. >> > >> > Signed-off-by: Igor

Re: [PATCH] staging: wilc1000: removed typedef from enum BSSTYPE_T

2018-01-09 Thread Greg KH
On Tue, Jan 09, 2018 at 02:37:42PM +0530, Ajay Singh wrote: > This patch removes typedef from enum BSSTYPE_T and > rename it to bss_types. > > It fixes "WARNING: do not add new typdefs" warning > reported by checkpatch.pl. > > Signed-off-by: ajaysk Hi, This is the

[PATCH 1/3] mt76x2: dfs: avoid tasklet scheduling during mt76x2_dfs_init_params()

2018-01-09 Thread Lorenzo Bianconi
Substitute tasklet_kill with tasklet_disable/tasklet_enable in order to guarantee dfs tasklet can not be executed during dfs parameter initialization Signed-off-by: Lorenzo Bianconi --- drivers/net/wireless/mediatek/mt76/mt76x2_dfs.c | 1 -

[PATCH 2/3] mt76x2: dfs: add set_domain handler

2018-01-09 Thread Lorenzo Bianconi
Add mt76x2_dfs_set_domain routine in order to properly reconfigure pattern detector when DFS domain has been changed Signed-off-by: Lorenzo Bianconi --- drivers/net/wireless/mediatek/mt76/mt76x2_dfs.c | 13 +

[PATCH 3/3] mt76x2: dfs: take into account dfs region in mt76x2_dfs_init_params()

2018-01-09 Thread Lorenzo Bianconi
Do not enable DFS state machine if dfs region is set to NL80211_DFS_UNSET Signed-off-by: Lorenzo Bianconi --- drivers/net/wireless/mediatek/mt76/mt76x2_dfs.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git

[PATCH 0/3] add set_domain routine to reconfigure mt76x2 dfs pd

2018-01-09 Thread Lorenzo Bianconi
Lorenzo Bianconi (3): mt76x2: dfs: avoid tasklet scheduling during mt76x2_dfs_init_params() mt76x2: dfs: add set_domain handler mt76x2: dfs: take into account dfs region in mt76x2_dfs_init_params() drivers/net/wireless/mediatek/mt76/mt76x2_dfs.c | 17 +++--

Re: [v2,01/10] qtnfmac: check that MAC exists in regulatory notifier

2018-01-09 Thread Sergey Matyukevich
Thanks Kalle, > > It is possible that regulatory notifier is called before MAC data > > was allocated. We need to verify that MAC data exists before trying > > to send a regulatory change event. > > > > Signed-off-by: Igor Mitsyanko > > 10 patches applied to

pull-request: wireless-drivers 2018-01-09

2018-01-09 Thread Kalle Valo
Hi Dave, My first pull request in 2018 so Happy New Year! This is for 4.15 to the net tree. Only two fixes this time so should be an easy pull. This is quite late due to the holidays but it has been pretty quiet so I guess I wasn't the only one trying to not touch the computer ;) And Linus said

Re: [09/11] brcmfmac: Remove array of functions

2018-01-09 Thread Kalle Valo
Arend van Spriel writes: > On 1/8/2018 6:20 PM, Kalle Valo wrote: >> Arend Van Spriel wrote: >> >>> Replace the array of functions with a pair of pointers to the >>> relevant functions. >>> >>> Signed-off-by: Ian Molton

Re: [09/11] brcmfmac: Remove array of functions

2018-01-09 Thread Arend van Spriel
On 1/8/2018 6:20 PM, Kalle Valo wrote: Arend Van Spriel wrote: Replace the array of functions with a pair of pointers to the relevant functions. Signed-off-by: Ian Molton Acked-by: Arend van Spriel

[PATCH V2 1/3] brcmfmac: Remove array of functions

2018-01-09 Thread Arend van Spriel
Replace the array of functions with a pair of pointers to the relevant functions. Signed-off-by: Ian Molton Acked-by: Arend van Spriel Signed-off-by: Arend van Spriel ---

[PATCH V2 3/3] brcmfmac: rename brcmf_sdiod_buff_{read,write}() functions

2018-01-09 Thread Arend van Spriel
Rename functions to brcmf_sdio_skbuff_{read,write}() as we pass an skbuff to this function. Signed-off-by: Arend van Spriel --- .../wireless/broadcom/brcm80211/brcmfmac/bcmsdh.c | 48 +++--- 1 file changed, 24 insertions(+), 24 deletions(-) diff

[PATCH V2 0/3] brcmfmac: restructuring sdio access functions - final drop (take 2)

2018-01-09 Thread Arend van Spriel
Resending remaining patch of the series, which have been rebased on the master branch of wireless-drivers-next. Arend van Spriel (3): brcmfmac: Remove array of functions brcmfmac: add comment block in brcmf_sdio_buscore_read() brcmfmac: rename brcmf_sdiod_buff_{read,write}() functions

[PATCH V2 2/3] brcmfmac: add comment block in brcmf_sdio_buscore_read()

2018-01-09 Thread Arend van Spriel
In brcmf_sdio_buscore_read() there is some special handling upon register access to chipid register of the chipcommon core. Add comment explaining why it is done here. Signed-off-by: Arend van Spriel --- drivers/net/wireless/broadcom/brcm80211/brcmfmac/sdio.c | 7

Re: [v2,01/10] qtnfmac: check that MAC exists in regulatory notifier

2018-01-09 Thread Kalle Valo
Sergey Matyukevich wrote: > From: Igor Mitsyanko > > It is possible that regulatory notifier is called before MAC data > was allocated. We need to verify that MAC data exists before trying > to send a regulatory change

Re: Re: [PATCH] mwifiex: cancel pcie/sdio work in remove/shutdown handler

2018-01-09 Thread Xinming Hu
Hi, > -Original Message- > From: Kalle Valo [mailto:kv...@codeaurora.org] > Sent: 2018年1月9日 15:40 > To: Brian Norris > Cc: Xinming Hu ; Linux Wireless > ; Dmitry Torokhov ; > raja...@google.com;

Re: [PATCH v2] b43: Replace mdelay with usleep_range in b43_radio_2057_init_post

2018-01-09 Thread Arend van Spriel
On 1/9/2018 10:47 AM, Jia-Ju Bai wrote: On 2018/1/9 17:07, Arend van Spriel wrote: On 1/9/2018 9:39 AM, Jia-Ju Bai wrote: On 2018/1/9 16:35, Greg KH wrote: On Tue, Jan 09, 2018 at 09:40:06AM +0800, Jia-Ju Bai wrote: b43_radio_2057_init_post is not called in an interrupt handler nor

Re: [PATCH v2] b43: Replace mdelay with usleep_range in b43_radio_2057_init_post

2018-01-09 Thread Jia-Ju Bai
On 2018/1/9 17:07, Arend van Spriel wrote: On 1/9/2018 9:39 AM, Jia-Ju Bai wrote: On 2018/1/9 16:35, Greg KH wrote: On Tue, Jan 09, 2018 at 09:40:06AM +0800, Jia-Ju Bai wrote: b43_radio_2057_init_post is not called in an interrupt handler nor holding a spinlock. The function mdelay in it

[PATCH] staging: wilc1000: removed enum typedef BUS_RELEASE_T

2018-01-09 Thread Ajay Singh
This patch removes enum typedef BUS_RELEASE_T and define "enum bus_release" to use instead of typedef. checkpatch.pl not to add new typedef warning is fixed with this patch. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wlan.c| 2 +-

[PATCH] staging: wilc1000: removed enum typedef BUS_ACQUIRE_T

2018-01-09 Thread Ajay Singh
This patch removes enum typedef BUS_ACQUIRE_T and define enum bus_acquire to use instead of typedef. checkpatch.pl not to add new typedef warning is fixed with this patch. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wlan.c| 2 +-

[PATCH] staging: wilc1000: removed enum typedef CHIP_PS_STATE_T

2018-01-09 Thread Ajay Singh
This patch removes enum typedef CHIP_PS_STATE_T and introduce enum chip_ps_states to use instead of typedef. checkpatch.pl not to add new typedef warning is fixed with this patch. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wlan.c| 2 +-

[PATCH] staging: wilc1000: removed enums typedef for BEACON_IE & TX_RATE_T

2018-01-09 Thread Ajay Singh
This patch removed the unnecessary enum typedef for BEACON_IE & TX_RATE_T It fix "WARNING: do not add new typedefs" reported by checkpatch.pl Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wlan_if.h | 8 1 file changed, 4 insertions(+), 4

[PATCH] staging: wilc1000: removed few unnecessary enums typedef

2018-01-09 Thread Ajay Singh
This patch removes following N_OPERATING_MODE_T,N_OBSS_DETECTION_T, N_PROTECTION_TYPE_T,N_SMPS_MODE_T,TX_ABORT_OPTION_T, typedef enum. Now, these enums are used as anonymous-enums for constants. checkpatch.pl warning to not add new typedef is fixes with this patch. Signed-off-by: Ajay Singh

[PATCH] staging: wilc1000: removed few unnecessary enums typedef

2018-01-09 Thread Ajay Singh
This patch removes following RSNA_REKEY_POLICY_T,SCAN_CLASS_FITLER_T, SCAN_PRI_T,CH_FILTER_T,N_PROTECTION_MODE_T,G_PROTECTION_MODE_T typedef enum. Now, these enums are used as anonymous-enums for constants. checkpatch.pl warning to avoid new typedef is fixes with this patch. Signed-off-by: Ajay

[PATCH] staging: wilc1000: removed unnecessary enum typedefs

2018-01-09 Thread Ajay Singh
This patch removes following G_PREAMBLE_T,SCANTYPE_T, USER_PS_MODE_T,SECURITY_T,ACK_POLICY_T,RESET_REQ_T typedef enum. Now, these enums are used as anonymous-enums for constants. checkpatch.pl warning to avoid new typedef is fixes with this patch. Signed-off-by: Ajay Singh

[PATCH] staging: wilc1000: remove unnecessary typedef enum G_OPERATING_MODE_T

2018-01-09 Thread Ajay Singh
This patch has removed G_OPERATING_MODE_T typedef enum. Now, its used as anonymous-enums for constants. checkpatch.pl warning to avoid new typedef is fixed with this patch. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_wlan_if.h | 4 ++-- 1 file changed,

[PATCH] staging: wilc1000: removed typedef from enum BSSTYPE_T

2018-01-09 Thread Ajay Singh
This patch removes typedef from enum BSSTYPE_T and rename it to bss_types. It fixes "WARNING: do not add new typdefs" warning reported by checkpatch.pl. Signed-off-by: ajaysk --- drivers/staging/wilc1000/host_interface.c | 2 +-

Re: [PATCH v2] b43: Replace mdelay with usleep_range in b43_radio_2057_init_post

2018-01-09 Thread Arend van Spriel
On 1/9/2018 9:39 AM, Jia-Ju Bai wrote: On 2018/1/9 16:35, Greg KH wrote: On Tue, Jan 09, 2018 at 09:40:06AM +0800, Jia-Ju Bai wrote: b43_radio_2057_init_post is not called in an interrupt handler nor holding a spinlock. The function mdelay in it can be replaced with usleep_range, to reduce

Re: [PATCH v2] b43: Replace mdelay with usleep_range in b43_radio_2057_init_post

2018-01-09 Thread Greg KH
On Tue, Jan 09, 2018 at 09:40:06AM +0800, Jia-Ju Bai wrote: > b43_radio_2057_init_post is not called in an interrupt handler > nor holding a spinlock. > The function mdelay in it can be replaced with usleep_range, > to reduce busy wait. > > Signed-off-by: Jia-Ju Bai >

Re: [1/3] ath10k: fix spelling error

2018-01-09 Thread Kalle Valo
Erik Stromdahl wrote: > Signed-off-by: Erik Stromdahl > Signed-off-by: Kalle Valo 3 patches applied to ath-next branch of ath.git, thanks. 5c9f07132706 ath10k: fix spelling error fbea11c8d583 ath10k: remove unused

Re: [v2,7/9] wil6210: configurable broadcast TX MCS

2018-01-09 Thread Kalle Valo
Maya Erez wrote: > Add 2 module parameters that control broadcast/multicast > TX packets: > 1. bcast_mcs0_limit - specify the maximum packet size > that will be sent with MCS 0. > 2. bcast_mcs - specify the MCS index to use when sending > packets larger than above

Re: [v2,6/9] wil6210: add support for headroom configuration

2018-01-09 Thread Kalle Valo
Maya Erez wrote: > Add module parameter for configuring the headroom size > in the skb allocation. > > Signed-off-by: Lazar Alexei > Signed-off-by: Maya Erez > Signed-off-by: Kalle Valo