[PATCH] wil6210: use memdup_user

2017-05-06 Thread Geliang Tang
Use memdup_user() helper instead of open-coding to simplify the code. Signed-off-by: Geliang Tang <geliangt...@gmail.com> --- drivers/net/wireless/ath/wil6210/debugfs.c | 12 1 file changed, 4 insertions(+), 8 deletions(-) diff --git a/drivers/net/wireless/ath/wil6210/debugf

[PATCH] wlcore: use memdup_user

2017-05-06 Thread Geliang Tang
Use memdup_user() helper instead of open-coding to simplify the code. Signed-off-by: Geliang Tang <geliangt...@gmail.com> --- drivers/net/wireless/ti/wlcore/debugfs.c | 13 +++-- 1 file changed, 3 insertions(+), 10 deletions(-) diff --git a/drivers/net/wireless/ti/wlcore/debugf

[PATCH v2 2/3] staging: rtl8723au: core: rtw_xmit: use list_first_entry_or_null()

2016-03-01 Thread Geliang Tang
Use list_first_entry_or_null() instead of list_empty() + container_of() to simplify the code. Signed-off-by: Geliang Tang <geliangt...@163.com> Acked-by: Jes Sorensen <jes.soren...@redhat.com> --- drivers/staging/rtl8723au/core/rtw_xmit.c | 26 -- 1 fil

[PATCH v2 3/3] staging: rtl8723au: core: rtw_recv: use list_first_entry()

2016-03-01 Thread Geliang Tang
Use list_first_entry() instead of container_of() to simplify the code. Signed-off-by: Geliang Tang <geliangt...@163.com> Acked-by: Jes Sorensen <jes.soren...@redhat.com> --- drivers/staging/rtl8723au/core/rtw_recv.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --g

[PATCH v2 0/3] staging: rtl8723au: use list_first_entry*

2016-03-01 Thread Geliang Tang
On Mon, Feb 22, 2016 at 09:39:15PM -0500, Jes Sorensen wrote: > Geliang Tang <geliangt...@163.com> writes: > > Use list_first_entry*() instead of container_of() to simplify the code. > > > > Signed-off-by: Geliang Tang <geliangt...@163.com> > > --- > &g

[PATCH v2 1/3] staging: rtl8723au: core: rtw_recv: use list_first_entry_or_null()

2016-03-01 Thread Geliang Tang
Use list_first_entry_or_null() instead of list_empty() + container_of() to simplify the code. Signed-off-by: Geliang Tang <geliangt...@163.com> Acked-by: Jes Sorensen <jes.soren...@redhat.com> --- drivers/staging/rtl8723au/core/rtw_recv.c | 42 --- 1 file

[PATCH] staging: rtl8723au: fix static checker warning

2016-03-01 Thread Geliang Tang
Fix the following static checker warning: drivers/staging/rtl8723au/core/rtw_sta_mgt.c:365 rtw_get_stainfo23a() error: potential NULL dereference 'psta'. Fixes: e280d71("staging: rtl8723au: use list_for_each_entry*()") Signed-off-by: Geliang Tang <geliangt...@163.com> ---

[PATCH] staging: rtl8723au: use list_first_entry*

2016-02-22 Thread Geliang Tang
Use list_first_entry*() instead of container_of() to simplify the code. Signed-off-by: Geliang Tang <geliangt...@163.com> --- drivers/staging/rtl8723au/core/rtw_recv.c | 49 +-- drivers/staging/rtl8723au/core/rtw_xmit.c | 26 +--- 2 files chang

[PATCH v5 1/3] staging: rtl8723au: use list_for_each_entry*()

2016-02-18 Thread Geliang Tang
Use list_for_each_entry*() instead of list_for_each*() to simplify the code. Signed-off-by: Geliang Tang <geliangt...@163.com> --- drivers/staging/rtl8723au/core/rtw_ap.c | 59 drivers/staging/rtl8723au/core/rtw_mlme.c | 28 -- drivers/s

[PATCH v5 3/3] staging: rtl8723au: whitespace and blank line cleaning

2016-02-18 Thread Geliang Tang
This patch cleans whitespaces and blank lines involved with previous two patchs in this patch set. Signed-off-by: Geliang Tang <geliangt...@163.com> --- drivers/staging/rtl8723au/core/rtw_ap.c | 33 +-- drivers/staging/rtl8723au/core/rtw_mlme.c

[PATCH v5 0/3] staging: rtl8723au: use list_for_each_entry*() and cleaning

2016-02-18 Thread Geliang Tang
s applied to the wrong git tree, please drop us a note to > > help improving the system] > > > > url: > > https://github.com/0day-ci/linux/commits/Geliang-Tang/staging-rtl8723au-use-list_for_each_entry/20160217-220638 > > config: i386-randconfig-s1-201607 (attach

[PATCH v5 2/3] staging: rtl8723au: core: rtw_recv: remove useless codes

2016-02-18 Thread Geliang Tang
There are some useless codes in rtw_free_recvframe23a_queue() and recvframe_defrag(), so remove them. Signed-off-by: Geliang Tang <geliangt...@163.com> Acked-by: Jes Sorensen <jes.soren...@redhat.com> --- drivers/staging/rtl8723au/core/rtw_recv.c | 9 ++--- 1 file changed, 2 inse

[PATCH v4 3/3] staging: rtl8723au: whitespace and blank line cleaning

2016-02-17 Thread Geliang Tang
This patch cleans whitespaces and blank lines involved with previous two patchs in this patch set. Signed-off-by: Geliang Tang <geliangt...@163.com> --- drivers/staging/rtl8723au/core/rtw_ap.c | 33 +-- drivers/staging/rtl8723au/core/rtw_mlme.c

[PATCH v4 0/3] staging: rtl8723au: use list_for_each_entry*() and cleaning

2016-02-17 Thread Geliang Tang
. Geliang Tang (3): staging: rtl8723au: use list_for_each_entry*() staging: rtl8723au: core: rtw_recv: remove useless codes staging: rtl8723au: whitespace and blank line cleaning drivers/staging/rtl8723au/core/rtw_ap.c | 92 ++- drivers/staging/rtl8723au/core/rtw_mlme.c

[PATCH v4 2/3] staging: rtl8723au: core: rtw_recv: remove useless codes

2016-02-17 Thread Geliang Tang
There are some useless codes in rtw_free_recvframe23a_queue() and recvframe_defrag(), so remove them. Signed-off-by: Geliang Tang <geliangt...@163.com> Acked-by: Jes Sorensen <jes.soren...@redhat.com> --- drivers/staging/rtl8723au/core/rtw_recv.c | 7 +-- 1 file changed, 1 ins

[PATCH v4 1/3] staging: rtl8723au: use list_for_each_entry*()

2016-02-17 Thread Geliang Tang
Use list_for_each_entry*() instead of list_for_each*() to simplify the code. Signed-off-by: Geliang Tang <geliangt...@163.com> --- drivers/staging/rtl8723au/core/rtw_ap.c | 59 drivers/staging/rtl8723au/core/rtw_mlme.c | 28 -- drivers/s

[PATCH v3 1/3] staging: rtl8723au: use list_for_each_entry*()

2016-02-06 Thread Geliang Tang
Use list_for_each_entry*() instead of list_for_each*() to simplify the code. Signed-off-by: Geliang Tang <geliangt...@163.com> --- Changes in v3: - split it into three patches. Changes in v2: - drop the coding style fixing in v1. --- drivers/staging/rtl8723au/core/rtw_ap.c

[PATCH v3 2/3] staging: rtl8723au: core: rtw_recv: remove useless codes

2016-02-06 Thread Geliang Tang
There are some useless codes in rtw_free_recvframe23a_queue() and recvframe_defrag(), so remove them. Signed-off-by: Geliang Tang <geliangt...@163.com> --- Changes in v3: - split it into three patches. Changes in v2: - drop the coding style fixing in v1. --- drivers/staging/rtl8723a

[PATCH v3 3/3] staging: rtl8723au: whitespace and blank line cleaning

2016-02-06 Thread Geliang Tang
This patch cleans whitespaces and blank lines surrounding list_for_each_entry*(). Signed-off-by: Geliang Tang <geliangt...@163.com> --- Changes in v3: - split it into three patches. Changes in v2: - drop the coding style fixing in v1. --- drivers/staging/rtl8723au/core/rtw_ap.c

[PATCH v2] staging: rtl8723au: use list_for_each_entry*()

2016-02-01 Thread Geliang Tang
Use list_for_each_entry*() instead of list_for_each*() to simplify the code. Signed-off-by: Geliang Tang <geliangt...@163.com> --- Changes in v2: - drop the coding style fixing in v1. --- drivers/staging/rtl8723au/core/rtw_ap.c | 92 ++- drivers/staging/rtl

[PATCH] staging: rtl8723au: use list_for_each_entry*()

2016-01-31 Thread Geliang Tang
Use list_for_each_entry*() instead of list_for_each*() to simplify the code. Fix coding style by the way. Signed-off-by: Geliang Tang <geliangt...@163.com> --- drivers/staging/rtl8723au/core/rtw_ap.c | 166 -- drivers/staging/rtl8723au/core/rtw_mlme.c

[PATCH 2/6] wlcore: use to_delayed_work

2016-01-01 Thread Geliang Tang
Use to_delayed_work() instead of open-coding it. Signed-off-by: Geliang Tang <geliangt...@163.com> --- drivers/net/wireless/ti/wlcore/main.c | 10 +- drivers/net/wireless/ti/wlcore/ps.c | 2 +- drivers/net/wireless/ti/wlcore/scan.c | 2 +- 3 files changed, 7 insertions

[PATCH 5/6] mwifiex: use to_delayed_work

2016-01-01 Thread Geliang Tang
Use to_delayed_work() instead of open-coding it. Signed-off-by: Geliang Tang <geliangt...@163.com> --- drivers/net/wireless/marvell/mwifiex/11h.c | 6 ++ 1 file changed, 2 insertions(+), 4 deletions(-) diff --git a/drivers/net/wireless/marvell/mwifiex/11h.c b/drivers/net/wireless/m

[PATCH 4/6] rtlwifi: use to_delayed_work

2016-01-01 Thread Geliang Tang
Use to_delayed_work() instead of open-coding it. Signed-off-by: Geliang Tang <geliangt...@163.com> --- drivers/net/wireless/realtek/rtlwifi/wifi.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/net/wireless/realtek/rtlwifi/wifi.h b/drivers/net/wireless/r

[PATCH 1/6] cfg80211/mac80211: use to_delayed_work

2016-01-01 Thread Geliang Tang
Use to_delayed_work() instead of open-coding it. Signed-off-by: Geliang Tang <geliangt...@163.com> --- net/mac80211/mlme.c | 3 +-- net/wireless/mlme.c | 2 +- 2 files changed, 2 insertions(+), 3 deletions(-) diff --git a/net/mac80211/mlme.c b/net/mac80211/mlme.c index 1c342e2..ea70917

[PATCH 3/6] wl1251: use to_delayed_work

2016-01-01 Thread Geliang Tang
Use to_delayed_work() instead of open-coding it. Signed-off-by: Geliang Tang <geliangt...@163.com> --- drivers/net/wireless/ti/wl1251/ps.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/net/wireless/ti/wl1251/ps.c b/drivers/net/wireless/ti/wl1251/ps.c index b

[PATCH 5/9] ipw2x00: sdhci-pci: use to_pci_dev()

2015-12-27 Thread Geliang Tang
Use to_pci_dev() instead of open-coding it. Signed-off-by: Geliang Tang <geliangt...@163.com> --- drivers/net/wireless/intel/ipw2x00/ipw2100.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/net/wireless/intel/ipw2x00/ipw2100.c b/drivers/net/wireless/intel/i

[PATCH 2/3] NFC: trf7970a: use to_spi_device

2015-12-22 Thread Geliang Tang
Use to_spi_device() instead of open-coding it. Signed-off-by: Geliang Tang <geliangt...@163.com> --- drivers/nfc/trf7970a.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/nfc/trf7970a.c b/drivers/nfc/trf7970a.c index f857feb..10842b7 100644 --- a/drive

[PATCH 4/7] iwlwifi: fix a problematic usage of WARN_ON_ONCE()

2015-11-25 Thread Geliang Tang
WARN_ON_ONCE() takes a condition rather than a format string. This patch converted WARN_ON_ONCE() to WARN_ONCE() instead. Signed-off-by: Geliang Tang <geliangt...@163.com> --- drivers/net/wireless/intel/iwlwifi/mvm/rs.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/d

[PATCH 5/9] staging: wilc1000: fix trivial typos

2015-10-18 Thread Geliang Tang
s/regsiter/register/ Signed-off-by: Geliang Tang <geliangt...@163.com> --- drivers/staging/wilc1000/linux_wlan.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/wilc1000/linux_wlan.c b/drivers/staging/wilc1000/linux_wlan.c index ccab89f..6dc5faf

[PATCH v2] ath6kl: drop unlikely behind WARN_ON()

2015-10-05 Thread Geliang Tang
WARN_ON() already contain an unlikely compiler flag. Drop it. Signed-off-by: Geliang Tang <geliangt...@163.com> --- Changes in v2: - change subject prefix to ath6kl. --- drivers/net/wireless/ath/ath6kl/cfg80211.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/d

[PATCH] mwifiex: fix a comment typo

2015-10-04 Thread Geliang Tang
Just fix a typo in the code comment. Signed-off-by: Geliang Tang <geliangt...@163.com> --- drivers/net/wireless/mwifiex/cfg80211.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/net/wireless/mwifiex/cfg80211.c b/drivers/net/wireless/mwifiex/cfg80211.c index 3