Re: [v4] Fix to avoid IS_ERR_VALUE and IS_ERR abuses on 64bit systems.

2016-08-01 Thread Arnd Bergmann
On Sunday, July 31, 2016 4:48:44 PM CEST Arvind Yadav wrote: > IS_ERR_VALUE() assumes that parameter is an unsigned long. > It can not be used to check if 'unsigned int' is passed insted. > Which tends to reflect an error. > > In 64bit architectures sizeof (int) == 4 && sizeof (long) == 8. >

Re: [PATCH v3 3/3] mac80211: mesh: fixed HT ies in beacon template

2016-08-01 Thread Johannes Berg
On Fri, 2016-07-22 at 14:26 +0900, Masashi Honma wrote: > On 2016年07月14日 05:07, Yaniv Machani wrote: > > + > > + /* if channel width is 20MHz - configure HT capab > > accordingly*/ > > + if (sdata->vif.bss_conf.chandef.width == > > NL80211_CHAN_WIDTH_20) { > > + cap &=

Re: [PATCH 3/3 v6] mac80211: Refactor ieee80211_iface_work

2016-08-01 Thread Johannes Berg
> + if (ieee80211_iface_work_handle_pkt_type(skb, sdata) && > + ieee80211_iface_work_handle_frame_control(skb, sdata)) { > + ieee80211_iface_work_handle_vif_type(skb, sdata); >   } > This ends up being pretty strange IMHO, using boolean

Re: [RFC v0 7/8] Input: ims-pcu: use firmware_stat instead of completion

2016-08-01 Thread Daniel Wagner
On 07/31/2016 09:23 AM, Dmitry Torokhov wrote: On July 30, 2016 9:58:17 AM PDT, "Luis R. Rodriguez" wrote: On Sat, Jul 30, 2016 at 02:42:41PM +0200, Arend van Spriel wrote: On 29-07-16 08:13, Daniel Wagner wrote: On 07/28/2016 09:01 PM, Bjorn Andersson wrote: On Thu 28

Re: [PATCH v3 3/3] mac80211: mesh: fixed HT ies in beacon template

2016-08-01 Thread Masashi Honma
On 2016年08月01日 19:03, Johannes Berg wrote: But why is that behaviour *correct*? We still support 40 MHz bandwidth things, we just don't use them if we disable HT40. I could not fully understand your concern... Do you mean we have 2 bugs about disabling HT40 ? 1) bits in HT capabilities IE

Re: [PATCH 2/3 v6] mac80211: Refactor ieee80211_iface_work

2016-08-01 Thread Johannes Berg
> Added ieee80211_iface_work_handle_frame_control. That function name doesn't really make sense - handle_mgmt() perhaps? johannes -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majord...@vger.kernel.org More majordomo info at

Re: [PATCH] iw: display 5/10 MHz channel widths

2016-08-01 Thread Johannes Berg
On Thu, 2016-07-21 at 11:39 -0400, Bob Copeland wrote: > iw was showing 'width: unknown' for channels on OCB interfaces; teach > it the values for 5/10 MHz so it will show the configured width. > Applied, thanks. johannes -- To unsubscribe from this list: send the line "unsubscribe

Re: [PATCH 1/2] cfg80211: Add support to set tx power for a station associated

2016-08-01 Thread Ben Greear
On 08/01/2016 02:29 AM, Johannes Berg wrote: Sure.. First use case will be to help with the problem of legacy client devices that roam across multiple APs. It is a classic enterprise Wi-Fi AP problem, often managed by a "network controller" unit that is connected to all the APs. The problem

Re: [PATCH 1/3 v6] mac80211: Refactor ieee80211_iface_work

2016-08-01 Thread Johannes Berg
Please don't submit three patches with identical subject. > Added ieee80211_iface_work_handle_pkt_type function. Moved part of Should also use present tense here - "Add ... function, move [...]". This also applies to the other patches. The if/else if/... -> switch change should also be part of

Re: [PATCH] ath10k: disable wake_tx_queue for older devices

2016-08-01 Thread Dave Taht
On Mon, Aug 1, 2016 at 1:35 AM, Roman Yeryomin wrote: > On 7 July 2016 at 19:30, Valo, Kalle wrote: >> Michal Kazior writes: >> >>> Ideally wake_tx_queue should be used regardless as >>> it is a requirement for reducing

Re: Dell Venue 8 Pro "Dell Wireless" (Atheros 6k) chipset with SDIO ID 0271:0418 not recognized/supported

2016-08-01 Thread Kalle Valo
Hi, please don't reply to me privately. Let's keep the discussion on the lists so that others can join and learn. "russianneuroman...@ya.ru" writes: >> That looks good to me, but please submit it officially as defined in >> the wiki > > Just to be sure I understand

Re: [PATCH 1/2] cfg80211: Add support to set tx power for a station associated

2016-08-01 Thread Johannes Berg
> Sure.. First use case will be to help with the problem of legacy > client devices that roam across multiple APs. It is a classic > enterprise Wi-Fi AP problem,  often managed by a "network controller" > unit that is connected to all the APs.  > The problem is how to handle seamless handoff of

Re: [PATCH v2 1/3] mac80211: mesh: flush stations before beacons are stopped

2016-08-01 Thread Johannes Berg
On Wed, 2016-07-13 at 14:44 +0300, Yaniv Machani wrote: > From: Maital Hahn > > Some drivers (e.g. wl18xx) expect that the last stage in the > de-initialization process will be stopping the beacons, similar to AP > flow. > Update ieee80211_stop_mesh() flow accordingly. > As peers

Re: [PATCH v3] cfg80211: Allow different beacon interval if driver supports

2016-08-01 Thread Johannes Berg
On Fri, 2016-07-22 at 15:12 +0530, Purushottam Kushwaha wrote: > Driver may allow support for different beacon interval on virtual > interfaces. > Allow if such support is advertised by driver. This adds new > ext_feature as > NL80211_EXT_FEATURE_DIFF_BEACON_INTERVAL. > My earlier comment

RE: [PATCH 1/1] mwifiex: remove superfluous condition

2016-08-01 Thread Amitkumar Karwar
> From: Heinrich Schuchardt [mailto:xypron.g...@gmx.de] > Sent: Sunday, July 31, 2016 4:09 PM > To: Amitkumar Karwar; Nishant Sarmukadam; Kalle Valo > Cc: linux-wireless@vger.kernel.org; net...@vger.kernel.org; linux- > ker...@vger.kernel.org; Heinrich Schuchardt > Subject: [PATCH 1/1] mwifiex:

RE: [PATCH 1/1] mwifiex: key_material_v2 remove superfluous condition

2016-08-01 Thread Amitkumar Karwar
> From: Heinrich Schuchardt [mailto:xypron.g...@gmx.de] > Sent: Sunday, July 31, 2016 5:41 PM > To: Amitkumar Karwar; Nishant Sarmukadam; Kalle Valo > Cc: linux-wireless@vger.kernel.org; net...@vger.kernel.org; linux- > ker...@vger.kernel.org; Heinrich Schuchardt > Subject: [PATCH 1/1] mwifiex:

Re: rfkill bound to a switch

2016-08-01 Thread Johannes Berg
On Thu, 2016-07-28 at 16:02 +0800, Kai Hendry wrote: > Hi there, > > Since laptops typically have a toggle button for killing and enabled > wifi, how does one supposed to bind rfkill like a toggle? > > I.e. knowing which state you are in so you can call {block,unblock} > accordingly? > >

Re: [PATCH v2 RESEND] qtnfmac: announcement of new FullMAC driver for Quantenna chipsets

2016-08-01 Thread Johannes Berg
> > > > > + /* bus private data */ > > > + char bus_priv[0]; > > You might want to - for future proofing - add some aligned() > > attribute. > > Otherwise, if struct mutex doesn't have a size that's a multiple of > > the > > pointer size, fields in here will not be aligned right. > > Right,

Re: [PATCH 1/4] mac80211: mesh: flush stations before beacons are stopped

2016-08-01 Thread Johannes Berg
On Wed, 2016-07-13 at 10:11 +, Machani, Yaniv wrote: > On Wed, Jun 29, 2016 at 10:14:19, Johannes Berg wrote: > > Cc: Hahn, Maital > > Subject: Re: [PATCH 1/4] mac80211: mesh: flush stations before > > beacons  > > are stopped > > > > On Tue, 2016-06-28 at 14:13 +0300, Yaniv Machani wrote: >

Re: [RFC v0 7/8] Input: ims-pcu: use firmware_stat instead of completion

2016-08-01 Thread Bjorn Andersson
On Sat 30 Jul 09:58 PDT 2016, Luis R. Rodriguez wrote: > On Sat, Jul 30, 2016 at 02:42:41PM +0200, Arend van Spriel wrote: > > + Luis (again) ;-) > > > > On 29-07-16 08:13, Daniel Wagner wrote: > > > On 07/28/2016 09:01 PM, Bjorn Andersson wrote: > > >> On Thu 28 Jul 11:33 PDT 2016, Dmitry

Re: [RFC v0 7/8] Input: ims-pcu: use firmware_stat instead of completion

2016-08-01 Thread Luis R. Rodriguez
On Mon, Aug 01, 2016 at 10:19:51AM -0700, Bjorn Andersson wrote: > On Sat 30 Jul 09:58 PDT 2016, Luis R. Rodriguez wrote: > > > On Sat, Jul 30, 2016 at 02:42:41PM +0200, Arend van Spriel wrote: > > > + Luis (again) ;-) > > > > > > On 29-07-16 08:13, Daniel Wagner wrote: > > > > On 07/28/2016

[v4] Fix to avoid IS_ERR_VALUE and IS_ERR abuses on 64bit systems.

2016-08-01 Thread Arvind Yadav
IS_ERR_VALUE() assumes that parameter is an unsigned long. It can not be used to check if 'unsigned int' is passed insted. Which tends to reflect an error. In 64bit architectures sizeof (int) == 4 && sizeof (long) == 8. IS_ERR_VALUE(x) is ((x) >= (unsigned long)-4095). IS_ERR_VALUE() of

[PATCH] drivers: wilc1000: remove references to semaphores

2016-08-01 Thread Joshua Houghton
* Update the comments that refer to semaphores * Remove redundant includes to semphore.h Signed-off-by: Joshua Houghton --- drivers/staging/wilc1000/TODO | 1 - drivers/staging/wilc1000/linux_wlan.c | 1 - drivers/staging/wilc1000/wilc_wfi_netdevice.h |

Re: [v4] Fix to avoid IS_ERR_VALUE and IS_ERR abuses on 64bit systems.

2016-08-01 Thread Scott Wood
On 08/01/2016 02:02 AM, Arnd Bergmann wrote: > On Sunday, July 31, 2016 4:48:44 PM CEST Arvind Yadav wrote: >> IS_ERR_VALUE() assumes that parameter is an unsigned long. >> It can not be used to check if 'unsigned int' is passed insted. >> Which tends to reflect an error. >> >> In 64bit

Re: [RFC v0 7/8] Input: ims-pcu: use firmware_stat instead of completion

2016-08-01 Thread Luis R. Rodriguez
On Mon, Aug 01, 2016 at 02:26:04PM +0200, Daniel Wagner wrote: > On 07/31/2016 09:23 AM, Dmitry Torokhov wrote: > >On July 30, 2016 9:58:17 AM PDT, "Luis R. Rodriguez" > >wrote: > >>On Sat, Jul 30, 2016 at 02:42:41PM +0200, Arend van Spriel wrote: > >>>On 29-07-16 08:13,

Re: [RFC v0 7/8] Input: ims-pcu: use firmware_stat instead of completion

2016-08-01 Thread Luis R. Rodriguez
On Sun, Jul 31, 2016 at 12:23:09AM -0700, Dmitry Torokhov wrote: > On July 30, 2016 9:58:17 AM PDT, "Luis R. Rodriguez" > wrote: > >On Sat, Jul 30, 2016 at 02:42:41PM +0200, Arend van Spriel wrote: > >> + Luis (again) ;-) > >> > >> On 29-07-16 08:13, Daniel Wagner wrote: > >>

Re: [PATCH v3 3/3] mac80211: mesh: fixed HT ies in beacon template

2016-08-01 Thread Masashi Honma
On 2016年08月01日 19:03, Johannes Berg wrote: But why is that behaviour *correct*? We still support 40 MHz bandwidth things, we just don't use them if we disable HT40. Or do you mean difference between "hardware capability" and "software capability" ? Do you think

Re: [RFC v0 7/8] Input: ims-pcu: use firmware_stat instead of completion

2016-08-01 Thread Dmitry Torokhov
On Mon, Aug 01, 2016 at 10:19:51AM -0700, Bjorn Andersson wrote: > On Sat 30 Jul 09:58 PDT 2016, Luis R. Rodriguez wrote: > > > On Sat, Jul 30, 2016 at 02:42:41PM +0200, Arend van Spriel wrote: > > > + Luis (again) ;-) > > > > > > On 29-07-16 08:13, Daniel Wagner wrote: > > > > On 07/28/2016

Re: [RFC v0 7/8] Input: ims-pcu: use firmware_stat instead of completion

2016-08-01 Thread Daniel Wagner
Hi Luis, I was ignorant on all the nasty details around the firmware loading. If I parse Luis' patches correctly they introduce an API which calls kernel_read_file_from_path() asynchronously: sysdata_file_request_async(..., ) *coookie = async_schedule_domain(request_sysdata_file_work_func(),