Re: RT2870 failure in kernel 4.12.8

2017-08-31 Thread Kalle Valo
Stanislaw Gruszka writes: > On Wed, Aug 30, 2017 at 12:03:06PM -0500, Larry Finger wrote: >> Stanislaw and Helmut, >> >> In a bug report at https://bugzilla.suse.com/show_bug.cgi?id=1055826, the OP >> reports that his RT3572 fails to work after an upgrade from the openSUSE

Re: [PATCH 5/5] qtnfmac: implement 64-bit dma support

2017-08-31 Thread Kalle Valo
Sergey Matyukevich writes: > Hello Kalle, > >> > - writel(QTN_HOST_LO32(paddr), >> > -PCIE_HDP_TX_HOST_Q_BASE_L(priv->pcie_reg_base)); >> > +#ifdef CONFIG_ARCH_DMA_ADDR_T_64BIT >> > writel(QTN_HOST_HI32(paddr), >> >

Re: rfkill(8) move and improvements

2017-08-31 Thread Karel Zak
On Wed, Aug 30, 2017 at 08:40:01PM +0100, Sami Kerola wrote: > On 1 July 2017 at 10:06, Sami Kerola wrote: > > I did couple last minute changes to my remote branch, that should now be > > ready for final review. > > > > git://github.com/kerolasa/lelux-utiliteetit.git rfkill > >

Re: [PATCH 5/5] qtnfmac: implement 64-bit dma support

2017-08-31 Thread Sergey Matyukevich
Hello Kalle, > > - writel(QTN_HOST_LO32(paddr), > > -PCIE_HDP_TX_HOST_Q_BASE_L(priv->pcie_reg_base)); > > +#ifdef CONFIG_ARCH_DMA_ADDR_T_64BIT > > writel(QTN_HOST_HI32(paddr), > > PCIE_HDP_TX_HOST_Q_BASE_H(priv->pcie_reg_base)); > > +#endif > > Personally I

[PATCH] mac80211: fix incorrect assignment of reassoc value

2017-08-31 Thread Simon Dinkin
this fix minor issue in the log message. in ieee80211_rx_mgmt_assoc_resp function, when assigning the reassoc value from the mgmt frame control: ieee80211_is_reassoc_resp function need to be used, instead of ieee80211_is_reassoc_req function. Signed-off-by: Simon Dinkin

Re: [v3,1/2] ath10k: add the PCI PM core suspend/resume ops

2017-08-31 Thread Kalle Valo
ryan...@qti.qualcomm.com wrote: > The actual PCI suspend/resume in ath10k has been handled in wow.c, > but in the case of the device doesn't support remote wakeup, > the .hif_suspend() and .hif_resume() will never be handled. > > ath10k_wow_op_suspend() > { > if

Re: [1/5] qtnfmac: drop -D__CHECK_ENDIAN from cflags

2017-08-31 Thread Kalle Valo
Sergey Matyukevich wrote: > Flag -D__CHECK_ENDIAN was wrong: it should be -D__CHECK_ENDIAN__ instead. > However now this flag is enabled by default, so it can be removed. > > Signed-off-by: Sergey Matyukevich 5 patches

Re: [v2] brcmfmac: Log chip id and revision

2017-08-31 Thread Kalle Valo
Hans de Goede wrote: > For debugging some problems, it is useful to know the chip revision > add a brcmf_info message logging this. > > Signed-off-by: Hans de Goede > Acked-by: Arend van Spriel Patch applied to

Re: [GIT] Networking

2017-08-31 Thread Kalle Valo
(Adding linux-wireless) Pavel Machek writes: > On Thu 2017-08-31 07:44:58, Kalle Valo wrote: >> David Miller writes: >> >> > From: Kalle Valo >> > Date: Wed, 30 Aug 2017 20:31:31 +0300 >> > >> >> AFAICS the bug was introduced by

Re: [v2] ath10k: sdio: remove unused struct member

2017-08-31 Thread Kalle Valo
Erik Stromdahl wrote: > irq_wq in struct ath10k_sdio is a remnant from an earlier > version of the sdio patchset. > > Its use was removed as a result of Kalle's review, but somehow > the struct member survived. > > It is not used and can therefore safely be removed. >

Re: [1/7] wil6210: ratelimit errors in TX/RX interrupts

2017-08-31 Thread Kalle Valo
Maya Erez wrote: > Sometimes there is a firmware crash but the hardware > is not fully stopped and continue to send TX/RX interrupts. > This can cause an overload of messages which can bring the > host down. Add ratelimit to these error messages to fix this. > >

[PATCH 20/25] mac80211_hwsim: Replace hrtimer tasklet with softirq hrtimer

2017-08-31 Thread Anna-Maria Gleixner
From: Thomas Gleixner Switch the timer to CLOCK_MONOTONIC_SOFT, which executed the timer callback in softirq context and remove the hrtimer_tasklet. Signed-off-by: Thomas Gleixner Signed-off-by: Anna-Maria Gleixner Cc: Johannes

Re: rtlwifi: rtl8723be: fix duplicated code for different branches

2017-08-31 Thread Kalle Valo
"Gustavo A. R. Silva" wrote: > Refactor code in order to avoid identical code for different branches. > > Addresses-Coverity-ID: 1248728 > Signed-off-by: Gustavo A. R. Silva > Acked-by: Larry Finger Patch applied to

[PATCH] ath9k: remove cast to void pointer

2017-08-31 Thread Himanshu Jha
casting to void pointer from any pointer type and vice-versa is done implicitly and therefore casting is not needed in such a case. Signed-off-by: Himanshu Jha --- drivers/net/wireless/ath/ath9k/ar9003_mac.c | 4 ++-- drivers/net/wireless/ath/ath9k/dfs.c

Re: ath10k: fix napi_poll budget overflow

2017-08-31 Thread Kalle Valo
ryan...@qti.qualcomm.com wrote: > In napi_poll, the budget number is used to control the amount of packets > we should handle per poll to balance the resource in the system. > > In the list of the amsdu packets reception, we check if there is budget > count left and handle the complete list of

Re: ath10k: activate user space firmware loading again

2017-08-31 Thread Kalle Valo
Hauke Mehrtens wrote: > In commit 9f5bcfe93315 ("ath10k: silence firmware file probing > warnings") the firmware loading was changed from request_firmware() to > request_firmware_direct() to silence some warnings in case it fails. > request_firmware_direct() directly searches

[PATCH] Correctly fail to suspend when SDIO does not support power on suspend

2017-08-31 Thread Eric Bentley
Return error when failing to set power management capabilities flag. This will cause the suspend to fail but the radio will continue to operate. Allowing this to fail without reporting error will cause the radio to be non-functional on resume as it will have lost power. Signed-off-by: Eric

Re: RT2870 failure in kernel 4.12.8

2017-08-31 Thread Larry Finger
On 08/31/2017 02:55 AM, Stanislaw Gruszka wrote: On Wed, Aug 30, 2017 at 12:03:06PM -0500, Larry Finger wrote: Stanislaw and Helmut, In a bug report at https://bugzilla.suse.com/show_bug.cgi?id=1055826, the OP reports that his RT3572 fails to work after an upgrade from the openSUSE Tumbleweed

[PATCH] wl1251: add a missing spin_lock_init()

2017-08-31 Thread Pavel Machek
From: Cong Wang wl1251: add a missing spin_lock_init() This fixes the following kernel warning: [ 5668.771453] BUG: spinlock bad magic on CPU#0, kworker/u2:3/9745 [ 5668.771850] lock: 0xce63ef20, .magic: , .owner: /-1, .owner_cpu: 0 [ 5668.772277]

Re: [PATCH] rtlwifi: refactor code in halbtcoutsrc module

2017-08-31 Thread Larry Finger
On 08/30/2017 11:46 AM, Gustavo A. R. Silva wrote: Function halbtc_get_wifi_rssi always returns rtlpriv->dm.undec_sm_pwdb. So this function can be removed and the value of rtlpriv->dm.undec_sm_pwdb assigned to *s32_tmp directly. This issue was first reported by Coverity as "identical code for

Re: [PATCH 18/30] brcmfmac: Cleanup offsetof()

2017-08-31 Thread Ian Molton
On 30/08/17 20:37, Arend van Spriel wrote: > On 22-08-17 13:25, Ian Molton wrote: >> +#define __sd_reg(field) \ >> +(offsetof(struct sdpcmd_regs, field)) > > I really dislike __foo() stuff. Please just stick with uppercase for > macros, so SD_REG(). I am fine with dropping the base here.

Re: [PATCH 03/30] brcmfmac: Split brcmf_sdiod_regrw_helper() up.

2017-08-31 Thread Ian Molton
On 30/08/17 19:59, Arend van Spriel wrote: >> +static int brcmf_sdiod_reg_write(struct brcmf_sdio_dev *sdiodev, u32 >> addr, >> + u8 regsz, void *data) > > Thought I mentioned this before, but the indentation should be aligned > to opening bracket. I checked this locally, and its

Re: [PATCH 13/30] brcmfmac: Clarify if using braces.

2017-08-31 Thread Ian Molton
On 30/08/17 20:11, Arend van Spriel wrote: >> Whilst this if () statement is technically correct, it lacks clarity. > > I don't see the unclarity here. In my opinion people reading the code > should have a good level in C language and a decent level of curiosity > when they come across a

[PATCH] rtlwifi: btcoexist: 23b 1ant: fix duplicated code for different branches

2017-08-31 Thread Larry Finger
A typo led to this issue, which was detected with the help of Coccinelle. In addition to fixing the error, the code is refactored to eliminate an if statement. Addresses-Coverity-ID: 1226788 Reported-by: Gustavo A. R. Silva Signed-off-by: Larry Finger

Re: [PATCH 01/30] brcmfmac: Fix parameter order in brcmf_sdiod_f0_writeb()

2017-08-31 Thread Ian Molton
On 30/08/17 19:51, Arend van Spriel wrote: > On 22-08-17 13:25, Ian Molton wrote: >> All the other IO functions are the other way round in this >> driver. Make this one match. > > Sorry for being a nit, but not sure why the commit message starts with a > tab. Not a problem - I don't mind

Re: RT2870 failure in kernel 4.12.8

2017-08-31 Thread Larry Finger
On 08/31/2017 02:55 AM, Stanislaw Gruszka wrote: I think it is the issue addressed by this 4.12 patch: https://marc.info/?l=linux-wireless=150366111408179=2 Patch for 4.13+ kernels is here: https://marc.info/?l=linux-wireless=150367345912061=2 A potential problem with this solution is that

Re: [PATCH] wl1251: add a missing spin_lock_init()

2017-08-31 Thread Pavel Machek
Hi! On Thu 2017-08-31 12:26:45, David Miller wrote: > From: Pavel Machek > Date: Thu, 31 Aug 2017 20:57:19 +0200 > > > Hi! > > > >> From: Pavel Machek > >> Date: Thu, 31 Aug 2017 16:47:43 +0200 > >> > >> > Dave, Linus -- can you still take the patch? > >> > >>

Re: [PATCH] wl1251: add a missing spin_lock_init()

2017-08-31 Thread David Miller
From: Pavel Machek Date: Thu, 31 Aug 2017 21:59:33 +0200 > Do you plan to send another pull request to Linus, and can you take > the patch, please? Yes and yes.

Re: [PATCH] wl1251: add a missing spin_lock_init()

2017-08-31 Thread Pavel Machek
Hi! > From: Pavel Machek > Date: Thu, 31 Aug 2017 16:47:43 +0200 > > > Dave, Linus -- can you still take the patch? > > Pavel, please do not bypass maintainers like this. > > It's really rude, and if you do things like that instead of > trying to work properly with us, your

Re: [PATCH] wl1251: add a missing spin_lock_init()

2017-08-31 Thread David Miller
From: Pavel Machek Date: Thu, 31 Aug 2017 16:47:43 +0200 > Dave, Linus -- can you still take the patch? Pavel, please do not bypass maintainers like this. It's really rude, and if you do things like that instead of trying to work properly with us, your relationship with these

Re: [v3,1/2] ath10k: add the PCI PM core suspend/resume ops

2017-08-31 Thread Kalle Valo
ryan...@qti.qualcomm.com wrote: > The actual PCI suspend/resume in ath10k has been handled in wow.c, > but in the case of the device doesn't support remote wakeup, > the .hif_suspend() and .hif_resume() will never be handled. > > ath10k_wow_op_suspend() > { > if

Re: [PATCH] wl1251: add a missing spin_lock_init()

2017-08-31 Thread David Miller
From: Pavel Machek Date: Thu, 31 Aug 2017 20:57:19 +0200 > Hi! > >> From: Pavel Machek >> Date: Thu, 31 Aug 2017 16:47:43 +0200 >> >> > Dave, Linus -- can you still take the patch? >> >> Pavel, please do not bypass maintainers like this. >> >> It's really rude,

Re: [PATCH] mwifiex: check for mfg_mode in add_virtual_intf

2017-08-31 Thread Brian Norris
On Thu, Aug 31, 2017 at 12:16:58AM +0530, Ganapathi Bhat wrote: > If driver is loaded with 'mfg_mode' enabled, then the sending > commands are not allowed. So, when mwifiex_send_cmd fails in > mwifiex_add_virtual_intf, driver must check for 'mfg_mode' before > returning error. > > Fixes:

Re: [PATCH] ath9k: remove cast to void pointer

2017-08-31 Thread Joe Perches
On Thu, 2017-08-31 at 18:37 +0530, Himanshu Jha wrote: > casting to void pointer from any pointer type and vice-versa is done > implicitly and therefore casting is not needed in such a case. You said you were going to remember to mention the tool and script that did this.

Re: [PATCH 1/2] iwlwifi: fix long debug print

2017-08-31 Thread Joe Perches
On Fri, 2017-08-25 at 11:27 +0300, Luca Coelho wrote: > From: Liad Kaufman > > There is a debug print that sometimes reaches over > 110 chars, thus generating a warning in those cases. What emits a warning here?

[PATCH 13/31] timer: Remove meaningless .data/.function assignments

2017-08-31 Thread Kees Cook
Several timer users needlessly reset their .function/.data fields during their timer callback, but nothing else changes them. Some users do not use their .data field at all. Each instance is removed here. Cc: Krzysztof Halasa Cc: Aditya Shankar Cc:

Re: [PATCH] Correctly fail to suspend when SDIO does not support power on suspend

2017-08-31 Thread Eric Bentley
Yep – tried to clean some white space up at the last minute…ugh On 8/31/17, 7:49 PM, "steve.deros...@gmail.com on behalf of Steve deRosier" wrote: On Thu, Aug 31, 2017 at 4:44 PM, Eric Bentley wrote:

[PATCH] Correctly fail to suspend when SDIO does not support power on suspend

2017-08-31 Thread Eric Bentley
Return error when failing to set power management capabilities flag.  This will cause the suspend to fail but the radio will continue to operate.  Allowing this to fail without reporting error will cause the radio to be non-functional on  resume as it will have lost power. Signed-off-by: Eric

Re: [PATCH] Correctly fail to suspend when SDIO does not support power on suspend

2017-08-31 Thread Steve deRosier
On Thu, Aug 31, 2017 at 4:44 PM, Eric Bentley wrote: > - if (sdio_set_host_pm_flags(sdiodev->func[1], sdio_flags)) > + if (sdio_set_host_pm_flags(sdiodev->func[1], sdio_flags)) ( Hi Eric, Shouldn't that be a '{' instead of '('? Maybe I'm missing some

Re: [PATCH v2] Correctly fail to suspend when SDIO does not support power on suspend

2017-08-31 Thread Eric Bentley
Return error when failing to set power management capabilities flag. This will cause the suspend to fail but the radio will continue to operate. Allowing this to fail without reporting error will cause the radio to be non-functional on resume as it will have lost power. Signed-off-by: Eric

Re: [PATCH 1/2] iwlwifi: fix long debug print

2017-08-31 Thread Luca Coelho
On Thu, 2017-08-31 at 14:57 -0700, Joe Perches wrote: > On Fri, 2017-08-25 at 11:27 +0300, Luca Coelho wrote: > > From: Liad Kaufman > > > > There is a debug print that sometimes reaches over > > 110 chars, thus generating a warning in those cases. > > What emits a

Re: [PATCH v2] Correctly fail to suspend when SDIO does not support power on suspend

2017-08-31 Thread Kalle Valo
Eric Bentley writes: > Return error when failing to set power management capabilities flag. This > will cause the suspend to fail but the radio > will continue to operate. Allowing this to fail without reporting error will > cause the radio to be non-functional on

Re: [PATCH 13/31] timer: Remove meaningless .data/.function assignments

2017-08-31 Thread Greg Kroah-Hartman
On Thu, Aug 31, 2017 at 04:29:25PM -0700, Kees Cook wrote: > Several timer users needlessly reset their .function/.data fields during > their timer callback, but nothing else changes them. Some users do not > use their .data field at all. Each instance is removed here. > > Cc: Krzysztof Halasa

Re: [PATCH v2] iwlwifi: pcie: move rx workqueue initialization to iwl_trans_pcie_alloc()

2017-08-31 Thread Luca Coelho
On Wed, 2017-08-30 at 17:57 +0300, David Weinehall wrote: > On Tue, Aug 22, 2017 at 10:37:29AM +0300, Luca Coelho wrote: > > From: Luca Coelho > > > > Work queues cannot be allocated when a mutex is held because the mutex > > may be in use and that would make it sleep.

Re: RT2870 failure in kernel 4.12.8

2017-08-31 Thread Stanislaw Gruszka
On Wed, Aug 30, 2017 at 12:03:06PM -0500, Larry Finger wrote: > Stanislaw and Helmut, > > In a bug report at https://bugzilla.suse.com/show_bug.cgi?id=1055826, the OP > reports that his RT3572 fails to work after an upgrade from the openSUSE > Tumbleweed kernel 4.12.7 to 4.12.8. I checked the