Re: [PATCH 02/19] ipw2x00: use to_pci_dev()

2016-03-24 Thread Stanislav Yakovlev
On 18 March 2016 at 06:20, Julian Calaby wrote: > From: Geliang Tang > > Use to_pci_dev() instead of open-coding it. > > Signed-off-by: Geliang Tang > Signed-off-by: Julian Calaby > --- >

[PATCH v3] cfg80211: add start / stop NAN commands

2016-03-24 Thread Emmanuel Grumbach
This allows user space to start/stop NAN interface. A NAN interface is like P2P device in a few aspects: it doesn't have a netdev associated to it. Add the new interface type and prevent operations that can't be executed on NAN interface like scan. Define several attributes that may be configured

Re: [PATCH v2] cfg80211: add start / stop NAN commands

2016-03-24 Thread Grumbach, Emmanuel
On Thu, 2016-03-24 at 19:30 +0100, Arend Van Spriel wrote: > > On 24-3-2016 16:12, Emmanuel Grumbach wrote: > > This allows user space to start/stop NAN interface. > > A NAN interface is like P2P device in a few aspects: it > > doesn't have a netdev associated to it. > > Add the new interface

Re: [PATCH v2] cfg80211: add start / stop NAN commands

2016-03-24 Thread Arend Van Spriel
On 24-3-2016 16:12, Emmanuel Grumbach wrote: > This allows user space to start/stop NAN interface. > A NAN interface is like P2P device in a few aspects: it > doesn't have a netdev associated to it. > Add the new interface type and prevent operations that > can't be executed on NAN interface

Re: Google Summer of Code 2016 - Many new applications

2016-03-24 Thread Greg KH
On Thu, Mar 24, 2016 at 02:39:55PM -0300, Till Kamppeter wrote: > Hi, > > tomorrow the student application period will end. Up to now we got 22 > applications, where many lokk interesting and some really strange. > > Most are for the kernel, many for LSB, and I had also some luck getting 3 > for

Google Summer of Code 2016 - Many new applications

2016-03-24 Thread Till Kamppeter
Hi, tomorrow the student application period will end. Up to now we got 22 applications, where many lokk interesting and some really strange. Most are for the kernel, many for LSB, and I had also some luck getting 3 for OpenPrinting. Please everyone of you, have a look whether there are

RE: [PATCH v2] mwifiex: advertise low priority scan feature

2016-03-24 Thread Amitkumar Karwar
> From: Wei-Ning Huang [mailto:wnhu...@chromium.org] > Sent: Tuesday, March 22, 2016 9:40 AM > To: Linux Wireless > Cc: LKML; Amitkumar Karwar; djku...@chromium.org; Wei-Ning Huang; > Nishant Sarmukadam; kv...@codeaurora.org; net...@vger.kernel.org > Subject: [PATCH v2] mwifiex: advertise low

Re: [PATCH 1/9] ath10k: speedup htt rx descriptor processing for tx completion

2016-03-24 Thread Manoharan, Rajkumar
[...] >> >> I see two new warnings on the kfifo_put() call: >> >> drivers/net/wireless/ath/ath10k/htt_rx.c:1722:22: warning: cast to non-scalar >> drivers/net/wireless/ath/ath10k/htt_rx.c:1722:22: warning: cast from >> non-scalar >> >> But I suspect they are false warnings due to my old compiler:

Re: [PATCH 1/9] ath10k: speedup htt rx descriptor processing for tx completion

2016-03-24 Thread Manoharan, Rajkumar
[...] > >> @@ -1712,7 +1710,20 @@ static void ath10k_htt_rx_frm_tx_compl(struct ath10k >> *ar, >> for (i = 0; i < resp->data_tx_completion.num_msdus; i++) { >> msdu_id = resp->data_tx_completion.msdus[i]; >> tx_done.msdu_id = __le16_to_cpu(msdu_id); >> -

[PATCH v2] cfg80211: allow the user space to change current NAN configuration

2016-03-24 Thread Emmanuel Grumbach
Some NAN configuration paramaters may change during the operation of the NaN device. For example, a user may want to update master preference value when the device gets plugged/unplugged to the power. Add API that allows to do so. Signed-off-by: Andrei Otcheretianski

[PATCH v2] cfg80211: add start / stop NAN commands

2016-03-24 Thread Emmanuel Grumbach
This allows user space to start/stop NAN interface. A NAN interface is like P2P device in a few aspects: it doesn't have a netdev associated to it. Add the new interface type and prevent operations that can't be executed on NAN interface like scan. Define several attributes that may be configured

[PATCH 2/4] ath10k: prefer kernel type 'u64' over 'u_int64_t'

2016-03-24 Thread Kalle Valo
Fixes checkpatch warnings: drivers/net/wireless/ath/ath10k/htt.h:1477: Prefer kernel type 'u64' over 'u_int64_t' drivers/net/wireless/ath/ath10k/htt.h:1480: Prefer kernel type 'u64' over 'u_int64_t' Signed-off-by: Kalle Valo --- drivers/net/wireless/ath/ath10k/htt.h |

[PATCH 1/4] ath10k: fix checkpatch warnings related to spaces

2016-03-24 Thread Kalle Valo
Fix checkpatch warnings about use of spaces with operators: spaces preferred around that '*' (ctx:VxV) This has been recently added to checkpatch. Signed-off-by: Kalle Valo --- drivers/net/wireless/ath/ath10k/ce.c|6 +++---

[PATCH 4/4] ath10k: prefer ether_addr_copy() over memcpy()

2016-03-24 Thread Kalle Valo
Fixes checkpatch warning: drivers/net/wireless/ath/ath10k/wmi.c:5800: Prefer ether_addr_copy() over memcpy() if the Ethernet addresses are __aligned(2) Signed-off-by: Kalle Valo --- drivers/net/wireless/ath/ath10k/wmi.c |5 ++--- 1 file changed, 2 insertions(+), 3

[PATCH 3/4] ath10k: prefer ether_addr_equal() or ether_addr_equal_unaligned() over memcmp()

2016-03-24 Thread Kalle Valo
Fixes checkpatch warnings: drivers/net/wireless/ath/ath10k/mac.c:452: Prefer ether_addr_equal() or ether_addr_equal_unaligned() over memcmp() drivers/net/wireless/ath/ath10k/mac.c:455: Prefer ether_addr_equal() or ether_addr_equal_unaligned() over memcmp()

Re: [RFD] workqueue: WQ_MEM_RECLAIM usage in network drivers

2016-03-24 Thread Johannes Berg
On Sun, 2016-03-20 at 14:55 -0400, Tejun Heo wrote: > If everything else is working, I'd be happy to throw in > WQ_MEM_RECLAIM but I really don't want to add it if it doesn't > actually achieve the goal.  Can a wireless person chime in here? > I think for many wireless devices the workqueue,

[PATCH 0/4] ath10k: fix recent checkpatch warnings

2016-03-24 Thread Kalle Valo
I updated checkpatch and noticed that there are few new warnings. --- Kalle Valo (4): ath10k: fix checkpatch warnings related to spaces ath10k: prefer kernel type 'u64' over 'u_int64_t' ath10k: prefer ether_addr_equal() or ether_addr_equal_unaligned() over memcmp()

Re: [1/2] bcma: fix building without OF_IRQ

2016-03-24 Thread Arnd Bergmann
On Thursday 24 March 2016 15:53:14 Kalle Valo wrote: > Arnd Bergmann writes: > > > On Wednesday 23 March 2016 15:52:43 Kalle Valo wrote: > >> > The bcma driver core can be built with or without DT support, but > >> > it fails to build when CONFIG_OF=y and CONFIG_OF_IRQ=n, which >

Re: [1/2] bcma: fix building without OF_IRQ

2016-03-24 Thread Kalle Valo
Arnd Bergmann writes: > On Wednesday 23 March 2016 15:52:43 Kalle Valo wrote: >> > The bcma driver core can be built with or without DT support, but >> > it fails to build when CONFIG_OF=y and CONFIG_OF_IRQ=n, which >> > can happen on platforms that do not support IRQ domains. >>

Re: [1/2] bcma: fix building without OF_IRQ

2016-03-24 Thread Arnd Bergmann
On Wednesday 23 March 2016 15:52:43 Kalle Valo wrote: > > The bcma driver core can be built with or without DT support, but > > it fails to build when CONFIG_OF=y and CONFIG_OF_IRQ=n, which > > can happen on platforms that do not support IRQ domains. > > > > ERROR: "irq_create_of_mapping"

Re: [PATCH 1/9] ath10k: speedup htt rx descriptor processing for tx completion

2016-03-24 Thread Valo, Kalle
Rajkumar Manoharan writes: > To optimize CPU usage htt rx descriptors will be reused instead of > refilling it for htt rx copy engine (CE5). To support that all htt rx > indications should be processed at same context. FIFO queue is used > to maintain tx completion

Re: [RFCv2 2/3] ath10k: report per-station tx/rate rates to mac80211

2016-03-24 Thread Michal Kazior
On 24 March 2016 at 13:23, Mohammed Shafi Shajakhan wrote: > On Thu, Mar 24, 2016 at 08:49:12AM +0100, Michal Kazior wrote: >> On 24 March 2016 at 08:19, Mohammed Shafi Shajakhan >> wrote: >> > Hi Michal, >> > >> > On Wed, Mar 16, 2016 at

Re: [RFCv2 2/3] ath10k: report per-station tx/rate rates to mac80211

2016-03-24 Thread Mohammed Shafi Shajakhan
On Thu, Mar 24, 2016 at 08:49:12AM +0100, Michal Kazior wrote: > On 24 March 2016 at 08:19, Mohammed Shafi Shajakhan > wrote: > > Hi Michal, > > > > On Wed, Mar 16, 2016 at 11:17:57AM +0100, Michal Kazior wrote: > >> The rate control is offloaded by firmware so it's > >>

Re: [PATCH v2 1/2] ath10k: Add support for ath10k_sta_statistics support

2016-03-24 Thread Mohammed Shafi Shajakhan
Hi Michal / Kalle, > > On Thu, Mar 17, 2016 at 12:35:00PM +0100, Michal Kazior wrote: > > On 17 March 2016 at 12:20, Mohammed Shafi Shajakhan > > wrote: > > > Hi Michal, > > > > > > On Thu, Mar 17, 2016 at 12:12:31PM +0100, Michal Kazior wrote: > > >> On 17 March 2016

Re: [PATCH 2/2] wil6210: add module parameter for alternate interface name

2016-03-24 Thread Lior David
On 3/23/2016 5:27 PM, Kalle Valo wrote: > Maya Erez writes: > >> From: Lior David >> >> Add a module parameter alt_ifname that when set, will name >> the primary network interface wigig instead of the default >> wlan. This helps platforms

Re: [RFCv2 2/3] ath10k: report per-station tx/rate rates to mac80211

2016-03-24 Thread Michal Kazior
On 24 March 2016 at 08:19, Mohammed Shafi Shajakhan wrote: > Hi Michal, > > On Wed, Mar 16, 2016 at 11:17:57AM +0100, Michal Kazior wrote: >> The rate control is offloaded by firmware so it's >> challanging to provide expected throughput value >> for given station. >> >>

Re: [RFCv2 2/3] ath10k: report per-station tx/rate rates to mac80211

2016-03-24 Thread Mohammed Shafi Shajakhan
Hi Michal, On Wed, Mar 16, 2016 at 11:17:57AM +0100, Michal Kazior wrote: > The rate control is offloaded by firmware so it's > challanging to provide expected throughput value > for given station. > > This approach is naive as it reports last tx rate > used for given station as provided by

Re: [PATCH v1 3/3] ath10k: Enable parsing per station rx duration for 10.4

2016-03-24 Thread Mohammed Shafi Shajakhan
Hi Kalle, On Thu, Mar 24, 2016 at 06:51:18AM +, Valo, Kalle wrote: > "Shajakhan, Mohammed Shafi (Mohammed Shafi)" > writes: > > I will make sure, I will run sparse before sending it for review > >

Re: [PATCH v1 3/3] ath10k: Enable parsing per station rx duration for 10.4

2016-03-24 Thread Valo, Kalle
"Shajakhan, Mohammed Shafi (Mohammed Shafi)" writes: > I will make sure, I will run sparse before sending it for review > http://linuxwireless.org/en/users/Drivers/ath10k/CodingStyle/#Linux_style > > make drivers/net/wireless/ath/ath10k/ C=2 CF="-D__CHECK_ENDIAN__" > >