[PATCH net] ipv6: Fix IPv6 packet loss in scenarios involving roaming + snooping switches

2017-02-02 Thread Linus Lüssing
When for instance a mobile Linux device roams from one access point to another with both APs sharing the same broadcast domain and a multicast snooping switch in between: 1)(c) <~~~> (AP1) <--[SSW]--> (AP2) 2) (AP1) <--[SSW]--> (AP2) <~~~> (c) Then currently IPv6 multicast

[PATCH V3 3/9] brcmfmac: merge two remaining brcmf_err macros

2017-02-02 Thread Rafał Miłecki
From: Rafał Miłecki Now we always have __brcmf_err function we can do perfectly fine with just one macro. Signed-off-by: Rafał Miłecki --- V3: Add this (new) patch --- drivers/net/wireless/broadcom/brcm80211/brcmfmac/debug.h | 14 +- 1 file

[PATCH V3 7/9] brcmfmac: sdio: store private pointer to struct brcmf_pub

2017-02-02 Thread Rafał Miłecki
From: Rafał Miłecki Having access to this struct is useful for using generic stuff and e.g. improving logging messages. Signed-off-by: Rafał Miłecki --- V2: Add this (new) patch --- drivers/net/wireless/broadcom/brcm80211/brcmfmac/sdio.c | 2 ++ 1 file

[PATCH V3 1/9] brcmfmac: merge two brcmf_err macros into one

2017-02-02 Thread Rafał Miłecki
From: Rafał Miłecki This allows simplifying the code by adding a simple IS_ENABLED check for CONFIG_BRCMDB symbol. Signed-off-by: Rafał Miłecki --- V3: Re-add this patch (it was initially submited as RFC) ---

[PATCH V3 2/9] brcmfmac: switch to C function (__brcmf_err) for printing errors

2017-02-02 Thread Rafał Miłecki
From: Rafał Miłecki This will allow extending code and using more detailed messages e.g. with the help of dev_err. Signed-off-by: Rafał Miłecki --- V3: Keep IS_ENABLED check in the macro as suggested by Felix ---

[PATCH V3 9/9] brcmfmac: use dev_err to print errors

2017-02-02 Thread Rafał Miłecki
From: Rafał Miłecki This adds a nice prefix to all error messages making it possible to identify device they are related to. It's really useful for e.g. home routers commonly having 2 or even 3 wireless devices. Signed-off-by: Rafał Miłecki ---

[PATCH V3 4/9] brcmfmac: add struct brcmf_pub parameter to the __brcmf_err

2017-02-02 Thread Rafał Miłecki
From: Rafał Miłecki This will allow getting struct device reference from the passed brcmf_pub for the needs of dev_err. More detailed messages are really important for home routers which frequently have 2 (or even 3) wireless cards supported by brcmfmac. Note that all calls

[PATCH V3 5/9] brcmfmac: pcie: store private pointer to struct brcmf_pub

2017-02-02 Thread Rafał Miłecki
From: Rafał Miłecki Getting this pointer in PCIe code is not trivial and requires using dev_get_drvdata helper which adds extra line of code. Having access to this struct is useful for using generic stuff and e.g. improving logging messages. Signed-off-by: Rafał Miłecki

Re: [PATCH 2/3] ath10k: use size_t for len variables

2017-02-02 Thread Sebastian Gottschall
consider that you changed the length of this datatype on 64 bit systems. unsigned int is always 32 bit, but size_t may be 64 bit too Am 02.02.2017 um 11:19 schrieb Amadeusz Sławiński: cleanup to consolidate type used for len variables Signed-off-by: Amadeusz Sławiński

[PATCH] ath10k: remove unneeded semicolon

2017-02-02 Thread Waldemar Rymarkiewicz
Remove redundant semicolon after switch statement. Signed-off-by: Waldemar Rymarkiewicz --- drivers/net/wireless/ath/ath10k/htt_rx.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/net/wireless/ath/ath10k/htt_rx.c

Re: [PATCH 1/3] ath10k: remove ath10k_vif_to_arvif()

2017-02-02 Thread Adrian Chadd
hiya, Removing this method makes the diff to FreeBSD larger, as "vif" in FreeBSD is a different pointer. (Yes, I have ath10k on freebsd working and I'd like to find a way to reduce the diff moving forward.) -adrian

[PATCH] staging: rtl8192u: move stats_IndicateArray off stack

2017-02-02 Thread Arnd Bergmann
Putting 128 pointers on the stack is rather wasteful, in particular on 64-bit architectures: drivers/staging/rtl8192u/ieee80211/rtl819x_TSProc.c: In function 'RxPktPendingTimeout': drivers/staging/rtl8192u/ieee80211/rtl819x_TSProc.c:92:1: warning: the frame size of 1072 bytes is larger than

[PATCH] mt76: fix debugfs_simple_attr.cocci warnings

2017-02-02 Thread Julia Lawall
Use DEFINE_DEBUGFS_ATTRIBUTE rather than DEFINE_SIMPLE_ATTRIBUTE for debugfs files. Rationale: DEFINE_SIMPLE_ATTRIBUTE + debugfs_create_file() imposes some significant overhead as compared to DEFINE_DEBUGFS_ATTRIBUTE + debugfs_create_file_unsafe(). Generated by:

Re: [PATCH v4 3/3] mt76: add driver code for MT76x2e

2017-02-02 Thread Lorenzo Bianconi
> Felix Fietkau writes: > >> On 2017-02-02 12:52, Felix Fietkau wrote: >>> This is a 2x2 PCIe 802.11ac chipset by MediaTek >>> >>> Signed-off-by: Felix Fietkau >> Kalle, Please also add: >> Signed-off-by: Lorenzo Bianconi >> >> Or

Re: [PATCH v4 3/3] mt76: add driver code for MT76x2e

2017-02-02 Thread Kalle Valo
Felix Fietkau writes: > On 2017-02-02 12:52, Felix Fietkau wrote: >> This is a 2x2 PCIe 802.11ac chipset by MediaTek >> >> Signed-off-by: Felix Fietkau > Kalle, Please also add: > Signed-off-by: Lorenzo Bianconi > > Or should I

Re: [PATCH v4 3/3] mt76: add driver code for MT76x2e

2017-02-02 Thread Felix Fietkau
On 2017-02-02 12:52, Felix Fietkau wrote: > This is a 2x2 PCIe 802.11ac chipset by MediaTek > > Signed-off-by: Felix Fietkau Kalle, Please also add: Signed-off-by: Lorenzo Bianconi Or should I resend? - Felix

Re: [PATCH V2 1/7] brcmfmac: switch to C function (__brcmf_err) for printing errors

2017-02-02 Thread Felix Fietkau
On 2017-02-02 13:16, Rafał Miłecki wrote: > From: Rafał Miłecki > > This will allow extending code and using more detailed messages e.g. > with the help of dev_err. Note that *two separated* brcmf_err macros > were replaced thanks to using a simple CONFIG_BRCMDBG symbol check

[PATCH V2 3/7] brcmfmac: pcie: store private pointer to struct brcmf_pub

2017-02-02 Thread Rafał Miłecki
From: Rafał Miłecki Getting this pointer in PCIe code is not trivial and requires using dev_get_drvdata helper which adds extra line of code. Having access to this struct is useful for using generic stuff and e.g. improving logging messages. Signed-off-by: Rafał Miłecki

[PATCH V2 1/7] brcmfmac: switch to C function (__brcmf_err) for printing errors

2017-02-02 Thread Rafał Miłecki
From: Rafał Miłecki This will allow extending code and using more detailed messages e.g. with the help of dev_err. Note that *two separated* brcmf_err macros were replaced thanks to using a simple CONFIG_BRCMDBG symbol check in the body. Signed-off-by: Rafał Miłecki

[PATCH V2 7/7] brcmfmac: use dev_err to print errors

2017-02-02 Thread Rafał Miłecki
From: Rafał Miłecki This adds a nice prefix to all error messages making it possible to identify device they are related to. It's really useful for e.g. home routers commonly having 2 or even 3 wireless devices. Signed-off-by: Rafał Miłecki ---

[PATCH V2 4/7] brcmfmac: usb: store private pointer to struct brcmf_pub

2017-02-02 Thread Rafał Miłecki
From: Rafał Miłecki Having access to this struct is useful for using generic stuff and e.g. improving logging messages. Signed-off-by: Rafał Miłecki --- drivers/net/wireless/broadcom/brcm80211/brcmfmac/usb.c | 12 1 file changed, 8

[PATCH V2 5/7] brcmfmac: sdio: store private pointer to struct brcmf_pub

2017-02-02 Thread Rafał Miłecki
From: Rafał Miłecki Having access to this struct is useful for using generic stuff and e.g. improving logging messages. Signed-off-by: Rafał Miłecki --- V2: Add this (new) patch --- drivers/net/wireless/broadcom/brcm80211/brcmfmac/sdio.c | 2 ++ 1 file

[PATCH V2 2/7] brcmfmac: add struct brcmf_pub parameter to the __brcmf_err

2017-02-02 Thread Rafał Miłecki
From: Rafał Miłecki This will allow getting struct device reference from the passed brcmf_pub for the needs of dev_err. More detailed messages are really important for home routers which frequently have 2 (or even 3) wireless cards supported by brcmfmac. Note that all calls

[PATCH v4 2/3] mt76: add common code shared between multiple chipsets

2017-02-02 Thread Felix Fietkau
This will be used by drivers for MT76x2e, MT7603e and MT7628 Signed-off-by: Felix Fietkau --- drivers/net/wireless/mediatek/mt76/debugfs.c | 76 drivers/net/wireless/mediatek/mt76/dma.c | 451 +++ drivers/net/wireless/mediatek/mt76/dma.h | 38

[PATCH v4 0/3] mt76: add new wireless driver for MediaTek MT76x2 PCIe chips

2017-02-02 Thread Felix Fietkau
Changes since v3: - DFS fixes - stability fixes - use wiphy_read_of_freq_limits Changes since v2: - lots of checkpatch cleanups - various tx path (and other) fixes - use the new bitfield API - documented device tree bindings Felix Fietkau (3): Documentation: dt: net: add mt76 wireless device

[PATCH v4 1/3] Documentation: dt: net: add mt76 wireless device binding

2017-02-02 Thread Felix Fietkau
Signed-off-by: Felix Fietkau --- .../bindings/net/wireless/mediatek,mt76.txt| 25 ++ 1 file changed, 25 insertions(+) create mode 100644 Documentation/devicetree/bindings/net/wireless/mediatek,mt76.txt diff --git

[PATCH 2/3] ath10k: use names in function definition arguments

2017-02-02 Thread Kalle Valo
Fixes new checkpatch warnings: drivers/net/wireless/ath/ath10k/htt.h:1823: function definition argument 'struct sk_buff *' should also have an identifier name drivers/net/wireless/ath/ath10k/wmi.h:6607: function definition argument 'struct wmi_start_scan_arg *' should also have an identifier

[PATCH 3/3] ath10k: few whitespace fixes

2017-02-02 Thread Kalle Valo
Fixes checkpatch warnings: drivers/net/wireless/ath/ath10k/pci.c:1593: Statements should start on a tabstop drivers/net/wireless/ath/ath10k/ce.c:962: Alignment should match open parenthesis Signed-off-by: Kalle Valo --- drivers/net/wireless/ath/ath10k/ce.c |6

[PATCH 1/3] ath10k: prefer unsigned int over just unsigned

2017-02-02 Thread Kalle Valo
Fixes new checkpatch warnings: drivers/net/wireless/ath/ath10k/htt.h:1639: Prefer 'unsigned int' to bare use of 'unsigned' drivers/net/wireless/ath/ath10k/htt.h:1660: Prefer 'unsigned int' to bare use of 'unsigned' Signed-off-by: Kalle Valo ---

[PATCH 2/3] ath10k: use size_t for len variables

2017-02-02 Thread Amadeusz Sławiński
cleanup to consolidate type used for len variables Signed-off-by: Amadeusz Sławiński --- drivers/net/wireless/ath/ath10k/core.c | 2 +- drivers/net/wireless/ath/ath10k/debug.c| 49 +++--- drivers/net/wireless/ath/ath10k/spectral.c |

[PATCH 1/3] ath10k: remove ath10k_vif_to_arvif()

2017-02-02 Thread Amadeusz Sławiński
it adds unnecessary level of indirection, while we just access structure field Signed-off-by: Amadeusz Sławiński --- drivers/net/wireless/ath/ath10k/mac.c | 68 +-- drivers/net/wireless/ath/ath10k/mac.h | 7 +---

[PATCH 3/3] ath10k: fix comment

2017-02-02 Thread Amadeusz Sławiński
I wanted to take a look and it's apparently in other header Signed-off-by: Amadeusz Sławiński --- drivers/net/wireless/ath/ath10k/wmi.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/net/wireless/ath/ath10k/wmi.h

[PATCH v4] rt2x00: avoid introducing a USB dependency in the rt2x00lib module

2017-02-02 Thread Stanislaw Gruszka
As reported by Felix: Though protected by an ifdef, introducing an usb symbol dependency in the rt2x00lib module is a major inconvenience for distributions that package kernel modules split into individual packages. Get rid of this unnecessary dependency by calling the usb related function from

Re: [PATCH v3] rt2x00: avoid introducing a USB dependency in the

2017-02-02 Thread Stanislaw Gruszka
On Wed, Feb 01, 2017 at 05:33:38PM +0100, Felix Fietkau wrote: > > v1 -> v2 do not break shutdown sequence > > v2 -> v3 update patch to current kernel version > What happened to the subject? It ends mid-sentence. I somehow truncated it during rework, will post fixed one. Thanks Stanislaw

[PATCH v2 2/3] ath9k_hw: check if the chip failed to wake up

2017-02-02 Thread Felix Fietkau
In an RFC patch, Sven Eckelmann and Simon Wunderlich reported: "QCA 802.11n chips (especially AR9330/AR9340) sometimes end up in a state in which a read of AR_CFG always returns 0xdeadbeef. This should not happen when when the power_mode of the device is ATH9K_PM_AWAKE." Include the check for

[PATCH v2 1/3] ath9k: rename tx_complete_work to hw_check_work

2017-02-02 Thread Felix Fietkau
Also include common MAC alive check. This should make the hang checks more reliable for modes where beacons are not sent and is used as a starting point for further hang check improvements Signed-off-by: Felix Fietkau --- drivers/net/wireless/ath/ath9k/ath9k.h | 6 ++---

[PATCH v2 3/3] ath9k: fix race condition in enabling/disabling IRQs

2017-02-02 Thread Felix Fietkau
The code currently relies on refcounting to disable IRQs from within the IRQ handler and re-enabling them again after the tasklet has run. However, due to race conditions sometimes the IRQ handler might be called twice, or the tasklet may not run at all (if interrupted in the middle of a reset).