Re: [PATCH] brcmfmac: return -EPERM when getting error in vendor command handler

2017-09-29 Thread Wright Feng
Hi Franky, On 2017/9/6 上午 04:02, Franky Lin wrote: On Mon, Sep 4, 2017 at 12:34 AM, Wright Feng wrote: Firmware returns proprietary error code when getting error in fil_cmd_data_set or fil_cmd_data_get. The vendor tools or utilities which uses libnl may stuck in some

[PATCH 2/2] rtlwifi: silence underflow warning

2017-09-29 Thread Dan Carpenter
My static checker complains that we have an upper bound but no lower bound. I suspect neither are really required but it doesn't hurt to add a check for negatives. Signed-off-by: Dan Carpenter diff --git a/drivers/net/wireless/realtek/rtlwifi/core.c

[PATCH] mwifiex: Random MAC address during scanning

2017-09-29 Thread Ganapathi Bhat
From: Karthik Ananthapadmanabha Driver will advertise RANDOM_MAC support only if the device supports this feature. Signed-off-by: Karthik Ananthapadmanabha Signed-off-by: Ganapathi Bhat ---

Re: [PATCH 09/10] mac80211_hwsim: Add command to control rx status RSSI

2017-09-29 Thread Luca Coelho
On Wed, 2017-09-06 at 12:33 +0200, Johannes Berg wrote: > On Sat, 2017-08-05 at 11:44 +0300, Luca Coelho wrote: > > > > +static int hwsim_fops_rx_rssi_write(void *dat, u64 val) > > +{ > > + struct mac80211_hwsim_data *data = dat; > > + int rssi = (int)val; > > That cast is wrong - you should

[PATCH 0/5] iwlwifi: fixes intended for 4.14 2017-09-29

2017-09-29 Thread Luca Coelho
From: Luca Coelho Hi, Another batch of fixes intended for 4.14. This one is a bit smaller than the previous one. These are the fixes: * Fix support for 3168 device series; * Fix a potential crash when using FW debugging recording; * Improve channel flags parsing to

[PATCH 1/5] iwlwifi: mvm: do not print security error in monitor mode

2017-09-29 Thread Luca Coelho
From: Shaul Triebitz In monitor mode we are not expected to decrypt encrypted packets (not having the keys). Hence we are expected to get an unknown rx security status. Keeping the print in monitor mode causes a print for each captured packet flooding the dmesg.

[PATCH 5/5] iwlwifi: nvm: set the correct offsets to 3168 series

2017-09-29 Thread Luca Coelho
From: Chaya Rachel Ivgi The driver currently handles two NVM formats, one for 7000 family and below, and one for 8000 family and above. The 3168 series uses something in between, so currently the driver uses incorrect offsets for it. Fix the incorrect offsets.

[PATCH 3/5] iwlwifi: mvm: return -ENODATA when reading the temperature with the FW down

2017-09-29 Thread Luca Coelho
From: Luca Coelho It seems that libsensors treats -EIO as a special non-recoverable failure when it tries to read the temperature while the firmware is not running. To solve that, change the error code to a milder -ENODATA. This fixes

[PATCH 2/5] iwlwifi: stop dbgc recording before stopping DMA

2017-09-29 Thread Luca Coelho
From: Golan Ben Ami Today we stop the device and the DMA without stopping the dbgc recording before. This causes host crashes when the DMA rate is high. Stop dbgc recording when clearing the fw debug configuration to fix this. Signed-off-by: Golan Ben Ami

[PATCH 4/5] iwlwifi: nvm-parse: unify channel flags printing

2017-09-29 Thread Luca Coelho
From: Johannes Berg The current channel flags printing is very strange and messy, in LAR we sometimes print the channel number and sometimes the frequency, in both we print a calculated value (whether ad-hoc is supported or not) etc. Unify all this to * print the

[PATCH 05/18] iwlwifi: pcie: dump registers when HW becomes inaccessible

2017-09-29 Thread Luca Coelho
From: Rajat Jain We conclude the HW became inaccessible when we timeout waiting for a bit to be set in a memory mapped register (CSR_GP_CNTRL). This conclusion may not be true because the bit may not get set due to: - a firmware issue - a driver issue - a PCI bus issue - a

[PATCH 10/18] iwlwifi: acpi: generalize iwl_mvm_sar_find_wifi_pkg()

2017-09-29 Thread Luca Coelho
From: Luca Coelho Move this function to acpi.c, renaming it to iwl_acpi_get_wifi_pkg(), because it can also be used with other methods (i.e. SPLC and WRDD). Signed-off-by: Luca Coelho --- drivers/net/wireless/intel/iwlwifi/fw/acpi.c | 52

[PATCH 08/18] iwlwifi: acpi: move ACPI method definitions to acpi.h

2017-09-29 Thread Luca Coelho
From: Luca Coelho Instead of defining each method where they are used and re-defining WIFI_DOMAIN in each one of them, move all the definitions to a central place and define the domain only a single time. Signed-off-by: Luca Coelho ---

[PATCH 02/18] iwlwifi: fw: api: remove excess enum value documentation

2017-09-29 Thread Luca Coelho
From: Johannes Berg These enum values don't exist, so remove their documentation as well. Signed-off-by: Johannes Berg Signed-off-by: Luca Coelho --- drivers/net/wireless/intel/iwlwifi/fw/api/sta.h | 4 1 file

[PATCH 07/18] iwlwifi: acpi: add common code to read from ACPI

2017-09-29 Thread Luca Coelho
From: Luca Coelho There are many places where the same process of invoking a method from ACPI is used, causing a lot of duplicate code. To improve this, introduce a new function to get an ACPI object by invoking an ACPI method that can be reused. Additionally, since

[PATCH 09/18] iwlwifi: acpi: move ACPI-related definitions to acpi.h

2017-09-29 Thread Luca Coelho
From: Luca Coelho The ACPI table size definitions were spread around the different files that used them. Move them all to a common place. Signed-off-by: Luca Coelho --- drivers/net/wireless/intel/iwlwifi/fw/acpi.h | 20 +

[PATCH 01/18] iwlwifi: mvm: don't send identical PHY_CTXT_CMD

2017-09-29 Thread Luca Coelho
From: Emmanuel Grumbach When we have an AP which supports HT and a single HT station is connected, we change the min_width from NL80211_CHAN_WIDTH_20_NOHT to NL80211_CHAN_WIDTH_20. This of course has no implication on the channel width but still sends a command to

[PATCH 03/18] iwlwifi: mvm: add marker cmd response struct.

2017-09-29 Thread Luca Coelho
From: Mordechay Goodstein This helps for documentation and clarifies the code by defining the exact response struct for the marker command. Signed-off-by: Mordechay Goodstein Signed-off-by: Luca Coelho ---

[PATCH 06/18] iwlwifi: mvm: change warning to warn_once()

2017-09-29 Thread Luca Coelho
From: Sara Sharon In case there is a FW bug where the BAID value in the metadata is not properly initialized we hit the warning for every RX packet. Change it to warn once and add elaborate message. Signed-off-by: Sara Sharon Signed-off-by: Luca

[PATCH 11/18] iwlwifi: acpi: use iwl_acpi_get_wifi_pkg when reading reading SPLC

2017-09-29 Thread Luca Coelho
From: Luca Coelho Instead of finding the wifi package with its own code, we can reuse the new iwl_acpi_get_wifi_pkg() function when reading the default power limit from SPLC. Signed-off-by: Luca Coelho ---

[PATCH 13/18] iwlwifi: acpi: remove a couple of unnecessary ifdefs

2017-09-29 Thread Luca Coelho
From: Luca Coelho Some of the #ifdef CONFIG_ACPI are not needed anymore, so they can be removed. Signed-off-by: Luca Coelho --- drivers/net/wireless/intel/iwlwifi/mvm/mvm.h | 2 -- drivers/net/wireless/intel/iwlwifi/pcie/drv.c | 6 -- 2

[PATCH 16/18] iwlwifi: acpi: move code that reads SPLC to acpi

2017-09-29 Thread Luca Coelho
From: Luca Coelho Move most of the set_dflt_pwr_limit() function to acpi.c and make it return the pwr_limit value instead of setting directly. Also rename it to iwl_acpi_get_pwr_limit(). Signed-off-by: Luca Coelho ---

[PATCH 14/18] iwlwifi: acpi: move function to get mcc into acpi code

2017-09-29 Thread Luca Coelho
From: Luca Coelho The iwl_get_bios_mcc() function was in the iwl-nvm-parse.c file, but it has nothing to do with the NVM. Move it to fw/acpi.c and rename it to iwl_acpi_get_mcc(). Signed-off-by: Luca Coelho ---

[PATCH 15/18] iwlwifi: fix indentation in a000 family configuration

2017-09-29 Thread Luca Coelho
From: Johannes Berg Fix the double indentation in the configuration structs for a000 family devices. Signed-off-by: Johannes Berg Signed-off-by: Luca Coelho --- drivers/net/wireless/intel/iwlwifi/cfg/a000.c | 100

[PATCH 17/18] iwlwifi: mvm: warn on invalid statistics size

2017-09-29 Thread Luca Coelho
From: Johannes Berg Getting the wrong statistics size is a problem, having a warning will help us catch it quicker during firmware/driver development. In released firmware/driver versions, we obviously make sure this won't happen. Signed-off-by: Johannes Berg

[PATCH] ath10k: check power save support in STA mode through FW IE

2017-09-29 Thread Kalle Valo
From: Venkateswara Naralasetty Currently ath10k host enables power save support in station mode by default for all firmwares but Power save for station mode still not supported in some of the firmware versions. Which results in firmware crash while issueing multiple

[PATCH 12/18] iwlwifi: acpi: make iwl_get_bios_mcc() use the common acpi functions

2017-09-29 Thread Luca Coelho
From: Luca Coelho The way iwl_get_bios_mcc() gets the WiFi package and checks for its integrity is almost identical to the new iwl_acpi_get_wifi_pkg() function. Instead of having duplicate code, convert it to use the common code. Signed-off-by: Luca Coelho

[PATCH 00/18] iwlwifi: updates intended for v4.15 2017-09-29

2017-09-29 Thread Luca Coelho
From: Luca Coelho Hi, Here's the second set of patches intended for 4.15. Nothing major, mostly just cleanups. These are the changes: * ACPI code refactoring; * Some coding-style fixes; * Avoid redundant command to the firmware; * Add a struct with the format of one

[PATCH 18/18] iwlwifi: remove dflt_pwr_limit from the transport

2017-09-29 Thread Luca Coelho
From: Luca Coelho The default power limit read from the SPLC method in ACPI doesn't have anything to do with the transport and is only used in the opmode, so we can remove it from the trans. Additionally, this value is only user when the opmode is starting, so we don't

[PATCH v2] ieee80211: Add WFA TPC report element OUI type

2017-09-29 Thread Luca Coelho
From: Avraham Stern Add Transmit Power Control OUI type definition for WLAN_OUI_MICROSOFT. Signed-off-by: Avraham Stern Signed-off-by: Luca Coelho --- include/linux/ieee80211.h | 1 + 1 file changed, 1 insertion(+)

carl9170 issue with sniffer mode and dropping probe responses

2017-09-29 Thread Steve deRosier
Hi, A patch went in to the carl9170 driver about 5 years go that addressed an issue with spurious ack noise from the hardware when it was put in sniffer mode. It changed the driver to drop the sniffer mode and instead keep it in STA mode with relaxed RX filtering. Patch [1] Discussion [2] All

[PATCH 04/10] rtlwifi: Implement rtl_get_tx_hw_rate to yield correct hw_rate

2017-09-29 Thread Larry Finger
From: Ping-Ke Shih Originally, we get legacy rate only, so we extend to get HT and VHT rate. Signed-off-by: Ping-Ke Shih Signed-off-by: Larry Finger Cc: Yan-Hsuan Chuang Cc: Birming Chiu

[PATCH 00/10] rtlwifi: Updates for 4.15 - first set

2017-09-29 Thread Larry Finger
Several of the sources in rtlwifi needed updates to support the RTL8822BE code currently in staging. As part of the process of moving that driver from staging to mainline, those updates will be applied to mainline. This set of patches is the first of that process. Signed-off-by: Larry Finger

[PATCH 03/10] rtlwifi: rtl8192ee: Make driver support 64bits DMA.

2017-09-29 Thread Larry Finger
From: Ping-Ke Shih 1. Both 32-bit and 64-bit use the same TX/RX buffer desc layout 2. Extend set_desc() and get_desc() to set and get 64-bit address 3. Remove directive DMA_IS_64BIT 4. Add module parameter to turn on 64-bit dma Signed-off-by: Ping-Ke Shih

[PATCH 01/10] rtlwifi: Fix MAX MPDU of VHT capability

2017-09-29 Thread Larry Finger
From: Ping-Ke Shih We must choose only one of VHT_CAP among IEEE80211_VHT_CAP_MAX_MPDU_LENGTH_3895, IEEE80211_VHT_CAP_MAX_MPDU_LENGTH_7991 and IEEE80211_VHT_CAP_MAX_MPDU_LENGTH_11454. Signed-off-by: Ping-Ke Shih Signed-off-by: Larry Finger

[PATCH 06/10] rtlwifi: Add TX/RX throughput statistics in period

2017-09-29 Thread Larry Finger
From: Ping-Ke Shih The statistic variables use u64 to get higher precision. Signed-off-by: Ping-Ke Shih Signed-off-by: Larry Finger Cc: Yan-Hsuan Chuang Cc: Birming Chiu Cc: Shaofu

[PATCH 02/10] rtlwifi: Remove redundant semicolon in wifi.h.

2017-09-29 Thread Larry Finger
From: Ping-Ke Shih The semicolon can cause compiler error, if it exists in if...else statement. Signed-off-by: Ping-Ke Shih Signed-off-by: Larry Finger Cc: Yan-Hsuan Chuang Cc: Birming Chiu

[PATCH 10/10] rtlwifi: Add module parameter ASPM

2017-09-29 Thread Larry Finger
From: Ping-Ke Shih On some platforms, enable ASPM will cause AER error to be logged, thus we use a parameter to selectively turn on ASPM. Signed-off-by: Ping-Ke Shih Signed-off-by: Larry Finger Cc: Yan-Hsuan Chuang

[PATCH 08/10] rtlwifi: Remove BAND_NUM and related fields

2017-09-29 Thread Larry Finger
From: Ping-Ke Shih These fields are unused, and we will define them in phydm later. Signed-off-by: Ping-Ke Shih Signed-off-by: Larry Finger Cc: Yan-Hsuan Chuang Cc: Birming Chiu Cc:

[PATCH 07/10] rtlwifi: Add RSSI and RF type to wifi.h for phydm

2017-09-29 Thread Larry Finger
From: Ping-Ke Shih These definition will be used by phydm later. Signed-off-by: Ping-Ke Shih Signed-off-by: Larry Finger Cc: Yan-Hsuan Chuang Cc: Birming Chiu Cc: Shaofu

[PATCH 05/10] rtlwifi: Add rtl_get_hal_edca_param() to generate register's format of EDCA.

2017-09-29 Thread Larry Finger
From: Ping-Ke Shih Convert from the value of ieee80211_tx_queue_params to Realtek's register value. Signed-off-by: Ping-Ke Shih Signed-off-by: Larry Finger Cc: Yan-Hsuan Chuang Cc: Birming Chiu

[PATCH 09/10] rtlwifi: Add bw_update parameter for RA mask update.

2017-09-29 Thread Larry Finger
From: Ping-Ke Shih - Add new parameter "is_bw_update" to control if current bandwidth setting is updated to FW RA. - After this commit, we keep the same setting as before. - Later, bandwidth update in watchdog is changed to false for 8822BE. Signed-off-by: Tsang-Shian Lin