Re: [OpenWrt-Devel] ath10k mesh + ap + encryption?

2017-01-24 Thread Sven Eckelmann
On Montag, 19. September 2016 11:34:00 CET Sven Eckelmann wrote:
> On Montag, 19. September 2016 08:43:56 CEST Simon Wunderlich wrote:
> [...]
> > > We're testing encrypted AP + Mesh quite successfully right now with
> > > this firmware: https://github.com/kvalo/ath10k-firmware/commit/307cb46b
> > > 06661ebd3186723b5002de769c7add83, of course that is for a QCA4019 chip.
> > > Which chip are you using? I can poke the firmware guys for possibility
> > > of getting a 10.4.3.2 firmware build for it.
[...]
>| 802.11s encrypted | 802.11s unencrypted
> ---+---+
> AP encrypted   | AP doesn't beacon | works
> AP unencrypted | AP doesn't beacon | works
> 
> I've also checked 10.2.4.70.12-2 (doesn't seem to support encrypted mesh at 
> all) and with rawmode=1 (makes no difference).

I just tested it with a IPQ4019 with the (10.4-)3.2.1-00050 image. And I see a 
similar problem with it. But the AP was not actually active (device was in AP 
mode but no channel was set and it didn't beacon). So we end up again with an 
incomplete initialized AP but hostapd was running.

I've simply disabled the LEDE wifi stuff and ran the attached autostart.sh 
manually. This seemed to work fine. This is rather odd because the same 
configuration for wpa_supplicant and hostapd was used. It also works fine with 
the normal LEDE setup scripts when encryption on the mesh device is disabled 
and it also works fine with ath9k.

With the LEDE scripts/netifd, hostapd thought that the AP went up:

root@lede:/# hostapd_cli status
Selected interface 'wlan0-1'
state=ENABLED
phy=phy0
freq=2462
num_sta_non_erp=0
num_sta_no_short_slot_time=0
num_sta_no_short_preamble=0
olbc=0
num_sta_ht_no_gf=0
num_sta_no_ht=0
num_sta_ht_20_mhz=0
num_sta_ht40_intolerant=0
olbc_ht=1
ht_op_mode=0x11
cac_time_seconds=0
cac_time_left_seconds=N/A
channel=11
secondary_channel=0
ieee80211n=1
ieee80211ac=0
bss[0]=wlan0-1
bssid[0]=ac:86:74:00:0e:35
ssid[0]=LEDE3-1
num_sta[0]=0

iw dev didn't think so:

Interface wlan0-1
ifindex 13
wdev 0x5
addr ac:86:74:00:0e:35
type AP
txpower 30.00 dBm

Interestingly, it sometimes (randomly) started to work when the AP interface 
was switched to psk2 for encryption instead of using an unencrypted AP.

Right now, it looks like an odd timing problem. Has someone else a good idea 
what to test?


Btw. we never received any (10.4-)3.2 based firmware for QCA988X from QCA. But 
I am also not sure if I find time to retest it again with QCA988x.

Kind regards,
Svennetwork={
ssid="openmesh"
key_mgmt=SAE
mode=5
frequency=2462
psk="9f0a965af38f2d0a13b66d8b46ab962c"
mcast_rate=18
}
driver=nl80211
logger_syslog=127
logger_syslog_level=2
logger_stdout=127
logger_stdout_level=2
hw_mode=g
channel=11
ieee80211n=1
ht_coex=0
ht_capab=[LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][MAX-AMSDU-7935][DSSS_CCK-40]
interface=wlan0-1
ctrl_interface=/var/run/hostapd
ap_isolate=1
disassoc_low_ack=1
preamble=1
wmm_enabled=1
ignore_broadcast_ssid=0
uapsd_advertisement_enabled=1
auth_algs=1
wpa=0
ssid=LEDE3-1
bridge=br-lan
bssid=00:11:22:33:17:02
config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'platform/soc/a00.wifi'
option htmode 'HT20'
option disabled '0'

config wifi-iface 'extra_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'LEDE3-1'
option encryption 'none'
option disabled 0
option macaddr 'ac:86:74:00:0e:35'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'LEDE2-1'
option encryption 'psk2'
option key 'testtest'
option macaddr 'ac:86:74:00:0e:36'
option disabled 1

config wifi-iface 'wmesh0'
option device 'radio0'
option ifname 'mesh0'
option network 'lan'
option mode 'mesh'
option mesh_id 'openmesh'
option disabled '0'
option mcast_rate '18000'
option macaddr 'ac:86:74:00:0e:37'
option mesh_ttl 1
option mesh_fwding 0
#option encryption 'none'
option ieee80211w 1
option encryption 'psk2+aes'
option key '9f0a965af38f2d0a13b66d8b46ab962c'


autostart.sh
Description: application/shellscript


signature.asc
Description: This is a digitally signed message part.


Re: [OpenWrt-Devel] ath10k mesh + ap + encryption?

2016-09-19 Thread Sven Eckelmann
On Montag, 19. September 2016 08:43:56 CEST Simon Wunderlich wrote:
[...]
> > We're testing encrypted AP + Mesh quite successfully right now with
> > this firmware: https://github.com/kvalo/ath10k-firmware/commit/307cb46b
> > 06661ebd3186723b5002de769c7add83, of course that is for a QCA4019 chip.
> > Which chip are you using? I can poke the firmware guys for possibility
> > of getting a 10.4.3.2 firmware build for it.
> 
> Hi Thomas,
> 
> thanks for the hint! We are using an older QCA9882. I assume your firmware
> will not work for this one? If you can poke the firmware guys, that would
> be great.
> :)
> 
> We also want to test the 70.52 firmware version next, maybe there were some
> changes since the .42 we used.

I have just checked it with 10.2.4.70.54:

   | 802.11s encrypted | 802.11s unencrypted
---+---+
AP encrypted   | AP doesn't beacon | works
AP unencrypted | AP doesn't beacon | works

I've also checked 10.2.4.70.12-2 (doesn't seem to support encrypted mesh at 
all) and with rawmode=1 (makes no difference).

Kind regards,
Sven

signature.asc
Description: This is a digitally signed message part.