Re: [PATCH] powerpc: add setclrbits macros

2007-08-16 Thread Geert Uytterhoeven
On Thu, 16 Aug 2007, Timur Tabi wrote: > This patch adds the setclrbits_xxx() macros, which are used to set and clear > multiple bits in a single read-modify-write operation. Specify the bits > to set in the 'set' parameter and the bits to clear in the 'clear' parameter. > These macros can also be

Re: [PATCH] fix compile warning in arch/powerpc/kernel/sysfs.c

2007-08-16 Thread Michael Neuling
It seems I missed a long discussion about this warning... Please ignore. Mikey In message <[EMAIL PROTECTED]> you wrote: > This fixes the following warning: > arch/powerpc/kernel/sysfs.c:388: warning: ignoring return value of > 'sysfs_create_group', declared with attribute warn_unused_result > >

[PATCH] serial: Add pci ids for PA Semi PWRficient onchip uarts

2007-08-16 Thread Olof Johansson
Add PCI IDs for the onchip UARTs on PA Semi PWRficient. Signed-off-by: Olof Johansson <[EMAIL PROTECTED]> Index: linux-2.6/drivers/serial/8250_pci.c === --- linux-2.6.orig/drivers/serial/8250_pci.c +++ linux-2.6/drivers/serial/8250_

[PATCH] [POWERPC] Fix interrupt routing and setup of ULI M1575 on FSL boards

2007-08-16 Thread Kumar Gala
The interrupt routing in the device trees for the ULI M1575 was inproperly using the interrupt line field as pci function. Fixed up the device tree's to actual conform for to specification and changed the interrupt mapping code so it just uses a static mapping setup as follows: PIRQA - IRQ9 PIRQB

[PATCH] [POWERPC] Add interrupt resource for RTC CMOS driver

2007-08-16 Thread Kumar Gala
The RTC CMOS driver expects the interrupt to be a resource of the platform device. Use a fixed interrupt value of 8 since on PPC if we are using this its off an i8259 which we ensure has interrupt numbers 0..15. Signed-off-by: Kumar Gala <[EMAIL PROTECTED]> --- arch/powerpc/sysdev/rtc_cmos_setup

Please pull from 'fixes-2.6.23' branch

2007-08-16 Thread Kumar Gala
Please pull from 'fixes-2.6.23' branch of master.kernel.org:/pub/scm/linux/kernel/git/galak/powerpc.git fixes-2.6.23 to receive the following updates: arch/powerpc/boot/dts/mpc8544ds.dts| 88 -- arch/powerpc/boot/dts/mpc8641_hpcn.dts | 114 ++-- arch/powe

Re: [PATCH 1/2] Add scaled time to taskstats based process accounting

2007-08-16 Thread Michael Neuling
In message <[EMAIL PROTECTED]> you wrote: > Michael Neuling wrote: > >> I'd also request for you to add a cpu_scaled_run_real_total for use > >> by delay accounting. cpu_scaled_run_real_total should be similar in > >> functionality to cpu_run_real_total. > > > > Will do. Should I add cpu_scaled_r

[PATCH] pasemi: Another IOMMU bugfix for 64K PAGE_SIZE

2007-08-16 Thread Olof Johansson
More fallout from the switch from PAGE_SIZE based IOMMU to the native page size for the driver. By pure luck it happened to work most of the time, since we end up invalidating the wrong entries in the TLB. Signed-off-by: Olof Johansson <[EMAIL PROTECTED]> Index: linux-2.6/arch/powerpc/platforms/

Re: [PATCH 1/2] Add scaled time to taskstats based process accounting

2007-08-16 Thread Balbir Singh
Michael Neuling wrote: >> I'd also request for you to add a cpu_scaled_run_real_total for use >> by delay accounting. cpu_scaled_run_real_total should be similar in >> functionality to cpu_run_real_total. > > Will do. Should I add cpu_scaled_run_real_total to the end of the > struct taskstat, or

Re: Machine automagically reboots with 2.6.23-rc2-mm2

2007-08-16 Thread Balbir Singh
Michael Neuling wrote: > > SLB shadow was bust. Make sure you have > edd0622bd2e8f755c960827e15aa6908c3c5aa94 > > [POWERPC] Fix potential duplicate entry in SLB shadow buffer > > We were getting a duplicate entry in the SLB shadow buffer in > slb_flush_and_rebolt() if the kernel

[PATCH] fix compile warning in arch/powerpc/kernel/sysfs.c

2007-08-16 Thread Michael Neuling
This fixes the following warning: arch/powerpc/kernel/sysfs.c:388: warning: ignoring return value of 'sysfs_create_group', declared with attribute warn_unused_result Signed-off-by: Michael Neuling <[EMAIL PROTECTED]> --- arch/powerpc/kernel/sysfs.c |8 ++-- 1 file changed, 6 insertions(+)

for-2.6.24 branch in powerpc.git created

2007-08-16 Thread Paul Mackerras
I have made a for-2.6.24 branch in powerpc.git and pushed the following patches to it. Paul. Becky Bruce (1): [POWERPC] Update lmb.h include protection to ASM_POWERPC David Gibson (4): [POWERPC] Fixes to allow use of Ebony's flash chips through physmap_of [POWERPC] Fix setting

Re: Machine automagically reboots with 2.6.23-rc2-mm2

2007-08-16 Thread Michael Neuling
> Hi, > > My machine reboots automatically after a few seconds of booting 2.6.23-rc2-mm 2. > I've tried several ways to debug the problem, but I've had no success. > I am not sure if this problem has been reported already, a few simple searche s > did not indicate that the problem had been reporte

Please pull powerpc.git merge branch

2007-08-16 Thread Paul Mackerras
Linus, Please do git pull \ git://git.kernel.org/pub/scm/linux/kernel/git/paulus/powerpc.git merge I have added one more patch from Ilpo Järvinen since the last pull request, removing an incorrect semicolon. Paul. arch/powerpc/boot/flatdevtree.c| 18 -- arch/powe

[PATCH 1/2] Add scaled time to taskstats based process accounting

2007-08-16 Thread Michael Neuling
This adds items to the taststats struct to account for user and system time based on scaling the CPU frequency and instruction issue rates. Adds account_(user|system)_time_scaled callbacks which architectures can use to account for time using this mechanism. Signed-off-by: Michael Neuling <[EMAIL

Re: [PATCH] powerpc: Implement atomic{, 64}_{read, write}() without volatile

2007-08-16 Thread Paul Mackerras
Segher Boessenkool writes: > Instead, use asm() like all other atomic operations already do. > +static __inline__ long atomic64_read(const atomic_t *v) > +static __inline__ void atomic64_set(atomic_t *v, long i) s/atomic_t/atomic64_t/ in both lines. I've edited my copy of the patch. Paul. ___

Re: [PATCH 1/2] Add scaled time to taskstats based process accounting

2007-08-16 Thread Michael Neuling
In message <[EMAIL PROTECTED]> you wrote: > Hi, Michael, > > Thanks for doing this, this is really useful. > > Michael Neuling wrote: > > This adds two items to the taststats struct to account for user and > > system time based on scaling the CPU frequency and instruction issue > > rates. > >

Re: [PATCH 2/2] [POWERPC] Add scaled time accounting

2007-08-16 Thread Michael Neuling
In message <[EMAIL PROTECTED]> you wrote: > Michael Neuling wrote: > > This adds POWERPC specific hooks for scaled time accounting. > > > > POWER6 includes a SPURR register. The SPURR is based off the PURR > > register but is scaled based on CPU frequency and issue rates. This > > gives a more

Re: [PATCH] [POWERPC] Invalid semicolon after if statement

2007-08-16 Thread Michael Ellerman
On Thu, 2007-08-16 at 18:40 +0200, Andreas Schwab wrote: > Segher Boessenkool <[EMAIL PROTECTED]> writes: > > >> Thanks to the frickin compiler for warning us, not. > > > > 4.3: "warning: suggest braces around empty body in an 'if' statement" > > > > 4.1: "warning: empty body in an if-statement" >

Re: 2.6.23-rc3 broken on G5

2007-08-16 Thread Andreas Schwab
Paul Mackerras <[EMAIL PROTECTED]> writes: > Andreas Schwab writes: > >> This change: >> >> commit edd0622bd2e8f755c960827e15aa6908c3c5aa94 >> Author: Paul Mackerras <[EMAIL PROTECTED]> >> Date: Fri Aug 10 21:04:07 2007 +1000 >> >> [POWERPC] Fix potential duplicate entry in SLB shadow buff

[PATCH] powerpc: add setclrbits macros

2007-08-16 Thread Timur Tabi
This patch adds the setclrbits_xxx() macros, which are used to set and clear multiple bits in a single read-modify-write operation. Specify the bits to set in the 'set' parameter and the bits to clear in the 'clear' parameter. These macros can also be used to set a multiple-bit bit pattern using a

Re: 2.6.23-rc3 broken on G5

2007-08-16 Thread Paul Mackerras
Andreas Schwab writes: > This change: > > commit edd0622bd2e8f755c960827e15aa6908c3c5aa94 > Author: Paul Mackerras <[EMAIL PROTECTED]> > Date: Fri Aug 10 21:04:07 2007 +1000 > > [POWERPC] Fix potential duplicate entry in SLB shadow buffer > > is broken on PowerMac G5. It crashes very ear

Re: [PATCH 1/2] Add scaled time to taskstats based process accounting

2007-08-16 Thread Paul Mackerras
Linas Vepstas writes: > My gut impression (maybe wrong?) is that the scaled time is, > in a certain sense, "more accurate" than the unscaled time. The "unscaled" time is just time, as in "how many seconds did this task spend on the CPU". It's what all the tools (except a certain proprietary work

Machine automagically reboots with 2.6.23-rc2-mm2

2007-08-16 Thread Balbir Singh
Hi, My machine reboots automatically after a few seconds of booting 2.6.23-rc2-mm2. I've tried several ways to debug the problem, but I've had no success. I am not sure if this problem has been reported already, a few simple searches did not indicate that the problem had been reported 2.6.23-rc1-

Re: [PATCH 1/1] libata: pata_pdc2027x PLL input clock fix

2007-08-16 Thread Alan Cox
> > Unfortunately this breaks pata_pdc2027x on my PowerMac G3: > > Did this ever get resolved? All went quiet so I assume its gone away ? ___ Linuxppc-dev mailing list Linuxppc-dev@ozlabs.org https://ozlabs.org/mailman/listinfo/linuxppc-dev

Re: [PATCH 1/1] libata: pata_pdc2027x PLL input clock fix

2007-08-16 Thread Jeff Garzik
Mikael Pettersson wrote: > (cc:ing linuxppc-dev) > > On Tue, 26 Jun 2007 13:43:15 +0800, Albert Lee wrote: >> Recently the PLL input clock of pata_pdc2027x is sometimes detected >> higer than expected (e.g. 20.027 MHz compared to 16.714 MHz). >> It seems sometimes the mdelay() function is not as p

Re: [PATCH v2] powerpc: add setmaskedbits macros

2007-08-16 Thread Timur Tabi
Benjamin Herrenschmidt wrote: >> The second example is actually a trick that lets me set some bits and clear >> others in one shot, so for the gumr_h register, all of the above values are >> single bits. I guess that's not a good example. > > Such tricks deserve at least a comment. Would it b

Re: adding Pegasus IDE quirk for pata_via

2007-08-16 Thread Olaf Hering
On Tue, Apr 10, Olaf Hering wrote: > Where is the correct place for drivers/ata? so, where is the place for via irq quirks in libata? ___ Linuxppc-dev mailing list Linuxppc-dev@ozlabs.org https://ozlabs.org/mailman/listinfo/linuxppc-dev

Re: adding Pegasus IDE quirk for pata_via

2007-08-16 Thread Olaf Hering
On Mon, Apr 09, Matt Sealey wrote: > + if (bridge) { > + u8 iir, irqlist[4] = { 14, 15, 10, > 11 }; > + > + pci_read_config_byte(bridge, > VIA_IDE_STEERING, &iir); What value has VIA_IDE_STEERING

Re: [ofa-general] [PATCH 7/7] IB/ehca: Prevent overwriting QP init attributes given by caller

2007-08-16 Thread Hoang-Nam Nguyen
[EMAIL PROTECTED] wrote on 16.08.2007 18:17:22: > I don't understand this patch. says this about > ib_create_qp(): > > * @qp_init_attr: A list of initial attributes required to create the > * QP. If QP creation succeeds, then the attributes are updated to > * the actual capabilities of t

Re: [PATCH] [POWERPC] Invalid semicolon after if statement

2007-08-16 Thread Andreas Schwab
Segher Boessenkool <[EMAIL PROTECTED]> writes: >> Thanks to the frickin compiler for warning us, not. > > 4.3: "warning: suggest braces around empty body in an 'if' statement" > > 4.1: "warning: empty body in an if-statement" > > Your GCC is too old :-) This warning is only enabled by -Wextra. O

Re: [PATCH v2] powerpc: add setmaskedbits macros

2007-08-16 Thread Benjamin Herrenschmidt
On Thu, 2007-08-16 at 10:26 -0500, Timur Tabi wrote: > Kumar Gala wrote: > > >> setmaskedbits_be32(&uccp->gumr_l, > >> UCC_SLOW_GUMR_L_MODE_QMC | UCC_SLOW_GUMR_L_TDCR_1 | > >> UCC_SLOW_GUMR_L_RDCR_16, > >> UCC_SLOW_GUMR_L_MODE_MASK | UCC_SLOW_GUMR_L_TDCR_MASK |

Re: [PATCH 1/2] Add scaled time to taskstats based process accounting

2007-08-16 Thread Linas Vepstas
On Thu, Aug 16, 2007 at 05:09:22PM +1000, Michael Neuling wrote: > This adds two items to the taststats struct to account for user and > system time based on scaling the CPU frequency and instruction issue > rates. > > Adds account_(user|system)_time_scaled callbacks which architectures > can use

Re: [ofa-general] [PATCH 7/7] IB/ehca: Prevent overwriting QP init attributes given by caller

2007-08-16 Thread Roland Dreier
I don't understand this patch. says this about ib_create_qp(): * @qp_init_attr: A list of initial attributes required to create the * QP. If QP creation succeeds, then the attributes are updated to * the actual capabilities of the created QP. So it seems the current code is actually cor

Re: [PATCH v2] powerpc: add setmaskedbits macros

2007-08-16 Thread Timur Tabi
Michael Ellerman wrote: > And if you're going to the trouble of making a macro, why not make it a > bit more useful and have it check that the value and the mask match, ie: > > (v & ~m == 0) What should I do if it fails this check? > Final random thought, you could make the size/endian an argum

Re: [PATCH v2] powerpc: add setmaskedbits macros

2007-08-16 Thread Timur Tabi
Kumar Gala wrote: >> setmaskedbits_be32(&uccp->gumr_l, >> UCC_SLOW_GUMR_L_MODE_QMC | UCC_SLOW_GUMR_L_TDCR_1 | >> UCC_SLOW_GUMR_L_RDCR_16, >> UCC_SLOW_GUMR_L_MODE_MASK | UCC_SLOW_GUMR_L_TDCR_MASK | >> UCC_SLOW_GUMR_L_RDCR_MASK); >> >> setmaskedbits_be

Re: [PATCH v2] powerpc: add setmaskedbits macros

2007-08-16 Thread Kumar Gala
On Aug 16, 2007, at 10:18 AM, Timur Tabi wrote: > Kumar Gala wrote: > >> Can you post a driver that uses this. I'm interested in seeing >> what the readability is really like using these macros. > > I do not yet have any drivers ready, but I can give you an example: > > setmaskedbits_be3

Re: [PATCH v2] powerpc: add setmaskedbits macros

2007-08-16 Thread Timur Tabi
Kumar Gala wrote: > Can you post a driver that uses this. I'm interested in seeing what the > readability is really like using these macros. I do not yet have any drivers ready, but I can give you an example: setmaskedbits_be32(&uccp->gumr_l, UCC_SLOW_GUMR_L_MODE_QMC |

Re: [PATCH] [POWERPC] Invalid semicolon after if statement

2007-08-16 Thread Segher Boessenkool
> Thanks to the frickin compiler for warning us, not. 4.3: "warning: suggest braces around empty body in an 'if' statement" 4.1: "warning: empty body in an if-statement" Your GCC is too old :-) Segher ___ Linuxppc-dev mailing list Linuxppc-dev@ozlab

[PATCH 2/6] powerpc: hash_preload fails to preload under CONFIG_PPC_MM_SLICES

2007-08-16 Thread Andy Whitcroft
Seems that a trailing ';' has slipped onto the end of the get_slice_psize checks under CONFIG_PPC_MM_SLICES causing us to return unconditionally and never preload. Signed-off-by: Andy Whitcroft <[EMAIL PROTECTED]> Cc: Paul Mackerras <[EMAIL PROTECTED]> Cc: linuxppc-dev@ozlabs.org --- arch/powerp

Re: [PATCH 2/2] [POWERPC] Add scaled time accounting

2007-08-16 Thread Balbir Singh
Michael Neuling wrote: > This adds POWERPC specific hooks for scaled time accounting. > > POWER6 includes a SPURR register. The SPURR is based off the PURR > register but is scaled based on CPU frequency and issue rates. This > gives a more accurate account of the instructions used per task. Th

Re: [PATCH 1/2] Add scaled time to taskstats based process accounting

2007-08-16 Thread Balbir Singh
Hi, Michael, Thanks for doing this, this is really useful. Michael Neuling wrote: > This adds two items to the taststats struct to account for user and > system time based on scaling the CPU frequency and instruction issue > rates. > > Adds account_(user|system)_time_scaled callbacks which archi

Re: [PATCH] [POWERPC] Invalid semicolon after if statement

2007-08-16 Thread Michael Ellerman
On Thu, 2007-08-16 at 01:03 +0300, Ilpo Järvinen wrote: > A similar fix to netfilter from Eric Dumazet inspired me to > look around a bit by using some grep/sed stuff as looking for > this kind of bugs seemed easy to automate. This is one of them > I found where it looks like this semicolon is not

Re: PS3 improved video mode autodetection for HDMI/DVI

2007-08-16 Thread Stefan Assmann
Geert Uytterhoeven schrieb: > If it fails, please add `#define DEBUG' to drivers/ps3/ps3av.c, send me the > `Monitor Info' output in the kernel log (dmesg), and tell me which of the > PS3 video modes (1-13) work and which don't. ps3av has a quirk database for > monitors that advertise non-working m

Re: [PATCH] [POWERPC] Invalid semicolon after if statement

2007-08-16 Thread Geert Uytterhoeven
On Thu, 16 Aug 2007, [ISO-8859-1] Ilpo J�rvinen wrote: > A similar fix to netfilter from Eric Dumazet inspired me to > look around a bit by using some grep/sed stuff as looking for > this kind of bugs seemed easy to automate. This is one of them > I found where it looks like this semicolon is not v

Re: [PATCH v2] powerpc: add setmaskedbits macros

2007-08-16 Thread Geert Uytterhoeven
On Thu, 16 Aug 2007, Michael Ellerman wrote: > Can you extract the masking logic, rather than repeating it 7 times: > > #define maskbits(a, v, m) ((a) & ~(m) | (v)) > > And if you're going to the trouble of making a macro, why not make it a > bit more useful and have it check that the value a

Re: System crash on boot_e500.S

2007-08-16 Thread Geert Uytterhoeven
On Wed, 15 Aug 2007, mike zheng wrote: > On 8/15/07, Scott Wood <[EMAIL PROTECTED]> wrote: > > mike zheng wrote: > > > Unfortunately, all the applications are running on 2.4 kernel. I can not > > > just throw the 2.4 kernel. > > > > And in what way does 2.6 break these applications? > > All the de

[PATCH 2/2] [POWERPC] Add scaled time accounting

2007-08-16 Thread Michael Neuling
This adds POWERPC specific hooks for scaled time accounting. POWER6 includes a SPURR register. The SPURR is based off the PURR register but is scaled based on CPU frequency and issue rates. This gives a more accurate account of the instructions used per task. The PURR and timebase will be const

[PATCH 1/2] Add scaled time to taskstats based process accounting

2007-08-16 Thread Michael Neuling
This adds two items to the taststats struct to account for user and system time based on scaling the CPU frequency and instruction issue rates. Adds account_(user|system)_time_scaled callbacks which architectures can use to account for time using this mechanism. Signed-off-by: Michael Neuling <[E