Re: [Kgdb-bugreport] 2.6.23-rc3-mm1: kgdb build failure on powerpc

2007-08-30 Thread Pete/Piet Delaney
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Jason Wessel wrote: Andrew Morton wrote: On Wed, 22 Aug 2007 17:44:12 -0500 Jason Wessel [EMAIL PROTECTED] wrote: +while (!atomic_read(debugger_active)); eek. We're in the process of hunting down and eliminating exactly this

Re: [Kgdb-bugreport] 2.6.23-rc3-mm1: kgdb build failure on powerpc

2007-08-30 Thread Pete/Piet Delaney
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Pete/Piet Delaney wrote: Jason Wessel wrote: Andrew Morton wrote: On Wed, 22 Aug 2007 17:44:12 -0500 Jason Wessel [EMAIL PROTECTED] wrote: +while (!atomic_read(debugger_active)); eek. We're in the process of hunting down and

Please pull powerpc.git merge branch

2007-08-30 Thread Paul Mackerras
Linus, Please do git pull \ git://git.kernel.org/pub/scm/linux/kernel/git/paulus/powerpc.git merge There are a couple more bug fixes for Cell plus one from Kumar, and defconfig updates. Paul. arch/powerpc/configs/celleb_defconfig | 196 + arch/powerpc/configs/chrp32_defconfig

Re: [PATCH 0/4] PowerPC 440EPx: Initial Sequoia support

2007-08-30 Thread Valentine Barshak
Josh Boyer wrote: On Wed, 2007-08-29 at 17:35 +0400, Valentine Barshak wrote: The following patches add initial PowerPC 440EPx Sequoia board support. The code is based mainly on the Bamboo board support by Josh Boyer. These patches have been modified according the comments for the previous

Re: dtc: Fix summary calculation in testsuite

2007-08-30 Thread Jon Loeliger
So, like, the other day David Gibson mumbled: The bookkeeping for producing the testsuite summary (total number of tests passed, failed and so forth) is broken. It uses $? across several tests, but for checks after the first, the value of $? will no longer contain the original return code,

Re: libfdt: Fix handling of trailing / in fdt_path_offset()

2007-08-30 Thread Jon Loeliger
So, like, the other day David Gibson mumbled: Currently, fdt_path_offset() returns FDL_ERR_BADOFFSET if given a path with a trailing '/'. In particular this means that fdt_path_offset(/) returns FDT_ERR_BADOFFSET rather than 0 as one would expect. This patch fixes the function to accept

Re: libfdt: Several new functions

2007-08-30 Thread Jon Loeliger
So, like, the other day David Gibson mumbled: This series of patches adds several new functions to libfdt. These are all read-only functions related to determining a given nodes node and ancestry. All three pplied. Thanks, jdl ___ Linuxppc-dev

Re: [PATCH 2.6.23] ibmebus: Prevent bus_id collisions

2007-08-30 Thread Joachim Fenkes
Nathan Lynch [EMAIL PROTECTED] wrote on 29.08.2007 20:12:32: Previously, ibmebus derived a device's bus_id from its location code. The location code is not guaranteed to be unique, so we might get bus_id collisions if two devices share the same location code. The OFDT full_name,

Re: [PATCH 6/9] bootwrapper: Add a zImage.bin.platform target.

2007-08-30 Thread Scott Wood
On Thu, Aug 30, 2007 at 10:34:09AM +1000, David Gibson wrote: Hrm.. I think the --binary option at least should be removed, and subsumed into the platform id - all other binary formats are selected by the platform name at present. And I think it's probably best to do that for --fixed-entry

Re: Please pull powerpc.git merge branch

2007-08-30 Thread Kumar Gala
On Aug 30, 2007, at 6:49 AM, Paul Mackerras wrote: Linus, Please do git pull \ git://git.kernel.org/pub/scm/linux/kernel/git/paulus/powerpc.git merge There are a couple more bug fixes for Cell plus one from Kumar, and defconfig updates. Paul. any reason you didn't pull this into your

Re: [PATCH 8/9] mpc82xx: Update mpc8272ads, and factor out PCI and reset.

2007-08-30 Thread Scott Wood
On Thu, Aug 30, 2007 at 09:56:16AM -0500, Kumar Gala wrote: It don't feel its a mishmash of crap its just how things are defined. Maybe the SOC node was a mistake, but I think we are past the point of return on that. The node itself wasn't a mistake -- the IMMR is relocatable, so it

Re: [PATCH 2/9] bootwrapper: Add strtoull().

2007-08-30 Thread Scott Wood
On Thu, Aug 30, 2007 at 10:52:22AM -0500, Milton Miller wrote: On Thu Aug 30 02:46:38 EST 2007, Scott Wood wrote: + if (*ptr = '0' *ptr = '9' *ptr '0' + base) + digit = *ptr - '0'; + else if (*ptr = 'A' *ptr 'A' + base - 10) +

Re: Document and implement an improved flash device binding for powerpc (v4)

2007-08-30 Thread Scott Wood
On Thu, Aug 30, 2007 at 11:21:18AM +1000, David Gibson wrote: +For JEDEC compatible devices, the following additional properties +are defined: + + - vendor-id : Contains the flash chip's vendor id (1 byte). + - device-id : Contains the flash chip's device id (1 byte). Are

Re: [PATCH 2.6.23] ibmebus: Prevent bus_id collisions

2007-08-30 Thread Nathan Lynch
Hi Joachim- Joachim Fenkes wrote: Nathan Lynch [EMAIL PROTECTED] wrote on 29.08.2007 20:12:32: Will anything break? Nope. Userspace programs should not depend on ibmebus' way of naming the devices; especially since some overly long loc_codes tended to be truncated and thus rendered

Re: Document and implement an improved flash device binding for powerpc (v4)

2007-08-30 Thread Scott Wood
On Thu, Aug 30, 2007 at 12:59:52PM -0500, Josh Boyer wrote: On Thu, 30 Aug 2007 12:29:33 -0500 Scott Wood [EMAIL PROTECTED] wrote: On Thu, Aug 30, 2007 at 11:21:18AM +1000, David Gibson wrote: +For JEDEC compatible devices, the following additional properties +are defined: +

Re: [PATCH 2.6.23] ibmebus: Prevent bus_id collisions

2007-08-30 Thread Arnd Bergmann
On Wednesday 29 August 2007, Joachim Fenkes wrote: Previously, ibmebus derived a device's bus_id from its location code. The location code is not guaranteed to be unique, so we might get bus_id collisions if two devices share the same location code. The OFDT full_name, however, is unique, so

Re: Document and implement an improved flash device binding for powerpc (v4)

2007-08-30 Thread Josh Boyer
On Thu, 30 Aug 2007 13:04:50 -0500 Scott Wood [EMAIL PROTECTED] wrote: On Thu, Aug 30, 2007 at 12:59:52PM -0500, Josh Boyer wrote: On Thu, 30 Aug 2007 12:29:33 -0500 Scott Wood [EMAIL PROTECTED] wrote: On Thu, Aug 30, 2007 at 11:21:18AM +1000, David Gibson wrote: +For JEDEC

Re: [PATCH 2/9] cpm2: Fix off-by-one error in setbrg().

2007-08-30 Thread Vitaly Bordug
On Tue, 28 Aug 2007 15:19:21 -0500 Scott Wood wrote: The hardware adds one to the BRG value to get the divider, so it must be subtracted by software. Prolly a note why it used to work, or what exactly this is resulting in the code. IIRC this was just fw-ported so arch/ppc should have this as

Re: [PATCH 3/9] cpm2: Add SCCs to cpm2_clk_setup(), and cpm2_smc_clk_setup().

2007-08-30 Thread Vitaly Bordug
On Tue, 28 Aug 2007 15:19:22 -0500 Scott Wood wrote: I would have it in the same patch, that adds clocking stuff to 8xx. And maybe in the same, segregate source rather then having it in the foo_common.c, to ease fix/update/rework. Just imho, not pressing for that. Signed-off-by: Scott Wood

Re: [PATCH 1/9] 8xx: Fix CONFIG_PIN_TLB.

2007-08-30 Thread Vitaly Bordug
On Tue, 28 Aug 2007 15:17:16 -0500 Scott Wood wrote: 1. Only map 512K of the IMMR, rather than 8M, to avoid conflicting with the default ioremap region. 2. The wrong register was being loaded into SPRN_MD_RPN. Signed-off-by: Scott Wood [EMAIL PROTECTED] Acked-by: Vitaly Bordug [EMAIL

Re: [PATCH 3/9] 8xx: Add pin and clock setting functions.

2007-08-30 Thread Vitaly Bordug
On Tue, 28 Aug 2007 15:17:19 -0500 Scott Wood wrote: These let board code set up pins and clocks without having to put magic numbers directly into the registers. I personally is not fond of such idea, but it would make this more understandable eases transfer to feature_call or qe pin setting

Re: [PATCH 7/9] 8xx: mpc885ads cleanup

2007-08-30 Thread Vitaly Bordug
On Tue, 28 Aug 2007 15:19:09 -0500 Scott Wood wrote: It now uses the new CPM binding and the generic pin/clock functions, and has assorted fixes and cleanup. good work, thanks. Signed-off-by: Scott Wood [EMAIL PROTECTED] Acked-by: Vitaly Bordug [EMAIL PROTECTED] ---

Re: [PATCH 3/9] cpm2: Add SCCs to cpm2_clk_setup(), and cpm2_smc_clk_setup().

2007-08-30 Thread Scott Wood
On Thu, Aug 30, 2007 at 02:25:48AM +0400, Vitaly Bordug wrote: I would have it in the same patch, that adds clocking stuff to 8xx. I was trying to keep the 8xx and 82xx patchsets reasonably separate. And maybe in the same, segregate source rather then having it in the foo_common.c, to ease

[PATCH 3/3] mpc8349emitx(gp): update defconfigs for 2.6.23

2007-08-30 Thread Grant Likely
From: Grant Likely [EMAIL PROTECTED] Signed-off-by: Grant Likely [EMAIL PROTECTED] CC: Scott Wood [EMAIL PROTECTED] CC: Kumar Gala [EMAIL PROTECTED] CC: Timur Tabi [EMAIL PROTECTED] --- arch/powerpc/configs/mpc834x_itx_defconfig | 292 +

[PATCH 1/3] bootwrapper: In cuImage, print message for ENET devices not found in tree

2007-08-30 Thread Grant Likely
From: Grant Likely [EMAIL PROTECTED] Signed-off-by: Grant Likely [EMAIL PROTECTED] CC: Scott Wood [EMAIL PROTECTED] CC: Kumar Gala [EMAIL PROTECTED] CC: David Gibson [EMAIL PROTECTED] --- arch/powerpc/boot/devtree.c | 14 +++--- 1 files changed, 7 insertions(+), 7 deletions(-) diff

[PATCH 2/3] mpc8349: Add linux, network-index to ethernet nodes in device tree

2007-08-30 Thread Grant Likely
From: Grant Likely [EMAIL PROTECTED] cuImage need to know the logical index of the ethernet devices in order to assign mac addresses. This patch adds the needed properties Signed-off-by: Grant Likely [EMAIL PROTECTED] CC: Scott Wood [EMAIL PROTECTED] CC: Kumar Gala [EMAIL PROTECTED] CC: Timur

Re: [PATCH] mpc5200: add cuimage support for mpc5200 boards

2007-08-30 Thread Scott Wood
On Thu, Aug 30, 2007 at 02:57:40PM -0600, Grant Likely wrote: diff --git a/arch/powerpc/boot/mpc52xx-psc.c b/arch/powerpc/boot/mpc52xx-psc.c new file mode 100644 index 000..46eecf0 --- /dev/null +++ b/arch/powerpc/boot/mpc52xx-psc.c @@ -0,0 +1,89 @@ +/* + * CPM serial console support.

Re: [PATCH v7 3/3] [POWERPC] MPC832x_RDB: update dts to use SPI1 in QE, register mmc_spi stub

2007-08-30 Thread Timur Tabi
Anton Vorontsov wrote: +static int __init mpc832x_spi_init(void) +{ + if (!machine_is(mpc832x_rdb)) + return 0; + + par_io_config_pin(3, 0, 3, 0, 1, 0); /* SPI1 MOSI, I/O */ + par_io_config_pin(3, 1, 3, 0, 1, 0); /* SPI1 MISO, I/O */ + par_io_config_pin(3,

Re: [PATCH] mpc5200: add cuimage support for mpc5200 boards

2007-08-30 Thread Grant Likely
On 8/30/07, Scott Wood [EMAIL PROTECTED] wrote: On Thu, Aug 30, 2007 at 02:57:40PM -0600, Grant Likely wrote: diff --git a/arch/powerpc/boot/mpc52xx-psc.c b/arch/powerpc/boot/mpc52xx-psc.c new file mode 100644 index 000..46eecf0 --- /dev/null +++ b/arch/powerpc/boot/mpc52xx-psc.c

Re: [PATCH 2.6.23] ibmebus: Prevent bus_id collisions

2007-08-30 Thread Linas Vepstas
On Thu, Aug 30, 2007 at 04:00:56PM +0200, Joachim Fenkes wrote: Plus, I rather like using the full_name since it also contains a descriptive name as opposed to being just nondescript numbers, helping the layman (ie user) to make sense out of a dev_id. Yes, well, but no. The location code

Re: [PATCH 2/9] cpm2: Fix off-by-one error in setbrg().

2007-08-30 Thread Vitaly Bordug
On Thu, 30 Aug 2007 15:13:12 -0500 Scott Wood wrote: On Thu, Aug 30, 2007 at 02:09:07AM +0400, Vitaly Bordug wrote: On Tue, 28 Aug 2007 15:19:21 -0500 Scott Wood wrote: The hardware adds one to the BRG value to get the divider, so it must be subtracted by software. Prolly a

Re: [PATCH] mpc5200: add cuimage support for mpc5200 boards

2007-08-30 Thread Matt Sealey
+/* + * Old U-boot compatibility for 8200 + * And this one? -- Matt Sealey [EMAIL PROTECTED] Genesi, Manager, Developer Relations Grant Likely wrote: On 8/30/07, Scott Wood [EMAIL PROTECTED] wrote: On Thu, Aug 30, 2007 at 02:57:40PM -0600, Grant Likely wrote: diff --git

Re: [PATCH 1/3] bootwrapper: In cuImage, print message for ENET devices not found in tree

2007-08-30 Thread David Gibson
On Thu, Aug 30, 2007 at 02:26:18PM -0600, Grant Likely wrote: From: Grant Likely [EMAIL PROTECTED] Signed-off-by: Grant Likely [EMAIL PROTECTED] CC: Scott Wood [EMAIL PROTECTED] CC: Kumar Gala [EMAIL PROTECTED] CC: David Gibson [EMAIL PROTECTED] Hrm... I thought Scott had deliberately

Re: [PATCH 2/3] Introduce new CPM device bindings.

2007-08-30 Thread David Gibson
On Thu, Aug 30, 2007 at 09:10:46AM -0500, Scott Wood wrote: On Thu, Aug 30, 2007 at 03:58:12PM +1000, David Gibson wrote: On Thu, Aug 30, 2007 at 12:48:54AM -0500, Scott Wood wrote: On Thu, Aug 30, 2007 at 10:55:59AM +1000, David Gibson wrote: Am I correct in thinking that it's basically

[PATCH -mm] pcmcia: Updates to electra_cf driver

2007-08-30 Thread Olof Johansson
Fix build of electra_cf, since the IO space setup interfaces were changed when BenH rewrote it. Also clean it up a bit, add 5V support, make it unloadable, remove some dead variables, etc. Signed-off-by: Olof Johansson [EMAIL PROTECTED] --- Andrew, I did this as an incremental patch that you

[PATCH] Remove unused variables in driver/ide/ppc/pmac.c

2007-08-30 Thread Tony Breeds
Fixes: CC [M] drivers/ide/ppc/pmac.o /scratch/tony/tmp/drivers/ide/ppc/pmac.c: In function 'pmac_ide_dma_check': /scratch/tony/tmp/drivers/ide/ppc/pmac.c:1815: warning: unused variable 'map' /scratch/tony/tmp/drivers/ide/ppc/pmac.c:1813: warning: unused variable 'pmif' Signed-off-by: Tony

Re: [PATCH 1/3] bootwrapper: In cuImage, print message for ENET devices not found in tree

2007-08-30 Thread Grant Likely
On 8/30/07, David Gibson [EMAIL PROTECTED] wrote: On Thu, Aug 30, 2007 at 02:26:18PM -0600, Grant Likely wrote: From: Grant Likely [EMAIL PROTECTED] Signed-off-by: Grant Likely [EMAIL PROTECTED] CC: Scott Wood [EMAIL PROTECTED] CC: Kumar Gala [EMAIL PROTECTED] CC: David Gibson [EMAIL

Re: [PATCH 1/3] bootwrapper: In cuImage, print message for ENET devices not found in tree

2007-08-30 Thread David Gibson
On Thu, Aug 30, 2007 at 10:14:41PM -0600, Grant Likely wrote: On 8/30/07, David Gibson [EMAIL PROTECTED] wrote: On Thu, Aug 30, 2007 at 02:26:18PM -0600, Grant Likely wrote: From: Grant Likely [EMAIL PROTECTED] Signed-off-by: Grant Likely [EMAIL PROTECTED] CC: Scott Wood [EMAIL

libfdt: Fix use of uninitialized variable in fdt_get_path()

2007-08-30 Thread David Gibson
My recent implemenetation of fdt_get_path() had a bug - the while loop tested offset which was unitialized on the first iteration. Depending on code surrounding the call, this could cause fdt_get_path() to return incorrect results. This patch corrects the problem by applying some more correct