Re: [PATCH 4/4] [POWERPC] CPM1: implement GPIO API

2007-12-22 Thread Jochen Friedrich
Hi Anton, Jochen, I kept your Signed-off-by, though this isn't your original patch. Hope you're okay with it. I also hope you'll test it. ;-) that's OK. Thanks, Jochen ___ Linuxppc-dev mailing list Linuxppc-dev@ozlabs.org

Re: [PATCH POWERPC] i2c: adds support for i2c bus on Frescale CPM1/CPM2 controllers

2007-12-22 Thread Jochen Friedrich
Hi Vitaly, I had an attempt a while ago to do this but haven't had enough time to get it completed, so I am glad to see it finally picked up. There was some sort of discussion that time, you seem to have some of those points addressed but something not, please check:

Re: Yet more patches added to for-2.6.25/master branches

2007-12-22 Thread David Woodhouse
http://patchwork.ozlabs.org/linuxppc/patch?id=15192 ? -- dwmw2 ___ Linuxppc-dev mailing list Linuxppc-dev@ozlabs.org https://ozlabs.org/mailman/listinfo/linuxppc-dev

Re: [PATCH 4/4] [POWERPC] CPM1: implement GPIO API

2007-12-22 Thread Jochen Friedrich
Hi Anton, I also hope you'll test it. ;-) yes. +int cpm_init_par_io(void) +{ + struct device_node *np; + const u32 *num_ports; + + np = of_find_node_by_name(NULL, fsl,cpm1-pario); + if (!np) + return -ENOENT; + I guess this should be: np =

Re: [PATCH 4/4] [POWERPC] CPM1: implement GPIO API

2007-12-22 Thread Anton Vorontsov
On Sat, Dec 22, 2007 at 05:08:14PM +0100, Jochen Friedrich wrote: Hi Anton, I also hope you'll test it. ;-) yes. +int cpm_init_par_io(void) +{ + struct device_node *np; + const u32 *num_ports; + + np = of_find_node_by_name(NULL, fsl,cpm1-pario); + if

[PATCH/RFC] powerpc: DBox2 Board Support

2007-12-22 Thread Jochen Friedrich
This patch adds device tree source, default config and setup code for DBox2 devices. Signed-off-by: Jochen Friedrich [EMAIL PROTECTED] --- arch/powerpc/boot/dts/dbox2.dts | 263 arch/powerpc/configs/dbox2_defconfig | 1042 ++

Re: Time for cell code reshuffle?

2007-12-22 Thread Benjamin Herrenschmidt
On Fri, 2007-12-21 at 09:23 -0800, Geoff Levand wrote: It seems platforms/cell should have the shared and/or generic code, and the other stuff moved into a new platform directory, but is it worth the effort? No, platforms/xxx isn't supposed to be shared code. That's was syslib is for.

Re: Time for cell code reshuffle?

2007-12-22 Thread Benjamin Herrenschmidt
On Fri, 2007-12-21 at 20:15 +0100, Arnd Bergmann wrote: It seems platforms/cell should have the shared and/or generic code, and the other stuff moved into a new platform directory, but is it worth the effort? There is very little code in platforms/cell that can not be generic, so I

Re: Time for cell code reshuffle?

2007-12-22 Thread Josh Boyer
On Sun, 23 Dec 2007 07:58:02 +1100 Benjamin Herrenschmidt [EMAIL PROTECTED] wrote: On Fri, 2007-12-21 at 09:23 -0800, Geoff Levand wrote: It seems platforms/cell should have the shared and/or generic code, and the other stuff moved into a new platform directory, but is it worth the

Re: [PATCH 2/3] (Resend part #1) Add the RapidIO support to powerpc architecture with memory mapping support.

2007-12-22 Thread Stephen Rothwell
Hi, This is a very large patch. It may be easier to review if it could be split on some logical way, that is at all possible (I don't know either way). This is just a quick note about some more trivial things. On Fri, 21 Dec 2007 17:58:43 +0800 Zhang Wei [EMAIL PROTECTED] wrote: +struct

Re: [PATCH] [POWERPC] MPC8360E-RDK: Device tree and board file

2007-12-22 Thread Stephen Rothwell
On Fri, 21 Dec 2007 23:23:09 +0300 Anton Vorontsov [EMAIL PROTECTED] wrote: +static struct of_device_id mpc836x_rdk_ids[] = { Please make this __initdata. -- Cheers, Stephen Rothwell[EMAIL PROTECTED] http://www.canb.auug.org.au/~sfr/ pgp6hCLGmk8wd.pgp Description: PGP

Re: [PATCH 1/3] [POWERPC] FSL UPM: routines to manage FSL UPMs

2007-12-22 Thread Stephen Rothwell
On Fri, 21 Dec 2007 23:39:25 +0300 Anton Vorontsov [EMAIL PROTECTED] wrote: +int fsl_upm_get_for(struct device_node *node, const char *name, + struct fsl_upm *upm) +{ + int ret; + struct device_node *lbus; + struct resource lbc_res; + ptrdiff_t mxmr_offs; +

Re: [PATCH 2/3] [POWERPC][NAND] FSL UPM NAND driver

2007-12-22 Thread Stephen Rothwell
On Fri, 21 Dec 2007 23:41:30 +0300 Anton Vorontsov [EMAIL PROTECTED] wrote: +static int __devinit upm_chip_probe(struct of_device *ofdev, + const struct of_device_id *ofid) +{ + struct upm_data *ud; + struct resource io_res; + const u32 *prop; +

Re: [PATCH 0/4] PowerPC: implement GPIO API

2007-12-22 Thread Segher Boessenkool
OF device tree GPIOs bindings are similar to IRQs: But GPIOs are a very different thing. Most importantly, the number of a GPIO is completely local to the GPIO controller. pario0: [EMAIL PROTECTED] { #gpio-cells = 2; Your Linux code doesn't actually use this. Why is it needed,

Re: [PATCH 1/4] [POWERPC] Implement GPIO API embryo

2007-12-22 Thread Segher Boessenkool
+int __of_parse_gpio_bank_pin(struct device_node *np, int index, + int bank_width, int max_bank) +{ + int bank; + int pin; + const u32 *gpios; + + /* + * We can get there only if of_get_gpio() succeeded, thus + * no need checking for

Re: [PATCH] ASoC drivers for the Freescale MPC8610 SoC

2007-12-22 Thread Timur Tabi
Scott Wood wrote: None of the SOC nodes in any DTS have a compatible entry. Not quite true; ep88xc, mpc8272ads, and pq2fads have them. Ah ok. So what should the compatible entry for 8641 be? compatible = fsl,mpc8641 That looks a lot like what a compatible entry for the CPU should

Re: [alsa-devel] [PATCH] ASoC drivers for the Freescale MPC8610 SoC

2007-12-22 Thread Timur Tabi
Lee Revell wrote: Please use DMA_32BIT_MASK (see include/linux/dma-mapping.h) instead of 0x. No prob. But did you see this comment: /* * NOTE: do not use the below macros in new code and do not add new definitions * here. * * Instead, just open-code DMA_BIT_MASK(n) within

Re: [PATCH] [POWERPC] MPC8360E-RDK: Device tree and board file

2007-12-22 Thread Timur Tabi
Anton Vorontsov wrote: 2. QE SCCs (slow UCCs, used as an UARTs) I a posted a driver that provides this support, I'm just waiting for Kumar to apply it. What revision of the 8360 does this board use? ___ Linuxppc-dev mailing list

Re: [PATCH] [POWERPC] MPC8360E-RDK: Device tree and board file

2007-12-22 Thread Timur Tabi
Anton Vorontsov wrote: + [EMAIL PROTECTED] { + #address-cells = 1; + #size-cells = 1; + compatible = fsl,qe; + ranges = 0 0xe010 0x0010; + reg = 0xe010 0x480; + /* filled by u-boot */ +

[PATCH] Add information on enabling sound on the MPC8641 HPCN

2007-12-22 Thread Timur Tabi
Add a comment to the DTS file for the MPC8641 HPCN describing a wiring change needed to get sound working on this board. Signed-off-by: Timur Tabi [EMAIL PROTECTED] --- For a two-line comment, I thought the DTS would be the best place to put this information.

Re: [PATCH 0/4] PowerPC: implement GPIO API

2007-12-22 Thread David Gibson
On Sun, Dec 23, 2007 at 03:47:50AM +0100, Segher Boessenkool wrote: OF device tree GPIOs bindings are similar to IRQs: But GPIOs are a very different thing. Most importantly, the number of a GPIO is completely local to the GPIO controller. Yes... just as interrupt specifiers are local to

Re: [PATCH 1/4] [POWERPC] Implement GPIO API embryo

2007-12-22 Thread David Gibson
On Sun, Dec 23, 2007 at 03:49:30AM +0100, Segher Boessenkool wrote: +int __of_parse_gpio_bank_pin(struct device_node *np, int index, +int bank_width, int max_bank) +{ + int bank; + int pin; + const u32 *gpios; + + /* +* We can get there only if

Re: [PATCH 17/21] [POWERPC] Base support for 440SPe Katmai eval board

2007-12-22 Thread Stephen Rothwell
On Fri, 21 Dec 2007 19:48:28 -0600 Josh Boyer [EMAIL PROTECTED] wrote: On Sat, 22 Dec 2007 11:21:05 +1100 Stephen Rothwell [EMAIL PROTECTED] wrote: On Fri, 21 Dec 2007 15:39:34 +1100 Benjamin Herrenschmidt [EMAIL PROTECTED] wrote: +++ linux-merge/arch/powerpc/platforms/44x/katmai.c

Re: [Cbe-oss-dev] Time for cell code reshuffle?

2007-12-22 Thread Jeremy Kerr
Hi all, To the question, where what it should go, I'd leave the decision to Jeremy, but my current idea would be: arch/powerpc/platforms/cell/spufs - arch/powerpc/spufs I'd suggest arch/powerpc/sysdev/spufs to keep arch/powerpc clean. However, this may also depend on the (intended)

Re: [patch v2] PS3: Fix printing of os-area magic numbers

2007-12-22 Thread Geoff Levand
On 12/20/2007 08:44 PM, Paul Mackerras wrote: Geoff Levand writes: Fix a bug in the printing of the os-area magic numbers which assumed that magic numbers were zero terminated strings. The magic numbers are represented in memory as integers. If the os-area sections are not initialized

[patch v3] PS3: Fix printing of os-area magic numbers

2007-12-22 Thread Geoff Levand
Fix a bug in the printing of the os-area magic numbers which assumed that magic numbers were zero terminated strings. The magic numbers are represented in memory as integers. If the os-area sections are not initialized correctly they could contained random data that would be printed to the

Re: Yet more patches added to for-2.6.25/master branches

2007-12-22 Thread Michael Neuling
Paulus, Can you take the crash shutdown hook patches as well for 2.6.25? http://patchwork.ozlabs.org/linuxppc/patch?person=414id=15546 http://patchwork.ozlabs.org/linuxppc/patch?person=414id=15547 Mikey In message [EMAIL PROTECTED] you wrote: Aegis Lin (1): [POWERPC] spufs: Use