[PATCH] powerpc: excplictly copy elements of pt_regs

2008-06-27 Thread Stephen Rothwell
Gcc 4.3 produced this warning: arch/powerpc/kernel/signal_64.c: In function 'restore_sigcontext': arch/powerpc/kernel/signal_64.c:161: warning: array subscript is above array bounds This is caused by us copying to aliases of elements of the pt_regs structure. Make those explicit. This adds

Re: [PATCH 01/12] pata_mpc52xx: use linux/of_platform.h instead of asm

2008-06-27 Thread Jeff Garzik
Stephen Rothwell wrote: Signed-off-by: Stephen Rothwell [EMAIL PROTECTED] --- drivers/ata/pata_mpc52xx.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) I am not sure who wants to take this. diff --git a/drivers/ata/pata_mpc52xx.c b/drivers/ata/pata_mpc52xx.c index

Re: [PATCH] ibm_newemac: Fixes entry of short packets

2008-06-27 Thread SathyaNarayanan
Hi benh, Please find my comments inline. On Tue, Jun 24, 2008 at 4:50 AM, Benjamin Herrenschmidt [EMAIL PROTECTED] wrote: On Mon, 2008-06-23 at 14:55 +0200, Stefan Roese wrote: From: Sathya Narayanan [EMAIL PROTECTED] Short packets has to be discarded by the driver. So this

Re: [PATCH] ibm_newemac: Fixes kernel crashes when speed of cable connected changes

2008-06-27 Thread SathyaNarayanan
Hi benh, Please find my comments inline. Thanks and regards, SathyaNarayanan On Tue, Jun 24, 2008 at 4:50 AM, Benjamin Herrenschmidt [EMAIL PROTECTED] wrote: On Mon, 2008-06-23 at 14:54 +0200, Stefan Roese wrote: From: Sathya Narayanan [EMAIL PROTECTED] The descriptor

Re: [PATCH] ibm_newemac: Fixes kernel crashes when speed of cable connected changes

2008-06-27 Thread Benjamin Herrenschmidt
for (i = 0; i NUM_TX_BUFF; ++i) { - if (dev-tx_skb[i]) { + if (dev-tx_skb[i] dev-tx_desc[i].data_ptr) { Why changing the test above ? The reason for changing this condition is , In

Re: [PATCH] ibm_newemac: Fixes entry of short packets

2008-06-27 Thread Benjamin Herrenschmidt
Actually , short packets are not allowed to flow through the higher layers, If any of the layer tried to use the extra room available may hit wit crash . Since it is a invalid packet it has to be dropped and freed in driver. Actually if you see in code, the other invalid packets

Re: [PATCH 26/60] microblaze_v4: time support

2008-06-27 Thread Thomas Gleixner
On Thu, 26 Jun 2008, [EMAIL PROTECTED] wrote: + +static inline void udelay(unsigned long usec) +{ +} shouldnt this function be named zerodelay() ? Thanks, tglx ___ Linuxppc-dev mailing list Linuxppc-dev@ozlabs.org

Re: [Resend][PATCH 1/8][Version 2] MPC5121 Update MPC5121ADS device tree

2008-06-27 Thread Arnd Bergmann
On Friday 27 June 2008, John Rigby wrote: On Thu, Jun 26, 2008 at 7:42 PM, David Gibson [EMAIL PROTECTED] wrote: [snip] [EMAIL PROTECTED] { compatible = fsl,mpc5121-immr; + device_type = soc; I realise we still need the unwanted device_type value on

Re: Please pull from 'powerpc-next' branch

2008-06-27 Thread Paul Mackerras
Kumar Gala writes: Paul, any update on when we might see some of the various patches pulled into powerpc-next? This weekend assuming I get over this gastric flu-like lurgy that I have at the moment. I've got some work I'd like to see in .27 but it needs Michael's code patching patches.

Re: [PATCH 48/60] microblaze_v4: headers simple files - empty or redirect to asm-generic

2008-06-27 Thread Adrian Bunk
On Fri, Jun 27, 2008 at 01:23:05AM +0200, Arnd Bergmann wrote: On Thursday 26 June 2008, Adrian Bunk wrote: Honestly, I do not completely like your approach of getting the microblaze port submitter to create the asm-generic files - I would personally prefer if the microblaze port would

[PATCH]: [MPC5200] (v2) Add ATA DMA support

2008-06-27 Thread Tim Yamin
Changes from previous version: - Add FIFO status error checking code before a DMA transaction starts and after it is completed. - Fix an incorrect check in the previous patch causing spurious dma table too small errors. Tim This patch adds MDMA/UDMA support (using BestComm for DMA) on the

Re: [RFC 1/3] powerpc: __copy_tofrom_user tweaked for Cell

2008-06-27 Thread Gunnar von Boehn
Hi Paul, In my experience, dcbz slows down the hot-cache case because it adds a few cycles to the execution time of the inner loop, and on most 64-bit PowerPC implementations, it doesn't actually help even in the cold-cache case because the store queue does enough write combining I agree

Re: [RFC/PATCH 0/3] sched: allow arch override of cpu power

2008-06-27 Thread Nathan Lynch
Breno Leitao wrote: Nathan Lynch wrote: There is an interesting quality of POWER6 cores, which each have 2 hardware threads: assuming one thread on the core is idle, the primary thread is a little faster than the secondary thread. To illustrate: I found this feature interesting and

Re: [PATCH 26/60] microblaze_v4: time support

2008-06-27 Thread Michal Simek
+ +static inline void udelay(unsigned long usec) +{ +} shouldnt this function be named zerodelay() ? Thanks, tglx I have prepared implementation of this function which sent me JW. I did some changes which I test it because I found problem there. M

Re: dtc: Address an assortment of portability problems

2008-06-27 Thread Scott Wood
David Gibson wrote: On Thu, Jun 26, 2008 at 10:25:28AM -0500, Scott Wood wrote: On Thu, Jun 26, 2008 at 11:03:49AM +1000, David Gibson wrote: - the endian handling functions in libfdt_env.h, based on endian.h and byteswap.h are replaced with some portable open-coded versions.

Re: [PATCH 48/60] microblaze_v4: headers simple files - empty or redirect to asm-generic

2008-06-27 Thread Michal Simek
Hi Adrian and Arnd, After all, it won't matter whether we'll unify resp. remove 22 or 23 files. That wasn't my idea. The logic was that if one more file exists in asm-generic that can be removed from the architectures, we get 22 more files to remove without anyone having to look at the

[PATCH] powerpc/booke: don't reinitialize time base

2008-06-27 Thread Kumar Gala
For some reason long ago I decided that we should zero out the time base when we calibrate the decrementer. The problem is that this can be harmful in SMP systems where the firmware has already synchronized the time bases on the various cores. Signed-off-by: Kumar Gala [EMAIL PROTECTED] ---

Re: Please pull from 'powerpc-next' branch

2008-06-27 Thread Kumar Gala
On Jun 27, 2008, at 6:27 AM, Paul Mackerras wrote: Kumar Gala writes: Paul, any update on when we might see some of the various patches pulled into powerpc-next? This weekend assuming I get over this gastric flu-like lurgy that I have at the moment. Uugh, that sucks. I've got some work

Re: [PATCH 48/60] microblaze_v4: headers simple files - empty or redirect to asm-generic

2008-06-27 Thread Sam Ravnborg
We need either all architectures changed or none at all - we do need the arch headers to become more similar, not more different. And this is why we need an agreement _before_ an asm-generic header gets added, not after it. We already have the agreement.. Files which are equal among

[PATCH] powerpc: Add 83xx and 86xx to 6xx Multiplatform

2008-06-27 Thread Kumar Gala
There isn't any reason at this point that we can't build 83xx 86xx support in with the other 6xx based boards. Twiddle the Kconfigs to allow this. Signed-off-by: Kumar Gala [EMAIL PROTECTED] --- arch/powerpc/platforms/83xx/Kconfig | 10 ++ arch/powerpc/platforms/86xx/Kconfig | 16

Re: cell-index vs. index vs. no index in I2C device nodes

2008-06-27 Thread Jochen Friedrich
Hi Timur, Anyone know when of_i2c.c is going to come online replace what's in fsl_soc.c? There is a patch being prepared to convert i2c-mpc from a platform driver to an of_platform driver making the fsl_soc.c code obsolete. See: http://patchwork.ozlabs.org/linuxppc/patch?id=18898 Thanks,

Re: [PATCHv3 1/2] [POWERPC] CPM2: Implement GPIO LIB API on CPM2 Freescale SoC.

2008-06-27 Thread Jochen Friedrich
Hi Laurent, Is there any pending issue or can this be applied to powerpc-next ? Looks OK to me. Signed-off-by: Laurent Pinchart [EMAIL PROTECTED] Cc: Jochen Friedrich [EMAIL PROTECTED] Acked-by: Jochen Friedrich [EMAIL PROTECTED] Thanks, Jochen

[PATCH v2] update crypto node definition and device tree instances

2008-06-27 Thread Kim Phillips
delete obsolete device-type property, delete model property (use compatible property instead), prepend fsl, to Freescale specific properties. Add nodes to device trees that are missing them, and fix broken property values in other trees. Signed-off-by: Kim Phillips [EMAIL PROTECTED] --- changes

Re: Merging seperate FDT-blobs?

2008-06-27 Thread Wolfram Sang
Hello David, On Mon, Jun 23, 2008 at 03:06:24PM +1000, David Gibson wrote: Hrm. I was assuming this would be handled by the code putting things together, rather than being encoded into the fragments. I envisaged something like: int fdt_graft(void *fdt, int parentoffset, const char

Re: [PATCH] powerpc/bootwrapper: Add documentation of boot wrapper targets

2008-06-27 Thread Scott Wood
On Wed, Jun 25, 2008 at 01:21:04PM -0700, Grant Likely wrote: + zImage.%: Image usable by OpenFirmware. Image expects firmware + to provide the device tree using OpenFirmware + interfaces. Typically general purpose hardware uses +

Re: [PATCH] powerpc: Add 83xx and 86xx to 6xx Multiplatform

2008-06-27 Thread Scott Wood
On Fri, Jun 27, 2008 at 11:36:36AM -0500, Kumar Gala wrote: There isn't any reason at this point that we can't build 83xx 86xx support in with the other 6xx based boards. Twiddle the Kconfigs to allow this. Likewise with 82xx -- why don't we just get rid of the Machine type choice, and turn

[PATCH v2] powerpc: Add 82xx/83xx/86xx to 6xx Multiplatform

2008-06-27 Thread Kumar Gala
There isn't any reason at this point that we can't build 82xx, 83xx 86xx support in with the other 6xx based boards. Twiddle the Kconfigs to allow this. This allows us to remove the machine type selection for related to 6xx. Signed-off-by: Kumar Gala [EMAIL PROTECTED] --- Added 82xx into

Re: [PATCH] powerpc: Add 83xx and 86xx to 6xx Multiplatform

2008-06-27 Thread Arnd Bergmann
On Friday 27 June 2008, Scott Wood wrote: On Fri, Jun 27, 2008 at 11:36:36AM -0500, Kumar Gala wrote: There isn't any reason at this point that we can't build 83xx 86xx support in with the other 6xx based boards.  Twiddle the Kconfigs to allow this. Likewise with 82xx -- why don't we just

Re: [PATCH] powerpc: Add 83xx and 86xx to 6xx Multiplatform

2008-06-27 Thread Kumar Gala
On Jun 27, 2008, at 2:35 PM, Arnd Bergmann wrote: On Friday 27 June 2008, Scott Wood wrote: On Fri, Jun 27, 2008 at 11:36:36AM -0500, Kumar Gala wrote: There isn't any reason at this point that we can't build 83xx 86xx support in with the other 6xx based boards. Twiddle the Kconfigs to

[PATCH] powerpc: Add dma nodes to 83xx, 85xx and 86xx boards

2008-06-27 Thread Kumar Gala
Added DMA nodes for the elo/elo-plus DMA engines. Renamed the interrupt controller alias in mpc832x_rdb.dts to ipic so that its the same as all the other boards. Signed-off-by: Kumar Gala [EMAIL PROTECTED] --- In my powerpc-next branch. - k arch/powerpc/boot/dts/asp834x-redboot.dts | 37

Re: [PATCH] POWERPC CPM: Minor cosmetic changes to udbg_putc

2008-06-27 Thread Scott Wood
Nye Liu wrote: udbg_putc is a *function pointer* that is initialized during udbg_init_cpm. It might not be initialized properly when called from udbg_putc_cpm(), so (recursively) call udbg_putc_cpm() directly. ACK Printing an X on initialization is ugly. How about a \n instead? D'oh, that

Re: [PATCH] powerpc: Add dma nodes to 83xx, 85xx and 86xx boards

2008-06-27 Thread Scott Wood
Kumar Gala wrote: diff --git a/arch/powerpc/boot/dts/asp834x-redboot.dts b/arch/powerpc/boot/dts/asp834x-redboot.dts index 972cf78..d140031 100644 --- a/arch/powerpc/boot/dts/asp834x-redboot.dts +++ b/arch/powerpc/boot/dts/asp834x-redboot.dts @@ -53,7 +53,7 @@

Re: issue with kgdb on ppc

2008-06-27 Thread SEEMA pm
Hello I got the gianfar.c patch and enabled CONFIG_NETCONSOLE and now i'm able to connect kgdb and gdb. But when i try to cont in gdb, the system tries to load the rootfs but fails and trys to reboot. Can someone please provide some help on this. dump: (gdb) c Continuing. RAMDISK: Compressed

[PATCH] FS_ENET: Don't attempt to set mii_speed when fec_inf is null

2008-06-27 Thread Nye Liu
From: Nye Liu [EMAIL PROTECTED] When using CONFIG_FIXED_PHY, fec_inf (fep-phydev-bus-priv) is NULL in fs_enet/mac-fec.c restart(). Dereferencing fec_inf when trying to set the mii_speed causes a kernel oops. Signed-off-by: Nye Liu [EMAIL PROTECTED] --- diff --git

[PATCH] POWERPC CPM: Minor cosmetic changes to udbg_putc

2008-06-27 Thread Nye Liu
From: Nye Liu [EMAIL PROTECTED] udbg_putc is a *function pointer* that is initialized during udbg_init_cpm. It might not be initialized properly when called from udbg_putc_cpm(), so (recursively) call udbg_putc_cpm() directly. Printing an X on initialization is ugly. How about a \n instead?

Re: [2.6 patch] asm/ptrace.h userspace headers cleanup

2008-06-27 Thread Roland McGrath
That all looks fine to me, though I won't claim to have paid close attention to the nits in the various odd archs' files. Thanks, Roland ___ Linuxppc-dev mailing list Linuxppc-dev@ozlabs.org https://ozlabs.org/mailman/listinfo/linuxppc-dev

Re: [PATCH] powerpc: Add dma nodes to 83xx, 85xx and 86xx boards

2008-06-27 Thread Kumar Gala
On Jun 27, 2008, at 3:28 PM, Scott Wood wrote: Kumar Gala wrote: diff --git a/arch/powerpc/boot/dts/asp834x-redboot.dts b/arch/ powerpc/boot/dts/asp834x-redboot.dts index 972cf78..d140031 100644 --- a/arch/powerpc/boot/dts/asp834x-redboot.dts +++ b/arch/powerpc/boot/dts/asp834x-redboot.dts

[PATCH v2] powerpc: Add dma nodes to 83xx, 85xx and 86xx boards

2008-06-27 Thread Kumar Gala
Added DMA nodes for the elo/elo-plus DMA engines. Renamed the interrupt controller alias in mpc832x_rdb.dts to ipic so that its the same as all the other boards. Signed-off-by: Kumar Gala [EMAIL PROTECTED] --- Some copy/paste bugs are now fixed (thanks Scott for actually looking at the patch).

Re: [PATCH] FS_ENET: Don't attempt to set mii_speed when fec_inf is null

2008-06-27 Thread Sergei Shtylyov
Hello. Nye Liu wrote: From: Nye Liu [EMAIL PROTECTED] When using CONFIG_FIXED_PHY, fec_inf (fep-phydev-bus-priv) is NULL in fs_enet/mac-fec.c restart(). Dereferencing fec_inf when trying to set the mii_speed causes a kernel oops. Signed-off-by: Nye Liu [EMAIL PROTECTED] --- diff --git

Re: [PATCH] FS_ENET: Don't attempt to set mii_speed when fec_inf is null

2008-06-27 Thread Nye Liu
Sorry! diff --git a/drivers/net/fs_enet/mac-fec.c b/drivers/net/fs_enet/mac-fec.c index 8a311d1..7359068 100644 --- a/drivers/net/fs_enet/mac-fec.c +++ b/drivers/net/fs_enet/mac-fec.c @@ -328,7 +328,8 @@ static void restart(struct net_device *dev) /* * Set MII speed. */

[PATCH] FS_ENET: Don't attempt to set mii_speed when fec_inf is null

2008-06-27 Thread Nye Liu
From: Nye Liu [EMAIL PROTECTED] When using CONFIG_FIXED_PHY, fec_inf (fep-phydev-bus-priv) is NULL in fs_enet/mac-fec.c restart(). Dereferencing fec_inf when trying to set the mii_speed causes a kernel oops. Signed-off-by: Nye Liu [EMAIL PROTECTED] --- diff --git

[PATCH V2] Keep 3 high personality bytes across exec

2008-06-27 Thread Eric B Munson
Currently when a 32 bit process is exec'd on a powerpc 64 bit host the value in the top three bytes of the personality is clobbered. This patch adds a check in the SET_PERSONALITY macro that will carry all the values in the top three bytes across the exec. These three bytes currently carry flags

Re: dtc: Address an assortment of portability problems

2008-06-27 Thread David Gibson
On Fri, Jun 27, 2008 at 09:53:03AM -0500, Scott Wood wrote: David Gibson wrote: On Thu, Jun 26, 2008 at 10:25:28AM -0500, Scott Wood wrote: On Thu, Jun 26, 2008 at 11:03:49AM +1000, David Gibson wrote: - the endian handling functions in libfdt_env.h, based on endian.h and byteswap.h are

Re: [PATCH 01/60] microblaze_v4: Kconfig patches

2008-06-27 Thread Paul Mundt
On Thu, Jun 26, 2008 at 02:29:30PM +0200, [EMAIL PROTECTED] wrote: +config HZ + int + default 100 + Consider using kernel/Kconfig.hz instead. +config DEFCONFIG_LIST + string + default arch/$ARCH/defconfig + init/Kconfig already has quite a few reasonable defaults for this,

Re: [PATCH 24/60] microblaze_v4: asm-offsets

2008-06-27 Thread Paul Mundt
On Thu, Jun 26, 2008 at 02:29:53PM +0200, [EMAIL PROTECTED] wrote: +#include linux/stddef.h +#include linux/sched.h +#include linux/kernel_stat.h +#include linux/ptrace.h +#include linux/hardirq.h +#include linux/thread_info.h + +#define DEFINE(sym, val) asm volatile(\n- #sym %0 #val : :

Re: [PATCH 25/60] microblaze_v4: process and init task function

2008-06-27 Thread Paul Mundt
On Thu, Jun 26, 2008 at 02:29:54PM +0200, [EMAIL PROTECTED] wrote: +void (*pm_power_off)(void) = NULL; +EXPORT_SYMBOL(pm_power_off); + +void cpu_idle(void) +{ + set_thread_flag(TIF_POLLING_NRFLAG); + + while (1) { + while (!need_resched()) +

Re: [PATCH 28/60] microblaze_v4: ptrace support

2008-06-27 Thread Paul Mundt
On Thu, Jun 26, 2008 at 02:29:57PM +0200, [EMAIL PROTECTED] wrote: +long arch_ptrace(struct task_struct *child, long request, long addr, long data) +{ + int rval; + + switch (request) { + unsigned long val, copied; + + case PTRACE_PEEKTEXT: /* read word at

[PATCH v2] powerpc/bootwrapper: Add documentation of boot wrapper targets

2008-06-27 Thread Grant Likely
From: Grant Likely [EMAIL PROTECTED] There have been many questions on and off the mailing list about how exactly the bootwrapper is used for embedded targets. Add some documentation and help text to try and clarify the system. Signed-off-by: Grant Likely [EMAIL PROTECTED] ---

Re: [PATCH 29/60] microblaze_v4: traps support

2008-06-27 Thread Paul Mundt
On Thu, Jun 26, 2008 at 02:29:58PM +0200, [EMAIL PROTECTED] wrote: +static int kstack_depth_to_print = 24; + x86 has a sysctl for this. It may be worth making this non-static and generalizing the ifdef case. Plenty of other architectures could benefit from this also. +void show_trace(struct

Re: [PATCH 30/60] microblaze_v4: support for a.out

2008-06-27 Thread Paul Mundt
On Thu, Jun 26, 2008 at 02:29:59PM +0200, [EMAIL PROTECTED] wrote: From: Michal Simek [EMAIL PROTECTED] Signed-off-by: Michal Simek [EMAIL PROTECTED] --- 0 files changed, 0 insertions(+), 0 deletions(-) create mode 100644 include/asm-microblaze/a.out.h a.out is going away for the

Re: [PATCH 59/60] microblaze_v4: syscall_table.S and unistd.h

2008-06-27 Thread Paul Mundt
On Thu, Jun 26, 2008 at 02:30:28PM +0200, [EMAIL PROTECTED] wrote: +#define __NR_semtimedop 325 +#define __NR_timerfd_settime 326 +#define __NR_timerfd_gettime 327 + +#ifdef __KERNEL__ + +#define __NR_syscalls327 + Off-by-1 on __NR_syscalls, this should be 328.

Re: [PATCH v2] update crypto node definition and device tree instances

2008-06-27 Thread Grant Likely
On Fri, Jun 27, 2008 at 9:52 AM, Kim Phillips [EMAIL PROTECTED] wrote: delete obsolete device-type property, delete model property (use compatible property instead), prepend fsl, to Freescale specific properties. Add nodes to device trees that are missing them, and fix broken property values

Re: [PATCH 01/12] pata_mpc52xx: use linux/of_platform.h instead of asm

2008-06-27 Thread Grant Likely
On Thu, Jun 26, 2008 at 11:37 PM, Jeff Garzik [EMAIL PROTECTED] wrote: Stephen Rothwell wrote: Signed-off-by: Stephen Rothwell [EMAIL PROTECTED] --- drivers/ata/pata_mpc52xx.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) I am not sure who wants to take this. diff --git

Re: [PATCH 12/60] microblaze_v4: Generic dts file for platforms

2008-06-27 Thread Grant Likely
On Thu, Jun 26, 2008 at 5:29 AM, [EMAIL PROTECTED] wrote: From: Michal Simek [EMAIL PROTECTED] Signed-off-by: Michal Simek [EMAIL PROTECTED] --- arch/microblaze/platform/generic/system.dts | 300 +++ 1 files changed, 300 insertions(+), 0 deletions(-) create