Re: [PATCH] powerpc: mtmsrd not defined

2010-08-31 Thread Sean MacLennan
On Wed, 1 Sep 2010 01:45:46 -0500 Kumar Gala wrote: > For what defconfig setup do you get the errors above? 44x/ebony_defconfig Then enable KPROBES (or XMON). Then put an #ifdef CONFIG_PPC_FPU in ldstfp.S. Cheers, Sean ___ Linuxppc-dev mailing li

Re: [PATCH] powerpc: mtmsrd not defined

2010-08-31 Thread Kumar Gala
On Aug 31, 2010, at 9:55 PM, Sean MacLennan wrote: > On Tue, 31 Aug 2010 13:46:05 -0400 > Sean MacLennan wrote: > >> On Tue, 31 Aug 2010 11:17:17 -0500 >> Kumar Gala wrote: >> >>> Can we add proper CONFIG_PPC_FPU into this file. >> >> If nobody beats me to it I can try this evening. >

Re: [PATCH v2 1/4] fsl_rio: fix compile errors

2010-08-31 Thread Kumar Gala
On Aug 31, 2010, at 10:40 PM, Li Yang wrote: > On Wed, Sep 1, 2010 at 5:39 AM, Kumar Gala wrote: >> >> On Jun 18, 2010, at 1:24 AM, Li Yang wrote: >> >>> Fixes the following compile problem on E500 platforms: >>> arch/powerpc/sysdev/fsl_rio.c: In function 'fsl_rio_mcheck_exception': >>> arch/p

Re: [PATCH][RFC] preempt_count corruption across H_CEDE call with CONFIG_PREEMPT on pseries

2010-08-31 Thread Michael Ellerman
On Tue, 2010-08-31 at 00:12 -0700, Darren Hart wrote: .. > > When running with the function plugin I had to stop the trace > immediately before entering start_secondary after an online or my traces > would not include the pseries_mach_cpu_die function, nor the tracing I > added there (possibly buf

Re: [PATCH v2 1/4] fsl_rio: fix compile errors

2010-08-31 Thread Li Yang
On Wed, Sep 1, 2010 at 5:39 AM, Kumar Gala wrote: > > On Jun 18, 2010, at 1:24 AM, Li Yang wrote: > >> Fixes the following compile problem on E500 platforms: >> arch/powerpc/sysdev/fsl_rio.c: In function 'fsl_rio_mcheck_exception': >> arch/powerpc/sysdev/fsl_rio.c:248: error: 'MCSR_MASK' undeclare

Re: [PATCH] powerpc: mtmsrd not defined

2010-08-31 Thread Sean MacLennan
On Tue, 31 Aug 2010 13:46:05 -0400 Sean MacLennan wrote: > On Tue, 31 Aug 2010 11:17:17 -0500 > Kumar Gala wrote: > > > Can we add proper CONFIG_PPC_FPU into this file. > > If nobody beats me to it I can try this evening. I had to give up. Without the CONFIG_PPC_FPU it compiles fine for

[v1 PATCH] ucc_geth: fix ethtool set ring param bug

2010-08-31 Thread Liang Li
It's common sense that when we should do change to driver ring desc/buffer etc only after 'stop/shutdown' the device. When we do change while devices/driver is running, kernel oops occur: [ r...@fsl_8569mds:/root> ethtool -G eth0 tx 256 r...@fsl_8569mds:/root> Oops: Kernel access of bad area, sig:

[PATCH 1/2] powerpc/mm: Assume first cpu is boot_cpuid not 0

2010-08-31 Thread Matthew McClintock
arch/powerpc/mm/mmu_context_nohash.c assumes the boot cpu will always have smp_processor_id() == 0. This patch fixes that assumption Signed-off-by: Matthew McClintock --- arch/powerpc/mm/mmu_context_nohash.c |6 -- 1 files changed, 4 insertions(+), 2 deletions(-) diff --git a/arch/power

[PATCH 2/2] powerpc/fsl_booke: Add support to boot from core other than 0

2010-08-31 Thread Matthew McClintock
First we check to see if we are the first core booting up. This is accomplished by comparing the boot_cpuid with -1, if it is we assume this is the first core coming up. Secondly, we need to update the initial thread info structure to reflect the actual cpu we are running on otherwise smp_processo

[PATCH v2] powerpc/fsl_soc: Search all global-utilities nodes for rstccr

2010-08-31 Thread Matthew McClintock
The first global-utilities node might not contain the rstcr property, so we should search all the nodes Signed-off-by: Matthew McClintock --- -Changed KERN_EMERG to KERN_ERR -Break if we do not find rstcr mapped -Restore of_put_node that was dropped arch/powerpc/sysdev/fsl_soc.c | 20

Re: [PATCH 0/8] v5 De-couple sysfs memory directories from memory sections

2010-08-31 Thread Anton Blanchard
Hi Nathan, > This set of patches de-couples the idea that there is a single > directory in sysfs for each memory section. The intent of the > patches is to reduce the number of sysfs directories created to > resolve a boot-time performance issue. On very large systems > boot time are getting ve

[git pull] Please pull powerpc.git merge branch

2010-08-31 Thread Kumar Gala
The following changes since commit 54a834043314c257210db2a9d59f8cc605571639: Michael Neuling (1): powerpc: Don't use kernel stack with translation off are available in the git repository at: git://git.kernel.org/pub/scm/linux/kernel/git/galak/powerpc.git ..BRANCH.NOT.VERIFIED.. Alex

Re: [PATCH] powerpc/85xx: Add P1021 PCI IDs and quirks

2010-08-31 Thread Kumar Gala
On Aug 8, 2010, at 9:03 AM, Anton Vorontsov wrote: > This is needed for proper PCI-E support on P1021 SoCs. > > Signed-off-by: Anton Vorontsov > --- > arch/powerpc/sysdev/fsl_pci.c |2 ++ > include/linux/pci_ids.h |2 ++ > 2 files changed, 4 insertions(+), 0 deletions(-) applied -

Re: [PATCH 5/7] arch/powerpc/sysdev/qe_lib/qe.c: Add of_node_put to avoid memory leak

2010-08-31 Thread Kumar Gala
On Aug 29, 2010, at 4:52 AM, Julia Lawall wrote: > Add a call to of_node_put in the error handling code following a call to > of_find_compatible_node. > > The semantic match that finds this problem is as follows: > (http://coccinelle.lip6.fr/) > > // > @r exists@ > local idexpression x; > expr

Re: [PATCH] arch/powerpc/platforms/83xx/mpc837x_mds.c: Add missing iounmap

2010-08-31 Thread Kumar Gala
On Aug 29, 2010, at 2:47 PM, Julia Lawall wrote: > The function of_iomap returns the result of calling ioremap, so iounmap > should be called on the result in the error handling code, as done in the > normal exit of the function. > > The sematic match that finds this problem is as follows: > (ht

Re: [PATCH] powerpc/85xx: Fix compile issue with p1022_ds due to lmb rename to memblock

2010-08-31 Thread Kumar Gala
On Aug 31, 2010, at 11:42 AM, Kumar Gala wrote: > arch/powerpc/platforms/85xx/p1022_ds.c:22:23: error: linux/lmb.h: No such > file or directory > arch/powerpc/platforms/85xx/p1022_ds.c: In function 'p1022_ds_setup_arch': > arch/powerpc/platforms/85xx/p1022_ds.c:100: error: implicit declaration o

Re: [PATCH v2 1/4] fsl_rio: fix compile errors

2010-08-31 Thread Kumar Gala
On Jun 18, 2010, at 1:24 AM, Li Yang wrote: > Fixes the following compile problem on E500 platforms: > arch/powerpc/sysdev/fsl_rio.c: In function 'fsl_rio_mcheck_exception': > arch/powerpc/sysdev/fsl_rio.c:248: error: 'MCSR_MASK' undeclared (first use > in this function) > > Also fixes the comp

Re: [PATCH 3/3] PPC: Fix compilation of mpc85xx_mds.c

2010-08-31 Thread Kumar Gala
On Aug 30, 2010, at 9:15 PM, Alexander Graf wrote: > Commit 99d8238f berobbed the for_each loop of its iterator! Let's be > nice and give it back, so it compiles for us. > > CC: Anton Vorontsov > Signed-off-by: Alexander Graf > --- > arch/powerpc/platforms/85xx/mpc85xx_mds.c |1 + > 1 files

Re: [PATCH 2/3] PPC: Fix compilation of fsl_rio.c

2010-08-31 Thread Kumar Gala
On Aug 31, 2010, at 1:10 PM, Scott Wood wrote: > On Tue, 31 Aug 2010 04:15:21 +0200 > Alexander Graf wrote: > >> Commit a52c8f52 introduced machine check magic for the RapidIO chip. >> Unfortunately it was so magical that it used constants that aren't even >> defined! >> >> This patch bluntly

Re: [PATCH 0/8] v5 De-couple sysfs memory directories from memory sections

2010-08-31 Thread Dave Hansen
On Mon, 2010-08-16 at 09:34 -0500, Nathan Fontenot wrote: > > It's not an unresolvable issue, as this is a must-fix problem. But you > > should tell us what your proposal is to prevent breakage of existing > > installations. A Kconfig option would be good, but a boot-time kernel > > command line

Re: [PATCH 2/3] PPC: Fix compilation of fsl_rio.c

2010-08-31 Thread Scott Wood
On Tue, 31 Aug 2010 04:15:21 +0200 Alexander Graf wrote: > Commit a52c8f52 introduced machine check magic for the RapidIO chip. > Unfortunately it was so magical that it used constants that aren't even > defined! > > This patch bluntly comments out the broken constant's usage. This > probably me

Re: [PATCH 1/7] drivers/macintosh/via-pmu-led.c: Add of_node_put to avoid memory leak

2010-08-31 Thread walter harms
Julia Lawall schrieb: > Add a call to of_node_put in the error handling code following a call to > of_find_node_by_path. > > The semantic match that finds this problem is as follows: > (http://coccinelle.lip6.fr/) > > // > @r exists@ > local idexpression x; > expression E,E1; > statement S; >

Re: [PATCH] powerpc: mtmsrd not defined

2010-08-31 Thread Sean MacLennan
On Tue, 31 Aug 2010 11:17:17 -0500 Kumar Gala wrote: > Can we add proper CONFIG_PPC_FPU into this file. If nobody beats me to it I can try this evening. Cheers, Sean ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozla

Re: [PATCH] gpiolib: Add 'struct gpio_chip' forward declaration for !GPIOLIB case

2010-08-31 Thread Anton Vorontsov
On Tue, Aug 31, 2010 at 10:44:14AM -0600, Grant Likely wrote: > On Tue, Aug 31, 2010 at 2:37 AM, Anton Vorontsov > wrote: > > On Tue, Aug 31, 2010 at 02:03:44AM -0600, Grant Likely wrote: > >> On Tue, Aug 24, 2010 at 01:26:23PM +0400, Anton Vorontsov wrote: > >> > With CONFIG_GPIOLIB=n, the 'stru

Re: [PATCH] powerpc/fsl_soc: Search all global-utilities nodes for rstccr

2010-08-31 Thread Timur Tabi
On Tue, Aug 31, 2010 at 11:26 AM, Matthew McClintock wrote: >> I'm not sure KERN_EMERG is warranted for this kind of error. > > I'm not sure either - I left it as it was before. My vote is to change it to KERN_ERR, but it's your call. >> So if a node has an fsl,rstcr property, but the of_iomap(

Re: [PATCH] gpiolib: Add 'struct gpio_chip' forward declaration for !GPIOLIB case

2010-08-31 Thread Grant Likely
On Tue, Aug 31, 2010 at 2:37 AM, Anton Vorontsov wrote: > On Tue, Aug 31, 2010 at 02:03:44AM -0600, Grant Likely wrote: >> On Tue, Aug 24, 2010 at 01:26:23PM +0400, Anton Vorontsov wrote: >> > With CONFIG_GPIOLIB=n, the 'struct gpio_chip' is not declared, >> > so the following pops up on PowerPC:

[PATCH] powerpc/85xx: Fix compile issue with p1022_ds due to lmb rename to memblock

2010-08-31 Thread Kumar Gala
arch/powerpc/platforms/85xx/p1022_ds.c:22:23: error: linux/lmb.h: No such file or directory arch/powerpc/platforms/85xx/p1022_ds.c: In function 'p1022_ds_setup_arch': arch/powerpc/platforms/85xx/p1022_ds.c:100: error: implicit declaration of function 'memblock_end_of_DRAM' arch/powerpc/platforms/

Re: [PATCH] powerpc/fsl_soc: Search all global-utilities nodes for rstccr

2010-08-31 Thread Matthew McClintock
On Aug 28, 2010, at 5:34 PM, Timur Tabi wrote: >> wrote: > >> + >> + for_each_node_by_name(np, "global-utilities") { >> + if ((of_get_property(np, "fsl,has-rstcr", NULL))) { >> + rstcr = of_iomap(np, 0) + 0xb0; >> + if (!rstcr) >>

Re: [PATCH 1/7] drivers/macintosh/via-pmu-led.c: Add of_node_put to avoid memory leak

2010-08-31 Thread Grant Likely
On Tue, Aug 31, 2010 at 10:16 AM, Vasiliy Kulikov wrote: > On Tue, Aug 31, 2010 at 18:08 +0200, Julia Lawall wrote: >> On Tue, 31 Aug 2010, walter harms wrote: >> > >   if (strncmp(model, "PowerBook", strlen("PowerBook")) != 0 && >> > >       strncmp(model, "iBook", strlen("iBook")) != 0 && >> > >

Re: [PATCH] powerpc: mtmsrd not defined

2010-08-31 Thread Kumar Gala
On Aug 22, 2010, at 5:48 PM, Sean MacLennan wrote: > On Mon, 23 Aug 2010 08:34:54 +1000 > Benjamin Herrenschmidt wrote: > >> I'd rather have a macro somewhere in ppc_asm.h (MTMSR ?) that does the >> right thing. We might even already have one... > > We do here is a new, improved patch. >

Re: [PATCH 1/7] drivers/macintosh/via-pmu-led.c: Add of_node_put to avoid memory leak

2010-08-31 Thread Vasiliy Kulikov
On Tue, Aug 31, 2010 at 18:08 +0200, Julia Lawall wrote: > On Tue, 31 Aug 2010, walter harms wrote: > > > > > > > Julia Lawall schrieb: > > > Add a call to of_node_put in the error handling code following a call to > > > of_find_node_by_path. [...] > > > --- a/drivers/macintosh/via-pmu-led.c > >

Re: [PATCH 1/7] drivers/macintosh/via-pmu-led.c: Add of_node_put to avoid memory leak

2010-08-31 Thread Grant Likely
On Tue, Aug 31, 2010 at 06:08:19PM +0200, Julia Lawall wrote: > On Tue, 31 Aug 2010, walter harms wrote: > > > @@ -92,8 +92,10 @@ static int __init via_pmu_led_init(void) > > > if (dt == NULL) > > > return -ENODEV; > > > model = of_get_property(dt, "model", NULL); > > > - if (model ==

Re: [PATCH 1/7] drivers/macintosh/via-pmu-led.c: Add of_node_put to avoid memory leak

2010-08-31 Thread Julia Lawall
On Tue, 31 Aug 2010, walter harms wrote: > > > Julia Lawall schrieb: > > Add a call to of_node_put in the error handling code following a call to > > of_find_node_by_path. > > > > The semantic match that finds this problem is as follows: > > (http://coccinelle.lip6.fr/) > > > > // > > @r exis

[PATCH 4/4] arch/powerpc/platforms/chrp/nvram.c: Add of_node_put to avoid memory leak

2010-08-31 Thread Julia Lawall
Add a call to of_node_put in the error handling code following a call to of_find_node_by_type. The semantic match that finds this problem is as follows: (http://coccinelle.lip6.fr/) // @r exists@ local idexpression x; expression E,E1,E2; statement S; @@ *x = (of_find_node_by_path |of_find_node

[PATCH 1/4] drivers/serial/ucc_uart.c: Add of_node_put to avoid memory leak

2010-08-31 Thread Julia Lawall
Add a call to of_node_put in the error handling code following a call to of_find_compatible_node or of_find_node_by_type. This patch also substantially reorganizes the error handling code in the function, to that it is possible first to jump to code that frees qe_port and then to jump to code that

Re: [PATCH] ucc_geth: fix ethtool set ring param bug

2010-08-31 Thread Ben Hutchings
On Tue, 2010-08-31 at 23:16 +0800, Liang Li wrote: > On Tue, Aug 31, 2010 at 03:41:22PM +0100, Ben Hutchings wrote: > > On Mon, 2010-08-30 at 22:47 +0800, Liang Li wrote: > > > It's common sense that when we should do change to driver ring > > > desc/buffer etc only after 'stop/shutdown' the device

Re: [PATCH] ucc_geth: fix ethtool set ring param bug

2010-08-31 Thread Liang Li
On Tue, Aug 31, 2010 at 03:41:22PM +0100, Ben Hutchings wrote: > On Mon, 2010-08-30 at 22:47 +0800, Liang Li wrote: > > It's common sense that when we should do change to driver ring > > desc/buffer etc only after 'stop/shutdown' the device. When we > > do change while devices/driver is running, ke

Re: [PATCH] ucc_geth: fix ethtool set ring param bug

2010-08-31 Thread Ben Hutchings
On Mon, 2010-08-30 at 22:47 +0800, Liang Li wrote: > It's common sense that when we should do change to driver ring > desc/buffer etc only after 'stop/shutdown' the device. When we > do change while devices/driver is running, kernel oops occur: [...] > diff --git a/drivers/net/ucc_geth_ethtool.c b/

SPI driver for MPC837xERDB

2010-08-31 Thread Ravi Gupta
Hi all, I am new to linux device driver development. I have to develop a SPI driver for MPC8377 processor based board. Right now I don't have a that board ready(but I have the MPC837xERDB with me), so I was thinking of developing and testing it on the RDB. But in MPC837xERDB, I don't have an SPI

[PATCH 2/2 v2] powerpc, pseries: Re-enable dispatch trace log userspace interface

2010-08-31 Thread Paul Mackerras
Since the cpu accounting code uses the hypervisor dispatch trace log now when CONFIG_VIRT_CPU_ACCOUNTING = y, the previous commit disabled access to it via files in the /sys/kernel/debug/powerpc/dtl/ directory in that case. This restores those files. To do this, we now have a hook that the cpu ac

[PATCH] powerpc/512x: fix clk_get() return value

2010-08-31 Thread Akinobu Mita
clk_get() should return an ERR_PTR value on error, not NULL. Signed-off-by: Akinobu Mita Cc: Grant Likely Cc: linuxppc-dev@lists.ozlabs.org --- arch/powerpc/platforms/512x/clock.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/arch/powerpc/platforms/512x/clock.c b/ar

Re: [PATCH] gpiolib: Add 'struct gpio_chip' forward declaration for !GPIOLIB case

2010-08-31 Thread Anton Vorontsov
On Tue, Aug 31, 2010 at 02:03:44AM -0600, Grant Likely wrote: > On Tue, Aug 24, 2010 at 01:26:23PM +0400, Anton Vorontsov wrote: > > With CONFIG_GPIOLIB=n, the 'struct gpio_chip' is not declared, > > so the following pops up on PowerPC: > > > > cc1: warnings being treated as errors > > In file

Re: [PATCH] gpiolib: Add 'struct gpio_chip' forward declaration for !GPIOLIB case

2010-08-31 Thread Grant Likely
On Tue, Aug 24, 2010 at 01:26:23PM +0400, Anton Vorontsov wrote: > With CONFIG_GPIOLIB=n, the 'struct gpio_chip' is not declared, > so the following pops up on PowerPC: > > cc1: warnings being treated as errors > In file included from arch/powerpc/platforms/52xx/mpc52xx_common.c:19: > includ

Re: [PATCH][RFC] preempt_count corruption across H_CEDE call with CONFIG_PREEMPT on pseries

2010-08-31 Thread Darren Hart
On 08/19/2010 08:58 AM, Ankita Garg wrote: > Hi Darren, > > On Thu, Jul 22, 2010 at 11:24:13AM -0700, Darren Hart wrote: >> >> With some instrumentation we were able to determine that the >> preempt_count() appears to change across the extended_cede_processor() >> call. Specifically across the pl