[PATCH] ppc, 83xx: rename and update kmeter1

2011-03-10 Thread Holger Brunck
Beside the MPC 8360 based board kmeter1 other km83xx boards from keymile will follow. Therefore the board specific naming kmeter1 for functions and files were replaced with km83xx. Additionally some updates were made: - update defconfig for 2.6.38 - rework flash partitioning in dts file

RE: [PATCH] driver/FSL SATA: Update RX_WATER_MARK for TRANSCFG

2011-03-10 Thread Kushwaha Prabhakar-B32579
Hi Jeff, I am not finding any comments on this. Could you please ACK this patch so that it can be applied in external list. --Prabhakar > -Original Message- > From: Kushwaha Prabhakar-B32579 > Sent: Monday, March 07, 2011 10:00 AM > To: linux-...@vger.kernel.org > Cc: jgar...@pobox.com

Re: [PATCH v4 2/2] powerpc: make MPIC honor the "pic-no-reset" device tree property

2011-03-10 Thread Benjamin Herrenschmidt
On Thu, 2011-03-10 at 11:23 -0600, Meador Inge wrote: > AFAIK, we can't rely on 'set_affinity' always being called. I don't > think it is called at all when !defined(CONFIG_SMP) and if it was, > then that would be an error: > > /* include/linux/irq.h */ > > #else /* CONFIG_SMP *

Re: [PATCH v4 2/2] powerpc: make MPIC honor the "pic-no-reset" device tree property

2011-03-10 Thread Benjamin Herrenschmidt
On Thu, 2011-03-10 at 11:23 -0600, Meador Inge wrote: > I agree. I shouldn't have cached that. We should probably introduce a > helper function to get the cpuid, though. The: > > unsigned int cpu = 0; > > if (mpic->flags & MPIC_PRIMARY) > cpu = hard_smp_process

Re: fsl_udc_core not initializing properly?

2011-03-10 Thread Matthew L. Creech
On Sat, Feb 19, 2011 at 1:01 PM, Matthew L. Creech wrote: > > Yes, it's there.  Here's the DTS entry in case anything else sticks out: > >                usb@23000 { >                        compatible = "fsl-usb2-dr"; >                        reg = <0x23000 0x1000>; >                        #addr

Re: [PATCH 0/5] make *_gate_vma accept mm_struct instead of task_struct

2011-03-10 Thread H. Peter Anvin
TIF_IA32 is set during the execution of a 32-bit system call - so touched on each compat system call. Is this the actual flag you want? A 32-bit address space flag is different from TIF_IA32. -- Sent from my mobile phone. Please pardon any lack of formatting. Stephen Wilson wrote: On Thu, Mar

Re: [PATCH 0/5] make *_gate_vma accept mm_struct instead of task_struct II

2011-03-10 Thread H. Peter Anvin
Sorry... I confused them too. It's TS_COMPAT which is problematic. -- Sent from my mobile phone. Please pardon any lack of formatting. Stephen Wilson wrote: On Thu, Mar 10, 2011 at 08:38:09AM -0800, Andi Kleen wrote: > On Thu, Mar 10, 2011 at 08:00:32AM -0800, Andi Kleen wrote: > > On Tue, Mar

Re: [PATCH v4 2/2] powerpc: make MPIC honor the "pic-no-reset" device tree property

2011-03-10 Thread Meador Inge
On 03/01/2011 09:22 PM, Benjamin Herrenschmidt wrote: diff --git a/arch/powerpc/include/asm/mpic.h b/arch/powerpc/include/asm/mpic.h index e000cce..7e1be12 100644 --- a/arch/powerpc/include/asm/mpic.h +++ b/arch/powerpc/include/asm/mpic.h @@ -325,6 +325,8 @@ struct mpic #ifdef CONFIG_PM

Re: [PATCH 0/5] make *_gate_vma accept mm_struct instead of task_struct II

2011-03-10 Thread Andi Kleen
On Thu, Mar 10, 2011 at 11:54:14AM -0500, Stephen Wilson wrote: > > On Thu, Mar 10, 2011 at 08:38:09AM -0800, Andi Kleen wrote: > > On Thu, Mar 10, 2011 at 08:00:32AM -0800, Andi Kleen wrote: > > > On Tue, Mar 08, 2011 at 07:31:56PM -0500, Stephen Wilson wrote: > > > > The only architecture this c

Re: [PATCH 0/5] make *_gate_vma accept mm_struct instead of task_struct II

2011-03-10 Thread Stephen Wilson
On Thu, Mar 10, 2011 at 08:38:09AM -0800, Andi Kleen wrote: > On Thu, Mar 10, 2011 at 08:00:32AM -0800, Andi Kleen wrote: > > On Tue, Mar 08, 2011 at 07:31:56PM -0500, Stephen Wilson wrote: > > > The only architecture this change impacts in any significant way is > > > x86_64. > > > The principle

Re: [PATCH 0/5] make *_gate_vma accept mm_struct instead of task_struct

2011-03-10 Thread Stephen Wilson
On Thu, Mar 10, 2011 at 08:00:32AM -0800, Andi Kleen wrote: > On Tue, Mar 08, 2011 at 07:31:56PM -0500, Stephen Wilson wrote: > > > > Morally, the question of whether an address lies in a gate vma should be > > asked > > with respect to an mm, not a particular task. > > > > Practically, droppin

Re: [PATCH 0/5] make *_gate_vma accept mm_struct instead of task_struct II

2011-03-10 Thread Andi Kleen
On Thu, Mar 10, 2011 at 08:00:32AM -0800, Andi Kleen wrote: > On Tue, Mar 08, 2011 at 07:31:56PM -0500, Stephen Wilson wrote: > > > > Morally, the question of whether an address lies in a gate vma should be > > asked > > with respect to an mm, not a particular task. > > > > Practically, dropping

Re: [PATCH 0/5] make *_gate_vma accept mm_struct instead of task_struct

2011-03-10 Thread Andi Kleen
On Tue, Mar 08, 2011 at 07:31:56PM -0500, Stephen Wilson wrote: > > Morally, the question of whether an address lies in a gate vma should be asked > with respect to an mm, not a particular task. > > Practically, dropping the dependency on task_struct will help make current and > future operations

Re: [BUG] rebuild_sched_domains considered dangerous

2011-03-10 Thread Peter Zijlstra
On Wed, 2011-03-09 at 14:01 +0100, Peter Zijlstra wrote: > On Wed, 2011-03-09 at 11:19 +0100, Peter Zijlstra wrote: > > No, the domain stuff is good, we allocate new domains and have a > > synchronize_sched() between us installing the new ones and freeing the > > old ones. > > Gah, if only.. OK,

[PATCH] ppc, 82xx: rename and update mgcoge board support

2011-03-10 Thread Holger Brunck
The mgcoge board from keymile is now base for some other similar boards. Therefore the board specific name mgcoge was renamed to a generic name km82xx. Additionally some enhancements were made: - rework partition table in dts file - add cpm2_pio_c gpio controller in dts file

RE: [rtc-linux] [PATCH] RTC driver(Linux) for PT7C4338 chip.

2011-03-10 Thread Jain Priyanka-B32167
Hi Wolfram, > -Original Message- > From: Wolfram Sang [mailto:w.s...@pengutronix.de] > Sent: Thursday, March 10, 2011 2:24 PM > To: Jain Priyanka-B32167 > Cc: rtc-li...@googlegroups.com; linuxppc-dev@lists.ozlabs.org; > a.zu...@towertech.it; p_gortma...@yahoo.com; a...@linux-foundation.o

Re: [rtc-linux] [PATCH] RTC driver(Linux) for PT7C4338 chip.

2011-03-10 Thread Wolfram Sang
Hi Priyanka, > Though register-set looks identical but features were different. Can you tell what exactly is different? > And also manufacturer is different. That does not matter. If you look at ds_type, there are already different manufacturers. They will be correctly distinguished by i2c_devi

Re: [PATCH 01/18] powerpc: Make decrementer interrupt robust against offlined CPUs

2011-03-10 Thread Michael Ellerman
On Tue, 2011-03-08 at 17:37 +1100, Benjamin Herrenschmidt wrote: > With some implementations, it is possible that a timer interrupt > occurs every few seconds on an offline CPU. In this case, just > re-arm the decrementer and return immediately > > Signed-off-by: Benjamin Herrenschmidt > --- > a