Re: [PATCH] atomic: add *_dec_not_zero

2011-05-03 Thread David Miller
From: Sven Eckelmann Date: Tue, 3 May 2011 23:30:35 +0200 > Introduce an *_dec_not_zero operation. Make this a special case of > *_add_unless because batman-adv uses atomic_dec_not_zero in different > places like re-broadcast queue or aggregation queue management. There > are other non-final pa

Re: [PATCH 1/3] [PATCH 1/3]powerpc/eeh: Propagate needs_freset flag to device at PE

2011-05-03 Thread Benjamin Herrenschmidt
On Fri, 2011-04-22 at 12:59 -0700, Richard A Lary wrote: > From: Richard A Lary > > For multifunction adapters with a PCI bridge or switch as the device > at the Partitionable Endpoint(PE), if one or more devices below PE > sets dev->needs_freset, that value will be set for the PE device. >

Re: [PATCH] powerpc: Fix xmon ml/mz commands to work with 64-bit values

2011-05-03 Thread Benjamin Herrenschmidt
On Wed, 2011-05-04 at 14:43 +1000, Benjamin Herrenschmidt wrote: > On Fri, 2011-04-08 at 08:18 -0400, Josh Boyer wrote: > > The ml and and mz commands in xmon currently only work on 32-bit values. > > This leads to odd issues when trying to use them on a ppc64 machine. If > > one specified 64-bit

Re: Read/write BCSR registers of PPC460EX

2011-05-03 Thread Benjamin Herrenschmidt
On Mon, 2011-05-02 at 15:42 +0200, Stefan Roese wrote: > > Thats a 64bit address, so you need this: > > static unsigned long long mem_addr = 0x4E100ULL; > > You should have seen a compilation warning about this too. No, he should use the device-tree :-) Cheers, Ben. ___

Re: Read/write BCSR registers of PPC460EX

2011-05-03 Thread Benjamin Herrenschmidt
On Mon, 2011-05-02 at 08:40 -0400, Josh Boyer wrote: > Aside from minor things like using unsigned int instead of unsigned > long, the code looks correct. The thing to check is if you are > ioremapping the right physical address, and making sure you're reading > a > proper location. Which is why

Re: [PATCH 0/1] ppc4xx: Fix PCIe scanning for the 460SX

2011-05-03 Thread Benjamin Herrenschmidt
On Sat, 2011-04-30 at 06:37 +1000, Benjamin Herrenschmidt wrote: > On Fri, 2011-04-29 at 12:02 -0500, Ayman El-Khashab wrote: > > On Tue, Apr 12, 2011 at 07:09:49PM -0700, Tirumala Marri wrote: > > > You originally submitted the support for 460ex. Can you chime in (and > > > review Ayman patch) ple

[PATCH 2/2] powerpc, mpc5200: update mpc5200_defconfig to fit for charon board.

2011-05-03 Thread Heiko Schocher
Add: - CONFIG_MTD_PLATRAM=y (selects CONFIG_MTD_RAM, so this is removed) - CONFIG_FIXED_PHY=y - CONFIG_SENSORS_LM80=y - CONFIG_FB_FOREIGN_ENDIAN=y - CONFIG_FB_SM501=m - CONFIG_RTC_DRV_DS1374=y also to the mpc5200_defconfig, as Grant suggested here: http://lists.ozlabs.org/pipermail/linuxppc-dev

[PATCH 1/2] powerpc, mpc52xx: update defconfig

2011-05-03 Thread Heiko Schocher
Did following steps: make mpc5200_defconfig make savedefconfig cp defconfig arch/powerpc/configs/mpc5200_defconfig Signed-off-by: Heiko Schocher cc: Grant Likely cc: Wolfgang Denk --- based against: git://git.secretlab.ca/git/linux-2.6 Grant: Don;t know, if this patch is needed, but with it,

Re: [PATCH] atomic: add *_dec_not_zero

2011-05-03 Thread Mike Frysinger
On Tue, May 3, 2011 at 17:30, Sven Eckelmann wrote: > Introduce an *_dec_not_zero operation.  Make this a special case of > *_add_unless because batman-adv uses atomic_dec_not_zero in different > places like re-broadcast queue or aggregation queue management. There > are other non-final patches whi

Re: [PATCH] powerpc: Fix xmon ml/mz commands to work with 64-bit values

2011-05-03 Thread Benjamin Herrenschmidt
On Fri, 2011-04-08 at 08:18 -0400, Josh Boyer wrote: > The ml and and mz commands in xmon currently only work on 32-bit values. > This leads to odd issues when trying to use them on a ppc64 machine. If > one specified 64-bit addresses to mz, it would loop on the same output > indefinitely. The ml

Re: [PATCH 0/2] powerpc/pseries: Reworked support for IO event interrupts

2011-05-03 Thread Benjamin Herrenschmidt
On Wed, 2011-05-04 at 14:28 +1000, Benjamin Herrenschmidt wrote: > Hi Frank ! > > There were several issues with your patch. Some were nasty bugs such > as kmalloc(...GFP_KERNEL) at interrupt time, or taking the rtas buffer > lock from an interrupt, others simply the code being ugly. > > I've rem

[PATCH 2/2] powerpc/pseries: Add support for IO event interrupts

2011-05-03 Thread Benjamin Herrenschmidt
From: Tseng-Hui (Frank) Lin This patch adds support for handling IO Event interrupts which come through at the /event-sources/ibm,io-events device tree node. The interrupts come through ibm,io-events device tree node are generated by the firmware to report IO events. The firmware uses the same i

[PATCH 0/2] powerpc/pseries: Reworked support for IO event interrupts

2011-05-03 Thread Benjamin Herrenschmidt
Hi Frank ! There were several issues with your patch. Some were nasty bugs such as kmalloc(...GFP_KERNEL) at interrupt time, or taking the rtas buffer lock from an interrupt, others simply the code being ugly. I've removed the "generic" event log parsing as it's not useful at this point and simpl

[PATCH 1/2] powerpc/pseries: Add RTAS event log v6 definition

2011-05-03 Thread Benjamin Herrenschmidt
From: Tseng-Hui (Frank) Lin This patch adds definitions of non-IBM specific v6 extended log definitions to rtas.h. Signed-off-by: Tseng-Hui (Frank) Lin Signed-off-by: Benjamin Herrenschmidt --- arch/powerpc/include/asm/rtas.h | 45 ++- 1 files changed, 44

[PATCH] powerpc: Rename slb0_limit() to safe_stack_limit() and add Book3E support

2011-05-03 Thread Benjamin Herrenschmidt
slb0_limit() wasn't a very descriptive name. This changes it along with a comment explaining what it's used for, and provides a 64-bit BookE implementation. Signed-off-by: Benjamin Herrenschmidt --- diff --git a/arch/powerpc/kernel/setup_64.c b/arch/powerpc/kernel/setup_64.c index 959c63c..c2ec0

[PATCH] atomic: add *_dec_not_zero

2011-05-03 Thread Sven Eckelmann
Introduce an *_dec_not_zero operation. Make this a special case of *_add_unless because batman-adv uses atomic_dec_not_zero in different places like re-broadcast queue or aggregation queue management. There are other non-final patches which may also want to use this macro. Reported-by: David S. M

Re: [PATCH 2/2] powerpc: add support for MPIC message register API

2011-05-03 Thread Scott Wood
On Mon, 2 May 2011 09:03:53 -0700 Hollis Blanchard wrote: > On 05/01/2011 08:41 PM, Kushwaha Prabhakar-B32579 wrote: > >> Perhaps an allocator could be added in the same patchset that adds such a > >> user. > > Yaa. It can be done. Otherwise module has to query each message unit for > > its avai

Re: [PATCH v6 0/6] powerpc, 52xx: add charon board support

2011-05-03 Thread Grant Likely
On Tue, May 3, 2011 at 1:24 AM, Heiko Schocher wrote: > > Ok. Done, just one more question: > > Why you didn;t pick up the patches: > > - powerpc, 5200: add support for charon board >  (Got an Acked-by from Wolfram Sang) > - powerpc, video: add SM501 support for charon board. I did pick them up a

Bootp hangs

2011-05-03 Thread Guillaume Dargaud
Hello all, maybe a bit off topic, more network than kernel, but who knows... I've had problems booting a new design (ML405 derivative), so I reverted to the old tested one... and it won't boot either. The kernel is in flash and my bootloader puts it in RAM and runs it. The root filesystem is ob

Re: [PATCH] powerpc: Add Initiate Coprocessor Store Word (icswx) support

2011-05-03 Thread Benjamin Herrenschmidt
On Tue, 2011-05-03 at 16:55 +1000, Anton Blanchard wrote: > Hi Ben, > > > My only comment (sorry Anton :-) would have been that we could lazily > > allocate the spinlock on the first use_cop() ... or do we have that > > potentially called in the wrong context ? > > I worry what might happen in a

Re: [PATCH v6 0/6] powerpc, 52xx: add charon board support

2011-05-03 Thread Heiko Schocher
Hello Grant, Grant Likely wrote: > On Mon, May 2, 2011 at 11:17 PM, Heiko Schocher wrote: >> Hello Grant, >> >> Grant Likely wrote: >>> On Tue, Mar 22, 2011 at 09:27:26AM +0100, Heiko Schocher wrote: cc: Wolfram Sang cc: Grant Likely cc: Benjamin Herrenschmidt cc: linux-fb.