Re: [PATCH 00/38] MMC updates, plus CuBox-i WiFi support

2014-04-25 Thread Russell King - ARM Linux
On Thu, Apr 24, 2014 at 01:13:05PM +0200, Ulf Hansson wrote: On 24 April 2014 12:57, Russell King - ARM Linux li...@arm.linux.org.uk wrote: This is nothing new or unexpected - it was last posted back in February, and I elected that it should be held off until after the last merge window.

[PATCH 05/13] IA64/PCI: Use new pci_is_bridge() to simplify code

2014-04-25 Thread Yijing Wang
Now we can use new pci_is_bridge() helper function to simplify code. Signed-off-by: Yijing Wang wangyij...@huawei.com --- arch/ia64/pci/fixup.c |4 +--- 1 files changed, 1 insertions(+), 3 deletions(-) diff --git a/arch/ia64/pci/fixup.c b/arch/ia64/pci/fixup.c index eee069a..1fe9aa5 100644

[PATCH 09/13] PCI, shpchp: Use new pci_is_bridge() to simplify code

2014-04-25 Thread Yijing Wang
Now we can use new pci_is_bridge() helper function to simplify code. Signed-off-by: Yijing Wang wangyij...@huawei.com --- drivers/pci/hotplug/shpchp_pci.c |3 +-- 1 files changed, 1 insertions(+), 2 deletions(-) diff --git a/drivers/pci/hotplug/shpchp_pci.c

[PATCH 11/13] PCI, acpiphp: Use new pci_is_bridge() to simplify code

2014-04-25 Thread Yijing Wang
Now we can use new pci_is_bridge() helper function to simplify code. Signed-off-by: Yijing Wang wangyij...@huawei.com --- drivers/pci/hotplug/acpiphp_glue.c |3 +-- 1 files changed, 1 insertions(+), 2 deletions(-) diff --git a/drivers/pci/hotplug/acpiphp_glue.c

[PATCH 06/13] powerpc/PCI: Use new pci_is_bridge() to simplify code

2014-04-25 Thread Yijing Wang
Now we can use new pci_is_bridge() helper function to simplify code. Signed-off-by: Yijing Wang wangyij...@huawei.com --- arch/powerpc/kernel/pci-hotplug.c |3 +-- arch/powerpc/kernel/pci_of_scan.c |3 +-- 2 files changed, 2 insertions(+), 4 deletions(-) diff --git

[PATCH 01/13] PCI: rename pci_is_bridge() to pci_has_subordinate()

2014-04-25 Thread Yijing Wang
pci_is_bridge() which seems to determine whether device is a bridge, returns true only when the subordinate bus exists. This confuses people. PCI device is a bridge means its header type(bit 0 through 6) is 0x1(PCI bridge) or 0x2(CardBus bridge). Rename the current pci_is_bridge() helper function

[PATCH 00/13] Refactor pci_is_brdige() to simplify code

2014-04-25 Thread Yijing Wang
This patchset rename the current pci_is_bridge() to pci_has_subordinate(), and introduce a new pci_is_bridge() which determine pci bridge by check dev-hdr_type. The new one is more accurate. PCIe Spec define the pci device is a bridge by the dev-hdr_type = 0x01 || 0x02. Yijing Wang (13): PCI:

[PATCH 04/13] x86/PCI: Use new pci_is_bridge() to simplify code

2014-04-25 Thread Yijing Wang
Now we can use new pci_is_bridge() helper function to simplify code. Signed-off-by: Yijing Wang wangyij...@huawei.com --- arch/x86/pci/fixup.c |4 +--- 1 files changed, 1 insertions(+), 3 deletions(-) diff --git a/arch/x86/pci/fixup.c b/arch/x86/pci/fixup.c index 94ae9ae..e5f000c 100644 ---

[PATCH 02/13] PCI: Introduce new pci_is_bridge() helper function

2014-04-25 Thread Yijing Wang
PCIe Spec define the PCI bridge is the PCI device which header type(bit 0 through 6) is 0x1(PCI bridge) or 0x2(CardBus bridge). Signed-off-by: Yijing Wang wangyij...@huawei.com --- include/linux/pci.h |6 ++ 1 files changed, 6 insertions(+), 0 deletions(-) diff --git

[PATCH 10/13] PCI, cpcihp: Use new pci_is_bridge() to simplify code

2014-04-25 Thread Yijing Wang
Now we can use new pci_is_bridge() helper function to simplify code. Signed-off-by: Yijing Wang wangyij...@huawei.com --- drivers/pci/hotplug/cpci_hotplug_pci.c |3 +-- 1 files changed, 1 insertions(+), 2 deletions(-) diff --git a/drivers/pci/hotplug/cpci_hotplug_pci.c

[PATCH 08/13] PCI, rpaphp: Use new pci_is_bridge() to simplify code

2014-04-25 Thread Yijing Wang
Now we can use new pci_is_bridge() helper function to simplify code. Signed-off-by: Yijing Wang wangyij...@huawei.com --- drivers/pci/hotplug/rpadlpar_core.c |3 +-- 1 files changed, 1 insertions(+), 2 deletions(-) diff --git a/drivers/pci/hotplug/rpadlpar_core.c

[PATCH 07/13] sparc/PCI: Use new pci_is_bridge() to simplify code

2014-04-25 Thread Yijing Wang
Now we can use new pci_is_bridge() helper function to simplify code. Signed-off-by: Yijing Wang wangyij...@huawei.com --- arch/sparc/kernel/pci.c |3 +-- 1 files changed, 1 insertions(+), 2 deletions(-) diff --git a/arch/sparc/kernel/pci.c b/arch/sparc/kernel/pci.c index 1555bbc..857ad77

[PATCH 12/13] PCI, pcmcia: Use new pci_is_bridge() to simplify code

2014-04-25 Thread Yijing Wang
Now we can use new pci_is_bridge() helper function to simplify code. Signed-off-by: Yijing Wang wangyij...@huawei.com --- drivers/pcmcia/cardbus.c |3 +-- 1 files changed, 1 insertions(+), 2 deletions(-) diff --git a/drivers/pcmcia/cardbus.c b/drivers/pcmcia/cardbus.c index 8bde619..4fe4cc4

[PATCH 03/13] PCI: Use new pci_is_bridge() to simplify code

2014-04-25 Thread Yijing Wang
Now we can use new pci_is_bridge() helper function to simplify code. Signed-off-by: Yijing Wang wangyij...@huawei.com --- drivers/pci/pci-acpi.c |8 +--- drivers/pci/probe.c |3 +-- drivers/pci/setup-bus.c |4 +--- 3 files changed, 3 insertions(+), 12 deletions(-) diff

[PATCH 13/13] PCI, pciehp: Use new pci_is_bridge() to simplify code

2014-04-25 Thread Yijing Wang
Now we can use new pci_is_bridge() helper function to simplify code. Signed-off-by: Yijing Wang wangyij...@huawei.com --- drivers/pci/hotplug/pciehp_pci.c |3 +-- 1 files changed, 1 insertions(+), 2 deletions(-) diff --git a/drivers/pci/hotplug/pciehp_pci.c

[RFC PATCH] Fix Oops in rtas_stop_self()

2014-04-25 Thread Li Zhong
When trying offline cpus, I noticed following Oops in rtas_stop_self(), and it seems caused by commit 41dd03a9. The Oops disappears after reverting this commit. After reading the code, I guess it might be caused by moving the rtas_args to stack. Still need some more time to read enter_rtas to

RE: [PATCH 00/13] Refactor pci_is_brdige() to simplify code

2014-04-25 Thread David Laight
From: Yijing Wang This patchset rename the current pci_is_bridge() to pci_has_subordinate(), and introduce a new pci_is_bridge() which determine pci bridge by check dev-hdr_type. The new one is more accurate. PCIe Spec define the pci device is a bridge by the dev-hdr_type = 0x01 || 0x02. That

Re: [PATCH 00/38] MMC updates, plus CuBox-i WiFi support

2014-04-25 Thread Ulf Hansson
On 25 April 2014 11:03, Russell King - ARM Linux li...@arm.linux.org.uk wrote: On Thu, Apr 24, 2014 at 01:13:05PM +0200, Ulf Hansson wrote: On 24 April 2014 12:57, Russell King - ARM Linux li...@arm.linux.org.uk wrote: This is nothing new or unexpected - it was last posted back in February,

Re: [PATCH 00/38] MMC updates, plus CuBox-i WiFi support

2014-04-25 Thread Russell King - ARM Linux
On Fri, Apr 25, 2014 at 01:18:28PM +0200, Ulf Hansson wrote: On 25 April 2014 11:03, Russell King - ARM Linux li...@arm.linux.org.uk wrote: On Thu, Apr 24, 2014 at 01:13:05PM +0200, Ulf Hansson wrote: On 24 April 2014 12:57, Russell King - ARM Linux li...@arm.linux.org.uk wrote: This

Re: [PATCH 00/38] MMC updates, plus CuBox-i WiFi support

2014-04-25 Thread Ulf Hansson
On 25 April 2014 13:20, Russell King - ARM Linux li...@arm.linux.org.uk wrote: On Fri, Apr 25, 2014 at 01:18:28PM +0200, Ulf Hansson wrote: On 25 April 2014 11:03, Russell King - ARM Linux li...@arm.linux.org.uk wrote: On Thu, Apr 24, 2014 at 01:13:05PM +0200, Ulf Hansson wrote: On 24

[PATCH 2/2] powerpc/powernv: Set memory_block_size_bytes to 256MB

2014-04-25 Thread Anton Blanchard
powerpc sets a low SECTION_SIZE_BITS to accomodate small pseries boxes. We default to 16MB memory blocks, and boxes with a lot of memory end up with enormous numbers of sysfs memory nodes. Set a more reasonable default for powernv of 256MB. Signed-off-by: Anton Blanchard an...@samba.org ---

[PATCH 1/2] powerpc: Allow ppc_md platform hook to override memory_block_size_bytes

2014-04-25 Thread Anton Blanchard
The pseries platform code unconditionally overrides memory_block_size_bytes regardless of the running platform. Create a ppc_md hook that so each platform can choose to do what it wants. Signed-off-by: Anton Blanchard an...@samba.org --- arch/powerpc/include/asm/machdep.h | 1 +

Re: [RFC PATCH] Fix Oops in rtas_stop_self()

2014-04-25 Thread Anton Blanchard
Hi, When trying offline cpus, I noticed following Oops in rtas_stop_self(), and it seems caused by commit 41dd03a9. The Oops disappears after reverting this commit. After reading the code, I guess it might be caused by moving the rtas_args to stack. Still need some more time to read

Re: [PATCH v4 2/8] cpufreq: Use cpufreq_for_each_* macros for frequency table iteration

2014-04-25 Thread Prabhakar Lad
Hi Stratos, Thanks for the patch. On Tue, Apr 22, 2014 at 4:30 AM, Stratos Karafotis strat...@semaphore.gr wrote: The cpufreq core now supports the cpufreq_for_each_entry and cpufreq_for_each_valid_entry macros helpers for iteration over the cpufreq_frequency_table, so use them. It should

[PATCH 22/32] mmc: sdhci: convert sdhci_set_uhs_signaling() into a library function

2014-04-25 Thread Russell King
Add sdhci_set_uhs_signaling() and always call the set_uhs_signaling method. This avoids quirks being added into sdhci_set_uhs_signaling(). Signed-off-by: Russell King rmk+ker...@arm.linux.org.uk --- drivers/mmc/host/sdhci-acpi.c | 2 ++ drivers/mmc/host/sdhci-bcm-kona.c | 1 +

Re: [PATCH v4 2/8] cpufreq: Use cpufreq_for_each_* macros for frequency table iteration

2014-04-25 Thread Stratos Karafotis
Hi Prabhakar, On 25/04/2014 03:31 μμ, Prabhakar Lad wrote: Hi Stratos, Thanks for the patch. On Tue, Apr 22, 2014 at 4:30 AM, Stratos Karafotis strat...@semaphore.gr wrote: The cpufreq core now supports the cpufreq_for_each_entry and cpufreq_for_each_valid_entry macros helpers for

Re: [PATCH 07/13] sparc/PCI: Use new pci_is_bridge() to simplify code

2014-04-25 Thread David Miller
From: Yijing Wang wangyij...@huawei.com Date: Fri, 25 Apr 2014 17:18:29 +0800 Now we can use new pci_is_bridge() helper function to simplify code. Signed-off-by: Yijing Wang wangyij...@huawei.com Acked-by: David S. Miller da...@davemloft.net ___

[PATCH v5 2/8] cpufreq: Use cpufreq_for_each_* macros for frequency table iteration

2014-04-25 Thread Stratos Karafotis
The cpufreq core now supports the cpufreq_for_each_entry and cpufreq_for_each_valid_entry macros helpers for iteration over the cpufreq_frequency_table, so use them. It should have no functional changes. Signed-off-by: Stratos Karafotis strat...@semaphore.gr --- drivers/cpufreq/acpi-cpufreq.c

Re: [PATCH v2 1/2] powerpc/pm: add api to get suspend state which is STANDBY or MEM

2014-04-25 Thread Scott Wood
On Thu, 2014-04-24 at 14:11 +0800, Dongsheng Wang wrote: From: Wang Dongsheng dongsheng.w...@freescale.com Add set_pm_suspend_state pm_suspend_state functions to set/get suspend state. When system going to sleep or deep sleep, devices can get the system suspend state(STANDBY/MEM) through

Re: [PATCH 2/3] powerpc, ptrace: Add new ptrace request macros for transactional memory

2014-04-25 Thread Pedro Alves
On 04/02/2014 08:02 AM, Anshuman Khandual wrote: This patch adds following new sets of ptrace request macros for transactional memory expanding the existing ptrace ABI on PowerPC. /* TM special purpose registers */ PTRACE_GETTM_SPRREGS PTRACE_SETTM_SPRREGS /* TM

Re: [PATCH 00/13] Refactor pci_is_brdige() to simplify code

2014-04-25 Thread Yijing Wang
On 2014/4/25 17:42, David Laight wrote: From: Yijing Wang This patchset rename the current pci_is_bridge() to pci_has_subordinate(), and introduce a new pci_is_bridge() which determine pci bridge by check dev-hdr_type. The new one is more accurate. PCIe Spec define the pci device is a bridge