[PATCH] powerpc/powernv: fix construction of opal PRD messages

2015-06-15 Thread Jeremy Kerr
We currently have a bug in the PRD code, where the contents of an incoming message (beyond the header) will be overwritten by the list item manipulations when adding to to the prd_msg_queue. This change reorders struct opal_prd_msg_queue_item, so that the message body doesn't overlap the

[PATCH V9 11/13] powerpc, perf: Change POWER8 PMU configuration to work with SW filters

2015-06-15 Thread Anshuman Khandual
The kernel now supports SW based branch filters for book3s systems with some specific requirements while dealing with HW supported branch filters in order to achieve overall OR semantics prevailing in perf branch stack sampling framework. This patch adapts the BHRB branch filter configuration to

RE: [RFC,v3 02/10] dpaa_eth: add support for DPAA Ethernet

2015-06-15 Thread Madalin-Cristian Bucur
-Original Message- From: Eric Dumazet [mailto:eric.duma...@gmail.com] On Wed, 2015-06-10 at 07:38 +, Madalin-Cristian Bucur wrote: Hi Eric, Can you please tell us if this change would be for the better? I was about to say yes to this request but checked and no other

[PATCH V9 08/13] powerpc, perf: Change the name of HW PMU branch filter tracking variable

2015-06-15 Thread Anshuman Khandual
This patch simply changes the name of the variable from 'bhrb_filter' to 'bhrb_hw_filter' in order to add one more variable which will track SW filters in generic powerpc book3s code which will be implemented in the subsequent patch. This patch does not change any functionality. Signed-off-by:

[PATCH V9 05/13] powerpc, perf: Change name type of 'pred' in power_pmu_bhrb_read

2015-06-15 Thread Anshuman Khandual
Branch record attributes 'mispred' and 'predicted' are single bit fields as defined in the perf ABI. Hence the data type of the field 'pred' used during BHRB processing should be changed from integer to bool. This patch also changes the name of the variable from 'pred' to 'mispred' making the

[PATCH V9 03/13] powerpc, perf: Replace last usage of get_cpu_var with this_cpu_ptr

2015-06-15 Thread Anshuman Khandual
The commit 69111bac42f5ce (powerpc: Replace __get_cpu_var uses) replaced all usage of get_cpu_var with this_cpu_ptr inside core perf event handling on powerpc. But it skipped one of them which is being replaced with this patch. Reported-by: Daniel Axtens d...@axtens.net Signed-off-by: Anshuman

[PATCH V9 06/13] powerpc, perf: Re organize BHRB processing

2015-06-15 Thread Anshuman Khandual
This patch cleans up some existing indentation problem in code and re organizes the BHRB processing code with an helper function named 'update_branch_entry' making it more readable. This patch does not change any functionality. Signed-off-by: Anshuman Khandual khand...@linux.vnet.ibm.com ---

[PATCH V9 12/13] powerpc, perf: Enable privilege mode SW branch filters

2015-06-15 Thread Anshuman Khandual
This patch enables privilege mode SW branch filters. Also modifies POWER8 PMU branch filter configuration so that the privilege mode branch filter implemented as part of base PMU event configuration is reflected in bhrb filter mask. As a result, the SW will skip and not try to process the

[PATCH V9 10/13] powerpc, perf: Enable SW filtering in branch stack sampling framework

2015-06-15 Thread Anshuman Khandual
This patch enables SW based post processing of BHRB captured branches to be able to meet more user defined branch filtration criteria in perf branch stack sampling framework. These changes increase the number of branch filters and their valid combinations on any powerpc64 server platform with BHRB

Re: Build regressions/improvements in v4.1-rc8

2015-06-15 Thread Geert Uytterhoeven
On Mon, Jun 15, 2015 at 12:56 PM, Geert Uytterhoeven ge...@linux-m68k.org wrote: JFYI, when comparing v4.1-rc8[1] to v4.1-rc7[3], the summaries are: - build errors: +10/-7 + /home/kisskb/slave/src/Documentation/prctl/disable-tsc-ctxt-sw-stress-test.c: error: impossible register constraint

RE: [RFC,v3 02/10] dpaa_eth: add support for DPAA Ethernet

2015-06-15 Thread Madalin-Cristian Bucur
-Original Message- From: Eric Dumazet [mailto:eric.duma...@gmail.com] On Wed, 2015-04-29 at 17:56 +0300, Madalin Bucur wrote: This introduces the Freescale Data Path Acceleration Architecture (DPAA) Ethernet driver (dpaa_eth) that builds upon the DPAA QMan, BMan, PAMU and FMan

[PATCH V9 13/13] selftests, powerpc: Add test for BHRB branch filters (HW SW)

2015-06-15 Thread Anshuman Khandual
This patch adds a test for verifying that all the branch stack sampling filters supported on powerpc work correctly. It also adds some assembly helper functions in this regard. This patch extends the generic event description to handle kernel mapped ring buffers. Signed-off-by: Anshuman Khandual

[PATCH V9 04/13] powerpc, perf: Restore privilege level filter support for BHRB

2015-06-15 Thread Anshuman Khandual
'commit 9de5cb0f6df8 (powerpc/perf: Add per-event excludes on Power8)' broke the PMU based BHRB privilege level filter. BHRB depends on the same MMCR0 bits for privilege level filter which was used to freeze all the PMCs as a group. Once we moved to individual event based privilege filters through

[PATCH V9 07/13] powerpc, perf: Re organize PMU branch filter processing on POWER8

2015-06-15 Thread Anshuman Khandual
This patch does some code re-arrangements to make it clear that kernel ignores any separate privilege level branch filter request and does not support any combinations of HW PMU branch filters. Signed-off-by: Anshuman Khandual khand...@linux.vnet.ibm.com --- arch/powerpc/perf/power8-pmu.c | 22

[PATCH V9 09/13] powerpc, lib: Add new branch analysis support functions

2015-06-15 Thread Anshuman Khandual
Generic powerpc branch analysis support added in the code patching library which will help the subsequent patch on SW based filtering of branch records in perf. Signed-off-by: Anshuman Khandual khand...@linux.vnet.ibm.com --- arch/powerpc/include/asm/code-patching.h | 15

[PATCH V9 00/13] powerpc, perf: Enable SW branch filters

2015-06-15 Thread Anshuman Khandual
This is the continuation (rebased and reworked) of the series posted at https://lkml.org/lkml/2014/5/5/153 (which is V6). I remember to have incremented the version count for the re-send of the first four patches of the series to Peter Z for generic review which got pulled in last year.

[PATCH V9 01/13] powerpc, perf: Drop the branch sample when 'from' cannot be fetched

2015-06-15 Thread Anshuman Khandual
BHRB (Branch History Rolling Buffer) is a rolling buffer. Hence we might end up in a situation where we have read one target address but when we try to read the next entry indicating the from address of the target address, the buffer just overflows. In this case, the captured from address will be

[PATCH V9 02/13] powerpc, perf: Change type of the bhrb_users variable

2015-06-15 Thread Anshuman Khandual
This patch just changes data type of bhrb_users variable from int to unsigned int because it never contains a negative value. Reported-by: Daniel Axtens d...@axtens.net Signed-off-by: Anshuman Khandual khand...@linux.vnet.ibm.com --- arch/powerpc/perf/core-book3s.c | 2 +- 1 file changed, 1

RE: [PATCH 08/12] fsl/fman: Add Frame Manager support

2015-06-15 Thread Liberman Igal
Hi Paul, Thank you very much for your feedback. I'm planning to address the issues you've raised in the next submission. Regards, Igal Liberman. -Original Message- From: Paul Bolle [mailto:pebo...@tiscali.nl] Sent: Thursday, June 11, 2015 12:38 PM To: Bucur Madalin-Cristian-B32716

Re: [RESEND PATCH V2 0/3] Allow user to request memory to be locked on page fault

2015-06-15 Thread Eric B Munson
On Thu, 11 Jun 2015, Andrew Morton wrote: On Thu, 11 Jun 2015 15:21:30 -0400 Eric B Munson emun...@akamai.com wrote: Ditto mlockall(MCL_ONFAULT) followed by munlock(). I'm not sure that even makes sense but the behaviour should be understood and tested. I have extended the

Re: [RFC,v3 02/10] dpaa_eth: add support for DPAA Ethernet

2015-06-15 Thread Eric Dumazet
On Mon, 2015-06-15 at 13:40 +, Madalin-Cristian Bucur wrote: -Original Message- From: Eric Dumazet [mailto:eric.duma...@gmail.com] On Wed, 2015-04-29 at 17:56 +0300, Madalin Bucur wrote: This introduces the Freescale Data Path Acceleration Architecture (DPAA) Ethernet

Re: [RESEND PATCH V2 0/3] Allow user to request memory to be locked on page fault

2015-06-15 Thread Eric B Munson
On Fri, 12 Jun 2015, Vlastimil Babka wrote: On 06/11/2015 09:34 PM, Andrew Morton wrote: On Thu, 11 Jun 2015 15:21:30 -0400 Eric B Munson emun...@akamai.com wrote: Ditto mlockall(MCL_ONFAULT) followed by munlock(). I'm not sure that even makes sense but the behaviour should be understood

Re: [RFC,v2,01/24] macintosh/nvram: Remove as unused

2015-06-15 Thread Michael Ellerman
On Sun, 2015-14-06 at 07:46:08 UTC, Finn Thain wrote: Signed-off-by: Finn Thain fth...@telegraphics.com.au Acked-by: Geert Uytterhoeven ge...@linux-m68k.org --- drivers/macintosh/nvram.c | 130 -- 1 file changed, 130 deletions(-) This seems

Re: [PATCH 08/12] fsl/fman: Add Frame Manager support

2015-06-15 Thread Scott Wood
On Mon, 2015-06-15 at 23:42 -0400, Bob Cochran wrote: On 06/10/2015 11:21 AM, Madalin Bucur wrote: +#define FM_QMI_NO_ECC_EXCEPTIONS /* P1 */ +#define FM_CSI_CFED_LIMIT /* P1 */ +#define FM_PEDANTIC_DMA/* P1 */ +#define

[RFC PATCH] perf/kvm: Guest Symbol Resolution for powerpc

2015-06-15 Thread Hemant Kumar
perf kvm {record|report} is used to record and report the performance profile of any workload on a guest. From the host, we can collect guest kernel statistics which is useful in finding out any contentions in guest kernel symbols for a certain workload. This feature is not available on powerpc

Re: [PATCH 08/12] fsl/fman: Add Frame Manager support

2015-06-15 Thread Bob Cochran
On 06/10/2015 11:21 AM, Madalin Bucur wrote: From: Igal Liberman igal.liber...@freescale.com Add Frame Manger Driver support. This patch adds The FMan configuration, initialization and runtime control routines. Signed-off-by: Igal Liberman igal.liber...@freescale.com ---

Re: [RFC v2 23/24] m68k/mac: Fix PRAM accessors

2015-06-15 Thread Finn Thain
On Mon, 15 Jun 2015, Geert Uytterhoeven wrote: Hi Finn, On Sun, Jun 14, 2015 at 9:46 AM, Finn Thain fth...@telegraphics.com.au wrote: --- linux.orig/arch/m68k/mac/misc.c 2015-06-14 17:46:02.0 +1000 +++ linux/arch/m68k/mac/misc.c 2015-06-14 17:46:03.0 +1000 @@

Re: [PATCH RESEND v4 1/3] kvm/powerpc: Export kvm exit reasons

2015-06-15 Thread Hemant Kumar
Hi Paul, On 06/15/2015 11:09 AM, Paul Mackerras wrote: On Mon, Jun 15, 2015 at 10:26:07AM +0530, Hemant Kumar wrote: To analyze the kvm exits with perf, we will need to map the exit codes with the exit reasons. Such a mapping exists today in trace_book3s.h. Currently its not exported to perf.

Re: [PATCH kernel] powerpc/iommu/ioda2: Enable compile with IOV=on and IOMMU_API=off

2015-06-15 Thread David Gibson
On Mon, Jun 15, 2015 at 05:49:59PM +1000, Alexey Kardashevskiy wrote: The pnv_pci_ioda2_unset_window() function is used to do the final cleanup of a DMA window being released: - via VFIO ioctl by the guest request; - via unplugging a virtual PCI function. However the function was under #ifdef

Re: [RFC PATCH] powerpc/numa: initialize distance lookup table from drconf path

2015-06-15 Thread Nikunj A Dadhania
Nikunj A Dadhania nik...@linux.vnet.ibm.com writes: Reworded commit log: From: Nikunj A Dadhania nik...@linux.vnet.ibm.com powerpc/numa: initialize distance lookup table from drconf path Ping ? Regards Nikunj ___ Linuxppc-dev mailing list

Re: [PATCH] powerpc/powernv: fix construction of opal PRD messages

2015-06-15 Thread Stewart Smith
Jeremy Kerr j...@ozlabs.org writes: We currently have a bug in the PRD code, where the contents of an incoming message (beyond the header) will be overwritten by the list item manipulations when adding to to the prd_msg_queue. This change reorders struct opal_prd_msg_queue_item, so that the

Re: [PATCH 0/2] Consolidate redundant register/stack access code

2015-06-15 Thread Kees Cook
On Mon, Jun 15, 2015 at 9:42 AM, David Long dave.l...@linaro.org wrote: From: David A. Long dave.l...@linaro.org Move duplicate and functionally equivalent code for accessing registers and stack (CONFIG_HAVE_REGS_AND_STACK_ACCESS_API) from arch subdirs into common kernel files. Note: Help

Re: [RFC v2 23/24] m68k/mac: Fix PRAM accessors

2015-06-15 Thread Geert Uytterhoeven
Hi Finn, On Sun, Jun 14, 2015 at 9:46 AM, Finn Thain fth...@telegraphics.com.au wrote: --- linux.orig/arch/m68k/mac/misc.c 2015-06-14 17:46:02.0 +1000 +++ linux/arch/m68k/mac/misc.c 2015-06-14 17:46:03.0 +1000 @@ -284,11 +287,31 @@ static void via_pram_command(int command

Re: [PATCH] cpufreq: qoriq: optimize the CPU frequency switching time

2015-06-15 Thread Rafael J. Wysocki
On Thursday, June 04, 2015 12:06:36 PM Viresh Kumar wrote: On 04-06-15, 14:25, yuantian.t...@freescale.com wrote: From: Tang Yuantian yuantian.t...@freescale.com Each time the CPU switches its frequency, the clock nodes in DTS are walked through to find proper clock source. This is

Re: [PATCH v4] powerpc/defconfig: new way of writing defconfig

2015-06-15 Thread Scott Wood
On Fri, 2015-06-12 at 21:52 -0500, Lijun Pan wrote: It is always a headache dealing with different defconfigs though they only differ in a few places. Hence we are proposing a new way of writing the defconfig: 1. Define a basic defconfig say mpc85xx_basic_defconfig 2. Spin off as much

Re: stable: Please include commit bb344ca5b90 (powerpc/mpc85xx: Add ranges to etsec2 nodes)

2015-06-15 Thread Zefan Li
On 2015/3/27 5:14, Scott Wood wrote: Commit bb344ca5b90df6 (powerpc/mpc85xx: Add ranges to etsec2 nodes) fixes a bug that was exposed by commit 746c9e9f92dd (of/base: Fix PowerPC address parsing hack). The latter commit was applied to stable trees, so the former should be as well. Queued

Re: [kernel] powerpc/powernv/ioda2: Add devices only from buses which belong to PE

2015-06-15 Thread Michael Ellerman
On Fri, 2015-12-06 at 06:19:17 UTC, Alexey Kardashevskiy wrote: The existing code puts all devices from a root PE to the same IOMMU group. However it is a possible situation when subordinate buses belong to separate PEs, in this case devices from these subordinate buses should be added to

Re: powerpc/powernv: Bump opal_init initcall priority

2015-06-15 Thread Michael Ellerman
On Mon, 2015-06-15 at 13:44 +1000, Alistair Popple wrote: On Fri, 12 Jun 2015 19:47:35 Michael Ellerman wrote: On Thu, 2015-11-06 at 09:25:29 UTC, Alistair Popple wrote: opal_init() is called via a machine_subsys_initcall(). Due to a hack in the eeh code the eeh driver is initialised with

[PATCH kernel] powerpc/iommu/ioda2: Enable compile with IOV=on and IOMMU_API=off

2015-06-15 Thread Alexey Kardashevskiy
The pnv_pci_ioda2_unset_window() function is used to do the final cleanup of a DMA window being released: - via VFIO ioctl by the guest request; - via unplugging a virtual PCI function. However the function was under #ifdef CONFIG_IOMMU_API and was missing. This moves the helper outside of

[PATCH 0/2] Consolidate redundant register/stack access code

2015-06-15 Thread David Long
From: David A. Long dave.l...@linaro.org Move duplicate and functionally equivalent code for accessing registers and stack (CONFIG_HAVE_REGS_AND_STACK_ACCESS_API) from arch subdirs into common kernel files. Note: Help regression testing s390, hexagon, and sh would be appreciated. Powerpc

[PATCH 1/2] Move the pt_regs_offset struct definition from arch to common include file

2015-06-15 Thread David Long
From: David A. Long dave.l...@linaro.org The pt_regs_offset structure is used for HAVE_REGS_AND_STACK_ACCESS_API feature and has identical definitions in four different arch ptrace.h include files. It seems unlikely that definition would ever need to be changed regardless of architecture so lets

[PATCH 2/2] Consolidate redundant register/stack access code

2015-06-15 Thread David Long
From: David A. Long dave.l...@linaro.org Several architectures have identical or functionally equivalent code implementing parts of the HAVE_REGS_AND_STACK_ACCESS_API feature. Move that code out of the architecture directories. Signed-off-by: David A. Long dave.l...@linaro.org ---

Re: [PATCH 0/2] Consolidate redundant register/stack access code

2015-06-15 Thread David Long
On 06/15/15 16:44, Kees Cook wrote: On Mon, Jun 15, 2015 at 9:42 AM, David Long dave.l...@linaro.org wrote: From: David A. Long dave.l...@linaro.org Move duplicate and functionally equivalent code for accessing registers and stack (CONFIG_HAVE_REGS_AND_STACK_ACCESS_API) from arch subdirs into