Re: [PATCH] powerpc/mm: Fixup wrong LPCR_VRMASD value

2016-12-16 Thread kbuild test robot
Hi Aneesh, [auto build test ERROR on powerpc/next] [also build test ERROR on v4.9 next-20161216] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url: https://github.com/0day-ci/linux/commits/Aneesh-Kumar-K-V/powerpc-mm-Fixup-wrong

Re: [PATCH V2 0/4] OPTPROBES for powerpc

2016-12-16 Thread Anju T Sudhakar
Hi Balbir, On Friday 16 December 2016 08:16 PM, Balbir Singh wrote: On 15/12/16 03:18, Anju T Sudhakar wrote: This is the V2 patchset of the kprobes jump optimization (a.k.a OPTPROBES)for powerpc. Kprobe being an inevitable tool for kernel developers, enhancing the performance of kprobe has

Re: [PATCH v3 11/15] livepatch: use kstrtobool() in enabled_store()

2016-12-16 Thread Josh Poimboeuf
On Fri, Dec 16, 2016 at 05:55:55PM +0100, Petr Mladek wrote: > On Thu 2016-12-08 12:08:36, Josh Poimboeuf wrote: > > The sysfs enabled value is a boolean, so kstrtobool() is a better fit > > for parsing the input string since it does the range checking for us. > > > > Suggested-by: Petr Mladek

Re: [PATCH v3 03/15] livepatch: temporary stubs for klp_patch_pending() and klp_update_patch_state()

2016-12-16 Thread Josh Poimboeuf
On Fri, Dec 16, 2016 at 03:41:59PM +0100, Petr Mladek wrote: > On Thu 2016-12-08 12:08:28, Josh Poimboeuf wrote: > > Create temporary stubs for klp_patch_pending() and > > klp_update_patch_state() so we can add TIF_PATCH_PENDING to different > > architectures in separate patches without breaking

Re: [PATCH v3 02/15] x86/entry: define _TIF_ALLWORK_MASK flags explicitly

2016-12-16 Thread Josh Poimboeuf
On Fri, Dec 16, 2016 at 03:17:35PM +0100, Petr Mladek wrote: > On Thu 2016-12-08 12:08:27, Josh Poimboeuf wrote: > > The _TIF_ALLWORK_MASK macro automatically includes the least-significant > > 16 bits of the thread_info flags, which is less than obvious and tends > > to create confusion and

Re: [PATCH v3 01/15] stacktrace/x86: add function for detecting reliable stack traces

2016-12-16 Thread Josh Poimboeuf
On Fri, Dec 16, 2016 at 02:07:39PM +0100, Petr Mladek wrote: > On Thu 2016-12-08 12:08:26, Josh Poimboeuf wrote: > > For live patching and possibly other use cases, a stack trace is only > > useful if it can be assured that it's completely reliable. Add a new > > save_stack_trace_tsk_reliable()

Re: [PATCH] perf TUI: Don't throw error for zero length symbols

2016-12-16 Thread Anton Blanchard
Hi Ravi, > > perf report (with TUI) exits with error when it finds a sample of > > zero length symbol(i.e. addr == sym->start == sym->end). Actually > > these are valid samples. Don't exit TUI and show report with such > > symbols. > > > > Link: https://lkml.org/lkml/2016/10/8/189 You can add:

Re: [PATCH V2 3/4] arch/powerpc: Implement Optprobes

2016-12-16 Thread Anju T Sudhakar
Hi Masami, On Friday 16 December 2016 07:32 PM, Masami Hiramatsu wrote: On Wed, 14 Dec 2016 21:48:27 +0530 Anju T Sudhakar wrote: Detour buffer contains instructions to create an in memory pt_regs. After the execution of the pre-handler, a call is made for

Re: [PATCH V2 0/4] OPTPROBES for powerpc

2016-12-16 Thread Naveen N. Rao
On 2016/12/17 01:46AM, Balbir Singh wrote: > > > On 15/12/16 03:18, Anju T Sudhakar wrote: > > This is the V2 patchset of the kprobes jump optimization > > (a.k.a OPTPROBES)for powerpc. Kprobe being an inevitable tool > > for kernel developers, enhancing the performance of kprobe has > > got

RE: [upstream-release] [PATCH net 2/4] fsl/fman: arm: call of_platform_populate() for arm64 platfrom

2016-12-16 Thread Madalin-Cristian Bucur
> From: Scott Wood > Sent: Thursday, December 15, 2016 8:42 PM > > On 12/15/2016 07:11 AM, Madalin Bucur wrote: > > From: Igal Liberman > > > > Signed-off-by: Igal Liberman > > --- > > drivers/net/ethernet/freescale/fman/fman.c | 10

Re: [PATCH v3 10/15] livepatch: move patching functions into patch.c

2016-12-16 Thread Petr Mladek
On Thu 2016-12-08 12:08:35, Josh Poimboeuf wrote: > Move functions related to the actual patching of functions and objects > into a new patch.c file. > > Signed-off-by: Josh Poimboeuf Looks fine. Reviewed-by: Petr Mladek Best Regards, Petr

Re: [PATCH v3 11/15] livepatch: use kstrtobool() in enabled_store()

2016-12-16 Thread Petr Mladek
On Thu 2016-12-08 12:08:36, Josh Poimboeuf wrote: > The sysfs enabled value is a boolean, so kstrtobool() is a better fit > for parsing the input string since it does the range checking for us. > > Suggested-by: Petr Mladek > Signed-off-by: Josh Poimboeuf

Re: [PATCH V2 2/4] powerpc: add helper to check if offset is within rel branch range

2016-12-16 Thread Anju T Sudhakar
Hi Masami, Thank you for reviewing the patch set. On Friday 16 December 2016 05:22 PM, Masami Hiramatsu wrote: On Wed, 14 Dec 2016 21:48:30 +0530 Anju T Sudhakar wrote: From: "Naveen N. Rao" The coding is OK to me. Please add a

Re: [PATCH v3 09/15] livepatch: remove unnecessary object loaded check

2016-12-16 Thread Petr Mladek
On Thu 2016-12-08 12:08:34, Josh Poimboeuf wrote: > klp_patch_object()'s callers already ensure that the object is loaded, > so its call to klp_is_object_loaded() is unnecessary. > > This will also make it possible to move the patching code into a > separate file. Fair enough. > Signed-off-by:

Re: [PATCH v3 08/15] livepatch: separate enabled and patched states

2016-12-16 Thread Petr Mladek
On Thu 2016-12-08 12:08:33, Josh Poimboeuf wrote: > Once we have a consistency model, patches and their objects will be > enabled and disabled at different times. For example, when a patch is > disabled, its loaded objects' funcs can remain registered with ftrace > indefinitely until the

Re: [PATCH v3 05/15] livepatch/powerpc: add TIF_PATCH_PENDING thread flag

2016-12-16 Thread Petr Mladek
On Thu 2016-12-08 12:08:30, Josh Poimboeuf wrote: > Add the TIF_PATCH_PENDING thread flag to enable the new livepatch > per-task consistency model for powerpc. The bit getting set indicates > the thread has a pending patch which needs to be applied when the thread > exits the kernel. > > The bit

Re: [PATCH v3 04/15] livepatch/x86: add TIF_PATCH_PENDING thread flag

2016-12-16 Thread Petr Mladek
On Thu 2016-12-08 12:08:29, Josh Poimboeuf wrote: > Add the TIF_PATCH_PENDING thread flag to enable the new livepatch > per-task consistency model for x86_64. The bit getting set indicates > the thread has a pending patch which needs to be applied when the thread > exits the kernel. > > The bit

Re: [PATCH 08/11] powerpc/kvm: KVM-HV HPT resizing stub implementation

2016-12-16 Thread Thomas Huth
On 15.12.2016 06:54, David Gibson wrote: > This patch adds a stub (always failing) implementation of the ioctl()s > for the HPT resizing PAPR extension. > > Signed-off-by: David Gibson > --- > arch/powerpc/include/asm/kvm_ppc.h | 4 >

Re: [PATCH] powerpc/livepatch: Remove klp_write_module_reloc() stub

2016-12-16 Thread Josh Poimboeuf
On Fri, Dec 16, 2016 at 11:44:24AM +0530, Kamalesh Babulal wrote: > commit 425595a7fc20 ("livepatch: reuse module loader code > to write relocations") offloads livepatch module relocation > write to arch specific module loader code. > > Remove unused klp_write_module_reloc() function stub. > >

Re: [PATCH V2 0/4] OPTPROBES for powerpc

2016-12-16 Thread Balbir Singh
On 15/12/16 03:18, Anju T Sudhakar wrote: > This is the V2 patchset of the kprobes jump optimization > (a.k.a OPTPROBES)for powerpc. Kprobe being an inevitable tool > for kernel developers, enhancing the performance of kprobe has > got much importance. > > Currently kprobes inserts a trap

Re: [PATCH v3 03/15] livepatch: temporary stubs for klp_patch_pending() and klp_update_patch_state()

2016-12-16 Thread Petr Mladek
On Thu 2016-12-08 12:08:28, Josh Poimboeuf wrote: > Create temporary stubs for klp_patch_pending() and > klp_update_patch_state() so we can add TIF_PATCH_PENDING to different > architectures in separate patches without breaking build bisectability. > > Signed-off-by: Josh Poimboeuf

Re: [PATCH v3 0/5] powerpc/mm: enable memory hotplug on radix

2016-12-16 Thread Balbir Singh
On 16/12/16 06:50, Reza Arbab wrote: > Memory hotplug is leading to hash page table calls, even on radix: > > ... > arch_add_memory > create_section_mapping > htab_bolt_mapping > BUG_ON(!ppc_md.hpte_insert); > > To

Re: [PATCH v3 02/15] x86/entry: define _TIF_ALLWORK_MASK flags explicitly

2016-12-16 Thread Petr Mladek
On Thu 2016-12-08 12:08:27, Josh Poimboeuf wrote: > The _TIF_ALLWORK_MASK macro automatically includes the least-significant > 16 bits of the thread_info flags, which is less than obvious and tends > to create confusion and surprises when reading or modifying the code. > > Define the flags

Re: [PATCH V2 4/4] arch/powerpc: Optimize kprobe in kretprobe_trampoline

2016-12-16 Thread Masami Hiramatsu
On Wed, 14 Dec 2016 21:48:28 +0530 Anju T Sudhakar wrote: > Kprobe placed on the kretprobe_trampoline during boot time can be > optimized, since the instruction at probe point is a 'nop'. > How simple & clever way! ;) Acked-by: Masami Hiramatsu

Re: [PATCH V2 3/4] arch/powerpc: Implement Optprobes

2016-12-16 Thread Masami Hiramatsu
On Wed, 14 Dec 2016 21:48:27 +0530 Anju T Sudhakar wrote: > Detour buffer contains instructions to create an in memory pt_regs. > After the execution of the pre-handler, a call is made for instruction > emulation. > The NIP is determined in advanced through dummy

Re: [PATCH 01/11] powerpc/kvm: Reserve capabilities and ioctls for HPT resizing

2016-12-16 Thread Thomas Huth
On 15.12.2016 06:53, David Gibson wrote: > This adds a new powerpc-specific KVM_CAP_SPAPR_RESIZE_HPT capability to > advertise whether KVM is capable of handling the PAPR extensions for > resizing the hashed page table during guest runtime. > > At present, HPT resizing is possible with KVM PR

Re: [PATCH v3 01/15] stacktrace/x86: add function for detecting reliable stack traces

2016-12-16 Thread Petr Mladek
On Thu 2016-12-08 12:08:26, Josh Poimboeuf wrote: > For live patching and possibly other use cases, a stack trace is only > useful if it can be assured that it's completely reliable. Add a new > save_stack_trace_tsk_reliable() function to achieve that. > > Scenarios which indicate that a stack

Re: [PATCH 3/3] powerpc/corenet: add support for the kmcent2 board

2016-12-16 Thread Valentin Longchamp
On 15/12/16 15:00, Joakim Tjernlund wrote: > On Thu, 2016-12-15 at 14:22 +0100, Valentin Longchamp wrote: >> This board is built around Freescale's T1040 SoC. >> >> The peripherals used by this design are: >> - DDR3 RAM with SPD support >> - parallel NOR Flash as boot medium >> - 1 PCIe bus (PCIe1

Re: [PATCH 07/11] powerpc/kvm: Create kvmppc_unmap_hpte_helper()

2016-12-16 Thread Thomas Huth
On 15.12.2016 06:54, David Gibson wrote: > The kvm_unmap_rmapp() function, called from certain MMU notifiers, is used > to force all guest mappings of a particular host page to be set ABSENT, and > removed from the reverse mappings. > > For HPT resizing, we will have some cases where we want to

Re: [PATCH 06/11] powerpc/kvm: Allow KVM_PPC_ALLOCATE_HTAB ioctl() to change HPT size

2016-12-16 Thread Thomas Huth
On 15.12.2016 06:53, David Gibson wrote: > The KVM_PPC_ALLOCATE_HTAB ioctl() is used to set the size of hashed page > table (HPT) that userspace expects a guest VM to have, and is also used to > clear that HPT when necessary (e.g. guest reboot). > > At present, once the ioctl() is called for the

Re: [PATCH 05/11] powerpc/kvm: Split HPT allocation from activation

2016-12-16 Thread Thomas Huth
On 15.12.2016 06:53, David Gibson wrote: > Currently, kvmppc_alloc_hpt() both allocates a new hashed page table (HPT) > and sets it up as the active page table for a VM. For the upcoming HPT > resize implementation we're going to want to allocate HPTs separately from > activating them. > > So,

Re: [PATCH V2 2/4] powerpc: add helper to check if offset is within rel branch range

2016-12-16 Thread Masami Hiramatsu
On Wed, 14 Dec 2016 21:48:30 +0530 Anju T Sudhakar wrote: > From: "Naveen N. Rao" > The coding is OK to me. Please add a description for this patch here, e.g. what is done by this patch, what kind of branch instruction will be

[PATCH] cpufreq: powernv: Add boost files to export ultra-turbo frequencies

2016-12-16 Thread Shilpasri G Bhat
In P8+, Workload Optimized Frequency(WOF) provides the capability to boost the cpu frequency based on the utilization of the other cpus running in the chip. The On-Chip-Controller(OCC) firmware will control the achievability of these frequencies depending on the power headroom available in the

Re: [PATCH 04/11] powerpc/kvm: Don't store values derivable from HPT order

2016-12-16 Thread Thomas Huth
On 15.12.2016 06:53, David Gibson wrote: > Currently the kvm_hpt_info structure stores the hashed page table's order, > and also the number of HPTEs it contains and a mask for its size. The > last two can be easily derived from the order, so remove them and just > calculate them as necessary with

Re: [PATCH] perf TUI: Don't throw error for zero length symbols

2016-12-16 Thread Ravi Bangoria
Hi Arnaldo, Can you please pick this up if it looks good? -Ravi On Tuesday 22 November 2016 02:10 PM, Ravi Bangoria wrote: > perf report (with TUI) exits with error when it finds a sample of zero > length symbol(i.e. addr == sym->start == sym->end). Actually these are > valid samples. Don't

Re: [PATCH] powerpc/livepatch: Remove klp_write_module_reloc() stub

2016-12-16 Thread Petr Mladek
On Fri 2016-12-16 11:44:24, Kamalesh Babulal wrote: > commit 425595a7fc20 ("livepatch: reuse module loader code > to write relocations") offloads livepatch module relocation > write to arch specific module loader code. > > Remove unused klp_write_module_reloc() function stub. Yup, the function

Re: [PATCH 01/11] powerpc/kvm: Reserve capabilities and ioctls for HPT resizing

2016-12-16 Thread Thomas Huth
On 15.12.2016 06:53, David Gibson wrote: > This adds a new powerpc-specific KVM_CAP_SPAPR_RESIZE_HPT capability to > advertise whether KVM is capable of handling the PAPR extensions for > resizing the hashed page table during guest runtime. > > At present, HPT resizing is possible with KVM PR

Re: [PATCH 03/11] powerpc/kvm: Gather HPT related variables into sub-structure

2016-12-16 Thread Thomas Huth
On 15.12.2016 06:53, David Gibson wrote: > Currently, the powerpc kvm_arch structure contains a number of variables > tracking the state of the guest's hashed page table (HPT) in KVM HV. This > patch gathers them all together into a single kvm_hpt_info substructure. > This makes life more

Re: [PATCH] powerpc/livepatch: Remove klp_write_module_reloc() stub

2016-12-16 Thread Balbir Singh
On 16/12/16 17:14, Kamalesh Babulal wrote: > commit 425595a7fc20 ("livepatch: reuse module loader code > to write relocations") offloads livepatch module relocation > write to arch specific module loader code. > > Remove unused klp_write_module_reloc() function stub. > > Signed-off-by:

Re: [PATCH 02/11] powerpc/kvm: Rename kvm_alloc_hpt() for clarity

2016-12-16 Thread Thomas Huth
On 15.12.2016 06:53, David Gibson wrote: > The difference between kvm_alloc_hpt() and kvmppc_alloc_hpt() is not at > all obvious from the name. In practice kvmppc_alloc_hpt() allocates an HPT > by whatever means, and calls kvm_alloc_hpt() which will attempt to allocate > it with CMA only. > > To

Re: [PATCH v6 2/4] irqchip/qeic: merge qeic init code from platforms to a common function

2016-12-16 Thread Marc Zyngier
On 16/12/16 08:43, Qiang Zhao wrote: > On 16/12/16 04:33, Marc Zyngier wrote: > >> -Original Message- >> From: Marc Zyngier [mailto:marc.zyng...@arm.com] >> Sent: Friday, December 16, 2016 4:33 PM >> To: Qiang Zhao ; o...@buserror.net;

RE: [PATCH v6 2/4] irqchip/qeic: merge qeic init code from platforms to a common function

2016-12-16 Thread Qiang Zhao
On 16/12/16 04:33, Marc Zyngier wrote: > -Original Message- > From: Marc Zyngier [mailto:marc.zyng...@arm.com] > Sent: Friday, December 16, 2016 4:33 PM > To: Qiang Zhao ; o...@buserror.net; t...@linutronix.de > Cc: ja...@lakedaemon.net; Xiaobo

Re: [PATCH v6 2/4] irqchip/qeic: merge qeic init code from platforms to a common function

2016-12-16 Thread Marc Zyngier
On 28/09/16 04:25, Zhao Qiang wrote: > The codes of qe_ic init from a variety of platforms are redundant, > merge them to a common function and put it to irqchip/irq-qeic.c > > For non-p1021_mds mpc85xx_mds boards, use "qe_ic_init(np, 0, > qe_ic_cascade_low_mpic, qe_ic_cascade_high_mpic);"