[PATCH] swim3: support highmem

2021-04-05 Thread Christoph Hellwig
swim3 only uses the virtual address of a bio to stash it into the data transfer using virt_to_bus. But the ppc32 virt_to_bus just uses the physical address with an offset. Replace virt_to_bus with a local hack that performs the equivalent transformation and stop asking for block layer bounce buff

Re: [PATCH v6 16/48] KVM: PPC: Book3S 64: Move interrupt early register setup to KVM

2021-04-05 Thread Paul Mackerras
On Mon, Apr 05, 2021 at 11:19:16AM +1000, Nicholas Piggin wrote: > Like the earlier patch for hcalls, KVM interrupt entry requires a > different calling convention than the Linux interrupt handlers > set up. Move the code that converts from one to the other into KVM. I don't see where you do anyth

Re: [PATCH] powerpc/mm: Add cond_resched() while removing hpte mappings

2021-04-05 Thread Vaibhav Jain
Hi Mpe, Thanks for looking into this patch. Michael Ellerman writes: > Vaibhav Jain writes: >> While removing large number of mappings from hash page tables for >> large memory systems as soft-lockup is reported because of the time >> spent inside htap_remove_mapping() like one below: >> >> w

Re: [PATCH v6 09/48] powerpc/64s: remove KVM SKIP test from instruction breakpoint handler

2021-04-05 Thread Paul Mackerras
On Tue, Apr 06, 2021 at 12:44:45PM +1000, Nicholas Piggin wrote: > Excerpts from Nicholas Piggin's message of April 5, 2021 11:19 am: > > The code being executed in KVM_GUEST_MODE_SKIP is hypervisor code with > > MSR[IR]=0, so the faults of concern are the d-side ones caused by access > > to guest

[PATCH v2] powerpc/64s: power4 nap fixup in C

2021-04-05 Thread Nicholas Piggin
There is no need for this to be in asm, use the new intrrupt entry wrapper. Tested-by: Andreas Schwab Signed-off-by: Nicholas Piggin --- Since v1: - Fixed the G5 hang bug (reproduced and QEMU and real hardware), added a comment about the tricky behaviour of irq_exit enabling interrupts. ---

Re: [PATCH] powerpc/64s: power4 nap fixup in C

2021-04-05 Thread Nicholas Piggin
Excerpts from Andreas Schwab's message of April 6, 2021 2:40 am: > On Apr 05 2021, Nicholas Piggin wrote: > >> I worked it out. There was a window where it could take another >> interrupt before the first one adjusts the nip. >> >> I managed to trigger it in qemu and this version fixed it. > > W

Re: [PATCH v6 09/48] powerpc/64s: remove KVM SKIP test from instruction breakpoint handler

2021-04-05 Thread Nicholas Piggin
Excerpts from Nicholas Piggin's message of April 5, 2021 11:19 am: > The code being executed in KVM_GUEST_MODE_SKIP is hypervisor code with > MSR[IR]=0, so the faults of concern are the d-side ones caused by access > to guest context by the hypervisor. > > Instruction breakpoint interrupts are not

Re: [PATCH 3/3] powerpc/sstep: Always test lmw and stmw

2021-04-05 Thread Jordan Niethe
On Fri, Apr 2, 2021 at 12:39 AM Michael Ellerman wrote: > > Hi Jordan, > > Jordan Niethe writes: > > Load Multiple Word (lmw) and Store Multiple Word (stmw) will raise an > > Alignment Exception: > > - Little Endian mode: always > > - Big Endian mode: address not word aligned > > > > These co

[PATCH] powerpc/pseries: remove unneeded semicolon

2021-04-05 Thread Yang Li
Eliminate the following coccicheck warning: ./arch/powerpc/platforms/pseries/lpar.c:1633:2-3: Unneeded semicolon Reported-by: Abaci Robot Signed-off-by: Yang Li --- arch/powerpc/platforms/pseries/lpar.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/arch/powerpc/platforms/p

Re: [PATCH 1/2] of: net: pass the dst buffer to of_get_mac_address()

2021-04-05 Thread Andrew Lunn
On Tue, Apr 06, 2021 at 03:19:11AM +0800, kernel test robot wrote: > Hi Michael, > > I love your patch! Yet something to improve: Looks correct. You missed the #else case for #ifdef CONFIG_OF in stmmac_platform.c Lets see what else 0-day finds before i start reviewing. Andrew

[PATCH 2/2] of: net: fix of_get_mac_addr_nvmem() for PCI and DSA nodes

2021-04-05 Thread Michael Walle
of_get_mac_address() already supports fetching the MAC address by an nvmem provider. But until now, it was just working for platform devices. Esp. it was not working for DSA ports and PCI devices. It gets more common that PCI devices have a device tree binding since SoCs contain integrated root com

[PATCH 1/2] of: net: pass the dst buffer to of_get_mac_address()

2021-04-05 Thread Michael Walle
of_get_mac_address() returns a "const void*" pointer to a MAC address. Lately, support to fetch the MAC address by an NVMEM provider was added. But this will only work with platform devices. It will not work with PCI devices (e.g. of an integrated root complex) and esp. not with DSA ports. There i

[PATCH 0/2] of: net: support non-platform devices in of_get_mac_address()

2021-04-05 Thread Michael Walle
of_get_mac_address() is commonly used to fetch the MAC address from the device tree. It also supports reading it from a NVMEM provider. But the latter is only possible for platform devices, because only platform devices are searched for a matching device node. Add a second method to fetch the NVME

Re: [PATCH 1/2] of: net: pass the dst buffer to of_get_mac_address()

2021-04-05 Thread kernel test robot
Hi Michael, I love your patch! Yet something to improve: [auto build test ERROR on next-20210401] [cannot apply to sunxi/sunxi/for-next xlnx/master wireless-drivers-next/master wireless-drivers/master robh/for-next linus/master v5.12-rc6 v5.12-rc5 v5.12-rc4 v5.12-rc6] [If your patch is applied

Re: [PATCH] ibmvnic: Use 'skb_frag_address()' instead of hand coding it

2021-04-05 Thread patchwork-bot+netdevbpf
Hello: This patch was applied to netdev/net-next.git (refs/heads/master): On Sun, 4 Apr 2021 10:54:37 +0200 you wrote: > 'page_address(skb_frag_page()) + skb_frag_off()' can be replaced by an > equivalent 'skb_frag_address()' which is less verbose. > > Signed-off-by: Christophe JAILLET > --- >

Re: [PATCH] powerpc/64s: power4 nap fixup in C

2021-04-05 Thread Andreas Schwab
On Apr 05 2021, Nicholas Piggin wrote: > I worked it out. There was a window where it could take another > interrupt before the first one adjusts the nip. > > I managed to trigger it in qemu and this version fixed it. Works for me as well. Andreas. -- Andreas Schwab, sch...@linux-m68k.org GPG

Re: [PATCH v2] powerpc: iommu: fix build when neither PCI or IBMVIO is set

2021-04-05 Thread Randy Dunlap
On 4/5/21 2:04 AM, Christophe Leroy wrote: > > > Le 04/04/2021 à 21:26, Randy Dunlap a écrit : >> When neither CONFIG_PCI nor CONFIG_IBMVIO is set/enabled, iommu.c has a >> build error. The fault injection code is not useful in that kernel config, >> so make the FAIL_IOMMU option depend on PCI ||

[PATCH] powerpc/kconfig: Restore alphabetic order of the selects under CONFIG_PPC

2021-04-05 Thread Christophe Leroy
Commit a7d2475af7ae ("powerpc: Sort the selects under CONFIG_PPC") sorted all selects under CONFIG_PPC. 4 years later, several items have been introduced at wrong place, a few other have been renamed without moving them to their correct place. Reorder them now. While we are at it, simplify the t

Re: [PATCH] powerpc/64s: power4 nap fixup in C

2021-04-05 Thread Nicholas Piggin
Excerpts from Nicholas Piggin's message of April 1, 2021 5:36 pm: > Excerpts from Andreas Schwab's message of March 30, 2021 2:23 am: >> On Mär 29 2021, Andreas Schwab wrote: >> >>> On Mär 29 2021, Michael Ellerman wrote: >>> Nicholas Piggin writes: > There is no need for this to be in a

Re: [PATCH] powerpc/32: Remove powerpc specific definition of 'ptrdiff_t'

2021-04-05 Thread Segher Boessenkool
On Mon, Apr 05, 2021 at 09:57:27AM +, Christophe Leroy wrote: > For unknown reason, old commit d27dfd388715 ("Import pre2.0.8") > changed 'ptrdiff_t' from 'int' to 'long'. > > GCC expects it as 'int' really, It isn't actually defined in the ABI as far as I can see (neither the old document or

Re: [PATCH RESEND v1 3/4] powerpc/vdso: Separate vvar vma from vdso

2021-04-05 Thread Andrei Vagin
On Wed, Mar 31, 2021 at 04:48:46PM +, Christophe Leroy wrote: > From: Dmitry Safonov > > Since commit 511157ab641e ("powerpc/vdso: Move vdso datapage up front") > VVAR page is in front of the VDSO area. In result it breaks CRIU > (Checkpoint Restore In Userspace) [1], where CRIU expects that

Re: [PATCH RESEND v1 2/4] lib/vdso: Add vdso_data pointer as input to __arch_get_timens_vdso_data()

2021-04-05 Thread Andrei Vagin
On Wed, Mar 31, 2021 at 04:48:45PM +, Christophe Leroy wrote: > For the same reason as commit e876f0b69dc9 ("lib/vdso: Allow > architectures to provide the vdso data pointer"), powerpc wants to > avoid calculation of relative position to code. > > As the timens_vdso_data is next page to vdso_d

Re: [PATCH RESEND v1 4/4] powerpc/vdso: Add support for time namespaces

2021-04-05 Thread Andrei Vagin
On Wed, Mar 31, 2021 at 04:48:47PM +, Christophe Leroy wrote: > This patch adds the necessary glue to provide time namespaces. > > Things are mainly copied from ARM64. > > __arch_get_timens_vdso_data() calculates timens vdso data position > based on the vdso data position, knowing it is the n

Re: [PATCH v2] powerpc/traps: Enhance readability for trap types

2021-04-05 Thread Xiongwei Song
Regards, Xiongwei > On Apr 2, 2021, at 8:36 AM, Nicholas Piggin wrote: > > Excerpts from Segher Boessenkool's message of April 2, 2021 2:11 am: >> On Thu, Apr 01, 2021 at 10:55:58AM +0800, Xiongwei Song wrote: >>> Segher Boessenkool 于2021年4月1日周四 上午6:15写道: >>> On Wed, Mar 31, 2021 at

Re: [PATCH v2] powerpc/traps: Enhance readability for trap types

2021-04-05 Thread Xiongwei Song
Regards, Xiongwei > On Apr 1, 2021, at 4:01 PM, Nicholas Piggin wrote: > > Excerpts from Michael Ellerman's message of April 1, 2021 12:39 pm: >> Segher Boessenkool writes: >>> On Wed, Mar 31, 2021 at 08:58:17PM +1100, Michael Ellerman wrote: So perhaps: EXC_SYSTEM_RESET >

Re: [PATCH v2] powerpc/traps: Enhance readability for trap types

2021-04-05 Thread Xiongwei Song
> On Apr 2, 2021, at 12:11 AM, Segher Boessenkool > wrote: > > On Thu, Apr 01, 2021 at 10:55:58AM +0800, Xiongwei Song wrote: >> Segher Boessenkool 于2021年4月1日周四 上午6:15写道: >> >>> On Wed, Mar 31, 2021 at 08:58:17PM +1100, Michael Ellerman wrote: So perhaps: EXC_SYSTEM_RESET >>

[PATCH] powerpc/32: Remove powerpc specific definition of 'ptrdiff_t'

2021-04-05 Thread Christophe Leroy
For unknown reason, old commit d27dfd388715 ("Import pre2.0.8") changed 'ptrdiff_t' from 'int' to 'long'. GCC expects it as 'int' really, and this leads to the following warning when building KFENCE: CC mm/kfence/report.o In file included from ./include/linux/printk.h:7, f

Re: [PATCH v2] powerpc: iommu: fix build when neither PCI or IBMVIO is set

2021-04-05 Thread Christophe Leroy
Le 04/04/2021 à 21:26, Randy Dunlap a écrit : When neither CONFIG_PCI nor CONFIG_IBMVIO is set/enabled, iommu.c has a build error. The fault injection code is not useful in that kernel config, so make the FAIL_IOMMU option depend on PCI || IBMVIO. Prevents this build error (warning escalated