Re: [PATCH v6 29/29] x86/tsc: Switch to perf-based hardlockup detector if TSC become unstable

2022-05-16 Thread Ricardo Neri
On Tue, May 10, 2022 at 10:14:00PM +1000, Nicholas Piggin wrote: > Excerpts from Ricardo Neri's message of May 6, 2022 10:00 am: > > The HPET-based hardlockup detector relies on the TSC to determine if an > > observed NMI interrupt was originated by HPET timer. Hence, this detector > > can no

Re: [PATCH v2 4/4] powerpc/52xx: Convert to use fwnode API

2022-05-16 Thread Michael Ellerman
Andy Shevchenko writes: > On Mon, May 16, 2022 at 05:05:12PM +0300, Andy Shevchenko wrote: >> On Mon, May 16, 2022 at 11:48:05PM +1000, Michael Ellerman wrote: >> > Andy Shevchenko writes: >> > > We may convert the GPT driver to use fwnode API for the sake >> > > of consistency of the used APIs

Re: [PATCH 21/30] panic: Introduce the panic pre-reboot notifier list

2022-05-16 Thread Guilherme G. Piccoli
On 16/05/2022 13:18, Luck, Tony wrote: >> [...] > Would it be possible to have some global "kdump is configured + enabled" flag? > > Then notifiers could make an informed choice on whether to deep dive to > get all the possible details (when there is no kdump) or just skim the high > level stuff

Re: [PATCH 24/30] panic: Refactor the panic path

2022-05-16 Thread Guilherme G. Piccoli
On 16/05/2022 07:21, Petr Mladek wrote: > [...] > Ah, it should have been: > > + notifiers vs. kmsg_dump > + notifiers vs. crash_dump > + crash_dump vs. kmsg_dump > > I am sorry for the confusion. Even "crash_dump" is slightly > misleading because there is no function with this

RE: [PATCH 21/30] panic: Introduce the panic pre-reboot notifier list

2022-05-16 Thread Luck, Tony
> So, my reasoning here is: this notifier should fit the info list, > definitely! But...it's very high risk for kdump. It deep dives into the > regmap API (there are locks in such code) plus there is an (MM)IO write > to the device and an ARM firmware call. So, despite the nature of this >

Re: [PATCH 18/30] notifier: Show function names on notifier routines if DEBUG_NOTIFIERS is set

2022-05-16 Thread Guilherme G. Piccoli
On 10/05/2022 14:29, Steven Rostedt wrote: > [...] > Also, don't sprinkle #ifdef in C code. Instead: > > if (IS_ENABLED(CONFIG_DEBUG_NOTIFIERS)) > pr_info("notifers: regsiter %ps()\n", > n->notifer_call); > > > Or define a print macro at the start of

Re: [PATCH 19/30] panic: Add the panic hypervisor notifier list

2022-05-16 Thread Evan Green
On Mon, May 16, 2022 at 8:07 AM Guilherme G. Piccoli wrote: > > Thanks for the review! > > I agree with the blinking stuff, I can rework and add all LED/blinking > stuff into the loop list, it does make sense. I'll comment a bit in the > others below... > > On 16/05/2022 11:01, Petr Mladek wrote:

Re: [PATCH 22/30] panic: Introduce the panic post-reboot notifier list

2022-05-16 Thread Guilherme G. Piccoli
On 16/05/2022 11:45, Petr Mladek wrote: > [...] > > The patch looks good to me. I would just suggest two changes. > > 1. I would rename the list to "panic_loop_list" instead of >"panic_post_reboot_list". > >It will be more clear that it includes things that are >needed before

Re: [PATCH 21/30] panic: Introduce the panic pre-reboot notifier list

2022-05-16 Thread Guilherme G. Piccoli
Thanks again for the review! Comments inline below: On 16/05/2022 11:33, Petr Mladek wrote: > [...] >> --- a/drivers/edac/altera_edac.c >> +++ b/drivers/edac/altera_edac.c >> @@ -2163,7 +2162,7 @@ static int altr_edac_a10_probe(struct platform_device >> *pdev) >> int dberror,

Re: [PATCH 19/30] panic: Add the panic hypervisor notifier list

2022-05-16 Thread Guilherme G. Piccoli
Thanks for the review! I agree with the blinking stuff, I can rework and add all LED/blinking stuff into the loop list, it does make sense. I'll comment a bit in the others below... On 16/05/2022 11:01, Petr Mladek wrote: > [...] >> --- a/arch/mips/sgi-ip22/ip22-reset.c >> +++

Re: [PATCH 20/30] panic: Add the panic informational notifier list

2022-05-16 Thread Guilherme G. Piccoli
On 16/05/2022 11:11, Petr Mladek wrote: > [...] > > All notifiers moved in this patch seems to fit well the "info" > notifier list. The patch looks good from this POV. > > I still have to review the rest of the patches to see if it > is complete. > > Best Regards, > Petr Thanks a bunch for the

[Bug 215389] pagealloc: memory corruption at building glibc-2.33 and running its' testsuite

2022-05-16 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=215389 --- Comment #23 from Erhard F. (erhar...@mailbox.org) --- Created attachment 300978 --> https://bugzilla.kernel.org/attachment.cgi?id=300978=edit kernel .config (5.18-rc6, CONFIG_LOWMEM_SIZE=0x2800, outline KASAN, PowerMac G4 DP) -- You

[Bug 215389] pagealloc: memory corruption at building glibc-2.33 and running its' testsuite

2022-05-16 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=215389 --- Comment #22 from Erhard F. (erhar...@mailbox.org) --- Created attachment 300977 --> https://bugzilla.kernel.org/attachment.cgi?id=300977=edit dmesg (5.18-rc6, CONFIG_LOWMEM_SIZE=0x2800, outline KASAN, PowerMac G4 DP) I increased

Re: (subset) [PATCH -next v4 0/7]arm64: add machine check safe support

2022-05-16 Thread Catalin Marinas
On Wed, 20 Apr 2022 03:04:11 +, Tong Tiangen wrote: > With the increase of memory capacity and density, the probability of > memory error increases. The increasing size and density of server RAM > in the data center and cloud have shown increased uncorrectable memory > errors. > > Currently,

Re: [PATCH v4 10/17] powerpc/64: interrupt soft-enable race fix

2022-05-16 Thread Christophe Leroy
Hi Nick. Le 17/06/2021 à 17:51, Nicholas Piggin a écrit : Prevent interrupt restore from allowing racing hard interrupts going ahead of previous soft-pending ones, by using the soft-masked restart handler to allow a store to clear the soft-mask while knowing nothing is soft-pending. This

Re: [PATCH 25/30] panic, printk: Add console flush parameter and convert panic_print to a notifier

2022-05-16 Thread Guilherme G. Piccoli
On 16/05/2022 11:56, Petr Mladek wrote: > [...] > I really like both changes. Just please split it them into two > patchset. I mean one patch for the new "panic_console_replay" > parameter and 2nd that moves "printk_info" into the notifier. > OK sure, will do that in V2. Thanks, Guilherme

Re: [PATCH 23/30] printk: kmsg_dump: Introduce helper to inform number of dumpers

2022-05-16 Thread Guilherme G. Piccoli
On 16/05/2022 11:50, Petr Mladek wrote: > [...] > Shame on me that I do not care that much about the style of the commit > message :-) > > Anyway, the code looks good to me. With the better commit message: > > Reviewed-by: Petr Mladek > Heheh, cool - I'll add your tag and improve the message

[PATCH] powerpc/irq: Remove arch_local_irq_restore() for !CONFIG_CC_HAS_ASM_GOTO

2022-05-16 Thread Christophe Leroy
All supported versions of GCC support asm goto. Remove the !CONFIG_CC_HAS_ASM_GOTO version of arch_local_irq_restore() Signed-off-by: Christophe Leroy --- arch/powerpc/kernel/irq.c | 77 --- 1 file changed, 77 deletions(-) diff --git

Re: [PATCH v2 4/4] powerpc/52xx: Convert to use fwnode API

2022-05-16 Thread Andy Shevchenko
On Mon, May 16, 2022 at 05:05:12PM +0300, Andy Shevchenko wrote: > On Mon, May 16, 2022 at 11:48:05PM +1000, Michael Ellerman wrote: > > Andy Shevchenko writes: > > > We may convert the GPT driver to use fwnode API for the sake > > > of consistency of the used APIs inside the driver. > > > > I'm

Re: [PATCH v2 4/4] powerpc/52xx: Convert to use fwnode API

2022-05-16 Thread Andy Shevchenko
On Mon, May 16, 2022 at 11:48:05PM +1000, Michael Ellerman wrote: > Andy Shevchenko writes: > > We may convert the GPT driver to use fwnode API for the sake > > of consistency of the used APIs inside the driver. > > I'm not sure about this one. > > It's more consistent to use fwnode in this

Re: [PATCH v2 4/4] powerpc/52xx: Convert to use fwnode API

2022-05-16 Thread Michael Ellerman
Andy Shevchenko writes: > We may convert the GPT driver to use fwnode API for the sake > of consistency of the used APIs inside the driver. I'm not sure about this one. It's more consistent to use fwnode in this driver, but it's very inconsistent with the rest of the powerpc code. We have

Re: [Buildroot] [PATCH] linux: Fix powerpc64le defconfig selection

2022-05-16 Thread Michael Ellerman
Arnout Vandecappelle writes: > On 10/05/2022 04:20, Joel Stanley wrote: >> The default defconfig target for the 64 bit powerpc kernel is >> ppc64_defconfig, the big endian configuration. >> >> When building for powerpc64le users want the little endian kernel as >> they can't boot LE userspace on

[PATCH v2] powerpc/ftrace: Remove ftrace init tramp once kernel init is complete

2022-05-16 Thread Naveen N. Rao
Stop using the ftrace trampoline for init section once kernel init is complete. Fixes: 67361cf8071286 ("powerpc/ftrace: Handle large kernel configs") Cc: sta...@vger.kernel.org # v4.20+ Signed-off-by: Naveen N. Rao --- v2: Update #ifdef to also check for CONFIG_FUNCTION_TRACER to address a build