Re: [PATCH 03/13] mm: Provide generic pmd_thp_or_huge()

2024-01-01 Thread Muchun Song
> On Jan 2, 2024, at 13:37, Peter Xu wrote: > > On Mon, Dec 25, 2023 at 02:29:53PM +0800, Muchun Song wrote: >>> @@ -1355,6 +1355,10 @@ static inline int pmd_write(pmd_t pmd) >>> #endif /* pmd_write */ >>> #endif /* CONFIG_TRANSPARENT_HUGEPAGE */ >>> +#ifndef pmd_thp_or_huge >> >> I think i

Re: [PATCH 05/13] mm: Introduce vma_pgtable_walk_{begin|end}()

2024-01-01 Thread Muchun Song
> On Jan 2, 2024, at 13:39, Peter Xu wrote: > > On Mon, Dec 25, 2023 at 02:34:48PM +0800, Muchun Song wrote: >> Reviewed-by: Muchun Song > > You're using the old email address here. Do you want me to also use the > linux.dev one that you suggested me to use? Either is OK for the RB tag. >

Re: [PATCH 05/13] mm: Introduce vma_pgtable_walk_{begin|end}()

2024-01-01 Thread Peter Xu
On Mon, Dec 25, 2023 at 02:34:48PM +0800, Muchun Song wrote: > Reviewed-by: Muchun Song You're using the old email address here. Do you want me to also use the linux.dev one that you suggested me to use? -- Peter Xu

Re: [PATCH 03/13] mm: Provide generic pmd_thp_or_huge()

2024-01-01 Thread Peter Xu
On Mon, Dec 25, 2023 at 02:29:53PM +0800, Muchun Song wrote: > > @@ -1355,6 +1355,10 @@ static inline int pmd_write(pmd_t pmd) > > #endif /* pmd_write */ > > #endif /* CONFIG_TRANSPARENT_HUGEPAGE */ > > +#ifndef pmd_thp_or_huge > > I think it may be the time to rename to pmd_thp_or_hugetlb, >

Re: [RFC PATCH 5/5] powerpc/smp: Remap boot CPU onto core 0 if >= nr_cpu_ids

2024-01-01 Thread Aneesh Kumar K . V
Michael Ellerman writes: > #ifdef CONFIG_PPC64 > int boot_cpu_hwid = -1; > @@ -492,12 +493,26 @@ void __init smp_setup_cpu_maps(void) > avail = !of_property_match_string(dn, > "enable-method", "spin-table"); > > - c

Re: [RFC PATCH 4/5] powerpc/smp: Factor out assign_threads()

2024-01-01 Thread Aneesh Kumar K . V
Michael Ellerman writes: > +static int assign_threads(unsigned cpu, unsigned int nthreads, bool avail, > May be rename 'avail' to 'present' > + const __be32 *hw_ids) > +{ > + for (int i = 0; i < nthreads && cpu < nr_cpu_ids; i++) { > + __be32 hwi

[PATCH v1 1/1] powerpc/powernv: fix up kernel compile issues

2024-01-01 Thread Luming Yu
up kernel is quite useful to silicon validation, despite it is rare to be found in server productions. the fixes are obvious. Not like IBM pSeries, it may be not necessary to have powernv SMP forced. It is difficult to compile a up kernel for pSerises as I've tried. Signed-off-by: Luming Yu --- v

Re: [RFC PATCH 5/5] powerpc/smp: Remap boot CPU onto core 0 if >= nr_cpu_ids

2024-01-01 Thread Pingfan Liu
On Fri, Dec 29, 2023 at 8:07 PM Michael Ellerman wrote: > > Michael Ellerman writes: > > If nr_cpu_ids is too low to include the boot CPU, remap the boot CPU > > onto logical core 0. > > Hi guys, > > I finally got time to look at this issue. I think this series should fix Thanks a lot for sparin

[powerpc:merge] BUILD SUCCESS 414e92af226ede4935509b0b5e041810c92e003f

2024-01-01 Thread kernel test robot
tree/branch: https://git.kernel.org/pub/scm/linux/kernel/git/powerpc/linux.git merge branch HEAD: 414e92af226ede4935509b0b5e041810c92e003f Automatic merge of 'master' into merge (2023-12-31 22:04) elapsed time: 1452m configs tested: 221 configs skipped: 3 The following configs have been built