Re: [PATCH 1/2] radix/kfence: map __kfence_pool at page granularity

2024-04-30 Thread IBM
Hari Bathini writes: > When KFENCE is enabled, total system memory is mapped at page level > granularity. But in radix MMU mode, ~3GB additional memory is needed > to map 100GB of system memory at page level granularity when compared > to using 2MB direct mapping. This is not desired considering

Re: [PATCH v15 00/16] Add audio support in v4l2 framework

2024-04-30 Thread Mark Brown
On Tue, Apr 30, 2024 at 05:27:52PM +0100, Mauro Carvalho Chehab wrote: > Mark Brown escreveu: > > On Tue, Apr 30, 2024 at 10:21:12AM +0200, Sebastian Fricke wrote: > > The discussion around this originally was that all the audio APIs are > > very much centered around real time operations rather

Re: [PATCH v4 13/15] drm/amd/display: Use ARCH_HAS_KERNEL_FPU_SUPPORT

2024-04-30 Thread Harry Wentland
On 2024-03-29 03:18, Samuel Holland wrote: > Now that all previously-supported architectures select > ARCH_HAS_KERNEL_FPU_SUPPORT, this code can depend on that symbol instead > of the existing list of architectures. It can also take advantage of the > common kernel-mode FPU API and method of

Re: [PATCH v4 12/15] drm/amd/display: Only use hard-float, not altivec on powerpc

2024-04-30 Thread Harry Wentland
On 2024-03-29 03:18, Samuel Holland wrote: > From: Michael Ellerman > > The compiler flags enable altivec, but that is not required; hard-float > is sufficient for the code to build and function. > > Drop altivec from the compiler flags and adjust the enable/disable code > to only enable FPU

Re: [PATCH 0/4] KVM: Fold kvm_arch_sched_in() into kvm_arch_vcpu_load()

2024-04-30 Thread Oliver Upton
On Tue, Apr 30, 2024 at 12:31:53PM -0700, Sean Christopherson wrote: > Drop kvm_arch_sched_in() and instead pass a @sched_in boolean to > kvm_arch_vcpu_load(). > > While fiddling with an idea for optimizing state management on AMD CPUs, > I wanted to skip re-saving certain host state when a vCPU

Re: [PATCH v2] kprobe/ftrace: bail out if ftrace was killed

2024-04-30 Thread Stephen Brennan
Steven Rostedt writes: > On Mon, 29 Apr 2024 10:47:18 -0700 > Stephen Brennan wrote: > >> If an error happens in ftrace, ftrace_kill() will prevent disarming >> kprobes. Eventually, the ftrace_ops associated with the kprobes will be >> freed, yet the kprobes will still be active, and when

[RFC PATCH v2 6/6] powerpc/iommu: Implement the iommu_table_group_ops for pSeries

2024-04-30 Thread Shivaprasad G Bhat
PPC64 IOMMU API defines iommu_table_group_ops which handles DMA windows for PEs, their ownership transfer, create/set/unset the TCE tables for the Dynamic DMA wundows(DDW). VFIOS uses these APIs for support on POWER. The commit 9d67c9433509 "(powerpc/iommu: Add "borrowing" iommu_table_group_ops)"

[RFC PATCH v2 4/6] vfio/spapr: Always clear TCEs before unsetting the window

2024-04-30 Thread Shivaprasad G Bhat
The PAPR expects the TCE table to have no entries at the time of unset window(i.e. remove-pe). The TCE clear right now is done before freeing the iommu table. On pSeries, the unset window makes those entries inaccessible to the OS and the H_PUT/GET calls fail on them with H_CONSTRAINED. On

[RFC PATCH v2 5/6] powerpc/iommu: Move dev_has_iommu_table() to iommu.c

2024-04-30 Thread Shivaprasad G Bhat
Move function dev_has_iommu_table() to powerpc/kernel/iommu.c as it is going to be used by machine specific iommu code as well in subsequent patches. Signed-off-by: Shivaprasad G Bhat --- arch/powerpc/include/asm/iommu.h |1 + arch/powerpc/kernel/eeh.c| 16

[RFC PATCH v2 3/6] powerpc/pseries/iommu: Use the iommu table[0] for IOV VF's DDW

2024-04-30 Thread Shivaprasad G Bhat
This patch basically brings consistency with PowerNV approach to use the first freely available iommu table when the default window is removed. The pSeries iommu code convention has been that the table[0] is for the default 32 bit DMA window and the table[1] is for the 64 bit DDW. With VFs

[RFC PATCH v2 2/6] powerpc/pseries/iommu: Fix the VFIO_IOMMU_SPAPR_TCE_GET_INFO ioctl output

2024-04-30 Thread Shivaprasad G Bhat
The ioctl VFIO_IOMMU_SPAPR_TCE_GET_INFO is not reporting the actuals on the platform as not all the details are correctly collected during the platform probe/scan into the iommu_table_group. Collect the information during the device setup time as the DMA window property is already looked up on

[RFC PATCH v2 1/6] powerpc/iommu: Move pSeries specific functions to pseries/iommu.c

2024-04-30 Thread Shivaprasad G Bhat
The PowerNV specific table_group_ops are defined in powernv/pci-ioda.c. The pSeries specific table_group_ops are sitting in the generic powerpc file. Move it to where it actually belong(pseries/iommu.c). Only code movement, no functional changes intended. Signed-off-by: Shivaprasad G Bhat ---

[RFC PATCH v2 0/6] powerpc: pSeries: vfio: iommu: Re-enable support for SPAPR TCE VFIO

2024-04-30 Thread Shivaprasad G Bhat
RFC v1 was posted here [1]. As I was testing more and fixing the issues, I realized its clean to have the table_group_ops implemented the way it is done on PowerNV and stop 'borrowing' the DMA windows for pSeries. This patch-set implements the iommu table_group_ops for pSeries for VFIO SPAPR TCE

Re: [PATCH 13/13] ASoC: sunxi: Use snd_soc_substream_to_rtd() for accessing private_data

2024-04-30 Thread Jernej Škrabec
Dne torek, 30. april 2024 ob 16:02:22 GMT +2 je Krzysztof Kozlowski napisal(a): > Do not open-code snd_soc_substream_to_rtd(). > > Signed-off-by: Krzysztof Kozlowski Reviewed-by: Jernej Skrabec Best regards, Jernej > --- > sound/soc/sunxi/sun50i-dmic.c | 2 +- > 1 file changed, 1

[PATCH 4/4] KVM: Delete the now unused kvm_arch_sched_in()

2024-04-30 Thread Sean Christopherson
Delete kvm_arch_sched_in() now that all implementations are nops. Signed-off-by: Sean Christopherson --- arch/arm64/include/asm/kvm_host.h | 1 - arch/loongarch/include/asm/kvm_host.h | 1 - arch/mips/include/asm/kvm_host.h | 1 - arch/powerpc/include/asm/kvm_host.h | 1 -

[PATCH 3/4] KVM: x86: Fold kvm_arch_sched_in() into kvm_arch_vcpu_load()

2024-04-30 Thread Sean Christopherson
Fold the guts of kvm_arch_sched_in() into kvm_arch_vcpu_load(), keying off the recently added @sched_in as appropriate. Note, there is a very slight functional change, as PLE shrink updates will now happen after blasting WBINVD, but that is quite uninteresting. Signed-off-by: Sean Christopherson

[PATCH 2/4] KVM: VMX: Move PLE grow/shrink helpers above vmx_vcpu_load()

2024-04-30 Thread Sean Christopherson
Move VMX's {grow,shrink}_ple_window() above vmx_vcpu_load() in preparation of moving the sched_in logic, which handles shrinking the PLE window, into vmx_vcpu_load(). No functional change intended. Signed-off-by: Sean Christopherson --- arch/x86/kvm/vmx/vmx.c | 64

[PATCH 1/4] KVM: Plumb in a @sched_in flag to kvm_arch_vcpu_load()

2024-04-30 Thread Sean Christopherson
Add a @sched_in flag to kvm_arch_vcpu_load() to note that the vCPU is being (re)loaded by kvm_sched_in(), i.e. after the vCPU was previously scheduled out. KVM x86 currently uses a dedicated kvm_arch_sched_in() hook, but that's unnecessarily brittle as the behavior of the arch hook heavily

[PATCH 0/4] KVM: Fold kvm_arch_sched_in() into kvm_arch_vcpu_load()

2024-04-30 Thread Sean Christopherson
Drop kvm_arch_sched_in() and instead pass a @sched_in boolean to kvm_arch_vcpu_load(). While fiddling with an idea for optimizing state management on AMD CPUs, I wanted to skip re-saving certain host state when a vCPU is scheduled back in, as the state (theoretically) shouldn't change for the

Re: [PATCH v15 00/16] Add audio support in v4l2 framework

2024-04-30 Thread Mauro Carvalho Chehab
Em Tue, 30 Apr 2024 23:46:03 +0900 Mark Brown escreveu: > On Tue, Apr 30, 2024 at 10:21:12AM +0200, Sebastian Fricke wrote: > > > first of all thanks for all of this work and I am very sorry for only > > emerging this late into the series, I sadly didn't notice it earlier. > > It might be

Re: [PATCH v15 00/16] Add audio support in v4l2 framework

2024-04-30 Thread Jaroslav Kysela
On 30. 04. 24 16:46, Mark Brown wrote: So instead of hammering a driver into the wrong destination, I would suggest bundling our forces and implementing a general memory-to-memory framework that both the media and the audio subsystem can use, that addresses the current shortcomings of the

Re: [PATCH v15 00/16] Add audio support in v4l2 framework

2024-04-30 Thread Mark Brown
On Tue, Apr 30, 2024 at 10:21:12AM +0200, Sebastian Fricke wrote: > first of all thanks for all of this work and I am very sorry for only > emerging this late into the series, I sadly didn't notice it earlier. It might be worth checking out the discussion on earlier versions... > 1. The biggest

[PATCH] powerpc: Set _IO_BASE to POISON_POINTER_DELTA not 0 for CONFIG_PCI=n

2024-04-30 Thread Michael Ellerman
With -Wextra clang warns about pointer arithmetic using a null pointer. When building with CONFIG_PCI=n, that triggers a warning in the IO accessors, eg: In file included from linux/arch/powerpc/include/asm/io.h:672: linux/arch/powerpc/include/asm/io-defs.h:23:1: warning: performing pointer

[PATCH 13/13] ASoC: sunxi: Use snd_soc_substream_to_rtd() for accessing private_data

2024-04-30 Thread Krzysztof Kozlowski
Do not open-code snd_soc_substream_to_rtd(). Signed-off-by: Krzysztof Kozlowski --- sound/soc/sunxi/sun50i-dmic.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/sound/soc/sunxi/sun50i-dmic.c b/sound/soc/sunxi/sun50i-dmic.c index c76628bc86c6..fedfa4fc95fb 100644 ---

[PATCH 12/13] ASoC: samsung: Use snd_soc_substream_to_rtd() for accessing private_data

2024-04-30 Thread Krzysztof Kozlowski
Do not open-code snd_soc_substream_to_rtd(). Signed-off-by: Krzysztof Kozlowski --- sound/soc/samsung/midas_wm1811.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/sound/soc/samsung/midas_wm1811.c b/sound/soc/samsung/midas_wm1811.c index f31244156ff6..0841e2e6f8ce 100644

[PATCH 11/13] ASoC: meson: Use snd_soc_substream_to_rtd() for accessing private_data

2024-04-30 Thread Krzysztof Kozlowski
Do not open-code snd_soc_substream_to_rtd(). Signed-off-by: Krzysztof Kozlowski --- sound/soc/meson/aiu-fifo.c | 2 +- sound/soc/meson/axg-fifo.c | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/sound/soc/meson/aiu-fifo.c b/sound/soc/meson/aiu-fifo.c index

[PATCH 10/13] ASoC: mediatek: Use snd_soc_substream_to_rtd() for accessing private_data

2024-04-30 Thread Krzysztof Kozlowski
Do not open-code snd_soc_substream_to_rtd(). Signed-off-by: Krzysztof Kozlowski --- sound/soc/mediatek/mt7986/mt7986-afe-pcm.c | 4 ++-- sound/soc/mediatek/mt8186/mt8186-afe-pcm.c | 14 +++--- sound/soc/mediatek/mt8186/mt8186-mt6366.c | 2 +-

[PATCH 09/13] ASoC: loongson: Use snd_soc_substream_to_rtd() for accessing private_data

2024-04-30 Thread Krzysztof Kozlowski
Do not open-code snd_soc_substream_to_rtd(). Signed-off-by: Krzysztof Kozlowski --- sound/soc/loongson/loongson_card.c | 2 +- sound/soc/loongson/loongson_dma.c | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/sound/soc/loongson/loongson_card.c

[PATCH 08/13] ASoC: kirkwood: Use snd_soc_substream_to_rtd() for accessing private_data

2024-04-30 Thread Krzysztof Kozlowski
Do not open-code snd_soc_substream_to_rtd(). Signed-off-by: Krzysztof Kozlowski --- sound/soc/kirkwood/kirkwood-dma.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/sound/soc/kirkwood/kirkwood-dma.c b/sound/soc/kirkwood/kirkwood-dma.c index ef00792e1d49..036b42058272

[PATCH 07/13] ASoC: img: Use snd_soc_substream_to_rtd() for accessing private_data

2024-04-30 Thread Krzysztof Kozlowski
Do not open-code snd_soc_substream_to_rtd(). Signed-off-by: Krzysztof Kozlowski --- sound/soc/img/img-i2s-in.c | 2 +- sound/soc/img/img-i2s-out.c | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/sound/soc/img/img-i2s-in.c b/sound/soc/img/img-i2s-in.c index

[PATCH 06/13] ASoC: fsl: Use snd_soc_substream_to_rtd() for accessing private_data

2024-04-30 Thread Krzysztof Kozlowski
Do not open-code snd_soc_substream_to_rtd(). Signed-off-by: Krzysztof Kozlowski --- sound/soc/fsl/fsl-asoc-card.c | 2 +- sound/soc/fsl/imx-card.c | 6 +++--- sound/soc/fsl/imx-hdmi.c | 2 +- sound/soc/fsl/imx-pcm-rpmsg.c | 6 +++--- 4 files changed, 8 insertions(+), 8 deletions(-)

[PATCH 05/13] ASoC: amd: Use snd_soc_substream_to_rtd() for accessing private_data

2024-04-30 Thread Krzysztof Kozlowski
Do not open-code snd_soc_substream_to_rtd(). Signed-off-by: Krzysztof Kozlowski --- sound/soc/amd/acp/acp-mach-common.c | 2 +- sound/soc/amd/acp3x-rt5682-max9836.c | 2 +- sound/soc/amd/ps/ps-sdw-dma.c| 2 +- 3 files changed, 3 insertions(+), 3 deletions(-) diff --git

[PATCH 04/13] ASoC: arm: Use snd_soc_substream_to_rtd() for accessing private_data

2024-04-30 Thread Krzysztof Kozlowski
Do not open-code snd_soc_substream_to_rtd(). Signed-off-by: Krzysztof Kozlowski --- sound/arm/pxa2xx-pcm-lib.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/sound/arm/pxa2xx-pcm-lib.c b/sound/arm/pxa2xx-pcm-lib.c index 51d2ff80df16..571e9d909cdf 100644 ---

[PATCH 03/13] ASoC: ti: Use snd_soc_substream_to_rtd() for accessing private_data

2024-04-30 Thread Krzysztof Kozlowski
Do not open-code snd_soc_substream_to_rtd(). Signed-off-by: Krzysztof Kozlowski --- sound/soc/ti/omap-hdmi.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/sound/soc/ti/omap-hdmi.c b/sound/soc/ti/omap-hdmi.c index 4513b527ab97..639bc83f4263 100644 ---

[PATCH 01/13] ASoC: qcom: Use snd_soc_substream_to_rtd() for accessing private_data

2024-04-30 Thread Krzysztof Kozlowski
Do not open-code snd_soc_substream_to_rtd(). Signed-off-by: Krzysztof Kozlowski --- sound/soc/qcom/apq8016_sbc.c | 4 ++-- sound/soc/qcom/qdsp6/q6apm-dai.c | 2 +- sound/soc/qcom/sc7180.c | 10 +- sound/soc/qcom/sc7280.c | 12 ++--

[PATCH 00/13] ASoC: Use snd_soc_substream_to_rtd() for accessing private_data

2024-04-30 Thread Krzysztof Kozlowski
ase-commit: 82415cf72c7e224be7a6496f3a53c0b365c2fe9d change-id: 20240430-asoc-snd-substream-clean-924b717d8f54 Best regards, -- Krzysztof Kozlowski

[PATCH 02/13] ASoC: tegra: Use snd_soc_substream_to_rtd() for accessing private_data

2024-04-30 Thread Krzysztof Kozlowski
Do not open-code snd_soc_substream_to_rtd(). Signed-off-by: Krzysztof Kozlowski --- sound/soc/tegra/tegra_asoc_machine.c | 2 +- sound/soc/tegra/tegra_pcm.c | 6 +++--- 2 files changed, 4 insertions(+), 4 deletions(-) diff --git a/sound/soc/tegra/tegra_asoc_machine.c

Re: [PATCH v15 00/16] Add audio support in v4l2 framework

2024-04-30 Thread Mauro Carvalho Chehab
Em Tue, 30 Apr 2024 10:47:13 +0200 Hans Verkuil escreveu: > On 30/04/2024 10:21, Sebastian Fricke wrote: > > Hey Shengjiu, > > > > first of all thanks for all of this work and I am very sorry for only > > emerging this late into the series, I sadly didn't notice it earlier. > > > > I would

[PATCH v2] mm/gup: Fix hugepd handling in hugetlb rework

2024-04-30 Thread Peter Xu
Commit a12083d721d7 added hugepd handling for gup-slow, reusing gup-fast functions. follow_hugepd() correctly took the vma pointer in, however didn't pass it over into the lower functions, which was overlooked. The issue is gup_fast_hugepte() uses the vma pointer to make the correct decision on

Re: [PATCH v7 05/16] module: make module_memory_{alloc,free} more self-contained

2024-04-30 Thread Philippe Mathieu-Daudé
On 29/4/24 14:16, Mike Rapoport wrote: From: "Mike Rapoport (IBM)" Move the logic related to the memory allocation and freeing into module_memory_alloc() and module_memory_free(). Signed-off-by: Mike Rapoport (IBM) --- kernel/module/main.c | 64 +++-

[PATCH 1/1] ALSA: aoa: soundbus: i2sbus: pcm: use 'time_left' variable with wait_for_completion_timeout()

2024-04-30 Thread Wolfram Sang
There is a confusing pattern in the kernel to use a variable named 'timeout' to store the result of wait_for_completion_timeout() causing patterns like: timeout = wait_for_completion_timeout(...) if (!timeout) return -ETIMEDOUT; with all kinds of permutations. Use 'time_left' as

Re: [EXT] [PATCH v8 6/6] docs: trusted-encrypted: add DCP as new trust source

2024-04-30 Thread David Gstir
Hi Jarkko, > On 30.04.2024, at 13:48, Kshitiz Varshney wrote: > > Hi David, > >> -Original Message- >> From: David Gstir >> Sent: Monday, April 29, 2024 5:05 PM >> To: Kshitiz Varshney >> >> Did you get around to testing this? >> I’d greatly appreciate a Tested-by for this. :-) >>

Re: [PATCH v3 2/2] fs/xattr: add *at family syscalls

2024-04-30 Thread Jan Kara
On Fri 26-04-24 18:20:14, Christian Göttsche wrote: > From: Christian Göttsche > > Add the four syscalls setxattrat(), getxattrat(), listxattrat() and > removexattrat(). Those can be used to operate on extended attributes, > especially security related ones, either relative to a pinned

RE: [EXT] [PATCH v8 6/6] docs: trusted-encrypted: add DCP as new trust source

2024-04-30 Thread Kshitiz Varshney
Hi David, > -Original Message- > From: David Gstir > Sent: Monday, April 29, 2024 5:05 PM > To: Kshitiz Varshney > Cc: Jarkko Sakkinen ; Mimi Zohar > ; James Bottomley ; Herbert > Xu ; David S. Miller > ; Shawn Guo ; Jonathan > Corbet ; Sascha Hauer ; > ker...@pengutronix.de; Fabio

Re: [PATCH v15 00/16] Add audio support in v4l2 framework

2024-04-30 Thread Hans Verkuil
On 30/04/2024 10:21, Sebastian Fricke wrote: > Hey Shengjiu, > > first of all thanks for all of this work and I am very sorry for only > emerging this late into the series, I sadly didn't notice it earlier. > > I would like to voice a few concerns about the general idea of adding > Audio support