Re: [PATCH 1/5] crypto: sha256 - remove duplicate generic hash init function

2021-12-22 Thread Julian Calaby
p, Aren't these two functions defined as static inline functions? It appears that these crypto_ wrappers were added so there's "actual" referenceable functions for these structs. Did this actually compile? Thanks, -- Julian Calaby Email: julian.cal...@gmail.com Profile: http://www.google.com/profiles/julian.calaby/

Re: [patch V2 11/15] completion: Use simple wait queues

2020-03-19 Thread Julian Calaby
pr_info("%s(): freeing\n", __func__); > ffs_data_clear(ffs); > BUG_ON(waitqueue_active(>ev.waitq) || > - waitqueue_active(>ep0req_completion.wait) || > + swait_active(>ep0req_complet

Re: [PATCH 16/67] powerpc: rename dma_direct_ to dma_nommu_

2018-01-03 Thread Julian Calaby
>> The address on the device side is sometimes (often?) offset from the CPU >> address. So eg. the device can DMA to RAM address 0x0 using address >> 0x800. >> >> Identity would imply 0 == 0 etc. >> >> I think "bijective" is the co

Re: [PATCH 17/67] microblaze: rename dma_direct to dma_microblaze

2017-12-29 Thread Julian Calaby
Hi Christoph, On Fri, Dec 29, 2017 at 7:18 PM, Christoph Hellwig <h...@lst.de> wrote: > This frees the dma_direct_* namespace for a generic implementation. Don't you mean "dma_nommu" not "dma_microblaze" in the subject line? Thanks, -- Julian Calaby Email: ju

Re: [PATCH 28/44] sparc: remove arch specific dma_supported implementations

2017-06-08 Thread Julian Calaby
nc_sg_for_cpu= sbus_sync_sg_for_cpu, > .sync_sg_for_device = sbus_sync_sg_for_device, > + .dma_supported = sbus_dma_supported, > }; > > static int __init sparc_register_ioport(void) Thanks, -- Julian Calaby Email: julian.cal...@gmail.com Profile: http://www.google.com/profiles/julian.calaby/

Re: [PATCH v4 0/3] checkpatch: handling of memory barriers

2016-01-11 Thread Julian Calaby
orrect memory barrier usage. >> >> This replaces the checkpatch patches in my series >> arch: barrier cleanup + barriers for virt >> and will be included in the pull request including >> the series. >> >> changes from v3: >> rename smp_barrier

Re: [PATCH v3 3/3] checkpatch: add virt barriers

2016-01-11 Thread Julian Calaby
Hi Michael, On Mon, Jan 11, 2016 at 9:35 PM, Michael S. Tsirkin <m...@redhat.com> wrote: > On Sun, Jan 10, 2016 at 02:52:16PM -0800, Joe Perches wrote: >> On Mon, 2016-01-11 at 09:13 +1100, Julian Calaby wrote: >> > On Mon, Jan 11, 2016 at 6:31 AM, Michael S. Tsirkin <m

Re: [PATCH v3 3/3] checkpatch: add virt barriers

2016-01-10 Thread Julian Calaby
sense to write this as: (?:smp|virt)_(?:$smp_barrier_stems) Thanks, -- Julian Calaby Email: julian.cal...@gmail.com Profile: http://www.google.com/profiles/julian.calaby/ ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [PATCH 0/5 v3] Fix NVMe driver support on Power with 32-bit DMA

2015-10-27 Thread Julian Calaby
error kind of thing? It will only fail on > architectures that actually build the NVME driver (as the only caller). > But I'm not sure how exactly to achieve that, if you could give a bit > more detail I'd appreciate it! He's suggesting that you _don't_ put a generic implementation in /incl

Re: [PATCH 0/5 v3] Fix NVMe driver support on Power with 32-bit DMA

2015-10-27 Thread Julian Calaby
Hi Nishanth, On Wed, Oct 28, 2015 at 10:40 AM, Nishanth Aravamudan <n...@linux.vnet.ibm.com> wrote: > On 28.10.2015 [09:57:48 +1100], Julian Calaby wrote: >> Hi Nishanth, >> >> On Wed, Oct 28, 2015 at 9:20 AM, Nishanth Aravamudan >> <n...@linux.vnet.ibm.com&

Re: RFC: prepare for struct scatterlist entries without page backing

2015-08-13 Thread Julian Calaby
Hi Christoph, On Fri, Aug 14, 2015 at 12:35 AM, Christoph Hellwig h...@lst.de wrote: On Thu, Aug 13, 2015 at 09:37:37AM +1000, Julian Calaby wrote: I.e. ~90% of this patch set seems to be just mechanically dropping BUG_ON()s and converting open coded stuff to use accessor functions (which

Re: RFC: prepare for struct scatterlist entries without page backing

2015-08-12 Thread Julian Calaby
the open coded stuff to accessor functions, then another to do the actual page-less sg stuff? Thanks, -- Julian Calaby Email: julian.cal...@gmail.com Profile: http://www.google.com/profiles/julian.calaby/ ___ Linuxppc-dev mailing list Linuxppc-dev

Re: [PATCH] of: return NUMA_NO_NODE from fallback of_node_to_nid()

2015-04-08 Thread Julian Calaby
[8118574c] new_slab+0x30c/0x3c0 [0.028000] RSP 88007d3dfc28 [0.028039] ---[ end trace f03690e70d7e4be6 ]--- Shouldn't this be in the commit message? Thanks, -- Julian Calaby Email: julian.cal...@gmail.com Profile: http://www.google.com/profiles/julian.calaby

Re: [PATCH v2 2/3] kernel/reboot.c: Add orderly_reboot for graceful reboot

2015-04-01 Thread Julian Calaby
be in a separate patch? Thanks, -- Julian Calaby Email: julian.cal...@gmail.com Profile: http://www.google.com/profiles/julian.calaby/ ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [BUG Fix Patch 1/6] Bug fix: Hold spinlock across find|remove /sys/firmware/memmap/X operation.

2013-01-15 Thread Julian Calaby
on failure. Why not make this completely kernel-doc compliant as you're already re-writing the comment? Thanks, -- Julian Calaby Email: julian.cal...@gmail.com Profile: http://www.google.com/profiles/julian.calaby/ .Plan: http://sites.google.com/site/juliancalaby

Re: [RFC PATCH 00/12] Merge common OpenFirmware device tree code

2009-10-06 Thread Julian Calaby
, and keep going. Thanks, -- Julian Calaby Email: julian.cal...@gmail.com .Plan: http://sites.google.com/site/juliancalaby/ ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: leds: Add openfirmware platform device support breaks sparc

2009-03-03 Thread Julian Calaby
to the sparc includes. These inconsistencies are causing more problems with PPC drivers depending on the generic infrastructure. See: http://lkml.org/lkml/2009/1/11/376 for a similar issue. Thanks, -- Julian Calaby Email: julian.cal...@gmail.com .Plan: http://sites.google.com/site/juliancalaby

Re: [PATCH] mb862xx: Restrict compliation of platform driver to PPC

2009-01-19 Thread Julian Calaby
Ping? Does anyone maintain this driver? (akpm: Sorry for cc'ing you on this, I'm not sure who else to send it to) On Mon, Jan 12, 2009 at 11:06, Julian Calaby julian.cal...@gmail.com wrote: mb862xx: Restrict compliation of platform driver to PPC The OpenFirmware part of this driver

Re: [PATCH] mb862xx: Restrict compliation of platform driver to PPC

2009-01-19 Thread Julian Calaby
with the same compiler. 2. These two platforms have slightly different OpenFirmware interfaces - so fixing it for both of these will be a pain. Thanks, -- Julian Calaby Email: julian.cal...@gmail.com .Plan: https://sites.google.com/site/juliancalaby

[PATCH] mb862xx: Restrict compliation of platform driver to PPC

2009-01-11 Thread Julian Calaby
to send this patch. 5. Please note that I am not a member of any of these lists, so please keep me CC'd. Thanks, Julian Calaby --- drivers/video/Kconfig |1 + 1 files changed, 1 insertions(+), 0 deletions(-) diff --git a/drivers/video/Kconfig b/drivers/video/Kconfig index 6372f8b..8f18169