Re: [PATCH v3 0/7] include: add setbits32/clrbits32/clrsetbits32/setbits64/clrbits64/clrsetbits64

2018-11-15 Thread LABBE Corentin
On Thu, Nov 15, 2018 at 09:33:48AM +, Russell King - ARM Linux wrote: > On Thu, Nov 15, 2018 at 10:30:34AM +0100, LABBE Corentin wrote: > > On Wed, Oct 24, 2018 at 09:57:00AM +0100, Russell King - ARM Linux wrote: > > > On Wed, Oct 24, 2018 at 07:35:46AM +, Co

Re: [PATCH v3 0/7] include: add setbits32/clrbits32/clrsetbits32/setbits64/clrbits64/clrsetbits64

2018-11-15 Thread LABBE Corentin
On Wed, Oct 24, 2018 at 09:57:00AM +0100, Russell King - ARM Linux wrote: > On Wed, Oct 24, 2018 at 07:35:46AM +, Corentin Labbe wrote: > > This patchset adds a new set of functions which are open-coded in lot of > > place. > > Basicly the pattern is always the same, "read, modify a bit,

Re: [PATCH v2 2/7] include: add setbits32/clrbits32/clrsetbits32/setbits64/clrbits64/clrsetbits64 in linux/setbits.h

2018-09-26 Thread LABBE Corentin
On Tue, Sep 25, 2018 at 07:05:00AM +0200, Christophe LEROY wrote: > > > Le 24/09/2018 à 21:04, Corentin Labbe a écrit : > > This patch adds setbits32/clrbits32/clrsetbits32 and > > setbits64/clrbits64/clrsetbits64 in linux/setbits.h header. > > Fix the patch subject and description. > > > > >

Re: [PATCH v2 1/7] powerpc: rename setbits32/clrbits32 to setbits32_be/clrbits32_be

2018-09-26 Thread LABBE Corentin
On Tue, Sep 25, 2018 at 06:56:23AM +0200, Christophe LEROY wrote: > Fix the patch title. > > > Le 24/09/2018 à 21:04, Corentin Labbe a écrit : > > Since setbits32/clrbits32 work on be32, it's better to remove ambiguity on > > the used data type. > > > > Signed-off-by: Corentin Labbe > > --- >

Re: [PATCH 2/5] include: add setbits32/clrbits32/clrsetbits32/setbits64/clrbits64/clrsetbits64 in linux/setbits.h

2018-09-10 Thread LABBE Corentin
On Mon, Sep 10, 2018 at 07:22:04AM +0200, Christophe LEROY wrote: > > > Le 07/09/2018 à 21:41, Corentin Labbe a écrit : > > This patch adds setbits32/clrbits32/clrsetbits32 and > > setbits64/clrbits64/clrsetbits64 in linux/setbits.h header. > > So you changed the name of setbits32() ... to

Re: [PATCH 1/5] powerpc: rename setbits32/clrbits32 to setbits32_be/clrbits32_be

2018-09-10 Thread LABBE Corentin
On Mon, Sep 10, 2018 at 07:16:56AM +0200, Christophe LEROY wrote: > > > Le 07/09/2018 à 21:41, Corentin Labbe a écrit : > > Since setbits32/clrbits32 work on be32, it's better to remove ambiguity on > > the used data type. > > Wouldn't it be better to call them setbits_be32() / clrbits_be32()

Re: [PATCH 2/5] include: add setbits32/clrbits32/clrsetbits32/setbits64/clrbits64/clrsetbits64 in linux/setbits.h

2018-09-10 Thread LABBE Corentin
On Fri, Sep 07, 2018 at 03:00:40PM -0500, Scott Wood wrote: > On Fri, 2018-09-07 at 19:41 +, Corentin Labbe wrote: > > This patch adds setbits32/clrbits32/clrsetbits32 and > > setbits64/clrbits64/clrsetbits64 in linux/setbits.h header. > > > > Signed-off-by: Corentin Labbe > > --- > >

Re: [PATCH] hwrng: pasemi_rng.c: Migrate to managed API

2016-08-25 Thread LABBE Corentin
On Thu, Aug 25, 2016 at 05:04:16PM +0530, PrasannaKumar Muralidharan wrote: > Use devm_ioremap and devm_hwrng_register instead of ioremap and > hwrng_register. This removes unregistering and error handling code. > > This patch is not tested with hardware as I don't have access to it. > >

Re: input: i8042: build failure on powerpc

2015-11-13 Thread LABBE Corentin
On Thu, Nov 12, 2015 at 07:41:17AM -0800, Guenter Roeck wrote: > On Thu, Nov 12, 2015 at 04:01:45PM +0100, LABBE Corentin wrote: > > Hello > > > > I have made a random .config for testing my powerpc cross-compiler and I > > got this fail: > > > > In

[PATCH 2/6] crypto: md5: use md5 IV MD5_HX instead of their raw value

2015-05-17 Thread LABBE Corentin
Since MD5 IV are now available in crypto/md5.h, use them. Signed-off-by: LABBE Corentin clabbe.montj...@gmail.com --- crypto/md5.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/crypto/md5.c b/crypto/md5.c index 36f5e5b..33d17e9 100644 --- a/crypto/md5.c +++ b/crypto

[PATCH 1/6] crypto: md5: add MD5 initial vectors

2015-05-17 Thread LABBE Corentin
This patch simply adds the MD5 IV in the md5 header. Signed-off-by: LABBE Corentin clabbe.montj...@gmail.com --- include/crypto/md5.h | 5 + 1 file changed, 5 insertions(+) diff --git a/include/crypto/md5.h b/include/crypto/md5.h index 65f299b..146af82 100644 --- a/include/crypto/md5.h

[PATCH 3/6] crypto: powerpc/md5: use md5 IV MD5_HX instead of their raw value

2015-05-17 Thread LABBE Corentin
Since MD5 IV are now available in crypto/md5.h, use them. Signed-off-by: LABBE Corentin clabbe.montj...@gmail.com --- arch/powerpc/crypto/md5-glue.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/arch/powerpc/crypto/md5-glue.c b/arch/powerpc/crypto/md5-glue.c index

[PATCH 5/6] crypto: n2: use md5 IV MD5_HX instead of their raw value

2015-05-17 Thread LABBE Corentin
Since MD5 IV are now available in crypto/md5.h, use them. Signed-off-by: LABBE Corentin clabbe.montj...@gmail.com --- drivers/crypto/n2_core.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/crypto/n2_core.c b/drivers/crypto/n2_core.c index 10a9aef..2e8dab9

[PATCH 4/6] crypto: sparc/md5: use md5 IV MD5_HX instead of their raw value

2015-05-17 Thread LABBE Corentin
Since MD5 IV are now available in crypto/md5.h, use them. Signed-off-by: LABBE Corentin clabbe.montj...@gmail.com --- arch/sparc/crypto/md5_glue.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/arch/sparc/crypto/md5_glue.c b/arch/sparc/crypto/md5_glue.c index b688731

[PATCH 6/6] crypto: octeon: use md5 IV MD5_HX instead of their raw value

2015-05-17 Thread LABBE Corentin
Since MD5 IV are now available in crypto/md5.h, use them. Signed-off-by: LABBE Corentin clabbe.montj...@gmail.com --- arch/mips/cavium-octeon/crypto/octeon-md5.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/arch/mips/cavium-octeon/crypto/octeon-md5.c b/arch/mips