Re: [PATCH v7 00/16] mm: jit/text allocator

2024-05-03 Thread Liviu Dudau
On Fri, May 03, 2024 at 09:28:25AM +0300, Mike Rapoport wrote: > On Fri, May 03, 2024 at 01:23:30AM +0100, Liviu Dudau wrote: > > On Thu, May 02, 2024 at 04:07:05PM -0700, Luis Chamberlain wrote: > > > On Thu, May 02, 2024 at 11:50:36PM +0100, Liviu Dudau wrote: > > > &

Re: [PATCH v7 00/16] mm: jit/text allocator

2024-05-02 Thread Liviu Dudau
On Thu, May 02, 2024 at 04:07:05PM -0700, Luis Chamberlain wrote: > On Thu, May 02, 2024 at 11:50:36PM +0100, Liviu Dudau wrote: > > On Mon, Apr 29, 2024 at 09:29:20AM -0700, Luis Chamberlain wrote: > > > On Mon, Apr 29, 2024 at 03:16:04PM +0300, Mike Rapoport wrote: > >

Re: [PATCH v7 00/16] mm: jit/text allocator

2024-05-02 Thread Liviu Dudau
On Mon, Apr 29, 2024 at 09:29:20AM -0700, Luis Chamberlain wrote: > On Mon, Apr 29, 2024 at 03:16:04PM +0300, Mike Rapoport wrote: > > From: "Mike Rapoport (IBM)" > > > > Hi, > > > > The patches are also available in git: > >

Re: [PATCH] Fix typo reigster to register

2019-07-29 Thread Liviu Dudau
m/malidp_regs.h > @@ -145,7 +145,7 @@ > #define MALIDP_SE_COEFFTAB_DATA_MASK 0x3fff > #define MALIDP_SE_SET_COEFFTAB_DATA(x) \ > ((x) & MALIDP_SE_COEFFTAB_DATA_MASK) > -/* Enhance coeffents reigster offset */ > +/* Enhance coeffents register off

Re: [PATCH v3 21/21] docs: hwmon: Add an index file and rename docs to *.rst

2019-04-17 Thread Liviu Dudau
.../hwmon/{smsc47m192 => smsc47m192.rst} | 0 > ...mitting-patches => submitting-patches.rst} | 6 +- > .../{sysfs-interface => sysfs-interface.rst} | 0 > Documentation/hwmon/{tc654 => tc654.rst} | 0 > Documentation/hwmon/{tc74 => tc74.rst}| 0

Re: [PATCH v2 21/21] docs: hwmon: Add an index file and rename docs to *.rst

2019-04-11 Thread Liviu Dudau
rename Documentation/hwmon/{sch5627 => sch5627.rst} (100%) > rename Documentation/hwmon/{sch5636 => sch5636.rst} (100%) > rename Documentation/hwmon/{scpi-hwmon => scpi-hwmon.rst} (100%) > rename Documentation/hwmon/{sht15 => sht15.rst} (100%) > rename Documentation

Re: [RFC PATCH 07/16] PCI: Separate pci_host_bridge creation out of pci_create_root_bus()

2014-11-21 Thread Liviu Dudau
On Fri, Nov 21, 2014 at 02:53:01AM +, Yijing Wang wrote: pci_create_host_bridge() can get pci_host_bridge ops while pci_create_root_bus() gets the bus ops. For find out the MSI controller, the domain number and any other HB specific stuff, you use the HB ops. For config R/W acceses

Re: [RFC PATCH 07/16] PCI: Separate pci_host_bridge creation out of pci_create_root_bus()

2014-11-20 Thread Liviu Dudau
On Thu, Nov 20, 2014 at 02:47:35AM +, Yijing Wang wrote: +static void pci_release_host_bridge_dev(struct device *dev) +{ + struct pci_host_bridge *bridge = to_pci_host_bridge(dev); + + if (bridge-release_fn) + bridge-release_fn(bridge); +

Re: [RFC PATCH 00/16] Refine PCI host bridge scan interfaces

2014-11-20 Thread Liviu Dudau
On Thu, Nov 20, 2014 at 12:54:48PM +0100, Tomasz Nowicki wrote: On 17.11.2014 15:13, Arnd Bergmann wrote: On Monday 17 November 2014 18:21:34 Yijing Wang wrote: This series is based Linux 3.18-rc1 and Lorenzo Pieralisi's arm PCI domain cleanup patches, link:

Re: [RFC PATCH 00/16] Refine PCI host bridge scan interfaces

2014-11-20 Thread Liviu Dudau
On Thu, Nov 20, 2014 at 01:53:48PM +0100, Tomasz Nowicki wrote: On 20.11.2014 13:08, Liviu Dudau wrote: On Thu, Nov 20, 2014 at 12:54:48PM +0100, Tomasz Nowicki wrote: On 17.11.2014 15:13, Arnd Bergmann wrote: On Monday 17 November 2014 18:21:34 Yijing Wang wrote: This series is based Linux

Re: [RFC PATCH 07/16] PCI: Separate pci_host_bridge creation out of pci_create_root_bus()

2014-11-19 Thread Liviu Dudau
On Wed, Nov 19, 2014 at 10:24:52AM +0800, Yijing Wang wrote: We need, some platforms pass NULL pointer as host bridge parent. Yijing, May I suggest a different approach here? Rather than having to pass an opaque pointer that gets converted by the host bridge driver back to the

Re: [RFC PATCH 07/16] PCI: Separate pci_host_bridge creation out of pci_create_root_bus()

2014-11-19 Thread Liviu Dudau
On Wed, Nov 19, 2014 at 01:42:52AM +, Yijing Wang wrote: On 2014/11/18 23:30, Liviu Dudau wrote: On Mon, Nov 17, 2014 at 10:21:41AM +, Yijing Wang wrote: There are some common PCI infos like domain, msi_controller, these infos are saved in arch PCI sysdata, and lots arch specific

Re: [RFC PATCH 08/16] PCI: Introduce pci_scan_host_bridge() and pci_host_info

2014-11-19 Thread Liviu Dudau
On Wed, Nov 19, 2014 at 02:09:12AM +, Yijing Wang wrote: struct pci_host_bridge *pci_create_host_bridge( - struct device *parent, u32 db, - struct pci_ops *ops, void *sysdata, - struct list_head *resources) + struct device *parent, u32 db,

Re: [RFC PATCH 02/16] PCI: Use pci_scan_root_bus() instead of pci_scan_bus()

2014-11-18 Thread Liviu Dudau
On Mon, Nov 17, 2014 at 10:21:36AM +, Yijing Wang wrote: From: Yijing Wang wangyijing0...@gmail.com Now we could use pci_scan_root_bus() instead of pci_scan_bus(), pass NULL resources means use the default io/mem. Actually, I think this patch goes in the wrong direction. You are adding

Re: [RFC PATCH 01/16] PCI: Enhance pci_scan_root_bus() to support default IO/MEM resources

2014-11-18 Thread Liviu Dudau
On Tue, Nov 18, 2014 at 11:46:06AM +, Yijing Wang wrote: On 2014/11/18 17:36, Arnd Bergmann wrote: On Tuesday 18 November 2014 15:44:23 Yijing Wang wrote: On 2014/11/17 18:08, Arnd Bergmann wrote: On Monday 17 November 2014 18:21:35 Yijing Wang wrote: -

Re: [RFC PATCH 04/16] PCI: Rip out pci_bus_add_devices() from pci_scan_root_bus()

2014-11-18 Thread Liviu Dudau
On Mon, Nov 17, 2014 at 10:21:38AM +, Yijing Wang wrote: Rip out pci_bus_add_devices() from pci_scan_root_bus() for following reasons. 1. pci_scan_root_bus() means we only do the scan, we should not add pci busses. 2. A lots of drviers which use pci_scan_root_bus() call

Re: [RFC PATCH 07/16] PCI: Separate pci_host_bridge creation out of pci_create_root_bus()

2014-11-18 Thread Liviu Dudau
On Tue, Nov 18, 2014 at 08:32:26AM +, Yijing Wang wrote: +LIST_HEAD(pci_host_bridge_list); +DECLARE_RWSEM(pci_host_bridge_sem); Unless the pci_host_bridge_sem is accessed thousands of times per second, it's normally better to use a simple mutex instead. OK, I will use simple

Re: [RFC PATCH 07/16] PCI: Separate pci_host_bridge creation out of pci_create_root_bus()

2014-11-18 Thread Liviu Dudau
On Mon, Nov 17, 2014 at 10:21:41AM +, Yijing Wang wrote: There are some common PCI infos like domain, msi_controller, these infos are saved in arch PCI sysdata, and lots arch specific functions like pci_domain_nr() and pcibios_msi_controller() required. We could separate pci_host_bridge

Re: [RFC PATCH 08/16] PCI: Introduce pci_scan_host_bridge() and pci_host_info

2014-11-18 Thread Liviu Dudau
On Mon, Nov 17, 2014 at 10:21:42AM +, Yijing Wang wrote: From: Yijing Wang wangyijing0...@gmail.com Now pci_host_bridge has been ripped out from pci root bus creation. Currently pci_scan_root_bus() lacks scalability, so platform host drivers have no proper way to configure

Re: [PATCH v2 00/22] Use MSI chip framework to configure MSI/MSI-X in all platforms

2014-09-29 Thread Liviu Dudau
On Mon, Sep 29, 2014 at 09:44:17AM +0800, Yijing Wang wrote: On 2014/9/28 19:21, Liviu Dudau wrote: On Sun, Sep 28, 2014 at 10:16:12AM +0800, Yijing Wang wrote: What I would like to see is a way of creating the pci_host_bridge structure outside the pci_create_root_bus(). That would

Re: [PATCH v2 00/22] Use MSI chip framework to configure MSI/MSI-X in all platforms

2014-09-28 Thread Liviu Dudau
On Sun, Sep 28, 2014 at 10:16:12AM +0800, Yijing Wang wrote: What I would like to see is a way of creating the pci_host_bridge structure outside the pci_create_root_bus(). That would then allow us to pass this sort of platform details like associated msi_chip into the host bridge and

Re: [PATCH v2 00/22] Use MSI chip framework to configure MSI/MSI-X in all platforms

2014-09-26 Thread Liviu Dudau
On Fri, Sep 26, 2014 at 11:42:23AM +0800, Yijing Wang wrote: I am actually in disagreement with you, Thierry. I don't like the general direction of the patches, or at least I don't like the fact that we don't have a portable way of setting up the msi_chip without having to rely on weak

Re: [PATCH v2 00/22] Use MSI chip framework to configure MSI/MSI-X in all platforms

2014-09-25 Thread Liviu Dudau
On Thu, Sep 25, 2014 at 09:42:36AM +0200, Thierry Reding wrote: On Thu, Sep 25, 2014 at 11:14:10AM +0800, Yijing Wang wrote: This series is based Bjorn's pci/msi branch git://git.kernel.org/pub/scm/linux/kernel/git/helgaas/pci.git pci/msi Currently, there are a lot of weak arch functions

Re: [PATCH v2 00/22] Use MSI chip framework to configure MSI/MSI-X in all platforms

2014-09-25 Thread Liviu Dudau
On Thu, Sep 25, 2014 at 06:49:38PM +0200, Thierry Reding wrote: On Thu, Sep 25, 2014 at 03:48:55PM +0100, Liviu Dudau wrote: On Thu, Sep 25, 2014 at 09:42:36AM +0200, Thierry Reding wrote: On Thu, Sep 25, 2014 at 11:14:10AM +0800, Yijing Wang wrote: This series is based Bjorn's pci/msi