RE: [PATCH v9 06/10] PCI: dwc: ep: Call dw_pcie_ep_init_registers() API directly from all glue drivers

2024-03-08 Thread Yoshihiro Shimoda
/pcie-rcar-gen4.c | 12 +++- Thank you for the patch! About pcie-rcar-gen4.c, Reviewed-by: Yoshihiro Shimoda Best regards, Yoshihiro Shimoda > drivers/pci/controller/dwc/pcie-uniphier-ep.c | 13 - > 10 files changed, 90 insertions(+), 26 deletions(-) > > dif

RE: [PATCH v9 02/10] PCI: dwc: ep: Rename dw_pcie_ep_exit() to dw_pcie_ep_deinit()

2024-03-08 Thread Yoshihiro Shimoda
einit() to make the > purpose of this API clear. This also aligns with the DWC host driver. > > Reviewed-by: Frank Li > Signed-off-by: Manivannan Sadhasivam Thank you for the patch! Reviewed-by: Yoshihiro Shimoda Best regards, Yoshihiro Shimoda > --- > drivers/pci/contro

RE: [PATCH v9 01/10] PCI: dwc: ep: Remove deinit() callback from struct dw_pcie_ep_ops

2024-03-08 Thread Yoshihiro Shimoda
> of dw_pcie_ep_exit() API in rcar_gen4_remove_dw_pcie_ep(). > > This simplifies the DWC layer. > > Reviewed-by: Frank Li > Signed-off-by: Manivannan Sadhasivam Thank you for the patch! Reviewed-by: Yoshihiro Shimoda Best regards, Yoshihiro Shimoda > --- > drivers/pci/controller/dwc

RE: [PATCH 3/3] PCI: dwc: Add dw_pcie_ep_{read,write}_dbi[2] helpers

2023-11-13 Thread Yoshihiro Shimoda
Hello Serge, > From: Serge Semin, Sent: Monday, November 13, 2023 9:41 PM > > On Mon, Nov 13, 2023 at 10:33:00AM +0900, Yoshihiro Shimoda wrote: > > The current code calculated some dbi[2] registers' offset by calling > > dw_pcie_ep_get_dbi[2]_offset() in each func

RE: [PATCH 0/3] PCI: dwc: Improve code readability

2023-11-13 Thread Yoshihiro Shimoda
ore.kernel.org/linux-pci/20230814230008.GA196797@bhelgaas/ I got it. I'll include the following patch on v2. https://lore.kernel.org/linux-pci/20230814-void-drivers-pci-controller-pcie-iproc-platform-v1-1-81a121607...@google.com/ Best regards, Yoshihiro Shimoda > > Krzysztof

RE: [PATCH 1/3] PCI: dwc: Rename to .init in struct dw_pcie_ep_ops

2023-11-13 Thread Yoshihiro Shimoda
Hi Serge, > From: Serge Semin, Sent: Monday, November 13, 2023 7:15 PM > > Hi Yoshihiro. > > On Mon, Nov 13, 2023 at 10:32:58AM +0900, Yoshihiro Shimoda wrote: > > Since the name of dw_pcie_ep_ops indicates that it's for ep obviously, > > rename a member .ep

RE: [PATCH 0/3] PCI: dwc: Improve code readability

2023-11-13 Thread Yoshihiro Shimoda
tr_t should fix the issue as well. I confirmed that the uintptr_t fixed the issue. I also think that adding a new struct with the mode is overkill. So, I would like to fix the issue by using the cast of uintptr_t. Best regards, Yoshihiro Shimoda > Gr{oetje,eeting}s, > >

[PATCH 3/3] PCI: dwc: Add dw_pcie_ep_{read,write}_dbi[2] helpers

2023-11-12 Thread Yoshihiro Shimoda
The current code calculated some dbi[2] registers' offset by calling dw_pcie_ep_get_dbi[2]_offset() in each function. To improve code readability, add dw_pcie_ep_{read,write}_dbi[2} and some data-width related helpers. Signed-off-by: Yoshihiro Shimoda --- .../pci/controller/dwc/pcie-designware

[PATCH 1/3] PCI: dwc: Rename to .init in struct dw_pcie_ep_ops

2023-11-12 Thread Yoshihiro Shimoda
Since the name of dw_pcie_ep_ops indicates that it's for ep obviously, rename a member .ep_init to .init. Signed-off-by: Yoshihiro Shimoda --- drivers/pci/controller/dwc/pci-dra7xx.c | 2 +- drivers/pci/controller/dwc/pci-imx6.c | 2 +- drivers/pci/controller/dwc/pci

[PATCH 2/3] PCI: dwc: Rename to .get_dbi_offset in struct dw_pcie_ep_ops

2023-11-12 Thread Yoshihiro Shimoda
Since meaning of .func_conf_select is difficult to understand, rename it to .get_dbi_offset. Signed-off-by: Yoshihiro Shimoda --- .../pci/controller/dwc/pci-layerscape-ep.c| 5 +- .../pci/controller/dwc/pcie-designware-ep.c | 108 +- drivers/pci/controller/dwc/pcie

[PATCH 0/3] PCI: dwc: Improve code readability

2023-11-12 Thread Yoshihiro Shimoda
linux.git/commit/?id=9baa8a18e31b7167885c11c38841ce92bbe20f4f [2] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=7873b49b41b92edb3395bff9a528eaf89da5e41c Yoshihiro Shimoda (3): PCI: dwc: Rename to .init in struct dw_pcie_ep_ops PCI: dwc: Rename to .get_dbi_offset in struct dw_pcie_ep

RE: [PATCH 08/20] dt-bindings: usb: renesas-xhci: Refer to the usb-xhci.yaml file

2020-10-20 Thread Yoshihiro Shimoda
dated > against the Generic xHCI DT schema. > > Signed-off-by: Serge Semin > --- Thank you for the patch! Reviewed-by: Yoshihiro Shimoda Best regards, Yoshihiro Shimoda