Re: [PATCH 2/3] powerpc/module32: Use symbolic instructions names.

2019-05-02 Thread Christophe Leroy
Le 29/04/2019 à 13:54, Segher Boessenkool a écrit : On Mon, Apr 29, 2019 at 10:43:27AM +, Christophe Leroy wrote: To increase readability/maintainability, replace hard coded instructions values by symbolic names. + /* lis r12,sym@ha */ +#define ENTRY_JMP0(sym)

Re: [PATCH 2/3] powerpc/module32: Use symbolic instructions names.

2019-04-29 Thread Segher Boessenkool
On Mon, Apr 29, 2019 at 10:43:27AM +, Christophe Leroy wrote: > To increase readability/maintainability, replace hard coded > instructions values by symbolic names. > + /* lis r12,sym@ha */ > +#define ENTRY_JMP0(sym) (PPC_INST_ADDIS | __PPC_RT(R12) | PPC_HA(sym)) > + /* addi

[PATCH 2/3] powerpc/module32: Use symbolic instructions names.

2019-04-29 Thread Christophe Leroy
To increase readability/maintainability, replace hard coded instructions values by symbolic names. Signed-off-by: Christophe Leroy --- arch/powerpc/kernel/module_32.c | 16 ++-- 1 file changed, 10 insertions(+), 6 deletions(-) diff --git a/arch/powerpc/kernel/module_32.c