Re: [PATCH v2 1/2] powerpc/timer - large decrementer support

2016-05-09 Thread Michael Neuling
> > > +static inline bool large_dec_supp(void) > > > +{ > > > + return cpu_has_feature(CPU_FTR_ARCH_300); > > > +} > > > + > > Can we rename this to is_large_dec()? > Honestly, I don't like either. How about have_large_dec() ? How about cpu_has_large_dec() like the underlying call? Mikey

Re: [PATCH v2 1/2] powerpc/timer - large decrementer support

2016-05-09 Thread oliver
On Mon, May 9, 2016 at 4:28 PM, Balbir Singh wrote: > > > On 04/05/16 17:37, Oliver O'Halloran wrote: >> POWER ISA v3 adds large decrementer (LD) mode of operation which increases >> the size of the decrementer register from 32 bits to an implementation >> defined with of

Re: [PATCH v2 1/2] powerpc/timer - large decrementer support

2016-05-09 Thread Balbir Singh
On 04/05/16 17:37, Oliver O'Halloran wrote: > POWER ISA v3 adds large decrementer (LD) mode of operation which increases > the size of the decrementer register from 32 bits to an implementation > defined with of up to 64 bits. > > This patch adds support for the LD on processors with the

[PATCH v2 1/2] powerpc/timer - large decrementer support

2016-05-04 Thread Oliver O'Halloran
POWER ISA v3 adds large decrementer (LD) mode of operation which increases the size of the decrementer register from 32 bits to an implementation defined with of up to 64 bits. This patch adds support for the LD on processors with the CPU_FTR_ARCH_300 cpu feature flag set. Even for CPUs with this