[PATCH 1/3] powerpc/fsl_soc: improve and simplify fsl_get_sys_freq

2016-10-29 Thread Heiner Kallweit
Use of_property_read_u32 instead of the generic of_get_property to simplify the code. In addition move the declaration of sysfreq into fsl_get_sys_freq because it's private to this function. Signed-off-by: Heiner Kallweit --- arch/powerpc/sysdev/fsl_soc.c | 14

[PATCH 2/3] powerpc/fsl_soc: improve and simplify get_brgfreq

2016-10-29 Thread Heiner Kallweit
Use of_property_read_u32 instead of the generic of_get_property to simplify the code. In addition move the declaration of brgfreq into get_brgfreq because it's private to this function. Signed-off-by: Heiner Kallweit --- arch/powerpc/sysdev/fsl_soc.c | 24

[PATCH 3/3] powerpc/fsl_soc: improve and simplify get_baudrate

2016-10-29 Thread Heiner Kallweit
Use of_property_read_u32 instead of the generic of_get_property to simplify the code. In addition move the declaration of fs_baudrate into get_baudrate because it's private to this function. Signed-off-by: Heiner Kallweit --- arch/powerpc/sysdev/fsl_soc.c | 10 ++

Re: [PATCH v6 02/11] locking/osq: Drop the overload of osq_lock()

2016-10-29 Thread Davidlohr Bueso
On Fri, 28 Oct 2016, Pan Xinhui wrote: /* * If we need to reschedule bail... so we can block. +* Use vcpu_is_preempted to detech lock holder preemption issue ^^ detect + * and break. Could you

[PATCH v2 11/19] edac: rename edac_core.h to edac_mc.h

2016-10-29 Thread Mauro Carvalho Chehab
Now, all left at edac_core.h are at drivers/edac/edac_mc.c, so rename it to edac_mc.h. Signed-off-by: Mauro Carvalho Chehab --- drivers/edac/altera_edac.c | 1 - drivers/edac/amd64_edac.h | 2 +- drivers/edac/amd76x_edac.c | 2

[PATCH 08/15] powerpc/iommu: use permission-specific DEVICE_ATTR variants

2016-10-29 Thread Julia Lawall
Use DEVICE_ATTR_RW for read-write attributes. This simplifies the source code, improves readbility, and reduces the chance of inconsistencies. The semantic patch that makes this change is as follows: (http://coccinelle.lip6.fr/) // @rw@ declarer name DEVICE_ATTR; identifier x,x_show,x_store;

[PATCH 00/15] use permission-specific DEVICE_ATTR variants

2016-10-29 Thread Julia Lawall
Use DEVICE_ATTR_RO etc. for read only attributes etc. This simplifies the source code, improves readbility, and reduces the chance of inconsistencies. The complete semantic patch is as follows: (http://coccinelle.lip6.fr/) // @ro@ declarer name DEVICE_ATTR; identifier x,x_show; @@

Re: [PATCH net-next] ibmveth: v1 calculate correct gso_size and set gso_type

2016-10-29 Thread Jonathan Maxwell
On Fri, Oct 28, 2016 at 5:08 AM, Eric Dumazet wrote: > On Thu, 2016-10-27 at 12:54 -0500, Thomas Falcon wrote: >> On 10/27/2016 10:26 AM, Eric Dumazet wrote: >> > On Wed, 2016-10-26 at 11:09 +1100, Jon Maxwell wrote: >> >> We recently encountered a bug where a few