[PATCH v2 1/2] powerpc/pci: unmap legacy INTx interrupts when a PHB is removed

2020-06-17 Thread Cédric Le Goater
When a passthrough IO adapter is removed from a pseries machine using hash MMU and the XIVE interrupt mode, the POWER hypervisor expects the guest OS to clear all page table entries related to the adapter. If some are still present, the RTAS call which isolates the PCI slot returns error 9001

Re: [PATCH 3/3] powerpc/8xx: Provide ptep_get() with 16k pages

2020-06-17 Thread Christophe Leroy
Le 17/06/2020 à 16:38, Peter Zijlstra a écrit : On Thu, Jun 18, 2020 at 12:21:22AM +1000, Michael Ellerman wrote: Peter Zijlstra writes: On Mon, Jun 15, 2020 at 12:57:59PM +, Christophe Leroy wrote: +#if defined(CONFIG_PPC_8xx) && defined(CONFIG_PPC_16K_PAGES) +#define

Re: [PATCH 3/3] powerpc/8xx: Provide ptep_get() with 16k pages

2020-06-17 Thread Peter Zijlstra
On Thu, Jun 18, 2020 at 12:21:22AM +1000, Michael Ellerman wrote: > Peter Zijlstra writes: > > On Mon, Jun 15, 2020 at 12:57:59PM +, Christophe Leroy wrote: > >> +#if defined(CONFIG_PPC_8xx) && defined(CONFIG_PPC_16K_PAGES) > >> +#define __HAVE_ARCH_PTEP_GET > >> +static inline pte_t

Re: [PATCH 3/3] powerpc/8xx: Provide ptep_get() with 16k pages

2020-06-17 Thread Michael Ellerman
Peter Zijlstra writes: > On Mon, Jun 15, 2020 at 12:57:59PM +, Christophe Leroy wrote: >> READ_ONCE() now enforces atomic read, which leads to: > >> Fixes: 2ab3a0a02905 ("READ_ONCE: Enforce atomicity for {READ,WRITE}_ONCE() >> memory accesses") >> Cc: Will Deacon >> Signed-off-by:

Re: [PATCH 1/3] mm/gup: Use huge_ptep_get() in gup_hugepte()

2020-06-17 Thread Michael Ellerman
Christophe Leroy writes: > gup_hugepte() reads hugepage table entries, it can't read > them directly, huge_ptep_get() must be used. > > Fixes: 2ab3a0a02905 ("READ_ONCE: Enforce atomicity for {READ,WRITE}_ONCE() > memory accesses") I see that commit in older versions of linux-next but not in

Re: [PATCH 0/3] Fix build failure with v5.8-rc1

2020-06-17 Thread Michael Ellerman
Christophe Leroy writes: > Commit 2ab3a0a02905 ("READ_ONCE: Enforce atomicity for > {READ,WRITE}_ONCE() memory accesses") leads to following build > failure on powerpc 8xx. I've put this in my fixes branch. cheers

Re: [PATCH v2 1/2] ASoC: bindings: fsl-asoc-card: Add compatible string for MQS

2020-06-17 Thread Mark Brown
On Wed, 17 Jun 2020 12:48:24 +0800, Shengjiu Wang wrote: > Add compatible string "fsl,imx-audio-mqs" for MQS, and move > "audio-routing" property to be optional for MQS doesn't need > such property. Applied to https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next Thanks!

Re: [PATCH v3 1/2] ASoC: bindings: fsl_spdif: Add new compatible string for imx6sx

2020-06-17 Thread Mark Brown
On Wed, 17 Jun 2020 14:58:00 +0800, Shengjiu Wang wrote: > Add new compatible string "fsl,imx6sx-spdif" in the binding document. > And add compatible string "fsl,vf610-spdif" which was missed before. Applied to https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next

Re: [PATCH] powerpc/8xx: use pmd_off() to access a PMD entry in pte_update()

2020-06-17 Thread Michael Ellerman
Mike Rapoport writes: > On Wed, Jun 17, 2020 at 09:21:42AM +1000, Michael Ellerman wrote: >> Andrew Morton writes: >> > On Mon, 15 Jun 2020 12:22:29 +0300 Mike Rapoport wrote: >> > >> >> From: Mike Rapoport >> >> >> >> The pte_update() implementation for PPC_8xx unfolds page table from the

Re: [PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()

2020-06-17 Thread Michal Hocko
On Wed 17-06-20 05:23:21, Matthew Wilcox wrote: > On Wed, Jun 17, 2020 at 01:31:57PM +0200, Michal Hocko wrote: > > On Wed 17-06-20 04:08:20, Matthew Wilcox wrote: > > > If you call vfree() under > > > a spinlock, you're in trouble. in_atomic() only knows if we hold a > > > spinlock for

Re: [PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()

2020-06-17 Thread Matthew Wilcox
On Wed, Jun 17, 2020 at 01:31:57PM +0200, Michal Hocko wrote: > On Wed 17-06-20 04:08:20, Matthew Wilcox wrote: > > If you call vfree() under > > a spinlock, you're in trouble. in_atomic() only knows if we hold a > > spinlock for CONFIG_PREEMPT, so it's not safe to check for in_atomic() > > in

Re: [PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()

2020-06-17 Thread Michal Hocko
On Wed 17-06-20 04:08:20, Matthew Wilcox wrote: > On Wed, Jun 17, 2020 at 09:12:12AM +0200, Michal Hocko wrote: > > On Tue 16-06-20 17:37:11, Matthew Wilcox wrote: > > > Not just performance critical, but correctness critical. Since kvfree() > > > may allocate from the vmalloc allocator, I really

[PATCH v5] powerpc/fadump: fix race between pstore write and fadump crash trigger

2020-06-17 Thread Sourabh Jain
When we enter into fadump crash path via system reset we fail to update the pstore. On the system reset path we first update the pstore then we go for fadump crash. But the problem here is when all the CPUs try to get the pstore lock to initiate the pstore write, only one CPUs will acquire the

Re: [PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()

2020-06-17 Thread Matthew Wilcox
On Wed, Jun 17, 2020 at 09:12:12AM +0200, Michal Hocko wrote: > On Tue 16-06-20 17:37:11, Matthew Wilcox wrote: > > Not just performance critical, but correctness critical. Since kvfree() > > may allocate from the vmalloc allocator, I really think that kvfree() > > should assert that it's

Re: [PATCH v5 01/13] powerpc: Remove Xilinx PPC405/PPC440 support

2020-06-17 Thread Michal Simek
>> Or if bamboo requires uImage to be built by default you can do it via >> Kconfig. >> >> diff --git a/arch/powerpc/platforms/44x/Kconfig >> b/arch/powerpc/platforms/44x/Kconfig >> index 39e93d23fb38..300864d7b8c9 100644 >> --- a/arch/powerpc/platforms/44x/Kconfig >> +++

Re: [PATCH 0/3] Fix build failure with v5.8-rc1

2020-06-17 Thread Will Deacon
[+Arnd in case he's interested in this series] On Mon, Jun 15, 2020 at 12:57:55PM +, Christophe Leroy wrote: > Commit 2ab3a0a02905 ("READ_ONCE: Enforce atomicity for > {READ,WRITE}_ONCE() memory accesses") leads to following build > failure on powerpc 8xx. > > To fix it, this small series

Re: [PATCH v5 01/13] powerpc: Remove Xilinx PPC405/PPC440 support

2020-06-17 Thread Michael Ellerman
Michael Ellerman writes: > Michal Simek writes: >> Or if bamboo requires uImage to be built by default you can do it via >> Kconfig. >> >> diff --git a/arch/powerpc/platforms/44x/Kconfig >> b/arch/powerpc/platforms/44x/Kconfig >> index 39e93d23fb38..300864d7b8c9 100644 >> ---

Re: [PATCH v5 01/13] powerpc: Remove Xilinx PPC405/PPC440 support

2020-06-17 Thread Michael Ellerman
Michal Simek writes: > On 16. 06. 20 20:16, Nathan Chancellor wrote: >> On Tue, Jun 16, 2020 at 04:45:20PM +0200, Michal Simek wrote: >>> On 16. 06. 20 2:27, Nathan Chancellor wrote: On Thu, May 21, 2020 at 04:55:52PM +, Christophe Leroy wrote: > From: Michal Simek > > The

Re: [PATCH V3 4/4] Documentation/mm: Add descriptions for arch page table helpers

2020-06-17 Thread Mike Rapoport
On Mon, Jun 15, 2020 at 09:07:57AM +0530, Anshuman Khandual wrote: > This adds a specific description file for all arch page table helpers which > is in sync with the semantics being tested via CONFIG_DEBUG_VM_PGTABLE. All > future changes either to these descriptions here or the debug test should

Re: [PATCH v2 12/12] x86/traps: Fix up invalid PASID

2020-06-17 Thread Peter Zijlstra
On Tue, Jun 16, 2020 at 04:23:46PM -0700, Fenghua Yu wrote: > Hi, Peter, > > On Mon, Jun 15, 2020 at 09:09:28PM +0200, Peter Zijlstra wrote: > > On Mon, Jun 15, 2020 at 11:55:29AM -0700, Fenghua Yu wrote: > > > > > Or do you suggest to add a random new flag in struct thread_info instead > > > of

Re: [PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()

2020-06-17 Thread Jo -l
Bonjour, Désolé, aucune traduction possible, En français pour comprendre! Merci slts > Le 17 06 2020 à 02:37, Matthew Wilcox a écrit : > > On Wed, Jun 17, 2020 at 01:01:30AM +0200, David Sterba wrote: >> On Tue, Jun 16, 2020 at 11:53:50AM -0700, Joe Perches wrote: >>> On Mon, 2020-06-15 at

Re: [PATCH v5 01/13] powerpc: Remove Xilinx PPC405/PPC440 support

2020-06-17 Thread Michal Simek
Hi Nathan, On 16. 06. 20 20:16, Nathan Chancellor wrote: > Hi Michal, > > On Tue, Jun 16, 2020 at 04:45:20PM +0200, Michal Simek wrote: >> >> >> On 16. 06. 20 2:27, Nathan Chancellor wrote: >>> On Thu, May 21, 2020 at 04:55:52PM +, Christophe Leroy wrote: From: Michal Simek

Re: [PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()

2020-06-17 Thread Michal Hocko
On Tue 16-06-20 17:37:11, Matthew Wilcox wrote: > On Wed, Jun 17, 2020 at 01:01:30AM +0200, David Sterba wrote: > > On Tue, Jun 16, 2020 at 11:53:50AM -0700, Joe Perches wrote: > > > On Mon, 2020-06-15 at 21:57 -0400, Waiman Long wrote: > > > > v4: > > > > - Break out the memzero_explicit()

[PATCH v3 2/2] ASoC: fsl_spdif: Add support for imx6sx platform

2020-06-17 Thread Shengjiu Wang
The one difference on imx6sx platform is that the root clock is shared with ASRC module, so we add a new flags "shared_root_clock" which means the root clock is not independent, then we will not do the clk_set_rate and clk_round_rate to avoid impact ASRC module usage. As add a new flags, we

[PATCH v3 1/2] ASoC: bindings: fsl_spdif: Add new compatible string for imx6sx

2020-06-17 Thread Shengjiu Wang
Add new compatible string "fsl,imx6sx-spdif" in the binding document. And add compatible string "fsl,vf610-spdif" which was missed before. Signed-off-by: Shengjiu Wang --- Documentation/devicetree/bindings/sound/fsl,spdif.txt | 6 +- 1 file changed, 5 insertions(+), 1 deletion(-) diff

Re: [PATCH v2 2/2] ASoC: fsl_spdif: Add support for imx6sx platform

2020-06-17 Thread Shengjiu Wang
On Wed, Jun 17, 2020 at 2:27 PM Nicolin Chen wrote: > > On Wed, Jun 17, 2020 at 12:30:17PM +0800, Shengjiu Wang wrote: > > The one difference on imx6sx platform is that the root clock > > is shared with ASRC module, so we add a new flags > > "shared_root_clock" which means the root clock is

Re: [PATCH 2/2] selftests/powerpc: Add prefixed loads/stores to alignment_handler test

2020-06-17 Thread Alistair Popple
Tested-by: Alistair Popple On Wednesday, 20 May 2020 12:11:03 PM AEST Jordan Niethe wrote: > Extend the alignment handler selftest to exercise prefixed load store > instructions. Add tests for prefixed VSX, floating point and integer > instructions. > > Skip prefix tests if ISA version does not

Re: [PATCH 1/2] selftests/powerpc: Allow choice of CI memory location in alignment_handler test

2020-06-17 Thread Alistair Popple
I've tested these on Mambo and they pass so: Tested-by: Alistair Popple On Wednesday, 20 May 2020 12:11:02 PM AEST Jordan Niethe wrote: > The alignment handler selftest needs cache-inhibited memory and > currently /dev/fb0 is relied on to provided this. This prevents running > the test on

Re: [PATCH v2 2/2] ASoC: fsl-asoc-card: Add MQS support

2020-06-17 Thread Nicolin Chen
On Wed, Jun 17, 2020 at 12:48:25PM +0800, Shengjiu Wang wrote: > The MQS codec isn't an i2c device, so use of_find_device_by_node > to get platform device pointer. > > Because MQS only support playback, then add a new audio map. > > And there maybe "model" property or no "audio-routing" property

Re: powerpc/pci: [PATCH 1/1 V3] PCIE PHB reset

2020-06-17 Thread Michael Ellerman
"Oliver O'Halloran" writes: > On Tue, Jun 16, 2020 at 9:55 PM Michael Ellerman wrote: >> wenxi...@linux.vnet.ibm.com writes: >> > From: Wen Xiong >> > >> > Several device drivers hit EEH(Extended Error handling) when triggering >> > kdump on Pseries PowerVM. This patch implemented a reset of

Re: [PATCH v2 2/2] ASoC: fsl_spdif: Add support for imx6sx platform

2020-06-17 Thread Nicolin Chen
On Wed, Jun 17, 2020 at 12:30:17PM +0800, Shengjiu Wang wrote: > The one difference on imx6sx platform is that the root clock > is shared with ASRC module, so we add a new flags > "shared_root_clock" which means the root clock is independent, "shared" means "not independent", against

<    1   2