[PATCH 1/3] ASoC: simple-card-utils: Support configure pin_name for asoc_simple_init_jack

2020-07-14 Thread Shengjiu Wang
Currently the pin_name is fixed in asoc_simple_init_jack, but some driver may use a different pin_name. So add a new parameter in asoc_simple_init_jack for configuring pin_name. If this parameter is NULL, then the default pin_name is used. Signed-off-by: Shengjiu Wang ---

[PATCH 0/3] ASoC: fsl-asoc-card: Support hp and mic detection

2020-07-14 Thread Shengjiu Wang
Support hp and mic detection. Add a parameter for asoc_simple_init_jack. Shengjiu Wang (3): ASoC: simple-card-utils: Support configure pin_name for asoc_simple_init_jack ASoC: bindings: fsl-asoc-card: Support hp-det-gpio and mic-det-gpio ASoC: fsl-asoc-card: Support Headphone and

Re: [PATCH 04/15] powerpc/powernv/pci: Initialise M64 for IODA1 as a 1-1 window

2020-07-14 Thread Alexey Kardashevskiy
On 10/07/2020 15:23, Oliver O'Halloran wrote: > We pre-configure the m64 window for IODA1 as a 1-1 segment-PE mapping, > similar to PHB3. Currently the actual mapping of segments occurs in > pnv_ioda_pick_m64_pe(), but we can move it into pnv_ioda1_init_m64() and > drop the IODA1 specific code

[PATCH] spi: ppc4xx: Convert to use GPIO descriptors

2020-07-14 Thread Linus Walleij
This converts the PPC4xx SPI driver to use GPIO descriptors. The driver is already just picking some GPIOs from the device tree so the conversion is pretty straight forward. However this driver is looking form a pure "gpios" property rather than the standard binding "cs-gpios" so we need to add a

Re: [PATCH 03/15] powerpc/powernv/pci: Add explicit tracking of the DMA setup state

2020-07-14 Thread Alexey Kardashevskiy
On 14/07/2020 15:58, Oliver O'Halloran wrote: > On Tue, Jul 14, 2020 at 3:37 PM Alexey Kardashevskiy wrote: >> >> On 10/07/2020 15:23, Oliver O'Halloran wrote: >>> There's an optimisation in the PE setup which skips performing DMA >>> setup for a PE if we only have bridges in a PE. The

Re: [PATCH 4/5] dma-mapping: add a dma_ops_bypass flag to struct device

2020-07-14 Thread Alexey Kardashevskiy
On 14/07/2020 17:07, Christoph Hellwig wrote: > On Mon, Jul 13, 2020 at 02:59:39PM +1000, Alexey Kardashevskiy wrote: >> >> >> On 09/07/2020 01:24, Christoph Hellwig wrote: >>> Several IOMMU drivers have a bypass mode where they can use a direct >>> mapping if the devices DMA mask is large

Re: [PATCH 4/5] dma-mapping: add a dma_ops_bypass flag to struct device

2020-07-14 Thread Christoph Hellwig
On Mon, Jul 13, 2020 at 02:59:39PM +1000, Alexey Kardashevskiy wrote: > > > On 09/07/2020 01:24, Christoph Hellwig wrote: > > Several IOMMU drivers have a bypass mode where they can use a direct > > mapping if the devices DMA mask is large enough. Add generic support > > to the core dma-mapping

Re: /sys/kernel/debug/kmemleak empty despite kmemleak reports

2020-07-14 Thread Paul Menzel
Dear Catalin, Am 13.07.20 um 20:27 schrieb Catalin Marinas: On Thu, Jul 09, 2020 at 11:08:52PM +0200, Paul Menzel wrote: Am 09.07.20 um 19:57 schrieb Catalin Marinas: On Thu, Jul 09, 2020 at 04:37:10PM +0200, Paul Menzel wrote: Despite Linux 5.8-rc4 reporting memory leaks on the IBM POWER 8

Re: [PATCH v3 4/6] powerpc/pseries/iommu: Remove default DMA window before creating DDW

2020-07-14 Thread Leonardo Bras
In fact, the changes over the last patch are more complex than the current patch. Just for reference, that's how enable_ddw() currently patches: @@ -1087,7 +1119,7 @@ static u64 enable_ddw(struct pci_dev *dev, struct device_node *pdn) struct device_node *dn; u32

Re: [PATCH 1/3] module: Rename module_alloc() to text_alloc() and move to kernel proper

2020-07-14 Thread Ard Biesheuvel
On Tue, 14 Jul 2020 at 05:04, Steven Rostedt wrote: > > On Mon, 13 Jul 2020 22:49:48 +0300 > Ard Biesheuvel wrote: > > > On arm64, we no longer use module_alloc for bpf or kprobes, to avoid > > wasting va space on code that does not need to be loaded close to the > > kernel. Also, module_alloc()

Re: [PATCH v2] powerpc/pseries: detect secure and trusted boot state of the system.

2020-07-14 Thread Daniel Axtens
Hi Nayna, Thanks! Would you be able to fold in some of the information from my reply to v1 into the changelog? Until we have public PAPR release with it, that information is the extent of the public documentation. It would be good to get it into the git log rather than just floating around in the

Re: [RFC PATCH 7/7] lazy tlb: shoot lazies, a non-refcounting lazy tlb option

2020-07-14 Thread Nicholas Piggin
Excerpts from Nicholas Piggin's message of July 14, 2020 3:04 pm: > Excerpts from Andy Lutomirski's message of July 14, 2020 4:18 am: >> >>> On Jul 13, 2020, at 9:48 AM, Nicholas Piggin wrote: >>> >>> Excerpts from Andy Lutomirski's message of July 14, 2020 1:59 am: > On Thu, Jul 9, 2020

Re: [PATCH v3 4/6] powerpc/pseries/iommu: Remove default DMA window before creating DDW

2020-07-14 Thread Leonardo Bras
On Tue, 2020-07-14 at 14:52 +1000, Alexey Kardashevskiy wrote: > > On 14/07/2020 12:40, Leonardo Bras wrote: > > Thank you for this feedback Alexey! > > > > On Mon, 2020-07-13 at 17:33 +1000, Alexey Kardashevskiy wrote: > > > [...] > > > > - int len, ret; > > > > + int len, ret,

Re: [PATCH 05/11] powerpc/smp: Dont assume l2-cache to be superset of sibling

2020-07-14 Thread Srikar Dronamraju
* Oliver O'Halloran [2020-07-14 15:40:09]: > On Tue, Jul 14, 2020 at 2:45 PM Srikar Dronamraju > wrote: > > > > Current code assumes that cpumask of cpus sharing a l2-cache mask will > > always be a superset of cpu_sibling_mask. > > > > Lets stop that assumption. > > It's been a while since I

Re: [PATCH v3] powerpc/perf: Use SIER_USER_MASK while updating SPRN_SIER for EBB events

2020-07-14 Thread Michael Ellerman
Athira Rajeev writes: >> On 19-Mar-2020, at 4:22 PM, Michael Ellerman wrote: >> >> Hi Athira, >> >> Athira Rajeev writes: >>> Sampled Instruction Event Register (SIER), is a PMU register, >> ^ >>

<    1   2