[Bug 215389] pagealloc: memory corruption at building glibc-2.33 and running its' testsuite

2021-12-26 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=215389 --- Comment #3 from Erhard F. (erhar...@mailbox.org) --- Bisecting will take some time. I'll report back as soon as I have any findings. -- You may reply to this email to add a comment. You are receiving this mail because: You are watching the

Re: [PATCH V2 5/8] sched: s390: Remove unused TASK_SIZE_OF

2021-12-26 Thread Guo Ren
On Sun, Dec 26, 2021 at 12:26 AM Heiko Carstens wrote: > > On Sat, Dec 25, 2021 at 12:54:27PM +0800, guo...@kernel.org wrote: > > From: Guo Ren > > > > This macro isn't used in Linux sched, now. Delete in > > include/linux/sched.h and arch's include/asm. > > > > Signed-off-by: Guo Ren > >

Re: [PATCH 1/3] mm: vmalloc: Let user to control huge vmalloc default behavior

2021-12-26 Thread Christophe Leroy
Le 26/12/2021 à 09:39, Kefeng Wang a écrit : > Add HUGE_VMALLOC_DEFAULT_ENABLED to let user to choose whether or > not enable huge vmalloc mappings by default, and this could make > more architectures to enable huge vmalloc mappings feature but > don't want to enable it by default. > > Add

[PATCH v2 1/4] powerpc/vdso: augment VDSO32 functions to support 64 bits build

2021-12-26 Thread Christophe Leroy
VDSO64 cacheflush.S datapage.S gettimeofday.S and vgettimeofday.c are very similar to their VDSO32 counterpart. VDSO32 counterpart is already more complete than the VDSO64 version as it supports both PPC32 vdso and 32 bits VDSO for PPC64. Use compat macros wherever necessary in PPC32 files so

[PATCH v2 2/4] powerpc/vdso: Rework VDSO32 makefile to add a prefix to object files

2021-12-26 Thread Christophe Leroy
In order to merge vdso32 and vdso64 build in following patch, rework Makefile is order to add -32 suffix to VDSO32 object files. Also change sigtramp.S to sigtramp32.S as VDSO64 sigtramp.S is too different to be squashed into VDSO32 sigtramp.S at the first place. gen_vdso_offsets.sh also becomes

Re: [PATCH v1 01/11] powerpc/code-patching: Remove pr_debug()/pr_devel() messages and fix check()

2021-12-26 Thread Michael Ellerman
On Thu, 2 Dec 2021 13:00:17 +0100, Christophe Leroy wrote: > code-patching has been working for years now, time has come to > remove debugging messages. > > Change useful message to KERN_INFO and remove other ones. > > Also add KERN_ERR to check() macro and change it into a do/while > to make

Re: [PATCH 1/3] powerpc/64s: Mask NIP before checking against SRR0

2021-12-26 Thread Michael Ellerman
On Wed, 22 Dec 2021 00:50:59 +1100, Michael Ellerman wrote: > When CONFIG_PPC_RFI_SRR_DEBUG=y we check that NIP and SRR0 match when > returning from interrupts. This can trigger falsely if NIP has either of > its two low bits set via sigreturn or ptrace, while SRR0 has its low two > bits masked in

Re: [PATCH] powerpc/32: Fix boot failure with GCC latent entropy plugin

2021-12-26 Thread Michael Ellerman
On Wed, 22 Dec 2021 13:07:31 +, Christophe Leroy wrote: > Boot fails with GCC latent entropy plugin enabled. > > This is due to early boot functions trying to access 'latent_entropy' > global data while the kernel is not relocated at its final > destination yet. > > As there is no way to

Re: [PATCH] selftests/powerpc: Add a test of sigreturning to the kernel

2021-12-26 Thread Michael Ellerman
On Thu, 9 Dec 2021 22:59:44 +1100, Michael Ellerman wrote: > We have a general signal fuzzer, sigfuz, which can modify the MSR & NIP > before sigreturn. But the chance of it hitting a kernel address and also > clearing MSR_PR is fairly slim. > > So add a specific test of sigreturn to a kernel

Re: [PATCH] powerpc: use swap() to make code cleaner

2021-12-26 Thread Michael Ellerman
On Sat, 18 Dec 2021 09:59:17 +0800, davidcomponent...@gmail.com wrote: > From: Yang Guang > > Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid > opencoding it. > > Applied to powerpc/next. [1/1] powerpc: use swap() to make code cleaner

Re: [PATCH v2 2/2] mm: usercopy: Warn vmalloc/module address in check_heap_object()

2021-12-26 Thread Christophe Leroy
Le 25/12/2021 à 13:06, Kefeng Wang a écrit : > virt_addr_valid() could be insufficient to validate the virt addr > on some architecture, which could lead to potential BUG which has > been found on arm64/powerpc64. > > Let's add WARN_ON to check if the virt addr is passed virt_addr_valid() > but

[PATCH] powerpc/xive: Add missing null check after calling kmalloc

2021-12-26 Thread Ammar Faizi
Commit 930914b7d528fc ("powerpc/xive: Add a debugfs file to dump internal XIVE state") forgot to add a null check. Add it. Cc: Cédric Le Goater Cc: Michael Ellerman Fixes: 930914b7d528fc6b0249bffc00564100bcf6ef75 ("powerpc/xive: Add a debugfs file to dump internal XIVE state") Signed-off-by:

Re: [PATCH] powerpc/ptdump: Fix DEBUG_WX since generic ptdump conversion

2021-12-26 Thread Michael Ellerman
On Fri, 3 Dec 2021 23:41:12 +1100, Michael Ellerman wrote: > In note_prot_wx() we bail out without reporting anything if > CONFIG_PPC_DEBUG_WX is disabled. > > But CONFIG_PPC_DEBUG_WX was removed in the conversion to generic ptdump, > we now need to use CONFIG_DEBUG_WX instead. > > > [...]

Re: [PATCH 4/5] powerpc/64: Add VIRTUAL_BUG_ON checks for __va and __pa addresses

2021-12-26 Thread Christophe Leroy
Le 25/12/2021 à 11:10, Nicholas Piggin a écrit : > Excerpts from Christophe Leroy's message of December 24, 2021 11:24 pm: >> Hi Nic, >> >> Le 24/07/2019 à 10:46, Nicholas Piggin a écrit : >>> Ensure __va is given a physical address below PAGE_OFFSET, and __pa is >>> given a virtual address

[PATCH v2 3/4] powerpc/vdso: Merge vdso64 and vdso32 into a single directory

2021-12-26 Thread Christophe Leroy
merge vdso64 into vdso32 and rename it vdso. Signed-off-by: Christophe Leroy --- arch/powerpc/Makefile | 4 +- arch/powerpc/kernel/Makefile | 6 +- .../kernel/{vdso64 => vdso}/.gitignore| 2 + arch/powerpc/kernel/{vdso32 => vdso}/Makefile | 35

[PATCH v2 4/4] powerpc/vdso: Move cvdso_call macros into gettimeofday.S

2021-12-26 Thread Christophe Leroy
Now that gettimeofday.S is unique, move cvdso_call and cvdso_call_time macros into that file which is the only user. Signed-off-by: Christophe Leroy --- arch/powerpc/include/asm/vdso/gettimeofday.h | 69 +--- arch/powerpc/kernel/vdso/gettimeofday.S | 61 - 2

Re: [PATCH] powerpc: dts: Remove "spidev" nodes

2021-12-26 Thread Michael Ellerman
On Fri, 17 Dec 2021 16:14:00 -0600, Rob Herring wrote: > "spidev" is not a real device, but a Linux implementation detail. It has > never been documented either. The kernel has WARNed on the use of it for > over 6 years. Time to remove its usage from the tree. > > Applied to powerpc/next.

Re: [PATCH kernel 0/6] powerpc: Build with LLVM_IAS=1

2021-12-26 Thread Michael Ellerman
On Tue, 21 Dec 2021 16:58:58 +1100, Alexey Kardashevskiy wrote: > This allows compiling the upstream Linux with the upstream llvm with one fix > on top; > https://reviews.llvm.org/D115419 > > This is based on sha1 > 798527287598 Michael Ellerman "Automatic merge of 'next' into merge >

Re: [PATCH misc-next] drivers/misc: remove redundant rc variable

2021-12-26 Thread Michael Ellerman
On Wed, 15 Dec 2021 06:04:38 +, cgel@gmail.com wrote: > From: Minghao Chi > > Return value from ocxl_context_attach() directly instead > of taking this in another redundant variable. > > Applied to powerpc/next. [1/1] drivers/misc: remove redundant rc variable

Re: [PATCH] powerpc/mpic: Use bitmap_zalloc() when applicable

2021-12-26 Thread Michael Ellerman
On Fri, 17 Dec 2021 22:54:12 +0100, Christophe JAILLET wrote: > 'mpic->protected' is a bitmap. So use 'bitmap_zalloc()' to simplify > code and improve the semantic, instead of hand writing it. > > Applied to powerpc/next. [1/1] powerpc/mpic: Use bitmap_zalloc() when applicable

Re: [PATCH v2 00/20] powerpc: Define eligible functions as __init

2021-12-26 Thread Michael Ellerman
On Thu, 16 Dec 2021 17:00:15 -0500, Nick Child wrote: > This patchset focuses on redefining/declaring functions that could be > labeled with the macro `__init`. From my understanding, an > initialization function is one which is only needed during the initial > phases of booting, after which it's

Re: [PATCH v2] powerpc/64s/radix: Fix huge vmap false positive

2021-12-26 Thread Michael Ellerman
On Thu, 16 Dec 2021 20:33:42 +1000, Nicholas Piggin wrote: > pmd_huge() is defined to false when HUGETLB_PAGE is not configured, but > the vmap code still installs huge PMDs. This leads to false bad PMD > errors when vunmapping because it is not seen as a huge PTE, and the bad > PMD check catches

Re: [PATCH] powerpc: fix spelling of "its"

2021-12-26 Thread Michael Ellerman
On Wed, 22 Dec 2021 16:39:42 -0800, Randy Dunlap wrote: > Use the possessive "its" instead of the contraction of "it is" (it's). > > Applied to powerpc/next. [1/1] powerpc: fix spelling of "its" https://git.kernel.org/powerpc/c/5b09250cca85ae6f91c9562cf1f5e5747de0a75d cheers

Re: [PATCH 1/3] mm: vmalloc: Let user to control huge vmalloc default behavior

2021-12-26 Thread Matthew Wilcox
On Mon, Dec 27, 2021 at 09:44:24AM +0800, Kefeng Wang wrote: > > On 2021/12/27 1:36, Christophe Leroy wrote: > > > > Le 26/12/2021 à 09:39, Kefeng Wang a écrit : > > > Add HUGE_VMALLOC_DEFAULT_ENABLED to let user to choose whether or > > > not enable huge vmalloc mappings by default, and this