[PATCH] Xilinx LL-TEMAC: Add Netpoll controller support

2009-10-13 Thread santosh shukla
From: Santosh Shukla Date: Tue, 13 Oct 2009 18:55:57 +0530 Subject: [PATCH] Xilinx LL-TEMAC: Add Netpoll controller support Adding Netpoll controller support to Xilinx LL-TEMAC ethernet driver.Replaced Rx, Tx tasklet schedule call with their handlers, Added correct version of call which can execu

Xilinx LL-TEMAC: Add Netpoll controller support

2009-10-13 Thread santosh shukla
From: Santosh Shukla Date: Tue, 13 Oct 2009 18:55:57 +0530 Subject: [PATCH] Xilinx LL-TEMAC: Add Netpoll controller support Adding Netpoll controller support to Xilinx LL-TEMAC ethernet driver. Replaced Rx, Tx tasklets schedule call with their handlers, Added correct version of call which can exe

[PATCH] Xilinx LL-TEMAC: Add Netpoll controller support

2009-10-13 Thread santosh shukla
From: Santosh Shukla Date: Tue, 13 Oct 2009 18:55:57 +0530 Subject: [PATCH] Xilinx LL-TEMAC: Add Netpoll controller support Adding Netpoll controller support to Xilinx LL-TEMAC ethernet driver.Repaced Rx, Tx tasklet schedule call with their handlers, Added correct version of call which can execut

Re: [v8 PATCH 1/8]: cpuidle: cleanup drivers/cpuidle/cpuidle.c

2009-10-13 Thread Arun R Bharadwaj
* Balbir Singh [2009-10-12 17:06:02]: > * Arun R B [2009-10-08 15:19:42]: > > > * Arun R Bharadwaj [2009-10-08 15:18:28]: > > > > This patch cleans up drivers/cpuidle/cpuidle.c > > Earlier cpuidle assumed pm_idle as the default idle loop. Break that > > assumption and make it more generic. cp

Re: [PATCH] powerpc: tracing: Add powerpc tracepoints for interrupt entry and exit

2009-10-13 Thread Benjamin Herrenschmidt
On Tue, 2009-10-06 at 15:05 +1100, Anton Blanchard wrote: > This patch adds powerpc specific tracepoints for interrupt entry and exit. .../ Breaks 6xx_defconfig: In file included from /home/benh/linux-powerpc-test/include/linux/device.h:23, from /home/benh/linux-powerpc-t

Re: [v8 PATCH 2/8]: cpuidle: implement a list based approach to register a set of idle routines.

2009-10-13 Thread Arun R Bharadwaj
* Andi Kleen [2009-10-12 20:00:05]: > Peter Zijlstra writes: > > > > So does it make sense to have a set of sets? > > > > Why not integrate them all into one set to be ruled by this governor > > thing? > > cpuidle is currently optional, that is why the two level hierarchy > is there so that you

Re: [PATCH] Ftrace : fix function_graph tracer OOPS

2009-10-13 Thread Benjamin Herrenschmidt
On Wed, 2009-10-14 at 11:43 +0530, Sachin Sant wrote: > Tested both the patches. Works fine. Thanks ! Stephen, you merge these yourself or you need me to pick them up in -powerpc ? Cheers, Ben. ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs

Re: [PATCH] Ftrace : fix function_graph tracer OOPS

2009-10-13 Thread Sachin Sant
Steven Rostedt wrote: On Thu, 2009-10-08 at 20:21 +0530, Sachin Sant wrote: Switch to LOAD_REG_ADDR(). Signed-off-by : Sachin Sant --- diff -Naurp old/arch/powerpc/kernel/entry_64.S new/arch/powerpc/kernel/entry_64.S --- old/arch/powerpc/kernel/entry_64.S 2009-10-08 18:37:44.0 +053

[PATCH 10/16] percpu: make percpu symbols in powerpc unique

2009-10-13 Thread Tejun Heo
This patch updates percpu related symbols in powerpc such that percpu symbols are unique and don't clash with local symbols. This serves two purposes of decreasing the possibility of global percpu symbol collision and allowing dropping per_cpu__ prefix from percpu symbols. * arch/powerpc/kernel/p

Re: [PATCH, RFC] powerpc, pci: fix MODPOST warning

2009-10-13 Thread Benjamin Herrenschmidt
On Mon, 2009-10-05 at 09:06 +0200, Heiko Schocher wrote: > Hello, > > Heiko Schocher wrote: > > making a powerpc target with PCI support, shows the > > following warning: > > > > MODPOST vmlinux.o > > WARNING: vmlinux.o(.text+0x10430): Section mismatch in reference from the > > function pcibio

[PATCH 6/6] powerpc: Enable sparse irq_descs on powerpc

2009-10-13 Thread Michael Ellerman
Defining CONFIG_SPARSE_IRQ enables generic code that gets rid of the static irq_desc array, and replaces it with an array of pointers to irq_descs. It also allows node local allocation of irq_descs, however we currently don't have the information available to do that, so we just allocate them on a

[PATCH 5/6] powerpc: Rearrange and fix show_interrupts() for sparse irq_descs

2009-10-13 Thread Michael Ellerman
Move the default case out of the if, ie. when we're just displaying an irq. And consolidate all the odd cases at the top, ie. printing the header and footer. And in the process cope with sparse irq_descs. Signed-off-by: Michael Ellerman --- arch/powerpc/kernel/irq.c | 64 +

[PATCH 4/6] powerpc: Make virq_debug_show() cope with sparse irq_descs

2009-10-13 Thread Michael Ellerman
Signed-off-by: Michael Ellerman --- arch/powerpc/kernel/irq.c |5 - 1 files changed, 4 insertions(+), 1 deletions(-) diff --git a/arch/powerpc/kernel/irq.c b/arch/powerpc/kernel/irq.c index 6563221..baa49eb 100644 --- a/arch/powerpc/kernel/irq.c +++ b/arch/powerpc/kernel/irq.c @@ -1065,8

[PATCH 3/6] powerpc: Remove get_irq_desc()

2009-10-13 Thread Michael Ellerman
get_irq_desc() is a powerpc-specific version of irq_to_desc(). That is reason enough to remove it, but it also doesn't know about sparse irq_desc support which irq_to_desc() does (when we enable it). Signed-off-by: Michael Ellerman --- arch/powerpc/include/asm/irq.h |2 - ar

[PATCH 2/6] powerpc/pseries: Use irq_has_action() in eeh_disable_irq()

2009-10-13 Thread Michael Ellerman
Rather than open-coding our own check, use irq_has_action() to check if an irq has an action - ie. is "in use". irq_has_action() doesn't take the descriptor lock, but it shouldn't matter - we're just using it as an indicator that the irq is in use. disable_irq_nosync() will take the descriptor loc

[PATCH 1/6] powerpc: Make NR_IRQS a CONFIG option

2009-10-13 Thread Michael Ellerman
The irq_desc array consumes quite a lot of space, and for systems that don't need or can't have 512 irqs it's just wasted space. The first 16 are reserved for ISA, so the minimum of 32 is really 16 - and no one has asked for more than 512 so leave that as the maximum. Signed-off-by: Michael Eller

[Fwd: [PATCH 2/2] i2c-powermac: Log errors]

2009-10-13 Thread Benjamin Herrenschmidt
--- Begin Message --- Log errors when they happen, otherwise we have no idea what went wrong. Signed-off-by: Jean Delvare Cc: Benjamin Herrenschmidt Cc: Paul Mackerras --- drivers/i2c/busses/i2c-powermac.c | 28 +++- 1 file changed, 23 insertions(+), 5 deletions(-)

[Fwd: [PATCH 1/2] i2c-powermac: Refactor i2c_powermac_smbus_xfer]

2009-10-13 Thread Benjamin Herrenschmidt
--- Begin Message --- I wanted to add some error logging to the i2c-powermac driver, but found that it was very difficult due to the way the i2c_powermac_smbus_xfer function is organized. Refactor the code in this function so that each low-level function is only called once. Signed-off-by: Jean D

Re: [PATCH] i2c-powermac: Reject unsupported I2C transactions

2009-10-13 Thread Benjamin Herrenschmidt
On Wed, 2009-09-30 at 22:14 +0200, Jean Delvare wrote: > The i2c-powermac driver doesn't support arbitrary multi-message I2C > transactions, only SMBus ones. Make it clear by returning an error if > a multi-message I2C transaction is attempted. This is better than only > processing the first messag

Re: [PATCH] of/platform: Implement support for dev_pm_ops

2009-10-13 Thread Benjamin Herrenschmidt
On Tue, 2009-10-13 at 02:44 +0400, Anton Vorontsov wrote: > I agree that there is some room for improvements in general (e.g. > merging platform and of_platform devices/drivers), but it's not as > easy as you would like to think. Let's make it in a separate step > that don't stop real features fro

Re: [RFC PATCH 05/12] of: add common header for flattened device tree representation

2009-10-13 Thread David Gibson
On Fri, Oct 09, 2009 at 01:07:57AM -0600, Grant Likely wrote: > On Fri, Oct 9, 2009 at 12:35 AM, David Gibson > wrote: > > On Tue, Oct 06, 2009 at 10:30:59PM -0600, Grant Likely wrote: > >> Add a common header file for working with the flattened device tree > >> data structure and merge the shared

Re: [PATCH 2/8] bitmap: Introduce bitmap_set, bitmap_clear, bitmap_find_next_zero_area

2009-10-13 Thread Akinobu Mita
On Wed, Oct 14, 2009 at 08:54:47AM +1100, Michael Ellerman wrote: > On Tue, 2009-10-13 at 18:10 +0900, Akinobu Mita wrote: > > My user space testing exposed off-by-one error find_next_zero_area > > in iommu-helper. > > Why not merge those tests into the kernel as a configurable boot-time > self-te

Re: New percpu & ppc64 perfs

2009-10-13 Thread Benjamin Herrenschmidt
On Wed, 2009-10-14 at 10:49 +0900, Tejun Heo wrote: > For 256M segment, I don't think much can be done but for 1T segment, > just limiting vmalloc area size to 1T should do the trick, no? Right. I'll have a look at it. Cheers, Ben. ___ Linuxppc-dev ma

[PATCH -mmotm] Fix bitmap-introduce-bitmap_set-bitmap_clear-bitmap_find_next_zero_area. patch

2009-10-13 Thread Akinobu Mita
Update PATCH 2/8 based on review comments by Andrew and bugfix exposed by user space testing. I didn't change argument of align_mask at this time because it turned out that it needs more changes in iommu-helper users. From: Akinobu Mita Subject: Fix bitmap-introduce-bitmap_set-bitmap_clear-bitm

Re: [PATCH] Ftrace : fix function_graph tracer OOPS

2009-10-13 Thread Steven Rostedt
On Thu, 2009-10-08 at 20:21 +0530, Sachin Sant wrote: > Switch to LOAD_REG_ADDR(). > > Signed-off-by : Sachin Sant > --- > diff -Naurp old/arch/powerpc/kernel/entry_64.S > new/arch/powerpc/kernel/entry_64.S > --- old/arch/powerpc/kernel/entry_64.S 2009-10-08 18:37:44.0 > +0530 > +++ new/

Re: New percpu & ppc64 perfs

2009-10-13 Thread Tejun Heo
Hello, Benjamin. Benjamin Herrenschmidt wrote: > So I found (and fixed, though the patch isn't upstream yet) the problem > that was causing the new percpu to hang when accessing the top of our > vmalloc space. > > However, I have some concerns about that choice of location for the > percpu datas.

New percpu & ppc64 perfs

2009-10-13 Thread Benjamin Herrenschmidt
Hi Tejun ! So I found (and fixed, though the patch isn't upstream yet) the problem that was causing the new percpu to hang when accessing the top of our vmalloc space. However, I have some concerns about that choice of location for the percpu datas. Basically, our MMU divides the address space i

Re: [PATCH 4/5 v3] kernel handling of memory DLPAR

2009-10-13 Thread Michael Ellerman
On Tue, 2009-10-13 at 13:13 -0500, Nathan Fontenot wrote: > This adds the capability to DLPAR add and remove memory from the kernel. The Hi Nathan, Sorry to only get around to reviewing version 3, time is a commodity in short supply :) > Index: powerpc/arch/powerpc/platforms/pseries/dlpar.c > =

Re: [PATCH 5/5 v2] kernel handling of CPU DLPAR

2009-10-13 Thread Michael Ellerman
On Tue, 2009-10-13 at 13:14 -0500, Nathan Fontenot wrote: > This adds the capability to DLPAR add and remove CPUs from the kernel. The > creates two new files /sys/devices/system/cpu/probe and > /sys/devices/system/cpu/release to handle the DLPAR addition and removal of > CPUs respectively. How do

Re: [PATCH 2/8] bitmap: Introduce bitmap_set, bitmap_clear, bitmap_find_next_zero_area

2009-10-13 Thread Michael Ellerman
On Tue, 2009-10-13 at 18:10 +0900, Akinobu Mita wrote: > My user space testing exposed off-by-one error find_next_zero_area > in iommu-helper. Why not merge those tests into the kernel as a configurable boot-time self-test? cheers signature.asc Description: This is a digitally signed message pa

Re: [PATCH 0/8] gianfar: Add support for hibernation

2009-10-13 Thread David Miller
From: Andy Fleming Date: Tue, 13 Oct 2009 12:22:38 -0500 > No, it was fine (though made unnecessary by other patches). The BD > has a union: > > struct { > u16 status; /* Status Fields */ > u16 length; /* Buffer length */ >

Re: [PATCH 5/5 v2] kernel handling of CPU DLPAR

2009-10-13 Thread Nathan Fontenot
This adds the capability to DLPAR add and remove CPUs from the kernel. The creates two new files /sys/devices/system/cpu/probe and /sys/devices/system/cpu/release to handle the DLPAR addition and removal of CPUs respectively. CPU DLPAR add is accomplished by writing the drc-index of the CPU to th

Re: [PATCH 4/5 v3] kernel handling of memory DLPAR

2009-10-13 Thread Nathan Fontenot
This adds the capability to DLPAR add and remove memory from the kernel. The patch extends the powerpc handling of memory_add_physaddr_to_nid(), which is called from the sysfs memory 'probe' file to first ensure that the memory has been added to the system. This is done by creating a platform sp

Re: [PATCH 1/5 v3] dynamic logical partitioning infrastructure

2009-10-13 Thread Nathan Fontenot
This patch provides the kernel DLPAR infrastructure in a new filed named dlpar.c. The functionality provided is for acquiring and releasing a resource from firmware and the parsing of information returned from the ibm,configure-connector rtas call. Additionally, this exports the pSeries reconf

Re: [PATCH 0/8] gianfar: Add support for hibernation

2009-10-13 Thread Andy Fleming
On Oct 13, 2009, at 1:57 AM, David Miller wrote: From: Anton Vorontsov Date: Mon, 12 Oct 2009 20:00:00 +0400 Here are few patches that add support for hibernation for gianfar driver. Technically, we could just do gfar_close() and then gfar_enet_open() sequence to restore gianfar functionali

Re: [Cbe-oss-dev] [PATCH] spufs: Fix test in spufs_switch_log_read()

2009-10-13 Thread Arnd Bergmann
On Tuesday 13 October 2009, Jeremy Kerr wrote: > > Or can this test be removed? > > I'd prefer just to remove the test. Yes, sounds good. Arnd <>< ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/lin

Re: From: Tim Abbott

2009-10-13 Thread Tim Abbott
Well, I think I just found a bug in git-send-email. I'll resend with the actual subject line. -Tim Abbott On Tue, 13 Oct 2009, Tim Abbott wrote: > There is already an architecture-independent __page_aligned_data macro > for this purpose, so removing the powerpc-specific macro should be

From: Tim Abbott

2009-10-13 Thread Tim Abbott
There is already an architecture-independent __page_aligned_data macro for this purpose, so removing the powerpc-specific macro should be harmless. Signed-off-by: Tim Abbott Cc: Benjamin Herrenschmidt Cc: Paul Mackerras Cc: linuxppc-...@ozlabs.org Cc: Sam Ravnborg --- arch/powerpc/include/asm

Re: [PATCH 1/2][v2] mm: add notifier in pageblock isolation for balloon drivers

2009-10-13 Thread Robert Jennings
On Fri, Oct 09, 2009 at 21:43:26 +0100, Mal Gorman wrote: > As you have tested this recently, would you be willing to post the > results? While it's not a requirement of the patch, it would be nice to have > an idea of how the effectiveness of memory hot-remove is improved when used > with the powe

Re: [Patch] powerpc: Fix memory leak in axon_msi.c

2009-10-13 Thread Arnd Bergmann
On Tuesday 13 October 2009, Michael Ellerman wrote: > cppcheck found a memory leak in axon_msi, if dcr_base or dcr_len are zero, > we have already allocated msic, so we should free it in the error path. > > Signed-off-by: Eric Sesterhenn > Acked-by: Michael Ellerman Acked-by: Arnd Bergmann ___

Re: [U-Boot] Linux seamless booting

2009-10-13 Thread Kenneth Johansson
On Mon, 2009-10-12 at 15:54 +0200, Fortini Matteo wrote: > Yes, that's what we're currently using, but the problem is a little > broader: I should answer to CAN messages in at most 100-200ms from > powerup, and that can be done in u-boot. if you are in that interval you definitely need to go to

Re: i2c-powermac fails

2009-10-13 Thread Jean Delvare
On Tue, 13 Oct 2009 20:32:28 +1100, Benjamin Herrenschmidt wrote: > On Tue, 2009-10-13 at 11:23 +0200, Jean Delvare wrote: > > Hi Ben, Paul, > > > > I had a report by Tim Shepard (Cc'd) that the therm_adt746x driver > > sometimes fails to initialize on his PowerBook G4 running kernel > > 2.6.31. T

Re: i2c-powermac fails

2009-10-13 Thread Benjamin Herrenschmidt
On Tue, 2009-10-13 at 11:23 +0200, Jean Delvare wrote: > Hi Ben, Paul, > > I had a report by Tim Shepard (Cc'd) that the therm_adt746x driver > sometimes fails to initialize on his PowerBook G4 running kernel > 2.6.31. The following error message can be seen in the logs when the > failure happens:

i2c-powermac fails

2009-10-13 Thread Jean Delvare
Hi Ben, Paul, I had a report by Tim Shepard (Cc'd) that the therm_adt746x driver sometimes fails to initialize on his PowerBook G4 running kernel 2.6.31. The following error message can be seen in the logs when the failure happens: therm_adt746x 7-002e: Thermostat failed to read config! After en

Re: [PATCH 2/8] bitmap: Introduce bitmap_set, bitmap_clear, bitmap_find_next_zero_area

2009-10-13 Thread Akinobu Mita
My user space testing exposed off-by-one error find_next_zero_area in iommu-helper. Some zero area cannot be found by this bug. Subject: [PATCH] Fix off-by-one error in find_next_zero_area Signed-off-by: Akinobu Mita --- lib/iommu-helper.c |2 +- 1 files changed, 1 insertions(+), 1 deletion

Re: [PATCH] powerpc/mm: Fix hang accessing top of vmalloc space

2009-10-13 Thread Sachin Sant
Benjamin Herrenschmidt wrote: On pSeries, we always force the IO space to be mapped using 4K pages even with a 64K base page size to cope with some limitations in the HV interface to some devices. However, the SLB miss handler code to discriminate between vmalloc and ioremap space uses a CPU fea

Re: [PATCH 0/8] gianfar: Add support for hibernation

2009-10-13 Thread David Miller
From: Anton Vorontsov Date: Mon, 12 Oct 2009 20:00:00 +0400 > Here are few patches that add support for hibernation for gianfar > driver. > > Technically, we could just do gfar_close() and then gfar_enet_open() > sequence to restore gianfar functionality after hibernation, but > close/open does