ucc_geth: Fix the wrong the Rx/Tx FIFO size

2009-11-27 Thread Dave Liu
current the Rx/Tx FIFO size settings cause problem when four UEC ethernets work simultaneously. eg: GETH1, UEM-J15, GETH2, UEC-J5 on 8569MDS board $ ifconfig eth0 10.193.20.166 $ ifconfig eth1 10.193.20.167 $ ifconfig eth2 10.193.20.168 then $ ifconfig eth3 10.193.20.169 The fourth

Re: [PATCH] Reserve memory for kdump kernel within RMO region

2009-11-27 Thread M. Mohan Kumar
On 11/27/2009 12:56 AM, Bernhard Walle wrote: M. Mohan Kumar schrieb: On 11/26/2009 12:22 AM, Bernhard Walle wrote: M. Mohan Kumar schrieb: Reserve memory for kdump kernel within RMO region When the kernel size exceeds 32MB(observed with some distros), memory for kdump kernel can not be

[PATCH] fix PPC floating point debug

2009-11-27 Thread Stefani Seibold
The PPC architecture is unable to debug applications using hardware floating point, because it would not save the floating point registers. After returning from the debugger, the contents of register was modified. This patch fix this bug. Signed-off-by: Stefani Seibold stef...@seibold.net ---

[PATCH] powerpc/ipic: support external edge triggered IRQ0

2009-11-27 Thread Norbert van Bolhuis
Currently an external edge triggered IRQ0 gives 2 problems. It gives a sense error (edge sense not supported on internal interrupts) and it isn't acked. This patch takes into account IRQ0 can be internal or external and fixes both issues. Signed-off-by: Norbert van Bolhuis nvbolh...@aimvalley.nl

Re: [PATCH v2] ppc440spe-adma: adds updated ppc440spe adma driver

2009-11-27 Thread Anatolij Gustschin
Tirumala Reddy Marri tma...@amcc.com wrote: Why are we having separate directory for 440spe. Can this be generalized arch/dma/ppc4xx/ppc4xx_dma.c ? currently there is only tested support for 440spe. If the driver will be extended to support other CPUs, then the renaming can be done while

Re: [PATCH 00/10 v6] Fix 8xx MMU/TLB

2009-11-27 Thread Joakim Tjernlund
Scott and Rex, I think we need you s-o-b to make it into the kernel proper. Marcelo and Vitaly, I noticed you guys are listed as 8xx maintainers. Have you seen this? What do you think? Jocke Joakim Tjernlund joakim.tjernl...@transmode.se wrote on 20/11/2009 11:21:01: Yet again an

Re: [PATCH] fix PPC floating point debug

2009-11-27 Thread Benjamin Herrenschmidt
On Fri, 2009-11-27 at 09:59 +0100, Stefani Seibold wrote: The PPC architecture is unable to debug applications using hardware floating point, because it would not save the floating point registers. After returning from the debugger, the contents of register was modified. This patch fix this

Re: [PATCH] Reserve memory for kdump kernel within RMO region

2009-11-27 Thread Simon Horman
On Fri, Nov 27, 2009 at 02:05:46PM +0530, M. Mohan Kumar wrote: On 11/27/2009 12:56 AM, Bernhard Walle wrote: M. Mohan Kumar schrieb: On 11/26/2009 12:22 AM, Bernhard Walle wrote: M. Mohan Kumar schrieb: Reserve memory for kdump kernel within RMO region When the kernel size exceeds

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-27 Thread Segher Boessenkool
+ soc { + #address-cells = 1; + #size-cells = 1; + #interrupt-cells = 1; This isn't an interrupt controller, don't put #interrupt-cells here. Isn't this needed to define what is to be expected in the interrupts properties of the child nodes?

Re: [RFC PATCH 02/19] powerpc: gamecube: device tree

2009-11-27 Thread Segher Boessenkool
Similarly, it is better to use a compatible value of something like: compatible = nintendo,flipper-immr; (instead of nintendo,flipper) because your describing just the internal bus, not the entire chip. I would just call the nodes flipper and hollywood. Either that, or not have these omnibus

Re: [RFC PATCH 06/19] powerpc: gamecube/wii: introduce GAMECUBE_COMMON

2009-11-27 Thread Segher Boessenkool
Add a config option GAMECUBE_COMMON to be used as a dependency for all options common to the Nintendo GameCube and Wii video game consoles. Maybe something like GAMECUBE_OR_WII instead? COMMON is so common it's meaningless. I don't like either GAMECUBE_OR_WII. It looks as if it can be

Re: [RFC PATCH 11/19] powerpc: gamecube/wii: flipper interrupt controller support

2009-11-27 Thread Segher Boessenkool
+/* + * Each interrupt has a corresponding bit in both + * the Interrupt Cause (ICR) and Interrupt Mask (IMR) registers. + * + * Enabling/disabling an interrupt line involves asserting/ clearing + * the corresponding bit in IMR. ACK'ing a request simply involves + * asserting the

Re: [PATCH] fix PPC floating point debug

2009-11-27 Thread Stefani Seibold
Am Freitag, den 27.11.2009, 22:01 +1100 schrieb Benjamin Herrenschmidt: On Fri, 2009-11-27 at 09:59 +0100, Stefani Seibold wrote: The PPC architecture is unable to debug applications using hardware floating point, because it would not save the floating point registers. After returning

Re: [PATCH] Reserve memory for kdump kernel within RMO region

2009-11-27 Thread M. Mohan Kumar
Hi, As of now the kdump kernel base is fixed to be 32MB. The intention of this patch is to modify that behaviour (for relocatable kernels) * Regular kernel size may exceed 32MB, in this case we can't have kdump kernelbase as 32MB. * crashkernel=auto also assumes that kdump kernelbase as

[PATCH 2.6.31] windfarm: add detection for second cpu pump

2009-11-27 Thread Bolko Maass
Windfarm SMU control is explicitly missing support for a second CPU pump in G5 PowerMacs. Such machines actually exist (specifically Quads with a second pump), so this patch adds detection for it. diff -uprN a/drivers/macintosh/windfarm_smu_controls.c

[PATCH] powerpc: Add Kconfig dependency on PCI_MSI for XICS and select for PSERIES

2009-11-27 Thread Mel Gorman
On Fri, Nov 27, 2009 at 01:40:26PM +1100, Benjamin Herrenschmidt wrote: On Wed, 2009-11-18 at 17:05 +, Mel Gorman wrote: diff --git a/arch/powerpc/platforms/Kconfig b/arch/powerpc/platforms/Kconfig index 04a8061..a82c470 100644 --- a/arch/powerpc/platforms/Kconfig +++

Re: [RFC PATCH 11/19] powerpc: gamecube/wii: flipper interrupt controller support

2009-11-27 Thread Albert Herranz
Segher Boessenkool wrote: +/* + * Each interrupt has a corresponding bit in both + * the Interrupt Cause (ICR) and Interrupt Mask (IMR) registers. + * + * Enabling/disabling an interrupt line involves asserting/clearing + * the corresponding bit in IMR. ACK'ing a request simply involves + *

Re: [PATCH] Reserve memory for kdump kernel within RMO region

2009-11-27 Thread Bernhard Walle
M. Mohan Kumar schrieb: Hi, As of now the kdump kernel base is fixed to be 32MB. The intention of this patch is to modify that behaviour (for relocatable kernels) * Regular kernel size may exceed 32MB, in this case we can't have kdump kernelbase as 32MB. * crashkernel=auto also

Re: [RFC PATCH 11/19] powerpc: gamecube/wii: flipper interrupt controller support

2009-11-27 Thread Benjamin Herrenschmidt
On Fri, 2009-11-27 at 18:27 +0100, Albert Herranz wrote: I checked it too on the Nintendo GameCube making the ack a no-op. It turns out that we _need_ to ack the RSW (Reset Switch) interrupt. The other interrupt sources checked (EXI, VI, DI, AI, DSP/ARAM) need no explicit ack. That would

Re: [RFC PATCH 12/19] powerpc: gamecube: platform support

2009-11-27 Thread Benjamin Herrenschmidt
On Fri, 2009-11-27 at 01:09 +0100, Segher Boessenkool wrote: We need it as it currently doesn't match with the default bus ids. Should I introduce a .type property matching any of those above in the soc node, and get rid of the explicit bus probe? You don't need any fake bus as far

Re: [PATCH 2.6.31] windfarm: add detection for second cpu pump

2009-11-27 Thread Benjamin Herrenschmidt
On Fri, 2009-11-27 at 16:44 +0100, Bolko Maass wrote: Windfarm SMU control is explicitly missing support for a second CPU pump in G5 PowerMacs. Such machines actually exist (specifically Quads with a second pump), so this patch adds detection for it. Thanks. BTW. The Signed-off-by:

Re: [PATCH 00/10 v6] Fix 8xx MMU/TLB

2009-11-27 Thread Benjamin Herrenschmidt
On Fri, 2009-11-27 at 11:57 +0100, Joakim Tjernlund wrote: Scott and Rex, I think we need you s-o-b to make it into the kernel proper. Marcelo and Vitaly, I noticed you guys are listed as 8xx maintainers. Have you seen this? What do you think? I think Marcelo isn't much involved with 8xx

[PATCH 0/8 userland!] systemtap: Add initial support for ppc32

2009-11-27 Thread Anton Vorontsov
Hi all, Here are some patches that add systemtap support for ppc32 machines. This is all pretty straightforward, though I didn't test it much, only run few 'hello world' taps and decided that it's good enough. ;-) I plan to test it more thoughtfully sometime next week, and fix missing things

[PATCH 1/8] Rename uprobes_ppc64.c to uprobes_ppc.c, use it for ppc32

2009-11-27 Thread Anton Vorontsov
The code *looks* generic enough, so I think it can be used for ppc32 without modifications. Signed-off-by: Anton Vorontsov avoront...@ru.mvista.com --- runtime/uprobes/uprobes_arch.c |4 +- runtime/uprobes/uprobes_arch.h |4 +- runtime/uprobes/uprobes_ppc.c | 147

[PATCH 2/8] Rename stack-ppc64.c to stack-ppc.c

2009-11-27 Thread Anton Vorontsov
There should be no functional changes in this patch. Signed-off-by: Anton Vorontsov avoront...@ru.mvista.com --- runtime/stack-ppc.c | 62 + runtime/stack-ppc64.c | 62 - runtime/stack.c |

[PATCH 3/8] stack-ppc: Adjust for ppc32

2009-11-27 Thread Anton Vorontsov
Get rid of magic numbers, use appropriate defines from ptrace.h. From now on stack-ppc.c should be suitable for ppc32. Signed-off-by: Anton Vorontsov avoront...@ru.mvista.com --- runtime/stack-ppc.c |4 ++-- runtime/stack.c |2 +- 2 files changed, 3 insertions(+), 3 deletions(-)

[PATCH 4/8] Implement ppc32 variant of __is_user_regs

2009-11-27 Thread Anton Vorontsov
* tapset/nd_syscalls.stp: Implement ppc32 variant of __is_user_regs. * tapset/syscalls.stp: Ditto. Signed-off-by: Anton Vorontsov avoront...@ru.mvista.com --- tapset/nd_syscalls.stp |3 +++ tapset/syscalls.stp|3 +++ 2 files changed, 6 insertions(+), 0 deletions(-) diff --git

[PATCH 5/8] Share ppc64 and ppc32 code where possible

2009-11-27 Thread Anton Vorontsov
* runtime/copy.c: Can use ppc64's code. * runtime/regs.h: Ditto. * runtime/string.h: Ditto. * tapset/context.stp: Ditto. * tapset/errno.stp: Ditto. Signed-off-by: Anton Vorontsov avoront...@ru.mvista.com --- runtime/copy.c |2 +- runtime/regs.h |2 +- runtime/string.h |6

[PATCH 6/8] Use proper types for do_div

2009-11-27 Thread Anton Vorontsov
do_div accepts unsigned 64-bit integer type for dividend, signed types would cause do_div's typecheck fail: stat-common.c: In function 'needed_space': stat-common.c:50: error: comparison of distinct pointer types lacks a cast ...same errors in time.c and tapset-timers.cxx's generated code... A

[PATCH 7/8] Implement _div64 and _mod64 for ppc32

2009-11-27 Thread Anton Vorontsov
_div64 and _mod64 arch-specific details were taken from gcc/longlong.h, just as it was done for i386. Signed-off-by: Anton Vorontsov avoront...@ru.mvista.com --- runtime/arith.c | 42 +++--- 1 files changed, 39 insertions(+), 3 deletions(-) diff --git

[PATCH 8/8] Change KERNEL_RELOC_SYMBOL to _stext on ppc32

2009-11-27 Thread Anton Vorontsov
Currently staprun fails at send_relocation_kernel(), this is because ppc32 doesn't have .__start symbol. I think we should use _stext, just as other arches. Signed-off-by: Anton Vorontsov avoront...@ru.mvista.com --- runtime/staprun/staprun.c |2 +- 1 files changed, 1 insertions(+), 1

Re: [PATCH v2 0/3] Kernel handling of Dynamic Logical Partitioning

2009-11-27 Thread Eric W. Biederman
Nathan Fontenot nf...@austin.ibm.com writes: version 2 of the patch set with updates from comments. The Dynamic Logical Partitioning (DLPAR) capabilities of the powerpc pseries platform allows for the addition and removal of resources (i.e. cpus, memory, pci devices) from a partition. The

unsubscribe

2009-11-27 Thread Gao Ya'nan
unsubscribe ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [PATCH v3 16/27] PPC: use helpers for rlimits

2009-11-27 Thread Benjamin Herrenschmidt
On Sat, 2009-11-28 at 00:05 +0100, Jiri Slaby wrote: Make sure compiler won't do weird things with limits. E.g. fetching them twice may return 2 different values after writable limits are implemented. I.e. either use newly added rlimit helpers or ACCESS_ONCE if not applicable. Thanks. I

Re: [RFC PATCH 11/19] powerpc: gamecube/wii: flipper interrupt controller support

2009-11-27 Thread Segher Boessenkool
It turns out that we _need_ to ack the RSW (Reset Switch) interrupt. The other interrupt sources checked (EXI, VI, DI, AI, DSP/ARAM) need no explicit ack. That would probably mean that the reset switch interrupt is an edge interrupt. Nah, it means that the RSW is a flip-flop. Segher

[PATCH v3 16/27] PPC: use helpers for rlimits

2009-11-27 Thread Jiri Slaby
Make sure compiler won't do weird things with limits. E.g. fetching them twice may return 2 different values after writable limits are implemented. I.e. either use newly added rlimit helpers or ACCESS_ONCE if not applicable. Signed-off-by: Jiri Slaby jsl...@suse.cz Cc: James Morris

Re: [RFC PATCH 11/19] powerpc: gamecube/wii: flipper interrupt controller support

2009-11-27 Thread Benjamin Herrenschmidt
On Sat, 2009-11-28 at 03:04 +0100, Segher Boessenkool wrote: It turns out that we _need_ to ack the RSW (Reset Switch) interrupt. The other interrupt sources checked (EXI, VI, DI, AI, DSP/ARAM) need no explicit ack. That would probably mean that the reset switch interrupt is an edge

Re: [RFC PATCH 12/19] powerpc: gamecube: platform support

2009-11-27 Thread Grant Likely
On Fri, Nov 27, 2009 at 2:35 PM, Benjamin Herrenschmidt b...@kernel.crashing.org wrote: On Fri, 2009-11-27 at 01:09 +0100, Segher Boessenkool wrote: We need it as it currently doesn't match with the default bus ids. Should I introduce a .type property matching any of those above in the

Re: [RFC PATCH 12/19] powerpc: gamecube: platform support

2009-11-27 Thread Grant Likely
On Fri, Nov 27, 2009 at 8:56 PM, Grant Likely grant.lik...@secretlab.ca wrote: On Fri, Nov 27, 2009 at 2:35 PM, Benjamin Herrenschmidt b...@kernel.crashing.org wrote: On Fri, 2009-11-27 at 01:09 +0100, Segher Boessenkool wrote: We need it as it currently doesn't match with the default bus

[PATCH 03/28] hvc_console: make the ops pointer const.

2009-11-27 Thread Amit Shah
From: Rusty Russell ru...@rustcorp.com.au This is nicer for modern R/O protection. And noone needs it non-const, so constify the callers as well. Signed-off-by: Rusty Russell ru...@rustcorp.com.au Signed-off-by: Amit Shah amit.s...@redhat.com To: Christian Borntraeger borntrae...@de.ibm.com Cc:

[PATCH 26/28] hvc_console: Export (GPL'ed) hvc_remove

2009-11-27 Thread Amit Shah
The virtio console, which uses hvc, will get the ability to hot-unplug ports. Export hvc_remove so that virtio_console can disassociate with hvc. Signed-off-by: Amit Shah amit.s...@redhat.com Cc: linuxppc-...@ozlabs.org --- drivers/char/hvc_console.c |1 + 1 files changed, 1 insertions(+), 0