Re: BUG in dma-mapping.h:218 // MESH SCSI driver not working

2010-03-19 Thread Stef Simoens
Hello, Some time ago (July 24th 2009 my mailbox says) I emailed you and the linuxppc-dev list about my problems booting from the mesh SCSI controller. I just compiled 2.6.31 (actually, gentoo-sources-2.6.31-r10); but the problem remains I know that 2.6.33 is out, but as I didn't see any

Re: [PATCH] PPC: Skip over OF_DT_NOP when unflattening the device tree

2010-03-19 Thread Jason Gunthorpe
On Fri, Mar 19, 2010 at 04:50:38PM +1100, Benjamin Herrenschmidt wrote: On Tue, 2010-03-09 at 12:30 -0700, Jason Gunthorpe wrote: NOPs within the property section are skipped, but NOPs between OF_DT_END_NODE and OF_DT_BEGIN_NODE were not. My firmware NOPs out entire nodes depending on

Re: [PATCH] PPC: Skip over OF_DT_NOP when unflattening the device tree

2010-03-19 Thread Grant Likely
On Fri, Mar 19, 2010 at 12:06 AM, Jason Gunthorpe jguntho...@obsidianresearch.com wrote: On Fri, Mar 19, 2010 at 04:50:38PM +1100, Benjamin Herrenschmidt wrote: On Tue, 2010-03-09 at 12:30 -0700, Jason Gunthorpe wrote: NOPs within the property section are skipped, but NOPs between

[git pull] Please pull powerpc.git merge branch

2010-03-19 Thread Benjamin Herrenschmidt
Hi Linus ! Here's a handful of powerpc fixes for 2.6.34, along with a patch from Fujita Tomonori to remove a config option that is mostly useless nowadays. Cheers, Ben. The following changes since commit 39710479303fd3affb3e204e9a7a75cc676977b5: Linus Torvalds (1): Merge branch

BestComm BD tasks, buffer done flag question

2010-03-19 Thread Roman Fietze
Hello, I'm using Grant's platform SCLPC/BestComm driver to transfer data from an FPGA (to disk). Very often I get a negative result from bcom_buffer_done because BCOM_BD_READY is not set. When searching for a solution I found this mail from Rob Broersen talking about a similar promlem in the

[PATCH]: Minor quibble in macintosh/windfarm_pm81.c

2010-03-19 Thread d binderman
Hello there, I just ran the sourceforge tool cppcheck over the source code of the new Linux kernel 2.6.34-rc1 It said [./macintosh/windfarm_pm81.c:760]: (style) Redundant condition. It is safe to deallocate a NULL poin ter [./macintosh/windfarm_pm81.c:762]: (style) Redundant condition. It is

[PATCH]: core/gpio-pmf.c: 3 * redundant code

2010-03-19 Thread d binderman
_ Send us your Hotmail stories and be featured in our newsletter http://clk.atdmt.com/UKM/go/195013117/direct/01/ Signed-off-by: David Binderman dcb...@hotmail.com ---

[GITPULL+PATCH 0/2 v3] irq: move some interrupt arch_* functions into struct irq_chip.

2010-03-19 Thread Ian Campbell
This small series ensures that struct irq_desc-chip_data is available for alternative irq_chip implementations. Since v2: pass x86_init_chip_data as a argument to irq_to_desc_alloc_node instead of calling in the arch code in order to get correct locking wrt the core code. Small impact on the SH

[PATCH 1/2] irq: move some interrupt arch_* functions into struct irq_chip.

2010-03-19 Thread Ian Campbell
Move arch_init_copy_chip_data and arch_free_chip_data into function pointers in struct irq_chip since they operate on irq_desc-chip_data. arch_init_chip_data cannot be moved into struct irq_chip because irq_desc-chip is not known at the time the irq_desc is setup. Instead rename

Re: [PATCH] powerpc/fsl: Add multiple MSI bank support

2010-03-19 Thread Kumar Gala
On Mar 18, 2010, at 10:06 PM, Michael Ellerman wrote: On Thu, 2010-03-18 at 09:53 -0500, Kumar Gala wrote: From: Lan Chunhe-B25806 b25...@freescale.com Freescale QorIQ P4080 has three MSI banks and the original code can not work well. This patch adds multiple MSI banks support for

[PATCH 4/7] hvc_console: Fix race between hvc_close and hvc_remove

2010-03-19 Thread Greg Kroah-Hartman
From: Amit Shah amit.s...@redhat.com Alan pointed out a race in the code where hvc_remove is invoked. The recent virtio_console work is the first user of hvc_remove(). Alan describes it thus: The hvc_console assumes that a close and remove call can't occur at the same time. In addition

[PATCH] [RFC] Xilinx Virtex 4 FX Soft FPU support

2010-03-19 Thread Sergey Temerkhanov
This patch enables support for Xilinx Virtex 4 FX singe-float FPU. Caveats: - Hard-float binaries which rely on in-kernel math emulation will give wrong results since they expect 64-bit double-precision instead of 32-bit single- precision

Re: [PATCH] [RFC] Xilinx Virtex 4 FX Soft FPU support

2010-03-19 Thread Sergey Temerkhanov
The patch. Regards, Resgey Temerkhanov diff -r 9d9ac97e095d .config --- a/.config Thu Feb 25 21:23:42 2010 +0300 +++ b/.config Thu Feb 25 21:49:02 2010 +0300 @@ -14,10 +14,12 @@ CONFIG_40x=y # CONFIG_44x is not set # CONFIG_E200 is not set +CONFIG_PPC_FPU=y CONFIG_4xx=y

[PATCH v5 01/10] swiotbl: add back swiotlb_alloc_boot()

2010-03-19 Thread Albert Herranz
This patch makes swiotlb_alloc_boot() available again. This weak function can be overloaded to modify slightly how the SWIOTLB and the overflow areas are allocated during boot. This will be used later to support the Nintendo Wii video game console, which requires placing the SWIOTLB area above

[PATCH v5 02/10] swiotlb: make swiotlb_bounce() __weak

2010-03-19 Thread Albert Herranz
This patch converts swiotlb_bounce() into a weak function making it overloadable by platform support code. This will be used later to support the Nintendo Wii video game console, which is a NOT_COHERENT_CACHE platform and requires explicit cache handling when dealing with the swiotlb bounce

[PATCH v5 04/10] powerpc: add min_direct_dma_addr

2010-03-19 Thread Albert Herranz
This patch adds min_direct_dma_addr to struct dev_archdata. min_direct_dma_addr can be used to define which is the minimum address suitable for a DMA operation. dma_capable() is updated to use this information in the SWIOTLB case. This will be used later to support the Nintendo Wii video game

[PATCH v5 05/10] USB: refactor unmap_urb_for_dma/map_urb_for_dma

2010-03-19 Thread Albert Herranz
Split unmap_urb_for_dma() and map_urb_for_dma() into smaller pieces to make the code easier to read and maintain. This patch adds four new URB flags which are used by map_urb_for_dma() to mark URBs with the exact method used to map the setup packet and/or the transfer buffer. These flags are

[PATCH v5 06/10] USB: add HCD_NO_COHERENT_MEM host controller driver flag

2010-03-19 Thread Albert Herranz
The HCD_NO_COHERENT_MEM USB host controller driver flag can be enabled to instruct the USB stack to avoid allocating coherent memory for USB buffers. This flag is useful to overcome some esoteric memory access restrictions found in some platforms. For example, the Nintendo Wii video game console

[PATCH v5 03/10] powerpc: add per-device dma coherent support

2010-03-19 Thread Albert Herranz
Use the generic per-device dma coherent allocator on powerpc. This allows a driver to declare coherent memory area from where a device can allocate coherent memory chunks. Signed-off-by: Albert Herranz albert_herr...@yahoo.es --- arch/powerpc/include/asm/dma-mapping.h |1 +

[PATCH v5 07/10] wii: have generic dma coherent

2010-03-19 Thread Albert Herranz
Let the Nintendo Wii gaming console use per-device dma coherent allocations. This will be used later by some of its drivers. Signed-off-by: Albert Herranz albert_herr...@yahoo.es --- arch/powerpc/platforms/embedded6xx/Kconfig |1 + 1 files changed, 1 insertions(+), 0 deletions(-) diff --git

[PATCH v5 00/10] wii: add usb 2.0 support

2010-03-19 Thread Albert Herranz
The following patch series adds USB 2.0 support for the Wii PowerPC platform via the EHCI controller present in the Hollywood chipset of the video game console. v4 - v5 - Set the default IO TLB size via the kernel command line. This is now possible on PowerPC thanks to a recent patch by Fujita

[PATCH v5 08/10] wii: add mem2 dma mapping ops

2010-03-19 Thread Albert Herranz
Some of the devices in the Hollywood chipset of the Nintendo Wii video game console have restrictions performing DMA transfers to the first contiguous RAM region (known as MEM1). For example, up to 3 bytes of the last word of a DMA transfer of a non-32 bit aligned length to MEM1 may be lost. Such

[PATCH v5 09/10] wii: enable swiotlb

2010-03-19 Thread Albert Herranz
Enable the use of a software IO TLB on the Nintendo Wii video game console. This is used by the platform DMA support code to overcome the limitations found in some of the devices within the Hollywood chipset. Signed-off-by: Albert Herranz albert_herr...@yahoo.es ---

[PATCH v5 10/10] wii: hollywood ehci controller support

2010-03-19 Thread Albert Herranz
Add support for the USB Enhanced Host Controller Interface included in the Hollywood chipset of the Nintendo Wii video game console. Signed-off-by: Albert Herranz albert_herr...@yahoo.es --- arch/powerpc/platforms/embedded6xx/Kconfig |1 + drivers/usb/host/Kconfig |8 +

Re: [PATCH v5 00/10] wii: add usb 2.0 support

2010-03-19 Thread Alan Stern
On Fri, 19 Mar 2010, Albert Herranz wrote: Alan: I think you are also working in a patchset to make {un}map_urb_for_dma remember how the urb was mapped, right? Yes; you can see an initial version here: http://marc.info/?l=linux-usbm=126901183419219w=2 This is a bug fix, so it's

Re: [PATCH 1/2] irq: move some interrupt arch_* functions into struct irq_chip.

2010-03-19 Thread Yinghai Lu
please check Subject: [PATCH -v4] irq: move some interrupt arch_* functions into struct irq_chip. From: Ian Campbell ian.campb...@citrix.com Move arch_init_copy_chip_data and arch_free_chip_data into function pointers in struct irq_chip since they operate on irq_desc-chip_data.

Re: [PATCH v5 00/10] wii: add usb 2.0 support

2010-03-19 Thread Albert Herranz
Alan Stern wrote: Alan: I think you are also working in a patchset to make {un}map_urb_for_dma remember how the urb was mapped, right? Yes; you can see an initial version here: http://marc.info/?l=linux-usbm=126901183419219w=2 This is a bug fix, so it's likely to be merged before

[v2 PATCH] of/flattree: Fix unhandled OF_DT_NOP tag when unflattening the device tree

2010-03-19 Thread Grant Likely
From: Jason Gunthorpe jguntho...@obsidianresearch.com NOPs within the property section are skipped, but NOPs between OF_DT_END_NODE and OF_DT_BEGIN_NODE were not. My firmware NOPs out entire nodes depending on various environment parameters. of_scan_flat_dt already handles NOP more generally.

Re: [PATCH v5 08/10] wii: add mem2 dma mapping ops

2010-03-19 Thread Konrad Rzeszutek Wilk
+int wii_set_mem2_dma_constraints(struct device *dev) +{ + struct dev_archdata *sd; + + sd = dev-archdata; + sd-max_direct_dma_addr = 0; + sd-min_direct_dma_addr = wii_hole_start + wii_hole_size; + + set_dma_ops(dev, wii_mem2_dma_ops); + return 0; +}

Re: [PATCH v5 08/10] wii: add mem2 dma mapping ops

2010-03-19 Thread Konrad Rzeszutek Wilk
+/* + * The mem2_dma device. + * + * This device owns a pool of coherent MEM2 memory that can be shared among + * several devices requiring MEM2 DMA buffers, instead of dedicating specific + * pools for each device. + * + * A device can use the shared coherent MEM2 memory pool by calling

Re: [v2 PATCH] of/flattree: Fix unhandled OF_DT_NOP tag when unflattening the device tree

2010-03-19 Thread David Gibson
On Fri, Mar 19, 2010 at 02:01:49PM -0600, Grant Likely wrote: From: Jason Gunthorpe jguntho...@obsidianresearch.com NOPs within the property section are skipped, but NOPs between OF_DT_END_NODE and OF_DT_BEGIN_NODE were not. My firmware NOPs out entire nodes depending on various environment

Re: [PATCH v5 08/10] wii: add mem2 dma mapping ops

2010-03-19 Thread Albert Herranz
Konrad Rzeszutek Wilk wrote: +/* + * The mem2_dma device. + * + * This device owns a pool of coherent MEM2 memory that can be shared among + * several devices requiring MEM2 DMA buffers, instead of dedicating specific + * pools for each device. + * + * A device can use the shared

Re: [PATCH v5 08/10] wii: add mem2 dma mapping ops

2010-03-19 Thread Albert Herranz
Konrad Rzeszutek Wilk wrote: +int wii_set_mem2_dma_constraints(struct device *dev) +{ +struct dev_archdata *sd; + +sd = dev-archdata; +sd-max_direct_dma_addr = 0; +sd-min_direct_dma_addr = wii_hole_start + wii_hole_size; + +set_dma_ops(dev, wii_mem2_dma_ops); +