RE: [PATCH 4/4][v2] rapidio, powerpc/85xx: Error interrupt handler for sRIO.

2010-11-17 Thread Xie Shaohui-B21989
Best Regards, Shaohui Xie From: Bounine, Alexandre [mailto:alexandre.boun...@idt.com] Sent: Tuesday, November 16, 2010 10:01 PM To: Xie Shaohui-B21989; a...@linux-foundation.org Cc: linux-ker...@vger.kernel.org; linuxppc-dev@lists.ozlabs.org; Li Yang-R58472; Gala Kumar-B11780; Zang

Re: [PATCH 1/5] of: Add support for linking device tree blobs into vmlinux

2010-11-17 Thread Sam Ravnborg
On Tue, Nov 16, 2010 at 02:41:36PM -0800, dirk.brande...@gmail.com wrote: From: Dirk Brandewie dirk.brande...@gmail.com This patch adds support for linking device tree blobs into vmlinux. Modifies asm-generic/vmlinux.lds.h to add linking .dtb.init.rodata sections into the .init.data section

[PATCH V2 0/3] at24: parse OF-data

2010-11-17 Thread Wolfram Sang
Here is the second round of this series: * 1/3 now uses __be32 instead of u32. * 2/3 is new and adds some more sanity checks * 3/3 is unchanged Grant, I hope you can pick 2/3 as well. Should make things easier and it is just a misc-driver (which I maintain) :) Wolfram Sang (3): misc: at24:

[PATCH 1/3] misc: at24: parse OF-data, too

2010-11-17 Thread Wolfram Sang
Information about the pagesize and read-only-status may also come from the devicetree. Parse this data, too, and act accordingly. While we are here, change the initialization printout a bit. write_max is useful to know to detect performance bottlenecks, the rest is superfluous. Signed-off-by:

[PATCH 2/3] misc: at24: add more sanity checks for parameters

2010-11-17 Thread Wolfram Sang
Side-effects happen when passing 0 to either io_limit or page_size. Give an error in case of this misconfiguration. Signed-off-by: Wolfram Sang w.s...@pengutronix.de --- drivers/misc/eeprom/at24.c | 10 ++ 1 files changed, 10 insertions(+), 0 deletions(-) diff --git

[PATCH 3/3] powerpc: pcm030/032: add pagesize to dts

2010-11-17 Thread Wolfram Sang
Signed-off-by: Wolfram Sang w.s...@pengutronix.de --- arch/powerpc/boot/dts/pcm030.dts |1 + arch/powerpc/boot/dts/pcm032.dts |3 ++- 2 files changed, 3 insertions(+), 1 deletions(-) diff --git a/arch/powerpc/boot/dts/pcm030.dts b/arch/powerpc/boot/dts/pcm030.dts index 8a4ec30..e7c36bc

Re: [PATCH 1/5] scripts: dtc: Merge in changes from the dtc repository

2010-11-17 Thread Jon Loeliger
On Tue, Nov 16, 2010 at 12:49:51PM -0800, John Bonesio wrote: Pull in recent changes from the main dtc repository. These changes primarily allow multiple device trees to be declared which are merged by dtc. This feature allows us to include a basic dts file and then provide more

Re: [PATCH 1/5] scripts: dtc: Merge in changes from the dtc repository

2010-11-17 Thread Jon Loeliger
Hmm, is there some documentation for how to use this feature? Specifically I have a custom board with multiple discrete computers on it which are only very slightly physically different from each other and I'd like to be able to avoid maintaining 2 nearly-exact copies of the same DTS file.

Re: [PATCH] powerpc: Per process DSCR

2010-11-17 Thread Kumar Gala
On Nov 16, 2010, at 6:31 PM, Anton Blanchard wrote: In order to add per process control of the DSCR, the following patch emulates read/write of the DSCR from userspace and saves and restores it on context switch. We add emulated stats to track how many times we do this. While writing this

Re: [PATCH] kgdb, ppc: Corrected the address using of current-thread.evr register

2010-11-17 Thread Kumar Gala
On Nov 16, 2010, at 4:02 PM, Jason Wessel wrote: On 11/16/2010 06:58 AM, Dongdong Deng wrote: Passing the address of current-thread.evr register to memcpy function. It turns out that out of all of my test configs and targets I did not have any that defined both CONFIG_FSL_BOOKE and

[PATCH] powerpc/mm: Fix module instruction tlb fault handling on Book-E 64

2010-11-17 Thread Kumar Gala
We were seeing oops like the following when we did an rmmod on a module: Unable to handle kernel paging request for instruction fetch Faulting instruction address: 0x80008010 Oops: Kernel access of bad area, sig: 11 [#1] SMP NR_CPUS=2 P5020 DS last sysfs file:

Re: [PATCH] kgdb, ppc: Corrected the address using of current-thread.evr register

2010-11-17 Thread Jason Wessel
On 11/17/2010 11:16 AM, Kumar Gala wrote: Thanks, Jason. Repost a version with the casts and I'll pick it up. - k I have the final version ready for a pull request that I was going to make in the next hour or two that is fully regression tested. If you would prefer to these changes in

Re: [PATCH] kgdb, ppc: Corrected the address using of current-thread.evr register

2010-11-17 Thread Kumar Gala
On Nov 17, 2010, at 11:21 AM, Jason Wessel wrote: On 11/17/2010 11:16 AM, Kumar Gala wrote: Thanks, Jason. Repost a version with the casts and I'll pick it up. - k I have the final version ready for a pull request that I was going to make in the next hour or two that is fully

Re: [PATCH 1/5] of: Add support for linking device tree blobs into vmlinux

2010-11-17 Thread David Daney
On 11/16/2010 10:14 PM, Dirk Brandewie wrote: On 11/16/2010 06:58 PM, Grant Likely wrote: On Tue, Nov 16, 2010 at 7:21 PM, Dirk Brandewie dirk.brande...@gmail.com wrote: On 11/16/2010 04:39 PM, David Daney wrote: Thanks for doing this. However I have a few comments... On 11/16/2010 02:41

Re: [PATCH 1/5] of: Add support for linking device tree blobs into vmlinux

2010-11-17 Thread Grant Likely
On Wed, Nov 17, 2010 at 10:27:51AM +0100, Sam Ravnborg wrote: On Tue, Nov 16, 2010 at 02:41:36PM -0800, dirk.brande...@gmail.com wrote: From: Dirk Brandewie dirk.brande...@gmail.com This patch adds support for linking device tree blobs into vmlinux. Modifies asm-generic/vmlinux.lds.h to

Re: [PATCH] kgdb, ppc: Corrected the address using of current-thread.evr register

2010-11-17 Thread Kumar Gala
From: Dongdong Deng dongdong.d...@windriver.com Date: Tue, 16 Nov 2010 16:02:00 -0600 Subject: [PATCH 4/4] kgdb: Fix regression in evr register handling Commit ff10b88b5a05c8f1646dd15fb9f6093c1384ff6d (kgdb,ppc: Individual register get/set for ppc) introduced a problem where memcpy was used

Re: [PATCH 1/5] of: Add support for linking device tree blobs into vmlinux

2010-11-17 Thread Sam Ravnborg
+ +DTC = $(objtree)/scripts/dtc/dtc + +quiet_cmd_dtc = DTC $@ Please avoid tabs in the output - all other uses spaces. (There is a tab between DTC and $@) + cmd_dtc = $(DTC) -O dtb -o $(obj)/$*.dtb -b 0 $(DTS_FLAGS) $(src)/dts/$*.dts Looks strange. How

Re: [PATCH] powerpc: Per process DSCR

2010-11-17 Thread Benjamin Herrenschmidt
On Wed, 2010-11-17 at 11:15 -0600, Kumar Gala wrote: We don't have no stinking DSCR ;). Would like this to be #ifdef CONFIG_PPC_BOOK3S_64. That or select it from the platform / CPUs that support it. Cheers, Ben. ___ Linuxppc-dev mailing list

Re: PowerMac8600 help ...

2010-11-17 Thread kevin diggs
Hi, I have managed to boot the G4 (GigE) using a kernel built with the 4.3.5 compiler on the 8600. I have also discovered what prevented firefox from working with 4.3.5. It was picking up the 3.4.6 libstdc++ (possibly other internal tidbits as well). Even something as simple as: #include

Re: PowerMac8600 help ...

2010-11-17 Thread Segher Boessenkool
I have also discovered what prevented firefox from working with 4.3.5. It was picking up the 3.4.6 libstdc++ (possibly other internal tidbits as well). So you installed (one of) those compilers incorrectly. P.S.: newer powermacs have a line in cpuinfo, like PowerMac 7,2. Does this uniquely

[PATCH 0/5] refactor dts files for mpc5200b based systems (take 2)

2010-11-17 Thread John Bonesio
I belive I've fixed the problems with the messed up [PATCH 1/5]. I've also incorporated changes per comments. The following series implements a set of changes to refactor dts (device tree source) files for systems using the mpc5200b SoC. The dtc changes allow a base dts to be defined in a common

[PATCH 2/5] powerpc/5200: dts: rename nodes to prepare for refactoring dts files

2010-11-17 Thread John Bonesio
This patch renames nodes in dts fils for MPC5200b files to prepare for refactoring of these files later. When refactoring it will be easier to verify the results if the node names aren't changing at the same time. Signed-off-by: John Bonesio bo...@secretlab.ca ---

[PATCH 3/5] powerpc/5200: dts: remove unused properties

2010-11-17 Thread John Bonesio
This patch remove unused properties in dts files in preparation of refactoring the dts files for MPC5200b based boards. Signed-off-by: John Bonesio bo...@secretlab.ca --- arch/powerpc/boot/dts/cm5200.dts|2 -- arch/powerpc/boot/dts/lite5200b.dts |3 ---

[PATCH 4/5] powerpc/5200: dts: Change combatible strings on localbus

2010-11-17 Thread John Bonesio
This patch changes some incorrect compatible strings on the local plus bus node in dts files for MPC5200b based systems. Signed-off-by: John Bonesio bo...@secretlab.ca --- arch/powerpc/boot/dts/cm5200.dts|2 +- arch/powerpc/boot/dts/digsy_mtc.dts |2 +-

application needs fast access to physical memory

2010-11-17 Thread steven . lin
My application needs a fast way to access a specific physical DDR memory region. The application runs on an MPC8548 PowerPC which has an MMU. I've tried two approaches that are typical for Linux, mmap() and using a kernel module that implements read()/write() into this region and I'm finding

[PATCH] powerpc: fix call to subpage_protection()

2010-11-17 Thread Michael Neuling
In: powerpc/mm: Fix pgtable cache cleanup with CONFIG_PPC_SUBPAGE_PROT commit d28513bc7f675d28b479db666d572e078ecf182d Author: David Gibson da...@gibson.dropbear.id.au subpage_protection() was changed to to take an mm rather a pgdir but it didn't change calling site in hashpage_preload().

Re: arch/powerpc/*/div64.S

2010-11-17 Thread Benjamin Herrenschmidt
On Sat, 2010-10-02 at 14:16 -0400, Albert Cahalan wrote: This looks like duplicated code getting out of sync. Right, tho your patch actually reverts the fix :-) I don't know if it's worth considering using common files for some /lib stuff there tho.. .the runtime env. is quite different...

Re: [PATCH 1/5] scripts: dtc: Merge in changes from the dtc repository

2010-11-17 Thread David Gibson
On Wed, Nov 17, 2010 at 09:47:55AM -0600, Jon Loeliger wrote: On Tue, Nov 16, 2010 at 12:49:51PM -0800, John Bonesio wrote: Pull in recent changes from the main dtc repository. These changes primarily allow multiple device trees to be declared which are merged by dtc. This feature

Re: linux-next: build warning in Linus' tree

2010-11-17 Thread Benjamin Herrenschmidt
On Mon, 2010-10-25 at 17:03 +1100, Stephen Rothwell wrote: Hi Arnaud, On Sun, 24 Oct 2010 23:47:09 -0400 Arnaud Lacombe lacom...@gmail.com wrote: The following patch should fix this warning. I think the following is preferable. Not tested yet, I will test tomorrow and submit properly

Re: linux-next: build warning in Linus' tree

2010-11-17 Thread Arnaud Lacombe
Hi, On Wed, Nov 17, 2010 at 10:55 PM, Benjamin Herrenschmidt b...@kernel.crashing.org wrote: On Mon, 2010-10-25 at 17:03 +1100, Stephen Rothwell wrote: Hi Arnaud, On Sun, 24 Oct 2010 23:47:09 -0400 Arnaud Lacombe lacom...@gmail.com wrote: The following patch should fix this warning. I

[PATCH 0/4] Patches from my local tree

2010-11-17 Thread mikey
Below are a few patches from my local tree ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

[PATCH 1/4] powerpc: remove unneeded cpu_setup/restore from POWER7 cputable entry

2010-11-17 Thread mikey
These are not needed so just remove them Signed-off-by: Michael Neuling mi...@neuling.org --- arch/powerpc/kernel/cputable.c |2 -- arch/powerpc/kernel/misc.S |5 - 2 files changed, 7 deletions(-) Index: linux-2.6-ozlabs/arch/powerpc/kernel/cputable.c

[PATCH 2/4] powerpc: remove POWER6 oprofile workarounds for POWER7

2010-11-17 Thread mikey
These are not needed on POWER7 so remove them. Signed-off-by: Michael Neuling mi...@neuling.org --- arch/powerpc/kernel/cputable.c |4 1 file changed, 4 deletions(-) Index: linux-2.6-ozlabs/arch/powerpc/kernel/cputable.c

[PATCH 3/4] powerpc: add POWER7+ cputable entry

2010-11-17 Thread mikey
This adds the POWER7+ cputable entry for the PVR 0x004a. Rest is the same as vanilla POWER7. Signed-off-by: Michael Neuling mi...@neuling.org --- arch/powerpc/kernel/cputable.c | 16 1 file changed, 16 insertions(+) Index: linux-2.6-ozlabs/arch/powerpc/kernel/cputable.c

[PATCH 4/4] powerpc: hash_preload: avoid avoidable void

2010-11-17 Thread mikey
Change pgdir from a void to real type. Having this as a void is stupid and has already caused 1 bug. Signed-off-by: Michael Neuling mi...@neuling.org --- arch/powerpc/mm/hash_utils_64.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) Index:

[git pull] Please pull powerpc.git merge branch

2010-11-17 Thread Benjamin Herrenschmidt
Hi Linus ! Here are a handful of bug fixes and trivialities for powerpc for you to pull. Thanks ! Cheers, Ben. The following changes since commit 7957f0a857754c555e07f58a3fb83ac29501478c: Linus Torvalds (1): Fix build failure due to hwirq.h needing smp_lock.h are available in the

[PATCH 1/2][v4] fsl_rio: move machine_check handler into machine_check_e500 machine_check_e500mc

2010-11-17 Thread Shaohui Xie
Signed-off-by: Shaohui Xie b21...@freescale.com Cc: Li Yang le...@freescale.com Cc: Kumar Gala kumar.g...@freescale.com Cc: Roy Zang tie-fei.z...@freescale.com Cc: Alexandre Bounine alexandre.boun...@idt.com --- arch/powerpc/include/asm/rio.h |5 + arch/powerpc/kernel/traps.c| 13

[PATCH 2/2][v3] rapidio, powerpc/85xx: Error interrupt handler for sRIO.

2010-11-17 Thread Shaohui Xie
The sRIO controller reports errors to the core with one signal, it uses register EPWISR to provides the core quick access to where the error occurred. The EPWISR indicates that there are 4 interrupts sources, port1, port2, message unit and port write receive, but the sRIO driver does not support