Re: powerpc: Add an inline function to update HID0

2015-08-04 Thread Gautham R Shenoy
Hi Michael, On Tue, Aug 04, 2015 at 08:08:58PM +1000, Michael Ellerman wrote: On Tue, 2015-04-08 at 08:30:58 UTC, Gautham R. Shenoy wrote: Section 3.7 of Version 1.2 of the Power8 Processor User's Manual prescribes that updates to HID0 be preceded by a SYNC instruction and followed by an

[PATCH v2] powerpc: Add an inline function to update HID0

2015-08-04 Thread Gautham R. Shenoy
Section 3.7 of Version 1.2 of the Power8 Processor User's Manual prescribes that updates to HID0 be preceded by a SYNC instruction and followed by an ISYNC instruction (Page 91). Create an inline function name update_hid0() which follows this recipe and invoke it from the static split core path.

[PATCH] powernv: Invoke opal_cec_reboot2() on unrecoverable HMI.

2015-08-04 Thread Mahesh J Salgaonkar
From: Mahesh Salgaonkar mah...@linux.vnet.ibm.com Invoke new opal_cec_reboot2() call with reboot type OPAL_REBOOT_PLATFORM_ERROR (for unrecoverable HMI interrupts) to inform BMC/OCC about this error, so that BMC can collect relevant data for error analysis and decide what component to

Re: powerpc: Add an inline function to update HID0

2015-08-04 Thread Michael Ellerman
On Tue, 2015-04-08 at 08:30:58 UTC, Gautham R. Shenoy wrote: Section 3.7 of Version 1.2 of the Power8 Processor User's Manual prescribes that updates to HID0 be preceded by a SYNC instruction and followed by an ISYNC instruction (Page 91). Create a function name update_hid0() which follows

RE: [v3, 1/2] powerpc/mpc85xx: Create dts components for the FSL QorIQ DPAA FMan

2015-08-04 Thread Liberman Igal
Regards, Igal Liberman -Original Message- From: Wood Scott-B07421 Sent: Tuesday, August 04, 2015 8:00 AM To: Liberman Igal-B31950 igal.liber...@freescale.com Cc: devicet...@vger.kernel.org; linuxppc-dev@lists.ozlabs.org; Bucur Madalin-Cristian-B32716 madalin.bu...@freescale.com;

Re: powerpc: Add an inline function to update HID0

2015-08-04 Thread Madhavan Srinivasan
On Tuesday 04 August 2015 03:38 PM, Michael Ellerman wrote: On Tue, 2015-04-08 at 08:30:58 UTC, Gautham R. Shenoy wrote: Section 3.7 of Version 1.2 of the Power8 Processor User's Manual prescribes that updates to HID0 be preceded by a SYNC instruction and followed by an ISYNC instruction

[PATCH] powerpc: Add an inline function to update HID0

2015-08-04 Thread Gautham R. Shenoy
Section 3.7 of Version 1.2 of the Power8 Processor User's Manual prescribes that updates to HID0 be preceded by a SYNC instruction and followed by an ISYNC instruction (Page 91). Create a function name update_hid0() which follows this recipe and invoke it from the static split core path.

Re: [V3] powerpc/irq: Enable some more exceptions in /proc/interrupts interface

2015-08-04 Thread Michael Ellerman
On Mon, 2015-13-07 at 08:16:06 UTC, Anshuman Khandual wrote: This patch enables facility unavailable exceptions for generic facility, FPU, ALTIVEC and VSX in /proc/interrupts listing by incrementing their newly added IRQ statistical counters as and when these exceptions happen. This also adds

[PATCH 4/5] powerpc/pseries: replace kmalloc + strlcpy

2015-08-04 Thread Andy Shevchenko
The helper kstrndup() will do the same in one line. Signed-off-by: Andy Shevchenko andriy.shevche...@linux.intel.com --- arch/powerpc/platforms/pseries/of_helpers.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/arch/powerpc/platforms/pseries/of_helpers.c

[PATCH 5/5] powerpc/pseries: re-use code from of_helpers module

2015-08-04 Thread Andy Shevchenko
The derive_parent() has similar semantics to what we have in newly introduced of_helpers module. The replacement reduces code base and propagates the actual error code to the caller. Signed-off-by: Andy Shevchenko andriy.shevche...@linux.intel.com --- arch/powerpc/platforms/pseries/dlpar.c | 31

[PATCH 3/5] powerpc/pseries: don't call strrchr() twice

2015-08-04 Thread Andy Shevchenko
There is no need to call strrchr() second time. We already know that in that case parent_path_len either 1 (/foo) or bigger (/foo/bar). Signed-off-by: Andy Shevchenko andriy.shevche...@linux.intel.com --- arch/powerpc/platforms/pseries/of_helpers.c | 2 +- 1 file changed, 1 insertion(+), 1

[PATCH 2/5] powerpc/pseries: fix a potential memory leak

2015-08-04 Thread Andy Shevchenko
In case we have a full node name like /foo/bar and /foo is not found the parent_path left unfreed. So, free a memory before return to a caller. Signed-off-by: Andy Shevchenko andriy.shevche...@linux.intel.com --- arch/powerpc/platforms/pseries/of_helpers.c | 6 ++ 1 file changed, 2

[PATCH 1/5] powerpc/pseries: extract of_helpers module

2015-08-04 Thread Andy Shevchenko
Extract a new module to share the code between other modules. There is no functional change. Signed-off-by: Andy Shevchenko andriy.shevche...@linux.intel.com --- arch/powerpc/platforms/pseries/Makefile | 1 + arch/powerpc/platforms/pseries/of_helpers.c | 38 +

Re: Missing Linux patches

2015-08-04 Thread leroy christophe
Le 02/08/2015 21:05, Markus Stockhausen a écrit : Hi Christophe, I saw that this patch from you is still missing in Linux mainline: https://lists.ozlabs.org/pipermail/linuxppc-dev/2014-September/121144.html Is there any reason for not using it? Markus Hi, I sent v3 of that Patch on 19 May

Re: [PATCH 6/6 v2] ASoC: fsl_ssi: adjust set DAI format in AC'97 mode

2015-08-04 Thread Mark Brown
On Tue, Aug 04, 2015 at 12:42:48AM +0200, Maciej S. Szmigiero wrote: In cases like this where only one patch of six patch series is updated should other ones be resubmitted as well to keep the full patch series together? Yes, any unapplied patches should be resubmitted. signature.asc

GPMC in device tree

2015-08-04 Thread Ran Shalit
Hello, I would please like to ask if describing flash nor used with GPMC, whould be done as described in: https://www.kernel.org/doc/Documentation/devicetree/bindings/mtd/gpmc-nor.txt It is described in the above link as TI's GPMC, so I'm not sure if it is relevent for powerpc too. Thank you,

Re: windfarm: decrement client count when unregistering

2015-08-04 Thread Michael Ellerman
On Fri, 2015-31-07 at 12:08:58 UTC, Paul Bolle wrote: wf_unregister_client() increments the client count when a client unregisters. That is obviously incorrect. Decrement that client count instead. Fixes: 75722d3992f5 ([PATCH] ppc64: Thermal control for SMU based machines) Signed-off-by:

Re: RFC: Reducing the number of non volatile GPRs in the ppc64 kernel

2015-08-04 Thread Segher Boessenkool
Hi Anton, On Wed, Aug 05, 2015 at 02:03:00PM +1000, Anton Blanchard wrote: While looking at traces of kernel workloads, I noticed places where gcc used a large number of non volatiles. Some of these functions did very little work, and we spent most of our time saving the non volatiles to the

RE: [1/2] powerpc/config: enable teranetics PHY

2015-08-04 Thread Shaohui Xie
On Tue, 2015-08-04 at 19:24 -0500, Scott Wood wrote: On Tue, 2015-08-04 at 19:18 -0500, Scott Wood wrote: On Fri, Jul 24, 2015 at 11:45:33AM +0800, shaohui xie wrote: From: Shaohui Xie shaohui@freescale.com The PHY uses XAUI interface to connect to MAC, mostly the PHY used

Re: [PATCH 1/5] powerpc/pseries: extract of_helpers module

2015-08-04 Thread Segher Boessenkool
Hi Andy, On Tue, Aug 04, 2015 at 05:36:45PM +0300, Andy Shevchenko wrote: +struct device_node *pseries_of_derive_parent(const char *path) +{ + struct device_node *parent = NULL; + char *parent_path = /; + size_t parent_path_len = strrchr(path, '/') - path + 1; + + /* reject

[PATCH V2 3/6] powerpc/powernv: use one M64 BAR in Single PE mode for one VF BAR

2015-08-04 Thread Wei Yang
In current implementation, when VF BAR is bigger than 64MB, it uses 4 M64 BAR in Single PE mode to cover the number of VFs required to be enabled. By doing so, several VFs would be in one VF Group and leads to interference between VFs in the same group. This patch changes the design by using one

[PATCH V2 5/6] powerpc/powernv: boundary the total vf bar size instead of the individual one

2015-08-04 Thread Wei Yang
Each VF could have 6 BARs at most. When the total BAR size exceeds the gate, after expanding it will also exhaust the M64 Window. This patch limits the boundary by checking the total VF BAR size instead of the individual BAR. Signed-off-by: Wei Yang weiy...@linux.vnet.ibm.com ---

Re: powerpc: Add an inline function to update HID0

2015-08-04 Thread Michael Ellerman
On Tue, 2015-08-04 at 19:36 +0530, Madhavan Srinivasan wrote: On Tuesday 04 August 2015 03:38 PM, Michael Ellerman wrote: On Tue, 2015-04-08 at 08:30:58 UTC, Gautham R. Shenoy wrote: Section 3.7 of Version 1.2 of the Power8 Processor User's Manual prescribes that updates to HID0 be

Re: [1/2] powerpc/config: enable teranetics PHY

2015-08-04 Thread Scott Wood
On Tue, 2015-08-04 at 22:06 -0500, Xie Shaohui-B21989 wrote: -Original Message- From: Xie Shaohui-B21989 Sent: Wednesday, August 05, 2015 11:00 AM To: Wood Scott-B07421 Cc: linuxppc-dev@lists.ozlabs.org Subject: RE: [1/2] powerpc/config: enable teranetics PHY On Tue,

[PATCH V2 0/6] Redesign SR-IOV on PowerNV

2015-08-04 Thread Wei Yang
In original design, it tries to group VFs to enable more number of VFs in the system, when VF BAR is bigger than 64MB. This design has a flaw in which one error on a VF will interfere other VFs in the same group. This patch series change this design by using M64 BAR in Single PE mode to cover

[PATCH V2 2/6] powerpc/powernv: simplify the calculation of iov resource

2015-08-04 Thread Wei Yang
The alignment of IOV BAR on PowerNV platform is the total size of the IOV BAR. No matter whether the IOV BAR is truncated or not, the total size could be calculated by (vfs_expanded * VF size). This patch simplifies the pnv_pci_iov_resource_alignment() by removing the first case. Signed-off-by:

Re: powerpc: Add an inline function to update HID0

2015-08-04 Thread Segher Boessenkool
On Tue, Aug 04, 2015 at 08:08:58PM +1000, Michael Ellerman wrote: +static inline void update_hid0(unsigned long hid0) +{ + /* +* The HID0 update should at the very least be preceded by a +* a SYNC instruction followed by an ISYNC instruction +*/ + mb(); +

RE: [1/2] powerpc/config: enable teranetics PHY

2015-08-04 Thread Shaohui Xie
-Original Message- From: Wood Scott-B07421 Sent: Wednesday, August 05, 2015 8:19 AM To: shaohui xie Cc: linuxppc-dev@lists.ozlabs.org; Xie Shaohui-B21989 Subject: Re: [1/2] powerpc/config: enable teranetics PHY On Fri, Jul 24, 2015 at 11:45:33AM +0800, shaohui xie wrote: From:

Re: GPMC in device tree

2015-08-04 Thread Ran Shalit
On Wed, Aug 5, 2015 at 12:25 AM, Scott Wood scottw...@freescale.com wrote: On Wed, 2015-08-05 at 00:22 +0300, Ran Shalit wrote: On Tue, Aug 4, 2015 at 11:31 PM, Scott Wood scottw...@freescale.com wrote: On Tue, 2015-08-04 at 23:26 +0300, Ran Shalit wrote: On Tue, Aug 4, 2015 at 9:54 PM,

RE: [1/2] powerpc/config: enable teranetics PHY

2015-08-04 Thread Shaohui Xie
-Original Message- From: Xie Shaohui-B21989 Sent: Wednesday, August 05, 2015 11:00 AM To: Wood Scott-B07421 Cc: linuxppc-dev@lists.ozlabs.org Subject: RE: [1/2] powerpc/config: enable teranetics PHY On Tue, 2015-08-04 at 19:24 -0500, Scott Wood wrote: On Tue, 2015-08-04 at

Re: [1/2] powerpc/config: enable teranetics PHY

2015-08-04 Thread Scott Wood
On Fri, Jul 24, 2015 at 11:45:33AM +0800, shaohui xie wrote: From: Shaohui Xie shaohui@freescale.com The PHY uses XAUI interface to connect to MAC, mostly the PHY used on riser card. Signed-off-by: Shaohui Xie shaohui@freescale.com ---

Re: [1/2] powerpc/config: enable teranetics PHY

2015-08-04 Thread Scott Wood
On Tue, 2015-08-04 at 19:24 -0500, Scott Wood wrote: On Tue, 2015-08-04 at 19:18 -0500, Scott Wood wrote: On Fri, Jul 24, 2015 at 11:45:33AM +0800, shaohui xie wrote: From: Shaohui Xie shaohui@freescale.com The PHY uses XAUI interface to connect to MAC, mostly the PHY used on

Re: GPMC in device tree

2015-08-04 Thread Scott Wood
On Wed, 2015-08-05 at 00:22 +0300, Ran Shalit wrote: On Tue, Aug 4, 2015 at 11:31 PM, Scott Wood scottw...@freescale.com wrote: On Tue, 2015-08-04 at 23:26 +0300, Ran Shalit wrote: On Tue, Aug 4, 2015 at 9:54 PM, Scott Wood scottw...@freescale.com wrote: On Tue, 2015-08-04 at 18:29

Re: [1/2] powerpc/config: enable teranetics PHY

2015-08-04 Thread Scott Wood
On Tue, 2015-08-04 at 19:18 -0500, Scott Wood wrote: On Fri, Jul 24, 2015 at 11:45:33AM +0800, shaohui xie wrote: From: Shaohui Xie shaohui@freescale.com The PHY uses XAUI interface to connect to MAC, mostly the PHY used on riser card. Signed-off-by: Shaohui Xie

Re: GPMC in device tree

2015-08-04 Thread Ran Shalit
On Tue, Aug 4, 2015 at 11:31 PM, Scott Wood scottw...@freescale.com wrote: On Tue, 2015-08-04 at 23:26 +0300, Ran Shalit wrote: On Tue, Aug 4, 2015 at 9:54 PM, Scott Wood scottw...@freescale.com wrote: On Tue, 2015-08-04 at 18:29 +0300, Ran Shalit wrote: Hello, I would please like to

Re: powerpc/corenet: use the mixed mode of MPIC when enabling CPU hotplug

2015-08-04 Thread Scott Wood
On Thu, Jul 23, 2015 at 11:55:45AM +0800, chenhui zhao wrote: Core reset may cause issue if using the proxy mode of MPIC. Use the mixed mode of MPIC if enabling CPU hotplug. Signed-off-by: Chenhui Zhao chenhui.z...@freescale.com --- arch/powerpc/platforms/85xx/corenet_generic.c | 8

Re: [PATCH v5 00/46] usb: gadget: rework ep matching and claiming mechanism

2015-08-04 Thread Felipe Balbi
Hi, On Fri, Jul 31, 2015 at 04:00:12PM +0200, Robert Baldyga wrote: Hello, This patch series reworks endpoint matching and claiming mechanism in epautoconf. From v2 there are couple of new patches adding 'ep_match' to usb_gadget_ops and removing chip-specific quirk handling from generic

[PATCH v2 4/8] xen: Use the correctly the Xen memory terminologies

2015-08-04 Thread Julien Grall
Based on include/xen/mm.h [1], Linux is mistakenly using MFN when GFN is meant, I suspect this is because the first support for Xen was for PV. This resulted in some misimplementation of helpers on ARM and confused developers about the expected behavior. For instance, with pfn_to_mfn, we expect

[PATCH v2 7/8] hvc/xen: Further s/MFN/GFN clean-up

2015-08-04 Thread Julien Grall
HVM_PARAM_CONSOLE_PFN is used to retrieved the console PFN for HVM guest. It returns a PFN (aka GFN) and not a MFN. Furthermore, use directly virt_to_gfn for both PV and HVM domain rather than doing a special case for each of the them. Signed-off-by: Julien Grall julien.gr...@citrix.com

[PATCH v2 0/8] Use correctly the Xen memory terminologies in Linux

2015-08-04 Thread Julien Grall
Hi all, This patch series aims to use the memory terminologies described in include/xen/mm.h [1] for Linux xen code. Linux is using mistakenly MFN when GFN is meant, I suspect this is because the first support of Xen was for PV. This has brought some misimplementation of memory helpers on ARM

Re: [PATCH v5 40/46] usb: gadget: epautoconf: rework ep_matches() function

2015-08-04 Thread Felipe Balbi
On Fri, Jul 31, 2015 at 04:00:52PM +0200, Robert Baldyga wrote: Rework ep_matches() function to make it shorter and more readable. Signed-off-by: Robert Baldyga r.bald...@samsung.com this regresses at least mass storage. How did you test it ? I'll keep all patches up to this one, please fix

Re: [PATCH v5 07/46] usb: dwc3: gadget: add ep capabilities support

2015-08-04 Thread Felipe Balbi
On Fri, Jul 31, 2015 at 04:00:19PM +0200, Robert Baldyga wrote: Convert endpoint configuration to new capabilities model. Signed-off-by: Robert Baldyga r.bald...@samsung.com --- drivers/usb/dwc3/gadget.c | 13 + 1 file changed, 13 insertions(+) diff --git

Re: Missing Linux patches

2015-08-04 Thread Scott Wood
On Tue, 2015-08-04 at 11:07 +0200, leroy christophe wrote: Le 02/08/2015 21:05, Markus Stockhausen a écrit : Hi Christophe, I saw that this patch from you is still missing in Linux mainline: https://lists.ozlabs.org/pipermail/linuxppc-dev/2014-September/121144.html Is there any

Re: [v5,RESEND] IFC: Change IO accessor based on endianness

2015-08-04 Thread Scott Wood
On Wed, 2015-05-27 at 20:19 -0500, Scott Wood wrote: On Wed, May 20, 2015 at 09:17:11PM -0500, Scott Wood wrote: From: Jaiprakash Singh b44...@freescale.com IFC IO accressor are set at run time based on IFC IP registers endianness.IFC node in DTS file contains information about

Re: GPMC in device tree

2015-08-04 Thread Scott Wood
On Tue, 2015-08-04 at 23:26 +0300, Ran Shalit wrote: On Tue, Aug 4, 2015 at 9:54 PM, Scott Wood scottw...@freescale.com wrote: On Tue, 2015-08-04 at 18:29 +0300, Ran Shalit wrote: Hello, I would please like to ask if describing flash nor used with GPMC, whould be done as described

Re: GPMC in device tree

2015-08-04 Thread Scott Wood
On Tue, 2015-08-04 at 18:29 +0300, Ran Shalit wrote: Hello, I would please like to ask if describing flash nor used with GPMC, whould be done as described in: https://www.kernel.org/doc/Documentation/devicetree/bindings/mtd/gpmc-nor.txt It is described in the above link as TI's GPMC, so I'm

Re: GPMC in device tree

2015-08-04 Thread Ran Shalit
On Tue, Aug 4, 2015 at 9:54 PM, Scott Wood scottw...@freescale.com wrote: On Tue, 2015-08-04 at 18:29 +0300, Ran Shalit wrote: Hello, I would please like to ask if describing flash nor used with GPMC, whould be done as described in:

[PATCH V2 4/6] powerpc/powernv: replace the hard coded boundary with gate

2015-08-04 Thread Wei Yang
Based on the limitation of M64 Window size, when VF BAR size is bigger than 64MB, IOV BAR just round up power of 2 of the total_vfs. While the 64MB is a magic boundary in code, which is hard to maintain. This patch replaces the hard coded boundary with gate, which is calculated from m64_segsize

[PATCH V2 1/6] powerpc/powernv: don't enable SRIOV when VF BAR contains non M64 BAR

2015-08-04 Thread Wei Yang
On PHB_IODA2, we enable SRIOV devices by mapping IOV BAR with M64 BARs. If a SRIOV device's BAR is not 64-bit prefetchable, this is not assigned from M64 windwo, which means M64 BAR can't work on it. This patch makes this explicit. Signed-off-by: Wei Yang weiy...@linux.vnet.ibm.com ---

Re: [PATCH v2 4/8] xen: Use the correctly the Xen memory terminologies

2015-08-04 Thread Boris Ostrovsky
On 08/04/2015 02:12 PM, Julien Grall wrote: /* * We detect special mappings in one of two ways: @@ -217,9 +232,13 @@ static inline unsigned long bfn_to_local_pfn(unsigned long mfn) /* VIRT - MACHINE conversion */ #define virt_to_machine(v)(phys_to_machine(XPADDR(__pa(v

[PATCH V2 6/6] powerpc/powernv: allocate discrete PE# when using M64 BAR in Single PE mode

2015-08-04 Thread Wei Yang
When M64 BAR is set to Single PE mode, the PE# assigned to VF could be discrete. This patch restructures the patch to allocate discrete PE# for VFs when M64 BAR is set to Single PE mode. Signed-off-by: Wei Yang weiy...@linux.vnet.ibm.com --- arch/powerpc/include/asm/pci-bridge.h |2 +-

RFC: Reducing the number of non volatile GPRs in the ppc64 kernel

2015-08-04 Thread Anton Blanchard
Hi, While looking at traces of kernel workloads, I noticed places where gcc used a large number of non volatiles. Some of these functions did very little work, and we spent most of our time saving the non volatiles to the stack and reading them back. It made me wonder if we have the right ratio