[PATCH] KVM: PPC: Book3S HV: add of_node_put() in success path

2018-07-06 Thread Nicholas Mc Guire
The call to of_find_compatible_node() is returning a pointer with incremented refcount so it must be explicitly decremented after the last use. As here it is only being used for checking of node presence but the result is not actually used in the success path it can be dropped immediately. Signed

Re: powerpc: 32BIT vs. 64BIT (PPC32 vs. PPC64)

2018-07-06 Thread Randy Dunlap
On 07/06/2018 06:45 PM, Benjamin Herrenschmidt wrote: > On Thu, 2018-07-05 at 14:30 -0700, Randy Dunlap wrote: >> Hi, >> >> Is there a good way (or a shortcut) to do something like: >> >> $ make ARCH=powerpc O=PPC32 [other_options] allmodconfig >> to get a PPC32/32BIT allmodconfig >> >> and also

Re: [PATCHv3 0/4] drivers/base: bugfix for supplier<-consumer ordering in device_kset

2018-07-06 Thread Pingfan Liu
On Fri, Jul 6, 2018 at 9:55 PM Pingfan Liu wrote: > > On Fri, Jul 6, 2018 at 4:47 PM Rafael J. Wysocki wrote: > > > > On Fri, Jul 6, 2018 at 10:36 AM, Lukas Wunner wrote: > > > [cc += Kishon Vijay Abraham] > > > > > > On Thu, Jul 05, 2018 at 11:18:28AM +0200, Rafael J. Wysocki wrote: > > >> OK,

Re: [PATCHv3 2/4] drivers/base: utilize device tree info to shutdown devices

2018-07-06 Thread Pingfan Liu
On Fri, Jul 6, 2018 at 5:54 PM Rafael J. Wysocki wrote: > > On Friday, July 6, 2018 5:02:15 AM CEST Pingfan Liu wrote: > > On Thu, Jul 5, 2018 at 6:13 PM Rafael J. Wysocki wrote: > > > > > > On Tuesday, July 3, 2018 8:50:40 AM CEST Pingfan Liu wrote: > > > > commit 52cdbdd49853 ("driver core: cor

Re: powerpc: 32BIT vs. 64BIT (PPC32 vs. PPC64)

2018-07-06 Thread Benjamin Herrenschmidt
On Thu, 2018-07-05 at 14:30 -0700, Randy Dunlap wrote: > Hi, > > Is there a good way (or a shortcut) to do something like: > > $ make ARCH=powerpc O=PPC32 [other_options] allmodconfig > to get a PPC32/32BIT allmodconfig > > and also be able to do: > > $make ARCH=powerpc O=PPC64 [other_options

NXP p1010se device trees only correct for P1010E/P1014E, not P1010/P1014 SoCs.

2018-07-06 Thread Tim Small
Hello, I contributed a patch to OpenWRT a couple of days ago to fix the device tree for a device which uses an NXP p1014 without the SEC4 module. I was wondering about getting a similar fix applied upstream... The device uses the P1014 (without SEC4 functionality), and includes: fsl/p1010si

Re: NXP p1010se device trees only correct for P1010E/P1014E, not P1010/P1014 SoCs.

2018-07-06 Thread Scott Wood
On Fri, 2018-07-06 at 15:50 +0100, Tim Small wrote: > Hello, > > I contributed a patch to OpenWRT a couple of days ago to fix the device > tree for a device which uses an NXP p1014 without the SEC4 module. I > was wondering about getting a similar fix applied upstream... > > The device uses th

Re: [RFC PATCH 2/2] dma-mapping: Clean up dma_get_required_mask() hooks

2018-07-06 Thread Robin Murphy
On 05/07/18 20:38, Christoph Hellwig wrote: On Wed, Jul 04, 2018 at 06:50:12PM +0100, Robin Murphy wrote: As for the other mask-related hooks, standardise the arch override into a Kconfig option, and also pull the generic implementation into the DMA mapping code rather than having it hide away i

Re: [RFC PATCH 1/2] dma-mapping: Clean up dma_set_*mask() hooks

2018-07-06 Thread Robin Murphy
On 05/07/18 20:37, Christoph Hellwig wrote: On Wed, Jul 04, 2018 at 06:50:11PM +0100, Robin Murphy wrote: Arch-specific implementions for dma_set_{coherent_,}mask() currently rely on an inconsistent mix of arch-defined Kconfig symbols and macro overrides. Now that we have a nice centralised home

Re: [PATCH V2 00/10] KASan ppc64 support

2018-07-06 Thread Christophe LEROY
Le 06/07/2018 à 16:11, Aneesh Kumar K.V a écrit : Christophe LEROY writes: Hi Aneesh, Are you still working on support for KASan for ppc64 ? Haven't got time to work on this. The hash memory layout makes it a bit complicated to implement this. Ok, maybe would be easier to start with

Re: [PATCH V2 00/10] KASan ppc64 support

2018-07-06 Thread Aneesh Kumar K.V
Christophe LEROY writes: > Hi Aneesh, > > Are you still working on support for KASan for ppc64 ? > Haven't got time to work on this. The hash memory layout makes it a bit complicated to implement this. -aneesh

Re: [PATCHv3 0/4] drivers/base: bugfix for supplier<-consumer ordering in device_kset

2018-07-06 Thread Pingfan Liu
On Fri, Jul 6, 2018 at 4:47 PM Rafael J. Wysocki wrote: > > On Fri, Jul 6, 2018 at 10:36 AM, Lukas Wunner wrote: > > [cc += Kishon Vijay Abraham] > > > > On Thu, Jul 05, 2018 at 11:18:28AM +0200, Rafael J. Wysocki wrote: > >> OK, so calling devices_kset_move_last() from really_probe() clearly is

Re: [PATCHv3 0/4] drivers/base: bugfix for supplier<-consumer ordering in device_kset

2018-07-06 Thread Pingfan Liu
On Fri, Jul 6, 2018 at 4:36 PM Lukas Wunner wrote: > > [cc += Kishon Vijay Abraham] > > On Thu, Jul 05, 2018 at 11:18:28AM +0200, Rafael J. Wysocki wrote: > > OK, so calling devices_kset_move_last() from really_probe() clearly is > > a mistake. > > > > I'm not really sure what the intention of it

RE: [PATCH 7/7 v5] arm64: dts: ls208xa: comply with the iommu map binding for fsl_mc

2018-07-06 Thread Nipun Gupta
> -Original Message- > From: Robin Murphy [mailto:robin.mur...@arm.com] > Sent: Tuesday, July 3, 2018 10:06 PM > To: Nipun Gupta ; will.dea...@arm.com; > robh...@kernel.org; r...@kernel.org; mark.rutl...@arm.com; > catalin.mari...@arm.com; gre...@linuxfoundation.org; Laurentiu Tudor > ; b

RE: [PATCH 5/7 v5] bus: fsl-mc: support dma configure for devices on fsl-mc bus

2018-07-06 Thread Nipun Gupta
> -Original Message- > From: Robin Murphy [mailto:robin.mur...@arm.com] > Sent: Tuesday, July 3, 2018 9:44 PM > To: Nipun Gupta ; will.dea...@arm.com; > robh...@kernel.org; r...@kernel.org; mark.rutl...@arm.com; > catalin.mari...@arm.com; gre...@linuxfoundation.org; Laurentiu Tudor > ; bh

RE: [PATCH 1/7 v5] Docs: dt: add fsl-mc iommu-map device-tree binding

2018-07-06 Thread Nipun Gupta
> -Original Message- > From: Robin Murphy [mailto:robin.mur...@arm.com] > Sent: Tuesday, July 3, 2018 8:10 PM > To: Nipun Gupta ; will.dea...@arm.com; > robh...@kernel.org; r...@kernel.org; mark.rutl...@arm.com; > catalin.mari...@arm.com; gre...@linuxfoundation.org; Laurentiu Tudor > ; bh

[PATCH v4 3/3] hwmon: Document the sensor enable attribute

2018-07-06 Thread Shilpasri G Bhat
Signed-off-by: Shilpasri G Bhat --- Documentation/hwmon/sysfs-interface | 62 + 1 file changed, 62 insertions(+) diff --git a/Documentation/hwmon/sysfs-interface b/Documentation/hwmon/sysfs-interface index fc337c3..f865dd7 100644 --- a/Documentation/hwmon/sys

[PATCH v4 2/3] hwmon: ibmpowernv: Add attributes to enable/disable sensor groups

2018-07-06 Thread Shilpasri G Bhat
On-Chip-Controller(OCC) is an embedded micro-processor in POWER9 chip which measures various system and chip level sensors. These sensors comprises of environmental sensors (like power, temperature, current and voltage) and performance sensors (like utilization, frequency). All these sensors are co

[PATCH v4 1/3] powernv:opal-sensor-groups: Add support to enable sensor groups

2018-07-06 Thread Shilpasri G Bhat
Adds support to enable/disable a sensor group at runtime. This can be used to select the sensor groups that needs to be copied to main memory by OCC. Sensor groups like power, temperature, current, voltage, frequency, utilization can be enabled/disabled at runtime. Signed-off-by: Shilpasri G Bhat

[PATCH v4 0/3] hwmon: Add attributes to enable/disable sensors

2018-07-06 Thread Shilpasri G Bhat
This patch series adds new attribute to enable or disable a sensor in runtime. v3 : https://lkml.org/lkml/2018/7/5/476 v2 : https://lkml.org/lkml/2018/7/4/263 v1 : https://lkml.org/lkml/2018/3/22/214 Shilpasri G Bhat (3): powernv:opal-sensor-groups: Add support to enable sensor groups hwmon:

Re: [PATCH 0/7 v5] Support for fsl-mc bus and its devices in SMMU

2018-07-06 Thread j...@8bytes.org
Hi Nipun, On Thu, Jun 21, 2018 at 03:59:27AM +, Nipun Gupta wrote: > Will this patch-set be taken for the next kernel release (and via which tree)? I can take this through IOMMU tree if nobody objects. Please work out the last remaining comment on patch 7 with Robin and then re-send with all

RE: [PATCH 0/7 v5] Support for fsl-mc bus and its devices in SMMU

2018-07-06 Thread Nipun Gupta
Thanks Joro, I will be sending it by mid of next week. Regards, Nipun > -Original Message- > From: j...@8bytes.org [mailto:j...@8bytes.org] > Sent: Friday, July 6, 2018 4:43 PM > To: Nipun Gupta > Cc: robin.mur...@arm.com; will.dea...@arm.com; > gre...@linuxfoundation.org; h...@lst.de

Re: [PATCHv3 0/4] drivers/base: bugfix for supplier<-consumer ordering in device_kset

2018-07-06 Thread Kishon Vijay Abraham I
+Grygorii, linux-omap On Friday 06 July 2018 02:06 PM, Lukas Wunner wrote: > [cc += Kishon Vijay Abraham] > > On Thu, Jul 05, 2018 at 11:18:28AM +0200, Rafael J. Wysocki wrote: >> OK, so calling devices_kset_move_last() from really_probe() clearly is >> a mistake. >> >> I'm not really sure what t

Re: [PATCHv3 2/4] drivers/base: utilize device tree info to shutdown devices

2018-07-06 Thread Rafael J. Wysocki
On Friday, July 6, 2018 5:02:15 AM CEST Pingfan Liu wrote: > On Thu, Jul 5, 2018 at 6:13 PM Rafael J. Wysocki wrote: > > > > On Tuesday, July 3, 2018 8:50:40 AM CEST Pingfan Liu wrote: > > > commit 52cdbdd49853 ("driver core: correct device's shutdown order") > > > places an assumption of supplier

Re: [PATCH v6 8/8] powernv/pseries: consolidate code for mce early handling.

2018-07-06 Thread Nicholas Piggin
On Wed, 04 Jul 2018 23:30:12 +0530 Mahesh J Salgaonkar wrote: > From: Mahesh Salgaonkar > > Now that other platforms also implements real mode mce handler, > lets consolidate the code by sharing existing powernv machine check > early code. Rename machine_check_powernv_early to > machine_check_c

[PATCH v3 1/2] powerpc: Detect the presence of big-cores via "ibm, thread-groups"

2018-07-06 Thread Gautham R. Shenoy
From: "Gautham R. Shenoy" On IBM POWER9, the device tree exposes a property array identifed by "ibm,thread-groups" which will indicate which groups of threads share a particular set of resources. As of today we only have one form of grouping identifying the group of threads in the core that shar

[PATCH v3 2/2] powerpc: Enable CPU_FTR_ASYM_SMT for interleaved big-cores

2018-07-06 Thread Gautham R. Shenoy
From: "Gautham R. Shenoy" A pair of IBM POWER9 SMT4 cores can be fused together to form a big-core with 8 SMT threads. This can be discovered via the "ibm,thread-groups" CPU property in the device tree which will indicate which group of threads that share the L1 cache, translation cache and instr

[PATCH v3 0/2] powerpc: Detection and scheduler optimization for POWER9 bigcore

2018-07-06 Thread Gautham R. Shenoy
From: "Gautham R. Shenoy" Hi, This is the third iteration of the patchset to add support for big-core on POWER9. The previous versions can be found here: v2: https://lkml.org/lkml/2018/7/3/401 v1: https://lkml.org/lkml/2018/5/11/245 Changes : v2 --> v3 - Set sane values in the tg->propert

Re: [PATCHv3 0/4] drivers/base: bugfix for supplier<-consumer ordering in device_kset

2018-07-06 Thread Rafael J. Wysocki
On Fri, Jul 6, 2018 at 10:36 AM, Lukas Wunner wrote: > [cc += Kishon Vijay Abraham] > > On Thu, Jul 05, 2018 at 11:18:28AM +0200, Rafael J. Wysocki wrote: >> OK, so calling devices_kset_move_last() from really_probe() clearly is >> a mistake. >> >> I'm not really sure what the intention of it was