Re: [PATCH v8 7/7] powerpc: add machine check safe copy_to_user

2019-08-10 Thread Santosh Sivaraj
Michael Ellerman writes: > Santosh Sivaraj writes: >> Use memcpy_mcsafe() implementation to define copy_to_user_mcsafe() >> >> Signed-off-by: Santosh Sivaraj >> --- >> arch/powerpc/Kconfig | 1 + >> arch/powerpc/include/asm/uaccess.h | 14 ++ >> 2 files changed, 15

Re: [PATCH v8 3/7] powerpc/mce: Fix MCE handling for huge pages

2019-08-10 Thread Santosh Sivaraj
Mahesh Jagannath Salgaonkar writes: > On 8/7/19 8:26 PM, Santosh Sivaraj wrote: >> From: Balbir Singh >> >> The current code would fail on huge pages addresses, since the shift would >> be incorrect. Use the correct page shift value returned by >> __find_linux_pte() to get the correct physical

Re: [GIT PULL] Please pull powerpc/linux.git powerpc-5.3-4 tag

2019-08-10 Thread Michael Ellerman
[ expanded Cc ] Linus Torvalds writes: > On Sat, Aug 10, 2019 at 3:11 AM Michael Ellerman wrote: >> >> Just one fix, a revert of a commit that was meant to be a minor improvement >> to >> some inline asm, but ended up having no real benefit with GCC and broke >> booting >> 32-bit machines

Re: [GIT PULL] Please pull powerpc/linux.git powerpc-5.3-4 tag

2019-08-10 Thread Nathan Chancellor
On Sat, Aug 10, 2019 at 10:21:01AM -0700, Linus Torvalds wrote: > On Sat, Aug 10, 2019 at 3:11 AM Michael Ellerman wrote: > > > > Just one fix, a revert of a commit that was meant to be a minor improvement > > to > > some inline asm, but ended up having no real benefit with GCC and broke > >

Re: [GIT PULL] Please pull powerpc/linux.git powerpc-5.3-4 tag

2019-08-10 Thread pr-tracker-bot
The pull request you sent on Sat, 10 Aug 2019 20:11:49 +1000: > https://git.kernel.org/pub/scm/linux/kernel/git/powerpc/linux.git > tags/powerpc-5.3-4 has been merged into torvalds/linux.git: https://git.kernel.org/torvalds/c/23df57afe8eebff6ece05a815934f2f70a851e0a Thank you! --

[PATCH v3] powerpc/fadump: sysfs for fadump memory reservation

2019-08-10 Thread Sourabh Jain
Add a sys interface to allow querying the memory reserved by fadump for saving the crash dump. Add an ABI doc entry for new sysfs interface. - /sys/kernel/fadump_mem_reserved Signed-off-by: Sourabh Jain --- Changelog: v1 -> v2: - Added ABI doc for new sysfs interface. v2 -> v3: -

Re: [GIT PULL] Please pull powerpc/linux.git powerpc-5.3-4 tag

2019-08-10 Thread Linus Torvalds
On Sat, Aug 10, 2019 at 3:11 AM Michael Ellerman wrote: > > Just one fix, a revert of a commit that was meant to be a minor improvement to > some inline asm, but ended up having no real benefit with GCC and broke > booting > 32-bit machines when using Clang. Pulled, but whenever there are

[Bug 204479] KASAN hit at modprobe zram

2019-08-10 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=204479 --- Comment #16 from Erhard F. (erhar...@mailbox.org) --- Created attachment 284309 --> https://bugzilla.kernel.org/attachment.cgi?id=284309=edit dmesg (kernel 5.3-rc3 + debug patch + shadow patch + parallel patch, PowerMac G4 DP) Also tested

Re: [PATCH v6 1/7] kvmppc: Driver to manage pages of secure guest

2019-08-10 Thread Bharata B Rao
On Sat, Aug 10, 2019 at 12:58:19PM +0200, Christoph Hellwig wrote: > > > +int kvmppc_devm_init(void) > > +{ > > + int ret = 0; > > + unsigned long size; > > + struct resource *res; > > + void *addr; > > + > > + size = kvmppc_get_secmem_size(); > > + if (!size) { > > + ret =

Re: [PATCH v6 1/7] kvmppc: Driver to manage pages of secure guest

2019-08-10 Thread Christoph Hellwig
> +#ifdef CONFIG_PPC_UV > +extern unsigned long kvmppc_h_svm_page_in(struct kvm *kvm, > + unsigned long gra, > + unsigned long flags, > + unsigned long page_shift); > +extern unsigned

Re: [PATCH] powerpc/rtas: unexport rtas_online_cpus_mask, rtas_offline_cpus_mask

2019-08-10 Thread Michael Ellerman
On Thu, 2019-07-18 at 16:22:14 UTC, Nathan Lynch wrote: > These aren't used by modular code, nor should they be. > > Fixes: 120496ac2d2d ("powerpc: Bring all threads online prior to > migration/hibernation") > Signed-off-by: Nathan Lynch Applied to powerpc next, thanks.

Re: [PATCH v2] powerpc/powernv: Restrict OPAL symbol map to only be readable by root

2019-08-10 Thread Michael Ellerman
On Fri, 2019-05-03 at 07:52:53 UTC, Andrew Donnellan wrote: > Currently the OPAL symbol map is globally readable, which seems bad as it > contains physical addresses. > > Restrict it to root. > > Suggested-by: Michael Ellerman > Cc: Jordan Niethe > Cc: Stewart Smith > Fixes: c8742f85125d

Re: [PATCH] powerpc/64s: Make boot look nice(r)

2019-08-10 Thread Michael Ellerman
On Thu, 2019-05-16 at 02:04:37 UTC, Nicholas Piggin wrote: > Radix boot looks like this: > > - > phys_mem_size = 0x2 > dcache_bsize = 0x80 > icache_bsize = 0x80 > cpu_features = 0xc06f8f5fb1a7 >possible

Re: [PATCH v2 1/5] powerpc/powernv: Move SCOM access code into powernv platform

2019-08-10 Thread Michael Ellerman
On Thu, 2019-05-09 at 05:11:15 UTC, Andrew Donnellan wrote: > The powernv platform is the only one that directly accesses SCOMs. Move the > support code to platforms/powernv, and get rid of the PPC_SCOM Kconfig > option, as SCOM support is always selected when compiling for powernv. > > This also

Re: [PATCH v2] powerpc/32: activate ARCH_HAS_PMEM_API and ARCH_HAS_UACCESS_FLUSHCACHE

2019-08-10 Thread Michael Ellerman
On Wed, 2019-07-31 at 06:31:41 UTC, Christophe Leroy wrote: > PPC32 also have flush_dcache_range() so it can also support > ARCH_HAS_PMEM_API and ARCH_HAS_UACCESS_FLUSHCACHE without changes. > > Signed-off-by: Christophe Leroy Applied to powerpc next, thanks.

Re: [PATCH] powerpc/xive: Update comment referencing magic loads from an ESB

2019-08-10 Thread Michael Ellerman
On Fri, 2019-08-02 at 00:08:35 UTC, Jordan Niethe wrote: > The comment above xive_esb_read() references magic loads from an ESB as > described xive.h. This has been inaccurate since commit 12c1f339cd49 > ("powerpc/xive: Move definition of ESB bits") which moved the > description. Update the

Re: [PATCH 1/1] pseries/hotplug-memory.c: Replace nested ifs by switch-case

2019-08-10 Thread Michael Ellerman
On Thu, 2019-08-01 at 22:52:51 UTC, Leonardo Bras wrote: > I noticed these nested ifs can be easily replaced by switch-cases, > which can improve readability. > > Signed-off-by: Leonardo Bras > Reviewed-by: David Hildenbrand Series applied to powerpc next, thanks.

Re: [PATCH 1/2] powerpc/xive: Use GFP_KERNEL instead of GFP_ATOMIC in 'xive_irq_bitmap_add()'

2019-08-10 Thread Michael Ellerman
On Thu, 2019-08-01 at 08:32:31 UTC, Christophe JAILLET wrote: > There is no need to use GFP_ATOMIC here. GFP_KERNEL should be enough. > GFP_KERNEL is also already used for another allocation just a few lines > below. > > Signed-off-by: Christophe JAILLET > Reviewed-by: Cédric Le Goater >

Re: [PATCH] powerpc/powernv: Print helpful message when cores guarded

2019-08-10 Thread Michael Ellerman
On Thu, 2019-08-01 at 05:16:30 UTC, Joel Stanley wrote: > Often the firmware will guard out cores after a crash. This often > undesirable, and is not immediately noticeable. > > This adds an informative message when a CPU device tree nodes are marked > bad in the device tree. > > Signed-off-by:

Re: [PATCH v2] PCI: rpaphp: Avoid a sometimes-uninitialized warning

2019-08-10 Thread Michael Ellerman
On Mon, 2019-06-03 at 22:11:58 UTC, Nathan Chancellor wrote: > When building with -Wsometimes-uninitialized, clang warns: > > drivers/pci/hotplug/rpaphp_core.c:243:14: warning: variable 'fndit' is > used uninitialized whenever 'for' loop exits because its condition is > false

[GIT PULL] Please pull powerpc/linux.git powerpc-5.3-4 tag

2019-08-10 Thread Michael Ellerman
-BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Hi Linus, Please pull another powerpc fix for 5.3: The following changes since commit d7e23b887f67178c4f840781be7a6aa6aeb52ab1: powerpc/kasan: fix early boot failure on PPC32 (2019-07-31 22:02:52 +1000) are available in the git repository at:

Re: [PATCH v8 7/7] powerpc: add machine check safe copy_to_user

2019-08-10 Thread Michael Ellerman
Santosh Sivaraj writes: > Use memcpy_mcsafe() implementation to define copy_to_user_mcsafe() > > Signed-off-by: Santosh Sivaraj > --- > arch/powerpc/Kconfig | 1 + > arch/powerpc/include/asm/uaccess.h | 14 ++ > 2 files changed, 15 insertions(+) > > diff --git

Re: [PATCH v3] Revert "powerpc: slightly improve cache helpers"

2019-08-10 Thread Michael Ellerman
Nick Desaulniers writes: > This reverts commit 6c5875843b87c3adea2beade9d1b8b3d4523900a. > > Work around Clang bug preventing ppc32 from booting. > > Link: https://bugs.llvm.org/show_bug.cgi?id=42762 > Link: https://github.com/ClangBuiltLinux/linux/issues/593 > Debugged-by: Nathan Chancellor >

Re: [PATCH v4 0/6] Remove x86-specific code from generic headers

2019-08-10 Thread Christoph Hellwig
On Fri, Aug 09, 2019 at 10:51:41PM +1000, m...@ellerman.id.au wrote: > I need to take this series via the powerpc tree because there is another > fairly large powerpc specific series dependent on it. > > I think this series already has pretty much all the acks it needs, which > almost never