Re: [PATCH v3 devicetree 0/2] Add Seville Ethernet switch to T1040RDB

2020-10-01 Thread Vladimir Oltean
On Thu, Oct 01, 2020 at 01:10:05PM -0700, David Miller wrote: > From: Vladimir Oltean > Date: Thu, 1 Oct 2020 16:20:11 +0300 > > > Seville is a DSA switch that is embedded inside the T1040 SoC, and > > supported by the mscc_seville DSA driver inside drivers/net/dsa/ocelot. > > > > This series

Re: [PATCH] ASoC: fsl_spdif: Fix unnecessary check in fsl_spdif_probe()

2020-10-01 Thread Mark Brown
On Wed, 26 Aug 2020 23:09:18 +0800, Tang Bin wrote: > The function fsl_spdif_probe() is only called with an openfirmware > platform device. Therefore there is no need to check that the passed > in device is NULL. Applied to https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git

Re: [PATCH -next] ASoC: fsl: imx-mc13783: use devm_snd_soc_register_card()

2020-10-01 Thread Mark Brown
On Tue, 29 Sep 2020 19:29:30 +0800, Qinglang Miao wrote: > Using devm_snd_soc_register_card() can make the code > shorter and cleaner. Applied to https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next Thanks! [1/1] ASoC: fsl: imx-mc13783: use devm_snd_soc_register_card()

Re: [PATCH 05/14] fs: don't allow kernel reads and writes without iter ops

2020-10-01 Thread Al Viro
On Thu, Oct 01, 2020 at 03:38:52PM -0700, Eric Biggers wrote: > mutex_lock(>pipe_mutex); > while (bytes) { > - wr = __kernel_write(file, data, bytes, NULL); > + wr = __kernel_write(file, data, bytes, >f_pos); Better loff_t dummy = 0; ...

Re: [PATCH 05/14] fs: don't allow kernel reads and writes without iter ops

2020-10-01 Thread Eric Biggers
file->f_op->write(file, p, count, pos); > - else if (file->f_op->write_iter) > - ret = new_sync_write(file, p, count, pos); > - else > - ret = -EINVAL; > - set_fs(old_fs); > + init_sync_kiocb(, file); > + kiocb.ki_pos = *pos; > + iov

Re: [PATCH 1/6] powerpc/time: Rename mftbl() to mftb()

2020-10-01 Thread Segher Boessenkool
On Thu, Oct 01, 2020 at 12:42:39PM +, Christophe Leroy wrote: > On PPC64, we have mftb(). > On PPC32, we have mftbl() and an #define mftb() mftbl(). > > mftb() and mftbl() are equivalent, their purpose is to read the > content of SPRN_TRBL, as returned by 'mftb' simplified instruction. > >

Re: [RFC PATCH next-20200930] treewide: Convert macro and uses of __section(foo) to __section("foo")

2020-10-01 Thread Joe Perches
On Thu, 2020-10-01 at 14:39 -0500, Segher Boessenkool wrch/ote: > Hi! > > On Thu, Oct 01, 2020 at 12:15:39PM +0200, Miguel Ojeda wrote: > > > So it looks like the best option is to exclude these > > > 2 files from conversion. > > > > Agreed. Nevertheless, is there any reason arch/powerpc/*

Re: [PATCH v3 devicetree 0/2] Add Seville Ethernet switch to T1040RDB

2020-10-01 Thread David Miller
From: Vladimir Oltean Date: Thu, 1 Oct 2020 16:20:11 +0300 > Seville is a DSA switch that is embedded inside the T1040 SoC, and > supported by the mscc_seville DSA driver inside drivers/net/dsa/ocelot. > > This series adds this switch to the SoC's dtsi files and to the T1040RDB > board file.

Re: [RFC PATCH next-20200930] treewide: Convert macro and uses of __section(foo) to __section("foo")

2020-10-01 Thread Segher Boessenkool
Hi! On Thu, Oct 01, 2020 at 12:15:39PM +0200, Miguel Ojeda wrote: > > So it looks like the best option is to exclude these > > 2 files from conversion. > > Agreed. Nevertheless, is there any reason arch/powerpc/* should not be > compiling cleanly with compiler.h? (CC'ing the rest of the PowerPC

Re: [RFC PATCH next-20200930] treewide: Convert macro and uses of __section(foo) to __section("foo")

2020-10-01 Thread Joe Perches
On Thu, 2020-10-01 at 12:15 +0200, Miguel Ojeda wrote: > Hi Joe, Buenas Miguel. > On Thu, Oct 1, 2020 at 12:56 AM Joe Perches wrote: > > So I installed the powerpc cross compiler, and > > nope, that doesn't work, it makes a mess. > > Thanks a lot for reviving the script and sending the

[PATCH v3 2/2] lkdtm/powerpc: Add SLB multihit test

2020-10-01 Thread Ganesh Goudar
To check machine check handling, add support to inject slb multihit errors. Reviewed-by: Michal Suchánek Co-developed-by: Mahesh Salgaonkar Signed-off-by: Mahesh Salgaonkar Signed-off-by: Ganesh Goudar --- drivers/misc/lkdtm/Makefile | 1 + drivers/misc/lkdtm/core.c

[PATCH v3 1/2] powerpc/mce: remove nmi_enter/exit from real mode handler

2020-10-01 Thread Ganesh Goudar
Use of nmi_enter/exit in real mode handler causes the kernel to panic and reboot on injecting slb mutihit on pseries machine running in hash mmu mode, As these calls try to accesses memory outside RMO region in real mode handler where translation is disabled. Add check to not to use these calls

[PATCH v3 0/2] powerpc/mce: Fix mce handler and add selftest

2020-10-01 Thread Ganesh Goudar
This patch series fixes mce handling for pseries, Adds LKDTM test for SLB multihit recovery and enables selftest for the same, basically to test MCE handling on pseries/powernv machines running in hash mmu mode. v3: * Merging selftest changes with patch 2/2, Instead of having separate patch. *

[PATCH] powerpc: Send SIGBUS from machine_check

2020-10-01 Thread Joakim Tjernlund
Embedded PPC CPU should send SIGBUS to user space when applicable. Signed-off-by: Joakim Tjernlund --- arch/powerpc/kernel/traps.c | 17 + 1 file changed, 17 insertions(+) diff --git a/arch/powerpc/kernel/traps.c b/arch/powerpc/kernel/traps.c index 0381242920d9..12715d24141c

[PATCH] powerpc/32s: Setup the early hash table at all time.

2020-10-01 Thread Christophe Leroy
At the time being, an early hash table is set up when CONFIG_KASAN is selected. There is nothing wrong with setting such an early hash table all the time, even if it is not used. This is a statically allocated 256 kB table which lies in the init data section. This makes the code simpler and may

Re: [PATCH v3 devicetree 1/2] powerpc: dts: t1040: add bindings for Seville Ethernet switch

2020-10-01 Thread Andrew Lunn
On Thu, Oct 01, 2020 at 04:20:12PM +0300, Vladimir Oltean wrote: > Add the description of the embedded L2 switch inside the SoC dtsi file > for NXP T1040. > > Signed-off-by: Vladimir Oltean > Reviewed-by: Maxim Kochetkov Reviewed-by: Andrew Lunn Andrew

Re: [PATCH v3 devicetree 2/2] powerpc: dts: t1040rdb: add ports for Seville Ethernet switch

2020-10-01 Thread Andrew Lunn
On Thu, Oct 01, 2020 at 04:20:13PM +0300, Vladimir Oltean wrote: > Define the network interface names for the switch ports and hook them up > to the 2 QSGMII PHYs that are onboard. > > A conscious decision was taken to go along with the numbers that are > written on the front panel of the board

[PATCH v3 devicetree 2/2] powerpc: dts: t1040rdb: add ports for Seville Ethernet switch

2020-10-01 Thread Vladimir Oltean
Define the network interface names for the switch ports and hook them up to the 2 QSGMII PHYs that are onboard. A conscious decision was taken to go along with the numbers that are written on the front panel of the board and not with the hardware numbers of the switch chip ports. The 2 numbering

[PATCH v3 devicetree 1/2] powerpc: dts: t1040: add bindings for Seville Ethernet switch

2020-10-01 Thread Vladimir Oltean
Add the description of the embedded L2 switch inside the SoC dtsi file for NXP T1040. Signed-off-by: Vladimir Oltean Reviewed-by: Maxim Kochetkov --- Changes in v3: Added definition for frame extraction interrupt, even if the driver doesn't use it at the moment. Changes in v2: Make switch node

[PATCH v3 devicetree 0/2] Add Seville Ethernet switch to T1040RDB

2020-10-01 Thread Vladimir Oltean
Seville is a DSA switch that is embedded inside the T1040 SoC, and supported by the mscc_seville DSA driver inside drivers/net/dsa/ocelot. This series adds this switch to the SoC's dtsi files and to the T1040RDB board file. Vladimir Oltean (2): powerpc: dts: t1040: add bindings for Seville

[PATCH 6/6] powerpc/time: Make get_tb() common to PPC32 and PPC64

2020-10-01 Thread Christophe Leroy
mftbu() is always defined now, so the #ifdef can be removed and replaced by an IS_ENABLED(CONFIG_PPC64) inside the PPC32 version of get_tb(). Signed-off-by: Christophe Leroy --- arch/powerpc/include/asm/time.h | 10 +++--- 1 file changed, 3 insertions(+), 7 deletions(-) diff --git

[PATCH 5/6] powerpc/time: Make get_tbl() common to PPC32 and PPC64

2020-10-01 Thread Christophe Leroy
On PPC64, get_tbl() is defined as an alias of get_tb() which return the result of mftb(). That exactly the same as what the PPC32 version does. We don't need two versions. Remove the PPC64 definition of get_tbl() and use the PPC32 version for both. Signed-off-by: Christophe Leroy ---

[PATCH 3/6] powerpc/time: Avoid using get_tbl() and get_tbu() internally

2020-10-01 Thread Christophe Leroy
get_tbl() is confusing as it returns the content of TBL register on PPC32 but the concatenation of TBL and TBU on PPC64. Use mftb() instead. Do the same with get_tbu() for consistency allthough it's name is less confusing. Signed-off-by: Christophe Leroy --- arch/powerpc/include/asm/delay.h |

[PATCH 1/6] powerpc/time: Rename mftbl() to mftb()

2020-10-01 Thread Christophe Leroy
On PPC64, we have mftb(). On PPC32, we have mftbl() and an #define mftb() mftbl(). mftb() and mftbl() are equivalent, their purpose is to read the content of SPRN_TRBL, as returned by 'mftb' simplified instruction. binutils seems to define 'mftbl' instruction as an equivalent of 'mftb'. However

[PATCH 4/6] powerpc/time: Remove get_tbu()

2020-10-01 Thread Christophe Leroy
get_tbu() is redundant with mftbu() and is not used anymore. Remove it. Signed-off-by: Christophe Leroy --- arch/powerpc/include/asm/time.h | 5 - 1 file changed, 5 deletions(-) diff --git a/arch/powerpc/include/asm/time.h b/arch/powerpc/include/asm/time.h index 3ef0f4b3299e..c4ea81c966b0

[PATCH 2/6] powerpc/time: Make mftb() common to PPC32 and PPC64

2020-10-01 Thread Christophe Leroy
No need to have two versions that are identical. CONFIG_PPC_CELL is only selected by PPC64 targets. CONFIG_E500 is the only PPC64 target selecting CONFIG_FSL_BOOK3E. Signed-off-by: Christophe Leroy --- arch/powerpc/include/asm/reg.h | 14 -- 1 file changed, 4 insertions(+), 10

[PATCH] powerpc/time: Remove ifdef in get_dec() and set_dec()

2020-10-01 Thread Christophe Leroy
Move SPRN_PIT definition in reg.h. This allows to remove ifdef in get_dec() and set_dec() and makes them more readable. Signed-off-by: Christophe Leroy --- arch/powerpc/include/asm/reg.h | 2 ++ arch/powerpc/include/asm/reg_booke.h | 1 - arch/powerpc/include/asm/time.h | 23

[PATCH] powerpc/time: Remove ifdef in get_vtb()

2020-10-01 Thread Christophe Leroy
SPRN_VTB and CPU_FTR_ARCH_207S are always defined, no need of an ifdef. Signed-off-by: Christophe Leroy --- arch/powerpc/include/asm/time.h | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/arch/powerpc/include/asm/time.h b/arch/powerpc/include/asm/time.h index

Re: [RFC PATCH next-20200930] treewide: Convert macro and uses of __section(foo) to __section("foo")

2020-10-01 Thread Miguel Ojeda
Hi Joe, On Thu, Oct 1, 2020 at 12:56 AM Joe Perches wrote: > > So I installed the powerpc cross compiler, and > nope, that doesn't work, it makes a mess. Thanks a lot for reviving the script and sending the treewide cleanup! > So it looks like the best option is to exclude these > 2 files from