[powerpc:next-test] BUILD SUCCESS 95c63df939789153540060ead8eb5d9fd4606274

2020-11-16 Thread kernel test robot
allnoconfig x86_64 randconfig-a003-20201116 x86_64 randconfig-a004-20201116 x86_64 randconfig-a002-20201116 x86_64 randconfig-a001-20201116 x86_64 randconfig-a005-20201116 x86_64 randconfig-a006-20201116 i386

[powerpc:merge] BUILD SUCCESS daeef940ffae4fdf0ca4865c26ce7c32cb13bd52

2020-11-16 Thread kernel test robot
-a002-20201110 x86_64 randconfig-a006-20201110 x86_64 randconfig-a001-20201110 x86_64 randconfig-a003-20201116 x86_64 randconfig-a005-20201116 x86_64 randconfig-a004-20201116 x86_64 randconfig-a002-20201116 x86_64

[powerpc:fixes-test] BUILD SUCCESS 75b49620267c700f0a07fec7f27f69852db70e46

2020-11-16 Thread kernel test robot
allyesconfig mips allmodconfig powerpc allyesconfig powerpc allmodconfig powerpc allnoconfig x86_64 randconfig-a003-20201116 x86_64 randconfig

[PATCH 1/2] powerpc: Retire e200 core (mpc555x processor)

2020-11-16 Thread Christophe Leroy
There is no defconfig selecting CONFIG_E200, and no platform. e200 is an earlier version of booke, a predecessor of e500, with some particularities like an unified cache instead of both an instruction cache and a data cache. Remove it. Signed-off-by: Christophe Leroy --- arch/powerpc/Makefile

[PATCH 2/2] powerpc: Remove ucache_bsize

2020-11-16 Thread Christophe Leroy
ppc601 and e200 were the users of ucache_bsize. ppc601 and e200 are now gone. Remove ucache_bsize. Signed-off-by: Christophe Leroy --- arch/powerpc/include/asm/elf.h | 2 +- arch/powerpc/kernel/setup-common.c | 4 arch/powerpc/kernel/setup_32.c | 1 - 3 files changed, 1

[PATCH] powerpc: fix create_section_mapping compile warning

2020-11-16 Thread Dan Williams
0day robot reports that a recent rework of how memory_add_physaddr_to_nid() and phys_to_target_node() are declared resulted in the following new compilation warning: arch/powerpc/mm/mem.c:91:12: warning: no previous prototype for 'create_section_mapping' [-Wmissing-prototypes] 91 | int __weak

Re: [PATCH 1/6] ibmvfc: byte swap login_buf.resp values in attribute show functions

2020-11-16 Thread Martin K. Petersen
Tyrel, > The checkpatch script only warns at 100 char lines these days. To be > fair though I did have two lines go over that limit by a couple > characters, there are a couple commit log typos, and I had an if > keyword with no space after before the opening parenthesis. So, I'll > happily

Re: [PATCH] powerpc/powernv/sriov: fix unsigned int win compared to less than zero

2020-11-16 Thread Michael Ellerman
Andrew Donnellan writes: > On 10/11/20 10:19 pm, xiakaixu1...@gmail.com wrote: >> From: Kaixu Xia >> >> Fix coccicheck warning: >> >> ./arch/powerpc/platforms/powernv/pci-sriov.c:443:7-10: WARNING: Unsigned >> expression compared with zero: win < 0 >>

Re: [PATCH 3/3] powerpc: fix -Wimplicit-fallthrough

2020-11-16 Thread Nathan Chancellor
On Sun, Nov 15, 2020 at 08:35:32PM -0800, Nick Desaulniers wrote: > The "fallthrough" pseudo-keyword was added as a portable way to denote > intentional fallthrough. Clang will still warn on cases where there is a > fallthrough to an immediate break. Add explicit breaks for those cases. > > Link:

Re: [PATCH 2/3] Revert "lib: Revert use of fallthrough pseudo-keyword in lib/"

2020-11-16 Thread Nathan Chancellor
On Sun, Nov 15, 2020 at 08:35:31PM -0800, Nick Desaulniers wrote: > This reverts commit 6a9dc5fd6170 ("lib: Revert use of fallthrough > pseudo-keyword in lib/") > > Now that we can build arch/powerpc/boot/ free of -Wimplicit-fallthrough, > re-enable these fixes for lib/. > > Link:

Re: [PATCH 1/3] powerpc: boot: include compiler_attributes.h

2020-11-16 Thread Nathan Chancellor
On Sun, Nov 15, 2020 at 08:35:30PM -0800, Nick Desaulniers wrote: > The kernel uses `-include` to include include/linux/compiler_types.h > into all translation units (see scripts/Makefile.lib), which #includes > compiler_attributes.h. > > arch/powerpc/boot/ uses different compiler flags from the

Re: [PATCH 1/2] kbuild: Hoist '--orphan-handling' into Kconfig

2020-11-16 Thread Nathan Chancellor
s it a little > > unruly to deal with in case it needs to be disabled for a specific > > linker version (in this case, ld.lld 10.0.1). > > Hi Nathan, > This patch fails to apply for me via b4 on next-20201116 due to a > conflict in arch/Kconfig:1028. Would you mind sending a reba

Re: [PATCH] ocxl: Mmio invalidation support

2020-11-16 Thread Andrew Donnellan
On 14/11/20 2:33 am, Christophe Lombard wrote: OpenCAPI 4.0/5.0 with TLBI/SLBI Snooping, is not used due to performance problems caused by the PAU having to process all incoming TLBI/SLBI commands which will cause them to back up on the PowerBus. When the Address Translation Mode requires TLB

Re: [PATCH] powerpc/powernv/memtrace: Fake non-memblock aligned sized traces

2020-11-16 Thread Jordan Niethe
On Mon, Nov 16, 2020 at 11:02 PM Michael Ellerman wrote: > > Jordan Niethe writes: > > The hardware trace macros which use the memory provided by memtrace are > > able to use trace sizes as small as 16MB. Only memblock aligned values > > can be removed from each NUMA node by writing that value

Re: Error: invalid switch -me200

2020-11-16 Thread Alan Modra
On Fri, Nov 13, 2020 at 06:50:15PM -0600, Segher Boessenkool wrote: > On Fri, Nov 13, 2020 at 04:37:38PM -0800, Fāng-ruì Sòng wrote: > > On Fri, Nov 13, 2020 at 4:23 PM Segher Boessenkool > > wrote: > > > On Fri, Nov 13, 2020 at 12:14:18PM -0800, Nick Desaulniers wrote: > > > > > > > Error:

Re: Error: invalid switch -me200

2020-11-16 Thread Segher Boessenkool
On Mon, Nov 16, 2020 at 02:27:12PM -0600, Scott Wood wrote: > On Fri, 2020-11-13 at 18:50 -0600, Segher Boessenkool wrote: > > All the others work fine (and are needed afaics), it is only -me200 that > > doesn't exist (in mainline binutils). Perhaps -me5500 will work for it > > instead. > >

Re: Error: invalid switch -me200

2020-11-16 Thread Scott Wood
On Fri, 2020-11-13 at 18:50 -0600, Segher Boessenkool wrote: > On Fri, Nov 13, 2020 at 04:37:38PM -0800, Fāng-ruì Sòng wrote: > > On Fri, Nov 13, 2020 at 4:23 PM Segher Boessenkool > > wrote: > > > On Fri, Nov 13, 2020 at 12:14:18PM -0800, Nick Desaulniers wrote: > > > > > > > Error: invalid

Re: [PATCH] powerpc: Drop -me200 addition to build flags

2020-11-16 Thread Scott Wood
On Mon, 2020-11-16 at 23:09 +1100, Michael Ellerman wrote: > Currently a build with CONFIG_E200=y will fail with: > > Error: invalid switch -me200 > Error: unrecognized option -me200 > > Upstream binutils has never supported an -me200 option. Presumably it > was supported at some point by

Re: [PATCH 3/5] perf/core: Fix arch_perf_get_page_size()

2020-11-16 Thread Liang, Kan
On 11/13/2020 6:19 AM, Peter Zijlstra wrote: The (new) page-table walker in arch_perf_get_page_size() is broken in various ways. Specifically while it is used in a locless manner, it doesn't depend on CONFIG_HAVE_FAST_GUP nor uses the proper _lockless offset methods, nor is careful to only

Re: [PATCH net-next 04/12] ibmvnic: Introduce xmit_more support using batched subCRQ hcalls

2020-11-16 Thread Thomas Falcon
On 11/14/20 5:46 PM, Jakub Kicinski wrote: On Thu, 12 Nov 2020 13:09:59 -0600 Thomas Falcon wrote: Include support for the xmit_more feature utilizing the H_SEND_SUB_CRQ_INDIRECT hypervisor call which allows the sending of multiple subordinate Command Response Queue descriptors in one

Re: [PATCH net-next 01/12] ibmvnic: Ensure that subCRQ entry reads are ordered

2020-11-16 Thread Jakub Kicinski
On Mon, 16 Nov 2020 12:28:05 -0600 Thomas Falcon wrote: > On 11/14/20 5:35 PM, Jakub Kicinski wrote: > > On Thu, 12 Nov 2020 13:09:56 -0600 Thomas Falcon wrote: > >> Ensure that received Subordinate Command-Response Queue > >> entries are properly read in order by the driver. > >> > >>

Re: [PATCH net-next 01/12] ibmvnic: Ensure that subCRQ entry reads are ordered

2020-11-16 Thread Thomas Falcon
On 11/14/20 5:35 PM, Jakub Kicinski wrote: On Thu, 12 Nov 2020 13:09:56 -0600 Thomas Falcon wrote: Ensure that received Subordinate Command-Response Queue entries are properly read in order by the driver. Signed-off-by: Thomas Falcon Are you sure this is not a bug fix? Yes, I guess it does

Re: [PATCH net-next 02/12] ibmvnic: Introduce indirect subordinate Command Response Queue buffer

2020-11-16 Thread Thomas Falcon
On 11/14/20 5:35 PM, Jakub Kicinski wrote: On Thu, 12 Nov 2020 13:09:57 -0600 Thomas Falcon wrote: This patch introduces the infrastructure to send batched subordinate Command Response Queue descriptors, which are used by the ibmvnic driver to send TX frame and RX buffer descriptors.

Re: [PATCH] ocxl: Mmio invalidation support

2020-11-16 Thread Frederic Barrat
On 13/11/2020 16:33, Christophe Lombard wrote: OpenCAPI 4.0/5.0 with TLBI/SLBI Snooping, is not used due to performance problems caused by the PAU having to process all incoming TLBI/SLBI commands which will cause them to back up on the PowerBus. When the Address Translation Mode requires

Re: [PATCH 0/5] perf/mm: Fix PERF_SAMPLE_*_PAGE_SIZE

2020-11-16 Thread Peter Zijlstra
On Mon, Nov 16, 2020 at 08:36:36AM -0800, Dave Hansen wrote: > On 11/16/20 8:32 AM, Matthew Wilcox wrote: > >> > >> That's really the best we can do from software without digging into > >> microarchitecture-specific events. > > I mean this is perf. Digging into microarch specific events is what

Re: [PATCH 0/5] perf/mm: Fix PERF_SAMPLE_*_PAGE_SIZE

2020-11-16 Thread Peter Zijlstra
On Mon, Nov 16, 2020 at 08:28:23AM -0800, Dave Hansen wrote: > On 11/16/20 7:54 AM, Matthew Wilcox wrote: > > It gets even more complicated with CPUs with multiple levels of TLB > > which support different TLB entry sizes. My CPU reports: > > > > TLB info > > Instruction TLB: 2M/4M pages, fully

Re: [PATCH 0/5] perf/mm: Fix PERF_SAMPLE_*_PAGE_SIZE

2020-11-16 Thread Dave Hansen
On 11/16/20 8:32 AM, Matthew Wilcox wrote: >> >> That's really the best we can do from software without digging into >> microarchitecture-specific events. > I mean this is perf. Digging into microarch specific events is what it > does ;-) Yeah, totally. But, if we see a bunch of 4k TLB hit

Re: [PATCH 0/5] perf/mm: Fix PERF_SAMPLE_*_PAGE_SIZE

2020-11-16 Thread Matthew Wilcox
On Mon, Nov 16, 2020 at 08:28:23AM -0800, Dave Hansen wrote: > On 11/16/20 7:54 AM, Matthew Wilcox wrote: > > It gets even more complicated with CPUs with multiple levels of TLB > > which support different TLB entry sizes. My CPU reports: > > > > TLB info > > Instruction TLB: 2M/4M pages, fully

Re: [PATCH 0/5] perf/mm: Fix PERF_SAMPLE_*_PAGE_SIZE

2020-11-16 Thread Dave Hansen
On 11/16/20 7:54 AM, Matthew Wilcox wrote: > It gets even more complicated with CPUs with multiple levels of TLB > which support different TLB entry sizes. My CPU reports: > > TLB info > Instruction TLB: 2M/4M pages, fully associative, 8 entries > Instruction TLB: 4K pages, 8-way associative,

[PATCH] powerpc/32s: Handle PROTFAULT in hash_page() also for CONFIG_PPC_KUAP

2020-11-16 Thread Christophe Leroy
On hash 32 bits, handling minor protection faults like unsetting dirty flag is heavy if done from the normal page_fault processing, because it implies hash table software lookup for flushing the entry and then a DSI is taken anyway to add the entry back. When KUAP was implemented, as explained in

Re: [PATCH 0/5] perf/mm: Fix PERF_SAMPLE_*_PAGE_SIZE

2020-11-16 Thread Matthew Wilcox
On Mon, Nov 16, 2020 at 06:43:57PM +0300, Kirill A. Shutemov wrote: > On Fri, Nov 13, 2020 at 12:19:01PM +0100, Peter Zijlstra wrote: > > Hi, > > > > These patches provide generic infrastructure to determine TLB page size from > > page table entries alone. Perf will use this (for either data or

[PATCH v2 3/5] powerpc/fault: Avoid heavy search_exception_tables() verification

2020-11-16 Thread Christophe Leroy
search_exception_tables() is an heavy operation, we have to avoid it. When KUAP is selected, we'll know the fault has been blocked by KUAP. Otherwise, it behaves just as if the address was already in the TLBs and no fault was generated. Signed-off-by: Christophe Leroy Reviewed-by: Nicholas

[PATCH v2 4/5] powerpc/fault: Perform exception fixup in do_page_fault()

2020-11-16 Thread Christophe Leroy
Exception fixup doesn't require the heady full regs saving, do it from do_page_fault() directly. For that, split bad_page_fault() in two parts. As bad_page_fault() can also be called from other places than handle_page_fault(), it will still perform exception fixup and fallback on

[PATCH v2 5/5] powerpc/mm: Don't WARN() on KUAP fault

2020-11-16 Thread Christophe Leroy
The WARN() in do_page_fault() is useless the problem is not in do_page_fault() but on the place which generated the DSI exception. We already have a dump from the Oops, no need of a WARN() in addition The warning emitted by bad_kernel_fault() is good enough. Signed-off-by: Christophe Leroy ---

[PATCH v2 1/5] powerpc/mm: sanity_check_fault() should work for all, not only BOOK3S

2020-11-16 Thread Christophe Leroy
The verification and message introduced by commit 374f3f5979f9 ("powerpc/mm/hash: Handle user access of kernel address gracefully") applies to all platforms, it should not be limited to BOOK3S. Make the BOOK3S version of sanity_check_fault() the one for all, and bail out earlier if not BOOK3S.

[PATCH v2 2/5] powerpc/fault: Unnest definition of page_fault_is_write() and page_fault_is_bad()

2020-11-16 Thread Christophe Leroy
To make it more readable, separate page_fault_is_write() and page_fault_is_bad() to avoir several levels of #ifdefs Reviewed-by: Nicholas Piggin Signed-off-by: Christophe Leroy --- arch/powerpc/mm/fault.c | 8 +--- 1 file changed, 5 insertions(+), 3 deletions(-) diff --git

Re: [PATCH 0/5] perf/mm: Fix PERF_SAMPLE_*_PAGE_SIZE

2020-11-16 Thread Kirill A. Shutemov
On Fri, Nov 13, 2020 at 12:19:01PM +0100, Peter Zijlstra wrote: > Hi, > > These patches provide generic infrastructure to determine TLB page size from > page table entries alone. Perf will use this (for either data or code address) > to aid in profiling TLB issues. I'm not sure it's an issue,

Re: Error: invalid switch -me200

2020-11-16 Thread Christophe Leroy
Quoting Michael Ellerman : Christophe Leroy writes: Le 14/11/2020 à 01:20, Segher Boessenkool a écrit : On Fri, Nov 13, 2020 at 12:14:18PM -0800, Nick Desaulniers wrote: Error: invalid switch -me200 Error: unrecognized option -me200 251 cpu-as-$(CONFIG_E200) += -Wa,-me200 Are those

[PATCH -next] powerpc/powernv/sriov: Fix unsigned comparison to zero

2020-11-16 Thread Zou Wei
Fixes coccicheck warnings: ./arch/powerpc/platforms/powernv/pci-sriov.c:443:7-10: WARNING: Unsigned expression compared with zero: win < 0 ./arch/powerpc/platforms/powernv/pci-sriov.c:462:7-10: WARNING: Unsigned expression compared with zero: win < 0 Signed-off-by: Zou Wei ---

Re: [PATCH V3] sched/rt, powerpc: Prepare for PREEMPT_RT

2020-11-16 Thread Michael Ellerman
Wang Qing writes: > PREEMPT_RT is a separate preemption model, CONFIG_PREEMPT will > be disabled when CONFIG_PREEMPT_RT is enabled, so we need > to add CONFIG_PREEMPT_RT output to __die(). > > Signed-off-by: Wang Qing Something fairly similar was posted previously. That time I said: I

Re: [PATCH] KVM: PPC: Book3S HV: XIVE: Fix possible oops when accessing ESB page

2020-11-16 Thread Michael Ellerman
Cédric Le Goater writes: > On 11/6/20 4:19 AM, Michael Ellerman wrote: >> Cédric Le Goater writes: >>> When accessing the ESB page of a source interrupt, the fault handler >>> will retrieve the page address from the XIVE interrupt 'xive_irq_data' >>> structure. If the associated KVM XIVE

Re: [PATCH] powerpc/pseries/hotplug-cpu: Fix memleak when cpus node not exist

2020-11-16 Thread Michael Ellerman
Tyrel Datwyler writes: > On 11/10/20 6:08 AM, Nathan Lynch wrote: >> Zhang Xiaoxu writes: >>> From: zhangxiaoxu >>> >>> If the cpus nodes not exist, we lost to free the 'cpu_drcs', which >>> will leak memory. >>> >>> Fixes: a0ff72f9f5a7 ("powerpc/pseries/hotplug-cpu: Remove double free in >>>

[PATCH] powerpc: Drop -me200 addition to build flags

2020-11-16 Thread Michael Ellerman
Currently a build with CONFIG_E200=y will fail with: Error: invalid switch -me200 Error: unrecognized option -me200 Upstream binutils has never supported an -me200 option. Presumably it was supported at some point by either a fork or Freescale internal binutils. We can't support code that

Re: [PATCH] powerpc/powernv/memtrace: Fake non-memblock aligned sized traces

2020-11-16 Thread Michael Ellerman
Jordan Niethe writes: > The hardware trace macros which use the memory provided by memtrace are > able to use trace sizes as small as 16MB. Only memblock aligned values > can be removed from each NUMA node by writing that value to > memtrace/enable in debugfs. This means setting up, say, a 16MB

Re: [PATCH 2/3] Revert "lib: Revert use of fallthrough pseudo-keyword in lib/"

2020-11-16 Thread kernel test robot
Hi Nick, I love your patch! Perhaps something to improve: [auto build test WARNING on powerpc/next] [also build test WARNING on linus/master v5.10-rc4 next-20201116] [cannot apply to pmladek/for-next] [If your patch is applied to the wrong git tree, kindly drop us a note. And when submitting

Re: [PATCH 3/3] powerpc: fix -Wimplicit-fallthrough

2020-11-16 Thread Miguel Ojeda
On Mon, Nov 16, 2020 at 5:35 AM Nick Desaulniers wrote: > > The "fallthrough" pseudo-keyword was added as a portable way to denote > intentional fallthrough. Clang will still warn on cases where there is a > fallthrough to an immediate break. Add explicit breaks for those cases. > > Link:

Re: [PATCH 2/3] Revert "lib: Revert use of fallthrough pseudo-keyword in lib/"

2020-11-16 Thread Miguel Ojeda
On Mon, Nov 16, 2020 at 5:35 AM Nick Desaulniers wrote: > > This reverts commit 6a9dc5fd6170 ("lib: Revert use of fallthrough > pseudo-keyword in lib/") > > Now that we can build arch/powerpc/boot/ free of -Wimplicit-fallthrough, > re-enable these fixes for lib/. > > Link:

Re: [PATCH 1/3] powerpc: boot: include compiler_attributes.h

2020-11-16 Thread Miguel Ojeda
On Mon, Nov 16, 2020 at 5:35 AM Nick Desaulniers wrote: > > It was also noted in 6a9dc5fd6170 that we could -D__KERNEL__ and > -include compiler_types.h like the main kernel does, though testing that > produces a whole sea of warnings to cleanup. This approach is minimally > invasive. I would

Re: [PATCH 2/3] Revert "lib: Revert use of fallthrough pseudo-keyword in lib/"

2020-11-16 Thread Miguel Ojeda
On Mon, Nov 16, 2020 at 7:26 AM Gustavo A. R. Silva wrote: > > Reviewed-by: Gustavo A. R. Silva .org :-) Cheers, Miguel

[PATCH 2/3] Revert "lib: Revert use of fallthrough pseudo-keyword in lib/"

2020-11-16 Thread Nick Desaulniers
This reverts commit 6a9dc5fd6170 ("lib: Revert use of fallthrough pseudo-keyword in lib/") Now that we can build arch/powerpc/boot/ free of -Wimplicit-fallthrough, re-enable these fixes for lib/. Link: https://github.com/ClangBuiltLinux/linux/issues/236 Signed-off-by: Nick Desaulniers ---

[PATCH 0/3] PPC: Fix -Wimplicit-fallthrough for clang

2020-11-16 Thread Nick Desaulniers
While cleaning up the last few -Wimplicit-fallthrough warnings in tree for Clang, I noticed commit 6a9dc5fd6170d ("lib: Revert use of fallthrough pseudo-keyword in lib/") which seemed to undo a bunch of fixes in lib/ due to breakage in arch/powerpc/boot/ not including compiler_types.h. We don't