[PATCH] FCC: fix confused base / offset

2008-04-09 Thread Sascha Hauer
(casted to void __iomem *) This patch fixes this in the way that dpram_offset holds the offset to the fcc dpram as the name suggests and the mem_offset field is renamed to mem of type void __iomem *. This way we get rid of some #ifdefs and type casts. Signed-off-by: Sascha Hauer [EMAIL PROTECTED

Re: [PATCH] FCC: fix confused base / offset

2008-04-09 Thread Sascha Hauer
On Wed, Apr 09, 2008 at 11:11:10AM -0500, Scott Wood wrote: On Wed, Apr 09, 2008 at 03:06:10PM +0200, Sascha Hauer wrote: This patch fixes a mixup in struct fs_platform_info. The struct has a field dpram_offset which really is no offset but an io pointer to the dpram (casted to u32

Re: [PATCH] FCC: fix confused base / offset

2008-04-10 Thread Sascha Hauer
On Wed, Apr 09, 2008 at 12:39:48PM -0500, Scott Wood wrote: Sascha Hauer wrote: Right, so it's probably not worth the effort. I stumbled on this while porting my board to the new binding code. I was quite confused when seeing this so I made this fix to understand what's going on here. BTW

Re: [PATCH] FCC: fix confused base / offset

2008-04-14 Thread Sascha Hauer
On Thu, Apr 10, 2008 at 11:38:00AM -0500, Scott Wood wrote: Hi Scott, Thank you for your help so far Sascha Hauer wrote: See bottom of this mail. The board really is a 8260 based board. Our bootloader does not fill in the clock values, so they are hardcoded. I'm not very sure about

Re: mpc5200: add interrupt type function

2008-04-18 Thread Sascha Hauer
On Wed, Apr 16, 2008 at 11:41:08PM -0700, Grant Likely wrote: On Wed, Apr 16, 2008 at 11:00 PM, Robert Schwebel [EMAIL PROTECTED] wrote: On Tue, Apr 15, 2008 at 05:29:54PM +0200, Robert Schwebel wrote: From: Sascha Hauer [EMAIL PROTECTED] Add a set_type function for external (GPIO

mpc5200b custom board upstreamable?

2008-04-24 Thread Sascha Hauer
Hi all, I had the intention to push the code for a custom mpc5200b board (freely available, no internal project) upstream. After cleaning up the code I realized that actually no board specific code is left and our board is well handled by the mpc5200_simple_platform machine. The only issue is

[PATCH] add gpiolib support for mpc5200

2008-04-24 Thread Sascha Hauer
to huge gaps. Signed-off-by: Sascha Hauer [EMAIL PROTECTED] --- arch/powerpc/platforms/52xx/Kconfig|6 arch/powerpc/platforms/52xx/Makefile |2 arch/powerpc/platforms/52xx/mpc52xx_gpio.c | 408 + 3 files changed, 416 insertions(+) Index: arch

Re: mpc5200b custom board upstreamable?

2008-04-24 Thread Sascha Hauer
On Thu, Apr 24, 2008 at 09:13:45AM -0600, Grant Likely wrote: On Thu, Apr 24, 2008 at 9:12 AM, Sascha Hauer [EMAIL PROTECTED] wrote: Hi all, I had the intention to push the code for a custom mpc5200b board (freely available, no internal project) upstream. After cleaning up the code I

Re: mpc5200b custom board upstreamable?

2008-04-24 Thread Sascha Hauer
On Thu, Apr 24, 2008 at 10:07:20AM -0600, Grant Likely wrote: On Thu, Apr 24, 2008 at 9:53 AM, Sascha Hauer [EMAIL PROTECTED] wrote: On Thu, Apr 24, 2008 at 09:13:45AM -0600, Grant Likely wrote: On Thu, Apr 24, 2008 at 9:12 AM, Sascha Hauer [EMAIL PROTECTED] wrote: Hi all

Re: [PATCH] add gpiolib support for mpc5200

2008-04-25 Thread Sascha Hauer
On Thu, Apr 24, 2008 at 12:45:49PM -0600, Grant Likely wrote: On Thu, Apr 24, 2008 at 9:36 AM, Sascha Hauer [EMAIL PROTECTED] wrote: Hi all, Feel free to comment on this. Sascha This patch adds gpiolib support for mpc5200 SOCs. I'm not sure whether it's a good idea to make

[PATCH] add gpiolib support for mpc5200

2008-04-25 Thread Sascha Hauer
This patch adds gpiolib support for mpc5200 SOCs. Changes since last submit: - fixed checkpatch warnings - use shadow variables for register accesses - make match tables const - Add documentation Signed-off-by: Sascha Hauer [EMAIL PROTECTED] --- Documentation/powerpc/mpc52xx-device-tree

[PATCH] add Phytec pcm030 board support

2008-04-25 Thread Sascha Hauer
Add board support for the Phytec pcm030 mpc5200b based board. It does not need any platform specific fixups and as such is handled as a mpc5200 simple platform. Signed-off-by: Sascha Hauer [EMAIL PROTECTED] --- arch/powerpc/boot/dts/pcm030.dts | 363 arch/powerpc/configs

Re: [PATCH] add gpiolib support for mpc5200

2008-04-25 Thread Sascha Hauer
is important.. flipping bits here and there without something in the way in the API is kind of clumsy) -- Matt Sealey [EMAIL PROTECTED] Genesi, Manager, Developer Relations Grant Likely wrote: On Thu, Apr 24, 2008 at 9:36 AM, Sascha Hauer [EMAIL PROTECTED] wrote: Hi all, Feel free

Re: [PATCH] add Phytec pcm030 board support

2008-05-06 Thread Sascha Hauer
On Mon, May 05, 2008 at 01:22:40PM -0400, Jon Smirl wrote: On 5/5/08, Grant Likely [EMAIL PROTECTED] wrote: On Mon, May 5, 2008 at 11:01 AM, Jon Smirl [EMAIL PROTECTED] wrote: Did this get fixed somehow? I used to need this to boot a pcm030. I'm sorry; I'm at a lost as to context.

Re: jffs2 and unaligned access

2008-05-07 Thread Sascha Hauer
On Wed, May 07, 2008 at 11:53:49AM +0100, David Woodhouse wrote: On Wed, 2008-05-07 at 12:27 +0200, Sascha Hauer wrote: memcpy_from/to_io() use word aligned accesses on the io side of memory. The MPC5200 local plus bus where our flashes are connected does not allow unaligned accesses, so we

Re: Comments on device tree for pcm030

2008-06-09 Thread Sascha Hauer
Hi, On Sun, Jun 08, 2008 at 03:08:33PM -0400, Jon Smirl wrote: Why not a compatible field in the top of the tree? Then you wouldn't need to list the boards in mpc5200_simple.c. compatible = phytec,pcm030,simple-mpc5200; Device tree has an entry for AC97 on PSC1. I don't think the

Re: [PATCH v1 05/24] clk: wrap I/O access for improved portability

2013-07-15 Thread Sascha Hauer
On Mon, Jul 15, 2013 at 08:47:34PM +0200, Gerhard Sittig wrote: diff --git a/drivers/clk/clk-divider.c b/drivers/clk/clk-divider.c index 6d55eb2..2c07061 100644 --- a/drivers/clk/clk-divider.c +++ b/drivers/clk/clk-divider.c @@ -104,7 +104,7 @@ static unsigned long

Re: [PATCH v1 15/24] serial: mpc512x: OF clock lookup, use the 'mclk' name

2013-07-15 Thread Sascha Hauer
On Mon, Jul 15, 2013 at 11:46:01PM +0200, Gerhard Sittig wrote: with device tree based clock lookup, the MCLK name no longer depends on the PSC index Signed-off-by: Gerhard Sittig g...@denx.de --- drivers/tty/serial/mpc52xx_uart.c |8 ++-- 1 file changed, 2 insertions(+), 6

Re: [PATCH v1 05/24] clk: wrap I/O access for improved portability

2013-07-18 Thread Sascha Hauer
On Thu, Jul 18, 2013 at 09:04:02AM +0200, Gerhard Sittig wrote: On Mon, Jul 15, 2013 at 21:38 +0200, Sascha Hauer wrote: On Mon, Jul 15, 2013 at 08:47:34PM +0200, Gerhard Sittig wrote: diff --git a/drivers/clk/clk-divider.c b/drivers/clk/clk-divider.c index 6d55eb2..2c07061 100644

Re: [PATCH v4 resent 1/2] ASoC: fsl: Add S/PDIF CPU DAI driver

2013-08-14 Thread Sascha Hauer
On Mon, Aug 12, 2013 at 08:05:27PM +0800, Nicolin Chen wrote: This patch add S/PDIF controller driver for Freescale SoC. Signed-off-by: Nicolin Chen b42...@freescale.com + +Required properties: + + - compatible : Compatible list, contains fsl,chip-spdif. Using general + fsl,fsl-spdif

Re: [alsa-devel] [PATCH v4 resent 1/2] ASoC: fsl: Add S/PDIF CPU DAI driver

2013-08-14 Thread Sascha Hauer
On Wed, Aug 14, 2013 at 04:48:02PM +0800, Nicolin Chen wrote: Hi Sascha, On Wed, Aug 14, 2013 at 09:50:17AM +0200, Sascha Hauer wrote: + - tx-clksrc-names : The names for all available clock sources for tx, which + is also being listed in SoC reference manual, ClkSrc_Sel bit

Re: [alsa-devel] [PATCH v4 resent 1/2] ASoC: fsl: Add S/PDIF CPU DAI driver

2013-08-14 Thread Sascha Hauer
On Wed, Aug 14, 2013 at 06:23:46PM +0800, Nicolin Chen wrote: Hi, Surely, if I misunderstand your point, please correct me. And if you have any sage idea, please guide me. Something like this: clocks = clks 197, clks 3, clks 197, clks 107, clks SPDIF_EXT, clks 118,

Re: [PATCH v5 1/2] ASoC: fsl: Add S/PDIF CPU DAI driver

2013-08-16 Thread Sascha Hauer
On Fri, Aug 16, 2013 at 12:43:31PM +0800, Nicolin Chen wrote: Hi Tomasz, Thank you for the comments. I'll revise them in v6. And below is my reply for you comments. On Thu, Aug 15, 2013 at 02:18:22PM +0200, Tomasz Figa wrote: + - clock-names : Includes the following entries:

Re: [PATCH v5 1/2] ASoC: fsl: Add S/PDIF CPU DAI driver

2013-08-16 Thread Sascha Hauer
On Fri, Aug 16, 2013 at 04:01:25PM +0800, Nicolin Chen wrote: Hi Sascha, Thank you for the detailed comments. On Fri, Aug 16, 2013 at 09:08:18AM +0200, Sascha Hauer wrote: Which of them the driver should use is configuration and thus normally should *not* be described

Re: [PATCH v5 1/2] ASoC: fsl: Add S/PDIF CPU DAI driver

2013-08-16 Thread Sascha Hauer
On Fri, Aug 16, 2013 at 05:53:58PM +0800, Nicolin Chen wrote: On Fri, Aug 16, 2013 at 10:56:32AM +0200, Sascha Hauer wrote: tx0-8 OptionalTx clock source for spdif playback. If absent, will use core clock. The index from 0 to 8

Re: [PATCH v5 1/2] ASoC: fsl: Add S/PDIF CPU DAI driver

2013-08-17 Thread Sascha Hauer
On Sat, Aug 17, 2013 at 02:28:04PM +0200, Tomasz Figa wrote: Also I would make this option required. Use a dummy clock for mux inputs that are grounded for a specific SoC. Some clocks are not from CCM and we haven't defined in imx6q-clk.txt, so in most cases we can't provide a

Re: [PATCH v5 1/2] ASoC: fsl: Add S/PDIF CPU DAI driver

2013-08-17 Thread Sascha Hauer
On Sat, Aug 17, 2013 at 02:26:40PM +0200, Tomasz Figa wrote: You mean tx0-7. Also I would make this option required. Use a dummy clock for mux inputs that are grounded for a specific SoC. Why do you need a dummy clock? The driver can simply try to grab all the possible clocks and

Re: [PATCH v5 1/2] ASoC: fsl: Add S/PDIF CPU DAI driver

2013-08-17 Thread Sascha Hauer
On Sat, Aug 17, 2013 at 02:56:11PM +0200, Tomasz Figa wrote: Hi Nicolin, First, you are right that all the properties you just commented are software configurations. And I got the point that device tree now can't allow any software configuration even if the actual hardware connection will

Re: [PATCH v5 1/2] ASoC: fsl: Add S/PDIF CPU DAI driver

2013-08-17 Thread Sascha Hauer
On Sat, Aug 17, 2013 at 05:13:20PM +0200, Tomasz Figa wrote: On Saturday 17 of August 2013 17:00:02 Sascha Hauer wrote: On Sat, Aug 17, 2013 at 02:26:40PM +0200, Tomasz Figa wrote: You mean tx0-7. Also I would make this option required. Use a dummy clock for mux inputs

Re: [PATCH v8 1/2] ASoC: fsl: Add S/PDIF CPU DAI driver

2013-08-19 Thread Sascha Hauer
Hi Nicolas, Some misc other comments inline. On Mon, Aug 19, 2013 at 08:08:48PM +0800, Nicolin Chen wrote: This patch implements a device-tree-only CPU DAI driver for Freescale + +struct fsl_spdif_priv { + struct spdif_mixer_control fsl_spdif_control; + struct snd_soc_dai_driver

Re: [PATCH v5 1/2] ASoC: fsl: Add S/PDIF CPU DAI driver

2013-08-22 Thread Sascha Hauer
wrote: Quoting Mark Rutland (2013-08-19 02:35:43) On Sat, Aug 17, 2013 at 04:17:18PM +0100, Tomasz Figa wrote: On Saturday 17 of August 2013 16:53:16 Sascha Hauer wrote: On Sat, Aug 17, 2013 at 02:28:04PM +0200, Tomasz Figa wrote: Also I would make

Re: [PATCH v5 1/2] ASoC: fsl: Add S/PDIF CPU DAI driver

2013-08-23 Thread Sascha Hauer
On Fri, Aug 23, 2013 at 12:49:19AM +0200, Tomasz Figa wrote: On Thursday 22 of August 2013 15:43:31 Mike Turquette wrote: Quoting Sascha Hauer (2013-08-22 14:00:35) On Thu, Aug 22, 2013 at 01:09:31PM +0100, Mark Rutland wrote: On Thu, Aug 22, 2013 at 08:19:10AM +0100, Mike Turquette

Re: [alsa-devel] [PATCH v5 1/2] ASoC: fsl: Add S/PDIF CPU DAI driver

2013-08-23 Thread Sascha Hauer
On Fri, Aug 23, 2013 at 01:58:15PM +0100, Mark Rutland wrote: On Fri, Aug 23, 2013 at 07:34:21AM +0100, Sascha Hauer wrote: On Fri, Aug 23, 2013 at 12:49:19AM +0200, Tomasz Figa wrote: On Thursday 22 of August 2013 15:43:31 Mike Turquette wrote: Quoting Sascha Hauer (2013-08-22 14:00:35

Re: [PATCH 2/3] dts: mpc512x: adjust clock specs for FEC nodes

2014-03-06 Thread Sascha Hauer
On Wed, Mar 05, 2014 at 11:52:09AM +0100, Gerhard Sittig wrote: On Wed, Mar 05, 2014 at 09:48 +0800, Shawn Guo wrote: On Mon, Mar 03, 2014 at 10:22:31AM +0100, Gerhard Sittig wrote: On Mon, Feb 24, 2014 at 11:25 +0100, Gerhard Sittig wrote: a recent FEC binding document update

Re: [PATCH 1/3] dma: imx-sdma: Add ssi dual fifo script support

2013-10-29 Thread Sascha Hauer
On Tue, Oct 29, 2013 at 08:33:15PM +0800, Nicolin Chen wrote: There's a script for SSI missing in current sdma script list. Thus add it. This script would allow SSI use its dual fifo mode to transimit/receive data without occasional hardware underrun/overrun. This patch also fixed a counting

Re: [PATCH v2 1/4] dma: imx-sdma: Add sdma firmware version 2 support

2013-10-31 Thread Sascha Hauer
; s32 ram_code_start_addr; You could add a comment here, like: /* End of v1 array */ Otherwise: Acked-by: Sascha Hauer s.ha...@pengutronix.de + s32 mcu_2_ssish_addr; + s32 ssish_2_mcu_addr; + s32 hdmi_dma_addr; }; /** -- 1.8.4 -- Pengutronix e.K

Re: [PATCH 0/7] update USB gadget driver fsl-usb2-udc

2012-10-19 Thread Sascha Hauer
Hi Christoph, What system are you working on? If it's i.MX you should use/work on the chipidea driver instead. Sascha On Fri, Oct 19, 2012 at 12:22:36PM +0200, Christoph Fritz wrote: This series updates USB gadget driver fsl-usb2-udc. Christoph Fritz (7): usb: gadget: fsl_udc: simplify

Re: [net-next-2.6 PATCH v2] can: SJA1000: generic OF platform bus driver

2009-05-26 Thread Sascha Hauer
On Tue, May 26, 2009 at 10:42:05AM +0100, Arnd Bergmann wrote: On Tuesday 26 May 2009, David Miller wrote: It's such a baroque thing, there is no reason to set it at all if you ask me. It's only use is to allow ISA and similar primitive bus devices to have their I/O ports changed via

Re: [PATCH 01/19] mxc_udc: add workaround for ENGcm09152 for i.MX25

2011-12-13 Thread Sascha Hauer
Hi Eric, To make the handling of your patches easier, please - send a cover letter for multiple patches - separate them at least by fixes and features - if possible, do not send patches aimed at multiple maintainers in a single series. I picked every patch looking like a fix for now myself,

Re: [PATCH] ASoC: fsl_sai: fix 1:1 bclk:mclk ratio support

2022-04-05 Thread Sascha Hauer
acilitate this. > > Fixes: a50b7926d015 ("ASoC: fsl_sai: implement 1:1 bclk:mclk ratio support") > Signed-off-by: Ahmad Fatoum Reviewed-by: Sascha Hauer Sascha > --- > sound/soc/fsl/fsl_sai.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > di

Re: [PATCH] ASoC: fsl: Check before clk_put() not needed

2022-06-01 Thread Sascha Hauer
On Wed, Jun 01, 2022 at 06:14:29AM -0700, Yihao Han wrote: > clk_put() already checks the clk ptr using !clk and IS_ERR() > so there is no need to check it again before calling it. > > Signed-off-by: Yihao Han > --- > sound/soc/fsl/imx-sgtl5000.c | 3 +-- > 1 file changed, 1 insertion(+), 2