[PATCH] powerpc/ptrace: Remove duplicate check from pt_regs_check()

2021-03-05 Thread Denis Efremov
"offsetof(struct pt_regs, msr) == offsetof(struct user_pt_regs, msr)" checked in pt_regs_check() twice in a row. Remove the second check. Signed-off-by: Denis Efremov --- arch/powerpc/kernel/ptrace/ptrace.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/arch/powerpc/kernel/ptrac

Re: [PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()

2020-06-17 Thread Denis Efremov
On 6/16/20 9:53 PM, Joe Perches wrote: > On Mon, 2020-06-15 at 21:57 -0400, Waiman Long wrote: >> v4: >> - Break out the memzero_explicit() change as suggested by Dan Carpenter >> so that it can be backported to stable. >> - Drop the "crypto: Remove unnecessary memzero_explicit()" patch

[PATCH v2 4/5] powerpc/PCI: Remove HAVE_ARCH_PCI_RESOURCE_TO_USER

2019-07-29 Thread Denis Efremov
The function pci_resource_to_user() was turned to a weak one. Thus, powerpc-specific version will automatically override the generic one and the HAVE_ARCH_PCI_RESOURCE_TO_USER macro should be removed. Signed-off-by: Denis Efremov --- arch/powerpc/include/asm/pci.h | 2 -- 1 file changed, 2

[PATCH v2 1/5] PCI: Convert pci_resource_to_user to a weak function

2019-07-29 Thread Denis Efremov
The patch turns pci_resource_to_user() to a weak function. Thus, architecture-specific versions will automatically override the generic one. This allows to remove the HAVE_ARCH_PCI_RESOURCE_TO_USER macro and avoid the conditional compilation for this single function. Signed-off-by: Denis Efremov

[PATCH v2 0/5] PCI: Convert pci_resource_to_user() to a weak function

2019-07-29 Thread Denis Efremov
in v2: 1. Removed __weak from pci_resource_to_user() declaration 2. Fixed typo s/spark/sparc/g Denis Efremov (5): PCI: Convert pci_resource_to_user to a weak function microblaze/PCI: Remove HAVE_ARCH_PCI_RESOURCE_TO_USER mips/PCI: Remove HAVE_ARCH_PCI_RESOURCE_TO_USER powerpc/PCI: Remove

Re: [EXTERNAL][PATCH 1/5] PCI: Convert pci_resource_to_user to a weak function

2019-07-29 Thread Denis Efremov
Hi Paul, On 29.07.2019 01:49, Paul Burton wrote: Hi Denis, This is wrong - using __weak on the declaration in a header will cause the weak attribute to be applied to all implementations too (presuming the C files containing the implementations include the header). You then get whichever impleen

[PATCH 4/5] powerpc/PCI: Remove HAVE_ARCH_PCI_RESOURCE_TO_USER

2019-07-28 Thread Denis Efremov
The function pci_resource_to_user() was turned to a weak one. Thus, powerpc-specific version will automatically override the generic one and the HAVE_ARCH_PCI_RESOURCE_TO_USER macro should be removed. Signed-off-by: Denis Efremov --- arch/powerpc/include/asm/pci.h | 2 -- 1 file changed, 2

[PATCH 1/5] PCI: Convert pci_resource_to_user to a weak function

2019-07-28 Thread Denis Efremov
The patch turns pci_resource_to_user() to a weak function. Thus, architecture-specific versions will automatically override the generic one. This allows to remove the HAVE_ARCH_PCI_RESOURCE_TO_USER macro and avoid the conditional compilation for this single function. Signed-off-by: Denis Efremov

[PATCH 0/5] PCI: Convert pci_resource_to_user() to a weak function

2019-07-28 Thread Denis Efremov
Architectures currently define HAVE_ARCH_PCI_RESOURCE_TO_USER if they want to provide their own pci_resource_to_user() implementation. This could be simplified if we make the generic version a weak function. Thus, architecture specific versions will automatically override the generic one. Denis

[PATCH 20/21] powerpc/ps3: remove inline marking of EXPORT_SYMBOL functions

2013-05-09 Thread Denis Efremov
EXPORT_SYMBOL and inline directives are contradictory to each other. The patch fixes this inconsistency. Found by Linux Driver Verification project (linuxtesting.org). Signed-off-by: Denis Efremov --- arch/powerpc/platforms/ps3/spu.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff